SolrNet: SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > Class Template Reference

  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SolrNet
  • Impl
  • FieldSerializers
  • AbstractFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > Class Template Reference

Strongly-typed abstract field parser. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >:
SolrNet.Impl.ISolrFieldSerializer SolrNet.Impl.FieldSerializers.BoolFieldSerializer SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer

List of all members.

Public Member Functions

abstract IEnumerable
< PropertyNode > 		Parse (T obj)
bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

template<T>
class SolrNet::Impl::FieldSerializers::AbstractFieldSerializer< T >

Strongly-typed abstract field parser.

Template Parameters:
T

Member Function Documentation

template<T >
bool SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

template<T >
IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/AbstractFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SolrNet
  • Mapping
  • Validation
  • Rules
  • AbstractSolrFieldTypeChecker
Public Member Functions | Protected Member Functions | Protected Attributes

SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker Class Reference

Abstract schema type checker. Uses a list of "safe" types and a list of "warning" types. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker

List of all members.

Public Member Functions

virtual ValidationResult | Validate (SolrFieldType solrFieldType, string propertyName, Type propertyType)
Validates a mapped document property against a Solr field type.
abstract bool | CanHandleType (Type propertyType)
Returns true if this type checked can handle propertyType

Protected Member Functions

AbstractSolrFieldTypeChecker (ICollection< string > safeTypes, ICollection< string > warningTypes)

Protected Attributes

readonly ICollection< string > | safeTypes
readonly ICollection< string > | warningTypes

Detailed Description

Abstract schema type checker. Uses a list of "safe" types and a list of "warning" types.

Member Function Documentation

abstract bool SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker.CanHandleType ( Type propertyType ) [pure virtual]

Returns true if this type checked can handle propertyType

Parameters:
propertyType Type to check if this checker can handle
Returns:

Implements SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker.

virtual ValidationResult SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker.Validate | ( | SolrFieldType | solrFieldType,
 |  | string | propertyName,
 |  | Type | propertyType
 | ) |  | [virtual]

Validates a mapped document property against a Solr field type.

Parameters:
solrFieldType
propertyName
propertyType
Returns:

Implements SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/AbstractSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.AbstractSolrQuery Class Reference

  • Class Members
  • SolrNet
  • AbstractSolrQuery
Public Member Functions | Static Public Member Functions

SolrNet.AbstractSolrQuery Class Reference

Abstract Solr query, used to define operator overloading. More...

Inheritance diagram for SolrNet.AbstractSolrQuery:
SolrNet.ISolrQuery SolrNet.SolrHasValueQuery SolrNet.SolrMultipleCriteriaQuery SolrNet.SolrNotQuery SolrNet.SolrQuery SolrNet.SolrQueryBoost SolrNet.SolrQueryByField SolrNet.SolrQueryByRange< RT > SolrNet.SolrQueryInList

List of all members.

Public Member Functions

AbstractSolrQuery Not ()
Negates this query.
AbstractSolrQuery | Boost (double factor)
Boosts this query.

Static Public Member Functions

static AbstractSolrQuery | operator& (AbstractSolrQuery a, AbstractSolrQuery b)
static AbstractSolrQuery | operator| (AbstractSolrQuery a, AbstractSolrQuery b)
static AbstractSolrQuery | operator+ (AbstractSolrQuery a, AbstractSolrQuery b)
static AbstractSolrQuery | operator- (AbstractSolrQuery a, AbstractSolrQuery b)
static bool | operator false (AbstractSolrQuery a)
static bool | operator true (AbstractSolrQuery a)
static AbstractSolrQuery | operator! (AbstractSolrQuery a)

Detailed Description

Abstract Solr query, used to define operator overloading.

Member Function Documentation

AbstractSolrQuery SolrNet.AbstractSolrQuery.Boost ( double factor )

Boosts this query.

Parameters:
factor
Returns:
AbstractSolrQuery SolrNet.AbstractSolrQuery.Not ( )

Negates this query.

Returns:
The documentation for this class was generated from the following file:
  • SolrNet/AbstractSolrQuery.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.AddCommand< T > Class Template Reference

  • SolrNet
  • Commands
  • AddCommand
Public Member Functions

SolrNet.Commands.AddCommand< T > Class Template Reference

Adds / updates documents to solr. More...

Inheritance diagram for SolrNet.Commands.AddCommand< T >:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

AddCommand (IEnumerable< KeyValuePair< T, double?>> documents, ISolrDocumentSerializer< T > serializer)
string | RemoveControlCharacters (string xml)
Removes UTF control characters, not valid in XML.
string | ConvertToXml ()
string | Execute (ISolrConnection connection)
Executes this command.

Detailed Description

template<T>
class SolrNet::Commands::AddCommand< T >

Adds / updates documents to solr.

Template Parameters:
T Document type

Member Function Documentation

template<T >
string SolrNet.Commands.AddCommand< T >.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

template<T >
string SolrNet.Commands.AddCommand< T >.RemoveControlCharacters ( string xml )

Removes UTF control characters, not valid in XML.

Parameters:
xml
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Commands/AddCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor Class Reference

  • SolrNet
  • Impl
  • DocumentPropertyVisitors
  • AggregateDocumentVisitor
Public Member Functions

SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor Class Reference

Aggregate document visitor. More...

Inheritance diagram for SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor:
SolrNet.Impl.ISolrDocumentPropertyVisitor

List of all members.

Public Member Functions

AggregateDocumentVisitor (IEnumerable< ISolrDocumentPropertyVisitor > visitors)
Aggregate document visitor.
void Visit (object doc, string fieldName, XmlNode field)
Visits a document with a raw xml Solr response field.

Detailed Description

Aggregate document visitor.

Constructor & Destructor Documentation

SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor.AggregateDocumentVisitor ( IEnumerable< ISolrDocumentPropertyVisitor > visitors )

Aggregate document visitor.

Parameters:
visitors Visitors to aggregate

Member Function Documentation

void SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor.Visit | ( | object | doc,
 |  | string | fieldName,
 |  | XmlNode | field
 | ) |  |

Visits a document with a raw xml Solr response field.

Parameters:
doc | Document object
fieldName | Solr field name
field | Raw XML Solr field

Implements SolrNet.Impl.ISolrDocumentPropertyVisitor.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/DocumentPropertyVisitors/AggregateDocumentVisitor.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer Class Reference

  • SolrNet
  • Impl
  • FacetQuerySerializers
  • AggregateFacetQuerySerializer
Public Member Functions

SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer:
SolrNet.Impl.ISolrFacetQuerySerializer

List of all members.

Public Member Functions

AggregateFacetQuerySerializer (ISolrFacetQuerySerializer[] serializers)
bool CanHandleType (Type t)
IEnumerable< KeyValuePair
< string, string > > 		Serialize (object q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/FacetQuerySerializers/AggregateFacetQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.AggregateFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • AggregateFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.AggregateFieldParser Class Reference

Aggregates ISolrFieldParsers. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.AggregateFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

AggregateFieldParser (IEnumerable< ISolrFieldParser > parsers)
Aggregates ISolrFieldParsers.
bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Aggregates ISolrFieldParsers.

Constructor & Destructor Documentation

SolrNet.Impl.FieldParsers.AggregateFieldParser.AggregateFieldParser ( IEnumerable< ISolrFieldParser > parsers )

Aggregates ISolrFieldParsers.

Parameters:
parsers

Member Function Documentation

bool SolrNet.Impl.FieldParsers.AggregateFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.AggregateFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.AggregateFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/AggregateFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.AggregateFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • AggregateFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.AggregateFieldSerializer Class Reference

Aggregates ISolrFieldSerializers. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.AggregateFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

AggregateFieldSerializer (IEnumerable< ISolrFieldSerializer > serializers)
bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Aggregates ISolrFieldSerializers.

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.AggregateFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.AggregateFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/AggregateFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.AggregateQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • AggregateQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.AggregateQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.AggregateQuerySerializer:
SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

AggregateQuerySerializer (ISolrQuerySerializer[] serializers)
bool | CanHandleType (Type t)
string | Serialize (object q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/AggregateQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.AllPropertiesMappingManager Class Reference

  • SolrNet
  • Mapping
  • AllPropertiesMappingManager
Public Member Functions

SolrNet.Mapping.AllPropertiesMappingManager Class Reference

Maps all properties in the class, with the same field name as the property. Note that unique keys must be added manually. More...

Inheritance diagram for SolrNet.Mapping.AllPropertiesMappingManager:
SolrNet.IReadOnlyMappingManager

List of all members.

Public Member Functions

ICollection< SolrFieldModel > | GetFields (Type type)
Gets fields mapped for this type.
SolrFieldModel | GetUniqueKey (Type type)
Gets unique key for the type.
ICollection< Type > | GetRegisteredTypes ()
void | SetUniqueKey (PropertyInfo property)
Sets the property that acts as unique key for a document type.

Detailed Description

Maps all properties in the class, with the same field name as the property. Note that unique keys must be added manually.

Member Function Documentation

ICollection<SolrFieldModel> SolrNet.Mapping.AllPropertiesMappingManager.GetFields ( Type type )

Gets fields mapped for this type.

Parameters:
type
Returns:
Empty collection if type is not mapped

Implements SolrNet.IReadOnlyMappingManager.

SolrFieldModel SolrNet.Mapping.AllPropertiesMappingManager.GetUniqueKey ( Type type )

Gets unique key for the type.

Parameters:
type
Returns:

Implements SolrNet.IReadOnlyMappingManager.

void SolrNet.Mapping.AllPropertiesMappingManager.SetUniqueKey ( PropertyInfo property )

Sets the property that acts as unique key for a document type.

Parameters:
property Unique key property
The documentation for this class was generated from the following file:
  • SolrNet/Mapping/AllPropertiesMappingManager.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.AttributesMappingManager Class Reference

  • SolrNet
  • Mapping
  • AttributesMappingManager
Public Member Functions

SolrNet.Mapping.AttributesMappingManager Class Reference

Gets mapping info from attributes like SolrFieldAttribute and SolrUniqueKeyAttribute More...

Inheritance diagram for SolrNet.Mapping.AttributesMappingManager:
SolrNet.IReadOnlyMappingManager

List of all members.

Public Member Functions

virtual IEnumerable
< KeyValuePair< PropertyInfo,
T[]> > 		GetPropertiesWithAttribute< T > (Type type)
ICollection< SolrFieldModel > | GetFields (Type type)
Gets fields mapped for this type.
virtual T[] | GetCustomAttributes< T > (PropertyInfo prop)
SolrFieldModel | GetUniqueKey (Type type)
Gets unique key for the type.
ICollection< Type > | GetRegisteredTypes ()

Detailed Description

Gets mapping info from attributes like SolrFieldAttribute and SolrUniqueKeyAttribute

Member Function Documentation

ICollection<SolrFieldModel> SolrNet.Mapping.AttributesMappingManager.GetFields ( Type type )

Gets fields mapped for this type.

Parameters:
type
Returns:
Empty collection if type is not mapped

Implements SolrNet.IReadOnlyMappingManager.

SolrFieldModel SolrNet.Mapping.AttributesMappingManager.GetUniqueKey ( Type type )

Gets unique key for the type.

Parameters:
type
Returns:

Implements SolrNet.IReadOnlyMappingManager.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/AttributesMappingManager.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.BoolFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • BoolFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.BoolFieldSerializer Class Reference

Parses bool values. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.BoolFieldSerializer:
SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

string SerializeBool (bool o)
override IEnumerable
< PropertyNode > 		Parse (bool obj)

Detailed Description

Parses bool values.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/BoolFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • BoolSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker Class Reference

Checks schema type of properties with bool type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

BoolSolrFieldTypeChecker ()
Checks schema type of properties with bool type.

Detailed Description

Checks schema type of properties with bool type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker.BoolSolrFieldTypeChecker ( )

Checks schema type of properties with bool type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/BoolSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.BoostQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • BoostQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.BoostQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.BoostQuerySerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

BoostQuerySerializer (ISolrQuerySerializer serializer)
override string Serialize (SolrQueryBoost q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/BoostQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.CfgHelper Class Reference

  • NHibernate
  • SolrNet
  • CfgHelper
Public Member Functions

NHibernate.SolrNet.CfgHelper Class Reference

Helper class to configure NHibernate-SolrNet integration. More...

List of all members.

Public Member Functions

CfgHelper (IReadOnlyMappingManager mapper, IServiceProvider provider)
Gets SolrNet components from a IServiceProvider, except for the IReadOnlyMappingManager
CfgHelper (IServiceProvider provider)
Gets SolrNet components from a IServiceProvider
CfgHelper ()
Gets SolrNet components from the current ServiceLocator
Configuration | Configure (Configuration config, bool autoCommit)
Registers SolrNet's NHibernate listeners.
ISolrSession | OpenSession (ISession session)
Wraps a NHibernate ISession and adds Solr operations.
ISolrSession | OpenSession (ISessionFactory sessionFactory)
Opens a new NHibernate ISession and wraps it to add Solr operations.

Detailed Description

Helper class to configure NHibernate-SolrNet integration.

Constructor & Destructor Documentation

NHibernate.SolrNet.CfgHelper.CfgHelper | ( | IReadOnlyMappingManager | mapper,
 |  | IServiceProvider | provider
 | ) |  |

Gets SolrNet components from a IServiceProvider, except for the IReadOnlyMappingManager

Parameters:
mapper | Use this mapper for NHibernate-SolrNet integration
provider | Used to fetch SolrNet components
NHibernate.SolrNet.CfgHelper.CfgHelper ( IServiceProvider provider )

Gets SolrNet components from a IServiceProvider

Parameters:
provider Used to fetch SolrNet components
NHibernate.SolrNet.CfgHelper.CfgHelper ( )

Gets SolrNet components from the current ServiceLocator

Member Function Documentation

Configuration NHibernate.SolrNet.CfgHelper.Configure | ( | Configuration | config,
 |  | bool | autoCommit
 | ) |  |

Registers SolrNet's NHibernate listeners.

Parameters:
config NHibernate configuration
autoCommit
Returns:
ISolrSession NHibernate.SolrNet.CfgHelper.OpenSession ( ISessionFactory sessionFactory )

Opens a new NHibernate ISession and wraps it to add Solr operations.

Returns:
ISolrSession NHibernate.SolrNet.CfgHelper.OpenSession ( ISession session )

Wraps a NHibernate ISession and adds Solr operations.

Parameters:
session ISession to wrap
Returns:
The documentation for this class was generated from the following file:
  • NHibernate.SolrNet/CfgHelper.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.CollapsedDocument Class Reference

  • SolrNet
  • CollapsedDocument
Properties

SolrNet.CollapsedDocument Class Reference

Field collapsing result. More...

List of all members.

Properties

string | Id [get, set]
Document ID /summary>
string | FieldValue [get, set]
int | CollapseCount [get, set]
Collapsed field count.

Detailed Description

Field collapsing result.

Property Documentation

int SolrNet.CollapsedDocument.CollapseCount [get, set]

Collapsed field count.

string SolrNet.CollapsedDocument.Id [get, set]

Document ID /summary>

summary> Collapsed Field Value /summary>

The documentation for this class was generated from the following file:
  • SolrNet/CollapsedDocument.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.CollapseParameters Class Reference

  • SolrNet
  • Commands
  • Parameters
  • CollapseParameters
Public Member Functions | Properties

SolrNet.Commands.Parameters.CollapseParameters Class Reference

Parameters to query collapse https://issues.apache.org/jira/browse/SOLR-236 More...

List of all members.

Public Member Functions

CollapseParameters (string field)

Properties

string | Field [get, set]
Field to group results by.
int | Threshold [get, set]
Number of continuous results allowed before collapsing.
int | MaxDocs [get, set]
limits the number of documents that CollapseFilter will process to create the filter DocSet. The intention of this is to be able to limit the time collapsing will take for very large result sets (obviously at the expense of accurate collapsing in those cases).
CollapseFacetMode | FacetMode [get, set]
Number of continuous results allowed before collapsing.
CollapseType | Type [get, set]
Collapse type: Adjacent or Normal.

Detailed Description

Parameters to query collapse https://issues.apache.org/jira/browse/SOLR-236

Property Documentation

CollapseFacetMode SolrNet.Commands.Parameters.CollapseParameters.FacetMode [get, set]

Number of continuous results allowed before collapsing.

string SolrNet.Commands.Parameters.CollapseParameters.Field [get, set]

Field to group results by.

int SolrNet.Commands.Parameters.CollapseParameters.MaxDocs [get, set]

limits the number of documents that CollapseFilter will process to create the filter DocSet. The intention of this is to be able to limit the time collapsing will take for very large result sets (obviously at the expense of accurate collapsing in those cases).

int SolrNet.Commands.Parameters.CollapseParameters.Threshold [get, set]

Number of continuous results allowed before collapsing.

CollapseType SolrNet.Commands.Parameters.CollapseParameters.Type [get, set]

Collapse type: Adjacent or Normal.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/CollapseParameters.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • CollapseResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > Class Template Reference

Parses collapse_counts from query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

void | Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
IEnumerable< CollapsedDocument > | ParseCollapsedResults (XmlNode node)
Parses collapsed document.ids and their counts.

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::CollapseResponseParser< T >

Parses collapse_counts from query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
IEnumerable<CollapsedDocument> SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >.ParseCollapsedResults ( XmlNode node )

Parses collapsed document.ids and their counts.

Parameters:
node
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/CollapseResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.CollapseResults Class Reference

  • SolrNet
  • CollapseResults
Properties

SolrNet.CollapseResults Class Reference

Collapse results More...

List of all members.

Properties

string | Field [get, set]
&collapse.field=
ICollection< CollapsedDocument > | CollapsedDocuments [get, set]
Collapsed document.ids and their counts.

Detailed Description

Collapse results

Property Documentation

ICollection<CollapsedDocument> SolrNet.CollapseResults.CollapsedDocuments [get, set]

Collapsed document.ids and their counts.

summary> Initializer /summary>

string SolrNet.CollapseResults.Field [get, set]

&collapse.field=

The documentation for this class was generated from the following file:
  • SolrNet/CollapseResults.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.CollectionFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • CollectionFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.CollectionFieldParser Class Reference

Parses 1-dimensional fields. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.CollectionFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

CollectionFieldParser (ISolrFieldParser valueParser)
bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.
IList | GetNonGenericCollectionProperty (XmlNode field)
Array | GetArrayProperty (XmlNode field, Type t)
IList | GetGenericCollectionProperty (XmlNode field, Type[] genericTypes)

Detailed Description

Parses 1-dimensional fields.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.CollectionFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.CollectionFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.CollectionFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/CollectionFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.CollectionFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • CollectionFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.CollectionFieldSerializer Class Reference

Serializes 1-dimensional collections. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.CollectionFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

CollectionFieldSerializer (ISolrFieldSerializer valueSerializer)
bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Serializes 1-dimensional collections.

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.CollectionFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.CollectionFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/CollectionFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.CommitCommand Class Reference

  • SolrNet
  • Commands
  • CommitCommand
Public Member Functions | Properties

SolrNet.Commands.CommitCommand Class Reference

Commits updates. More...

Inheritance diagram for SolrNet.Commands.CommitCommand:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

string | Execute (ISolrConnection connection)
Executes this command.

Properties

bool | WaitFlush [get, set]
Block until index changes are flushed to disk Default is true.
bool | WaitSearcher [get, set]
Block until a new searcher is opened and registered as the main query searcher, making the changes visible. Default is true.
bool | ExpungeDeletes [get, set]
Merge segments with deletes away Default is false.
int | MaxSegments [get, set]
Optimizes down to, at most, this number of segments Default is 1.

Detailed Description

Commits updates.

Member Function Documentation

string SolrNet.Commands.CommitCommand.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

Property Documentation

bool SolrNet.Commands.CommitCommand.ExpungeDeletes [get, set]

Merge segments with deletes away Default is false.

int SolrNet.Commands.CommitCommand.MaxSegments [get, set]

Optimizes down to, at most, this number of segments Default is 1.

bool SolrNet.Commands.CommitCommand.WaitFlush [get, set]

Block until index changes are flushed to disk Default is true.

bool SolrNet.Commands.CommitCommand.WaitSearcher [get, set]

Block until a new searcher is opened and registered as the main query searcher, making the changes visible. Default is true.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/CommitCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.CommitOptions Class Reference

  • SolrNet
  • Commands
  • Parameters
  • CommitOptions
Public Member Functions | Properties

SolrNet.Commands.Parameters.CommitOptions Class Reference

Commit/optimize options. More...

List of all members.

Public Member Functions

CommitOptions ()
Commit/optimize options.

Properties

bool | WaitSearcher [get, set]
Block until a new searcher is opened and registered as the main query searcher, making the changes visible. Default is true.
bool | WaitFlush [get, set]
Block until index changes are flushed to disk Default is true.
int | MaxSegments [get, set]
Optimizes down to at most this number of segments Default is 1.
bool | ExpungeDeletes [get, set]
Merge segments with deletes away.

Detailed Description

Commit/optimize options.

Constructor & Destructor Documentation

SolrNet.Commands.Parameters.CommitOptions.CommitOptions ( )

Commit/optimize options.

Property Documentation

bool SolrNet.Commands.Parameters.CommitOptions.ExpungeDeletes [get, set]

Merge segments with deletes away.

Requires Solr 1.4

int SolrNet.Commands.Parameters.CommitOptions.MaxSegments [get, set]

Optimizes down to at most this number of segments Default is 1.

Requires Solr 1.3

bool SolrNet.Commands.Parameters.CommitOptions.WaitFlush [get, set]

Block until index changes are flushed to disk Default is true.

bool SolrNet.Commands.Parameters.CommitOptions.WaitSearcher [get, set]

Block until a new searcher is opened and registered as the main query searcher, making the changes visible. Default is true.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/CommitOptions.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Utils.Container Class Reference

  • SolrNet
  • Utils
  • Container
Public Member Functions | Protected Member Functions

SolrNet.Utils.Container Class Reference

Basic built-in dependency-injection container. More...

Inheritance diagram for SolrNet.Utils.Container:
SolrNet.Utils.IContainer

List of all members.

Public Member Functions

Container (Container c)
Creates a new container copying all components from another container.
void | Register< T > (Converter< IContainer, T > factory)
Adds a component implementing T Component key is T 's Type.FullName
void | Register< T > (string key, Converter< IContainer, T > factory)
Adds a component implementing T with the specified key.
void | Register (string key, Type serviceType, Converter< IContainer, object > factory)
Adds a component.
void | RemoveAll< T > ()
Removes all components with service type T
void | Remove< T > ()
Removes the default component for service type T
void | Remove< T > (string key)
Removes the component with key key implementing service type T
void | Remove (string key, Type serviceType)
Removes the component with key key implementing service type serviceType
void | Clear ()
Removes all component registrations from this container.

Protected Member Functions

override object | DoGetInstance (Type serviceType, string key)
override IEnumerable< object > | DoGetAllInstances (Type serviceType)

Detailed Description

Basic built-in dependency-injection container.

Constructor & Destructor Documentation

SolrNet.Utils.Container.Container ( Container c )

Creates a new container copying all components from another container.

Parameters:
c

Member Function Documentation

void SolrNet.Utils.Container.Clear ( )

Removes all component registrations from this container.

void SolrNet.Utils.Container.Register | ( | string | key,
 |  | Type | serviceType,
 |  | Converter< IContainer, object > | factory
 | ) |  |

Adds a component.

Parameters:
key | Component key
serviceType | Component service type
factory | Component factory method. Must return serviceType or a descendant

Implements SolrNet.Utils.IContainer.

void SolrNet.Utils.Container.Register< T > | ( | string | key,
 |  | Converter< IContainer, T > | factory
 | ) |  |

Adds a component implementing T with the specified key.

Template Parameters:
T Service type
Parameters:
factory | Component factory method
key | Component key

Implements SolrNet.Utils.IContainer.

void SolrNet.Utils.Container.Register< T > ( Converter< IContainer, T > factory )

Adds a component implementing T Component key is T 's Type.FullName

Template Parameters:
T Service type
Parameters:
factory Component factory method

Implements SolrNet.Utils.IContainer.

void SolrNet.Utils.Container.Remove | ( | string | key,
 |  | Type | serviceType
 | ) |  |

Removes the component with key key implementing service type serviceType

Parameters:
key | Component key
serviceType | Service type

Implements SolrNet.Utils.IContainer.

void SolrNet.Utils.Container.Remove< T > ( string key )

Removes the component with key key implementing service type T

Template Parameters:
T Service type
Parameters:
key Component key

Implements SolrNet.Utils.IContainer.

void SolrNet.Utils.Container.Remove< T > ( )

Removes the default component for service type T

Template Parameters:
T Service type

Implements SolrNet.Utils.IContainer.

void SolrNet.Utils.Container.RemoveAll< T > ( )

Removes all components with service type T

Template Parameters:
T Service type

Implements SolrNet.Utils.IContainer.

The documentation for this class was generated from the following file:
  • SolrNet/Utils/Container.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DateFacetingResult Class Reference

  • SolrNet
  • DateFacetingResult
Public Member Functions | Properties

SolrNet.DateFacetingResult Class Reference

Date faceting result. More...

List of all members.

Public Member Functions

DateFacetingResult ()
Date faceting result.

Properties

string | Gap [get, set]
The gap.
DateTime | End [get, set]
Maximum value.
IList< KeyValuePair< DateTime,
int > > 		DateResults [get, set]
The date faceting results.
IDictionary< FacetDateOther, int > | OtherResults [get, set]
Other date faceting results.

Detailed Description

Date faceting result.

Constructor & Destructor Documentation

SolrNet.DateFacetingResult.DateFacetingResult ( )

Date faceting result.

Property Documentation

IList<KeyValuePair<DateTime, int> > SolrNet.DateFacetingResult.DateResults [get, set]

The date faceting results.

DateTime SolrNet.DateFacetingResult.End [get, set]

Maximum value.

string SolrNet.DateFacetingResult.Gap [get, set]

The gap.

IDictionary<FacetDateOther, int> SolrNet.DateFacetingResult.OtherResults [get, set]

Other date faceting results.

The documentation for this class was generated from the following file:
  • SolrNet/DateFacetingResult.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.DateTimeFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • DateTimeFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.DateTimeFieldParser Class Reference

Parses datetime fields. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.DateTimeFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.
DateTime | ParseDate (string s)

Detailed Description

Parses datetime fields.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.DateTimeFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.DateTimeFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.DateTimeFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/DateTimeFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • DateTimeFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer Class Reference

Serializes datetime fields. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer:
SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

string SerializeDate (DateTime dt)
override IEnumerable
< PropertyNode > 		Parse (DateTime obj)

Detailed Description

Serializes datetime fields.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/DateTimeFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • DateTimeRangeQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer Class Reference

List of all members.

Public Member Functions

DateTimeRangeQuerySerializer (ISolrFieldSerializer fieldSerializer)
string | SerializeSingle (object o)
override string | Serialize (SolrQueryByRange< DateTime > q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/DateTimeRangeQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • DateTimeSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker Class Reference

Checks schema type of properties with DateTime type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

DateTimeSolrFieldTypeChecker ()
Checks schema type of properties with DateTime type.

Detailed Description

Checks schema type of properties with DateTime type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker.DateTimeSolrFieldTypeChecker ( )

Checks schema type of properties with DateTime type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/DateTimeSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.DecimalFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • DecimalFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.DecimalFieldParser Class Reference

Parses decimal fields. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.DecimalFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses decimal fields.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.DecimalFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.DecimalFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.DecimalFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/DecimalFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • DecimalSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker Class Reference

Checks schema type of properties with decimal type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

ValidationResult | Validate (SolrFieldType solrFieldType, string propertyName, Type propertyType)
Validates a mapped document property against a Solr field type.
bool | CanHandleType (Type propertyType)

Detailed Description

Checks schema type of properties with decimal type.

Member Function Documentation

ValidationResult SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker.Validate | ( | SolrFieldType | solrFieldType,
 |  | string | propertyName,
 |  | Type | propertyType
 | ) |  |

Validates a mapped document property against a Solr field type.

Parameters:
solrFieldType
propertyName
propertyType
Returns:

Implements SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/DecimalSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor Class Reference

  • SolrNet
  • Impl
  • DocumentPropertyVisitors
  • DefaultDocumentVisitor
Public Member Functions

SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor Class Reference

Default document visitor. More...

Inheritance diagram for SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor:
SolrNet.Impl.ISolrDocumentPropertyVisitor

List of all members.

Public Member Functions

DefaultDocumentVisitor (IReadOnlyMappingManager mapper, ISolrFieldParser parser)
Default document visitor.
void Visit (object doc, string fieldName, XmlNode field)
Visits a document with a raw xml Solr response field.

Detailed Description

Default document visitor.

Constructor & Destructor Documentation

SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor.DefaultDocumentVisitor | ( | IReadOnlyMappingManager | mapper,
 |  | ISolrFieldParser | parser
 | ) |  |

Default document visitor.

Parameters:
mapper
parser

Member Function Documentation

void SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor.Visit | ( | object | doc,
 |  | string | fieldName,
 |  | XmlNode | field
 | ) |  |

Visits a document with a raw xml Solr response field.

Parameters:
doc | Document object
fieldName | Solr field name
field | Raw XML Solr field

Implements SolrNet.Impl.ISolrDocumentPropertyVisitor.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/DocumentPropertyVisitors/DefaultDocumentVisitor.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer Class Reference

  • SolrNet
  • Impl
  • FacetQuerySerializers
  • DefaultFacetQuerySerializer
Public Member Functions

SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer:
SolrNet.Impl.ISolrFacetQuerySerializer

List of all members.

Public Member Functions

DefaultFacetQuerySerializer (ISolrQuerySerializer querySerializer, ISolrFieldSerializer fieldSerializer)
bool CanHandleType (Type t)
IEnumerable< KeyValuePair
< string, string > > 		Serialize (object q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/FacetQuerySerializers/DefaultFacetQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.DefaultFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • DefaultFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.DefaultFieldParser Class Reference

Default field parser. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.DefaultFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

DefaultFieldParser ()
Default field parser.
bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Default field parser.

Constructor & Destructor Documentation

SolrNet.Impl.FieldParsers.DefaultFieldParser.DefaultFieldParser ( )

Default field parser.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.DefaultFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.DefaultFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.DefaultFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/DefaultFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.DefaultFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • DefaultFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.DefaultFieldSerializer Class Reference

Aggregates the default ISolrFieldSerializers. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.DefaultFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Aggregates the default ISolrFieldSerializers.

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.DefaultFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.DefaultFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/DefaultFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.DefaultQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • DefaultQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.DefaultQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.DefaultQuerySerializer:
SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

DefaultQuerySerializer (ISolrFieldSerializer fieldSerializer)
bool | CanHandleType (Type t)
string | Serialize (object q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/DefaultQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.Impl.DelegatingSession Class Reference

  • NHibernate
  • SolrNet
  • Impl
  • DelegatingSession
Public Member Functions | Properties

NHibernate.SolrNet.Impl.DelegatingSession Class Reference

Inheritance diagram for NHibernate.SolrNet.Impl.DelegatingSession:
NHibernate.SolrNet.SolrSession

List of all members.

Public Member Functions

DelegatingSession (ISession session)
void | Dispose ()
void | Flush ()
IDbConnection | Disconnect ()
void | Reconnect ()
void | Reconnect (IDbConnection connection)
IDbConnection | Close ()
void | CancelQuery ()
bool | IsDirty ()
object | GetIdentifier (object obj)
bool | Contains (object obj)
void | Evict (object obj)
object | Load (System.Type theType, object id, LockMode lockMode)
object | Load (string entityName, object id, LockMode lockMode)
object | Load (System.Type theType, object id)
T | Load< T > (object id, LockMode lockMode)
T | Load< T > (object id)
object | Load (string entityName, object id)
void | Load (object obj, object id)
void | Replicate (object obj, ReplicationMode replicationMode)
void | Replicate (string entityName, object obj, ReplicationMode replicationMode)
object | Save (object obj)
void | Save (object obj, object id)
object | Save (string entityName, object obj)
void | SaveOrUpdate (object obj)
void | SaveOrUpdate (string entityName, object obj)
void | Update (object obj)
void | Update (object obj, object id)
void | Update (string entityName, object obj)
object | Merge (object obj)
object | Merge (string entityName, object obj)
void | Persist (object obj)
void | Persist (string entityName, object obj)
object | SaveOrUpdateCopy (object obj)
object | SaveOrUpdateCopy (object obj, object id)
void | Delete (object obj)
void | Delete (string entityName, object obj)
IList | Find (string query)
IList | Find (string query, object value, IType type)
IList | Find (string query, object[] values, IType[] types)
IEnumerable | Enumerable (string query)
IEnumerable | Enumerable (string query, object value, IType type)
IEnumerable | Enumerable (string query, object[] values, IType[] types)
ICollection | Filter (object collection, string filter)
ICollection | Filter (object collection, string filter, object value, IType type)
ICollection | Filter (object collection, string filter, object[] values, IType[] types)
int | Delete (string query)
int | Delete (string query, object value, IType type)
int | Delete (string query, object[] values, IType[] types)
void | Lock (object obj, LockMode lockMode)
void | Lock (string entityName, object obj, LockMode lockMode)
void | Refresh (object obj)
void | Refresh (object obj, LockMode lockMode)
LockMode | GetCurrentLockMode (object obj)
ITransaction | BeginTransaction ()
ITransaction | BeginTransaction (IsolationLevel isolationLevel)
ICriteria | CreateCriteria< T > ()
ICriteria | CreateCriteria< T > (string alias)
ICriteria | CreateCriteria (System.Type persistentClass)
ICriteria | CreateCriteria (System.Type persistentClass, string alias)
ICriteria | CreateCriteria (string entityName)
ICriteria | CreateCriteria (string entityName, string alias)
IQuery | CreateQuery (string queryString)
IQuery | CreateFilter (object collection, string queryString)
IQuery | GetNamedQuery (string queryName)
IQuery | CreateSQLQuery (string sql, string returnAlias, System.Type returnClass)
IQuery | CreateSQLQuery (string sql, string[] returnAliases, System.Type[] returnClasses)
ISQLQuery | CreateSQLQuery (string queryString)
void | Clear ()
object | Get (System.Type clazz, object id)
object | Get (System.Type clazz, object id, LockMode lockMode)
object | Get (string entityName, object id)
T | Get< T > (object id)
T | Get< T > (object id, LockMode lockMode)
string | GetEntityName (object obj)
IFilter | EnableFilter (string filterName)
IFilter | GetEnabledFilter (string filterName)
void | DisableFilter (string filterName)
IMultiQuery | CreateMultiQuery ()
ISession | SetBatchSize (int batchSize)
ISessionImplementor | GetSessionImplementation ()
IMultiCriteria | CreateMultiCriteria ()
ISession | GetSession (EntityMode entityMode)

Properties

EntityMode | ActiveEntityMode [get]
FlushMode | FlushMode [get, set]
CacheMode | CacheMode [get, set]
ISessionFactory | SessionFactory [get]
IDbConnection | Connection [get]
bool | IsOpen [get]
bool | IsConnected [get]
ITransaction | Transaction [get]
ISessionStatistics | Statistics [get]
The documentation for this class was generated from the following file:
  • NHibernate.SolrNet/Impl/DelegatingSession.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DeleteBy Class Reference

  • SolrNet
  • DSL
  • Impl
  • DeleteBy
Public Member Functions

SolrNet.DSL.Impl.DeleteBy Class Reference

List of all members.

Public Member Functions

DeleteBy (ISolrConnection connection)
void | ById (string id)
void | ByIds (IEnumerable< string > ids)
void | ByQuery (ISolrQuery q)
void | ByQuery (string q)
The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DeleteBy.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam Class Reference

  • SolrNet
  • Commands
  • Parameters
  • DeleteByIdAndOrQueryParam
Public Member Functions

SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam Class Reference

Parameter to delete document(s) by one or more ids and or a query parameters. More...

Inheritance diagram for SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam:
SolrNet.Commands.Parameters.ISolrDeleteParam

List of all members.

Public Member Functions

DeleteByIdAndOrQueryParam (IEnumerable< string > ids, ISolrQuery query, ISolrQuerySerializer querySerializer)
IEnumerable< XmlNode > ToXmlNode ()
Converts this parameter to xml representation.

Detailed Description

Parameter to delete document(s) by one or more ids and or a query parameters.

Member Function Documentation

IEnumerable<XmlNode> SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam.ToXmlNode ( )

Converts this parameter to xml representation.

Returns:

Implements SolrNet.Commands.Parameters.ISolrDeleteParam.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/DeleteByIdAndOrQueryParam.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.DeleteCommand Class Reference

  • SolrNet
  • Commands
  • DeleteCommand
Public Member Functions | Properties

SolrNet.Commands.DeleteCommand Class Reference

Deletes document(s), either by id or by query. More...

Inheritance diagram for SolrNet.Commands.DeleteCommand:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

DeleteCommand (ISolrDeleteParam deleteParam)
string | Execute (ISolrConnection connection)
Executes this command.

Properties

bool | FromPending [get, set]
Deprecated in Solr 1.3.
bool | FromCommitted [get, set]
Deprecated in Solr 1.3.
ISolrDeleteParam | DeleteParam [get]

Detailed Description

Deletes document(s), either by id or by query.

Member Function Documentation

string SolrNet.Commands.DeleteCommand.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

Property Documentation

bool SolrNet.Commands.DeleteCommand.FromCommitted [get, set]

Deprecated in Solr 1.3.

bool SolrNet.Commands.DeleteCommand.FromPending [get, set]

Deprecated in Solr 1.3.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/DeleteCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.DoubleFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • DoubleFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.DoubleFieldParser Class Reference

Parses double fields. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.DoubleFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses double fields.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.DoubleFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.DoubleFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.DoubleFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/DoubleFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • DoubleSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker Class Reference

Checks schema type of properties with double type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

DoubleSolrFieldTypeChecker ()
Checks schema type of properties with double type.

Detailed Description

Checks schema type of properties with double type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker.DoubleSolrFieldTypeChecker ( )

Checks schema type of properties with double type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/DoubleSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DSLFacetFieldOptions< T > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • DSLFacetFieldOptions
Public Member Functions

SolrNet.DSL.Impl.DSLFacetFieldOptions< T > Class Template Reference

Inheritance diagram for SolrNet.DSL.Impl.DSLFacetFieldOptions< T >:
SolrNet.DSL.Impl.DSLRun< T > SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.IDSLRun< T >

List of all members.

Public Member Functions

DSLFacetFieldOptions (ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, SolrFacetFieldQuery facetQuery)
IDSLFacetFieldOptions< T > | LimitTo (int limit)
Maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.
IDSLFacetFieldOptions< T > | DontSortByCount ()
Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.
IDSLFacetFieldOptions< T > | WithPrefix (string prefix)
Limits the terms on which to facet to those starting with the given string prefix.
IDSLFacetFieldOptions< T > | WithMinCount (int count)
Minimum counts for facet fields that should be included in the response. The default value is 0.
IDSLFacetFieldOptions< T > | StartingAt (int offset)
Indicates an offset into the list of constraints to allow paging. The default value is 0.
IDSLFacetFieldOptions< T > | IncludeMissing ()
Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.

template<T>
class SolrNet::DSL::Impl::DSLFacetFieldOptions< T >

Member Function Documentation

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.DontSortByCount ( )

Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.

Implements SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.IncludeMissing ( )

Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.

Implements SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.LimitTo ( int limit )

Maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.

Implements SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.StartingAt ( int offset )

Indicates an offset into the list of constraints to allow paging. The default value is 0.

Implements SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.WithMinCount ( int count )

Minimum counts for facet fields that should be included in the response. The default value is 0.

Implements SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.WithPrefix ( string prefix )

Limits the terms on which to facet to those starting with the given string prefix.

Implements SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DSLFacetFieldOptions.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DSLQuery< T > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • DSLQuery
Public Member Functions

SolrNet.DSL.Impl.DSLQuery< T > Class Template Reference

Inheritance diagram for SolrNet.DSL.Impl.DSLQuery< T >:
SolrNet.DSL.Impl.DSLRun< T > SolrNet.DSL.Impl.IDSLQuery< T > SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.DSLQueryRange< T, RT >

List of all members.

Public Member Functions

DSLQuery (ISolrConnection connection)
DSLQuery (ISolrConnection connection, ISolrQuery query)
IDSLQueryRange< T > | ByRange< RT > (string fieldName, RT from, RT to)
IDSLQueryBy< T > | By (string fieldName)

template<T>
class SolrNet::DSL::Impl::DSLQuery< T >

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DSLQuery.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DSLQueryBetween< T, RT > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • DSLQueryBetween
Public Member Functions

SolrNet.DSL.Impl.DSLQueryBetween< T, RT > Class Template Reference

Inheritance diagram for SolrNet.DSL.Impl.DSLQueryBetween< T, RT >:
SolrNet.DSL.Impl.IDSLQueryBetween< T, RT >

List of all members.

Public Member Functions

DSLQueryBetween (string fieldName, ISolrConnection connection, ISolrQuery query, RT from)
IDSLQuery< T > And (RT i)

template<T, RT>
class SolrNet::DSL::Impl::DSLQueryBetween< T, RT >

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DSLQueryBetween.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DSLQueryBy< T > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • DSLQueryBy
Public Member Functions

SolrNet.DSL.Impl.DSLQueryBy< T > Class Template Reference

Inheritance diagram for SolrNet.DSL.Impl.DSLQueryBy< T >:
SolrNet.DSL.Impl.IDSLQueryBy< T >

List of all members.

Public Member Functions

DSLQueryBy (string fieldName, ISolrConnection connection, ISolrQuery query)
IDSLQuery< T > | Is (string s)
IDSLQueryBetween< T, RT > | Between< RT > (RT i)

template<T>
class SolrNet::DSL::Impl::DSLQueryBy< T >

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DSLQueryBy.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DSLQueryRange< T, RT > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • DSLQueryRange
Public Member Functions

SolrNet.DSL.Impl.DSLQueryRange< T, RT > Class Template Reference

Inheritance diagram for SolrNet.DSL.Impl.DSLQueryRange< T, RT >:
SolrNet.DSL.Impl.DSLQuery< T > SolrNet.DSL.Impl.IDSLQueryRange< T > SolrNet.DSL.Impl.DSLRun< T > SolrNet.DSL.Impl.IDSLQuery< T > SolrNet.DSL.Impl.IDSLQuery< T > SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.IDSLRun< T >

List of all members.

Public Member Functions

DSLQueryRange (ISolrConnection connection, ISolrQuery query, string fieldName, RT from, RT to)
IDSLQuery< T > | Exclusive ()
IDSLQuery< T > | Inclusive ()

template<T, RT>
class SolrNet::DSL::Impl::DSLQueryRange< T, RT >

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DSLQueryRange.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.DSLRun< T > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • DSLRun
Public Member Functions | Protected Attributes

SolrNet.DSL.Impl.DSLRun< T > Class Template Reference

Inheritance diagram for SolrNet.DSL.Impl.DSLRun< T >:
SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.DSLFacetFieldOptions< T > SolrNet.DSL.Impl.DSLQuery< T > SolrNet.DSL.Impl.DSLQueryRange< T, RT >

List of all members.

Public Member Functions

DSLRun (ISolrConnection connection)
DSLRun (ISolrConnection connection, ISolrQuery query)
DSLRun (ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order)
DSLRun (ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, HighlightingParameters highlight)
ISolrQueryResults< T > | Run ()
ISolrQueryResults< T > | Run (int start, int rows)
IDSLRun< T > | OrderBy (string fieldName)
IDSLRun< T > | OrderBy (string fieldName, Order o)
IDSLFacetFieldOptions< T > | WithFacetField (string fieldName)
IDSLRun< T > | WithFacetQuery (string q)
IDSLRun< T > | WithFacetQuery (ISolrQuery q)
IDSLRun< T > | WithHighlighting (HighlightingParameters parameters)
IDSLRun< T > | WithHighlightingFields (params string[] fields)
override string | ToString ()

Protected Attributes

readonly ICollection< SortOrder > | order = new List<SortOrder>()
readonly ICollection
< ISolrFacetQuery > 		facets = new List<ISolrFacetQuery>()
readonly HighlightingParameters | highlight
ISolrConnection | connection
ISolrQuery | query

template<T>
class SolrNet::DSL::Impl::DSLRun< T >

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/DSLRun.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.EnumFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • EnumFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.EnumFieldParser Class Reference

Inheritance diagram for SolrNet.Impl.FieldParsers.EnumFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.EnumFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.EnumFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.EnumFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/EnumFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.FacetDateOther Class Reference

  • SolrNet
  • FacetDateOther
Public Member Functions | Protected Member Functions | Protected Attributes | Properties

SolrNet.FacetDateOther Class Reference

Indicates that in addition to the counts for each date range constraint between facet.date.start and facet.date.end, counts should also be computed for other. More...

List of all members.

Public Member Functions

override bool | Equals (object obj)
override int | GetHashCode ()
override string | ToString ()

Protected Member Functions

FacetDateOther (string value)

Protected Attributes

readonly string | value

Properties

static FacetDateOther | Before [get]
All records with field values lower then lower bound of the first range.
static FacetDateOther | After [get]
All records with field values greater then the upper bound of the last range.
static FacetDateOther | Between [get]
All records with field values between the start and end bounds of all ranges.
static FacetDateOther | None [get]
Compute none of this information. Overrides all other options.
static FacetDateOther | All [get]
Shortcut for before, between, and after.

Detailed Description

Indicates that in addition to the counts for each date range constraint between facet.date.start and facet.date.end, counts should also be computed for other.

Property Documentation

FacetDateOther SolrNet.FacetDateOther.After [static, get]

All records with field values greater then the upper bound of the last range.

FacetDateOther SolrNet.FacetDateOther.All [static, get]

Shortcut for before, between, and after.

FacetDateOther SolrNet.FacetDateOther.Before [static, get]

All records with field values lower then lower bound of the first range.

FacetDateOther SolrNet.FacetDateOther.Between [static, get]

All records with field values between the start and end bounds of all ranges.

FacetDateOther SolrNet.FacetDateOther.None [static, get]

Compute none of this information. Overrides all other options.

The documentation for this class was generated from the following file:
  • SolrNet/FacetDateOther.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.FacetParameters Class Reference

  • SolrNet
  • Commands
  • Parameters
  • FacetParameters
Properties

SolrNet.Commands.Parameters.FacetParameters Class Reference

Faceting parameters. More...

List of all members.

Properties

ICollection< ISolrFacetQuery > | Queries [get, set]
Collection of facet queries.
string | Prefix [get, set]
Limits the terms on which to facet to those starting with the given string prefix.
bool | Sort [get, set]
Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.
int | Limit [get, set]
This param indicates the maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.
int | Offset [get, set]
This param indicates an offset into the list of constraints to allow paging. The default value is 0.
int | MinCount [get, set]
This param indicates the minimum counts for facet fields should be included in the response. The default value is 0.
bool | Missing [get, set]
Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.
int | EnumCacheMinDf [get, set]
This param indicates the minimum document frequency (number of documents matching a term) for which the filterCache should be used when determining the constraint count for that term. This is only used during the term enumeration method of faceting (field type faceting on multi-valued or full-text fields). A value greater than zero will decrease memory usage of the filterCache, but increase the query time. When faceting on a field with a very large number of terms, and you wish to decrease memory usage, try a low value of 25 to 50 first. The default value is 0, causing the filterCache to be used for all terms in the field.

Detailed Description

Faceting parameters.

Property Documentation

int SolrNet.Commands.Parameters.FacetParameters.EnumCacheMinDf [get, set]

This param indicates the minimum document frequency (number of documents matching a term) for which the filterCache should be used when determining the constraint count for that term. This is only used during the term enumeration method of faceting (field type faceting on multi-valued or full-text fields). A value greater than zero will decrease memory usage of the filterCache, but increase the query time. When faceting on a field with a very large number of terms, and you wish to decrease memory usage, try a low value of 25 to 50 first. The default value is 0, causing the filterCache to be used for all terms in the field.

int SolrNet.Commands.Parameters.FacetParameters.Limit [get, set]

This param indicates the maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.

int SolrNet.Commands.Parameters.FacetParameters.MinCount [get, set]

This param indicates the minimum counts for facet fields should be included in the response. The default value is 0.

bool SolrNet.Commands.Parameters.FacetParameters.Missing [get, set]

Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.

int SolrNet.Commands.Parameters.FacetParameters.Offset [get, set]

This param indicates an offset into the list of constraints to allow paging. The default value is 0.

string SolrNet.Commands.Parameters.FacetParameters.Prefix [get, set]

Limits the terms on which to facet to those starting with the given string prefix.

ICollection<ISolrFacetQuery> SolrNet.Commands.Parameters.FacetParameters.Queries [get, set]

Collection of facet queries.

bool SolrNet.Commands.Parameters.FacetParameters.Sort [get, set]

Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/FacetParameters.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • FacetsResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > Class Template Reference

Parses facets from query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

void | Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
IDictionary< string, int > | ParseFacetQueries (XmlNode node)
Parses facet queries results.
IDictionary< string,
ICollection< KeyValuePair
< string, int > > > 		ParseFacetFields (XmlNode node)
Parses facet fields results.
IDictionary< string,
DateFacetingResult > 		ParseFacetDates (XmlNode node)
Parses facet dates results.
KeyValuePair< K, V > | KV< K, V > (K key, V value)
DateFacetingResult | ParseDateFacetingNode (XmlNode node)

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::FacetsResponseParser< T >

Parses facets from query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
IDictionary<string, DateFacetingResult> SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >.ParseFacetDates ( XmlNode node )

Parses facet dates results.

Parameters:
node
Returns:
template<T >
IDictionary<string, ICollection<KeyValuePair<string, int> > > SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >.ParseFacetFields ( XmlNode node )

Parses facet fields results.

Parameters:
node
Returns:
template<T >
IDictionary<string, int> SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >.ParseFacetQueries ( XmlNode node )

Parses facet queries results.

Parameters:
node
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/FacetsResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.FieldDefinition Class Reference

  • SolrNet
  • DSL
  • Impl
  • FieldDefinition
Public Member Functions

SolrNet.DSL.Impl.FieldDefinition Class Reference

List of all members.

Public Member Functions

FieldDefinition (string fieldName)
RangeDefinition< T > | From< T > (T from)
SolrQueryInList | In< T > (params T[] values)
SolrQueryByField | Is< T > (T value)
SolrQueryByRange< string > | HasAnyValue ()
The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/FieldDefinition.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.FloatFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • FloatFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.FloatFieldParser Class Reference

Parses float values. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.FloatFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses float values.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.FloatFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.FloatFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.FloatFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/FloatFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • FloatSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker Class Reference

Checks schema type of properties with float type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

FloatSolrFieldTypeChecker ()
Checks schema type of properties with float type.

Detailed Description

Checks schema type of properties with float type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker.FloatSolrFieldTypeChecker ( )

Checks schema type of properties with float type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/FloatSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.FormattableFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • FormattableFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.FormattableFieldSerializer Class Reference

Serializes objects that implement IFormattable More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.FormattableFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Serializes objects that implement IFormattable

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.FormattableFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.FormattableFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/FormattableFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Utils.Func Class Reference

  • SolrNet
  • Utils
  • Func
Public Member Functions | Static Public Member Functions

SolrNet.Utils.Func Class Reference

Functional utilities Mostly from http://diditwith.net/PermaLink,guid,a1a76478-03d2-428f-9db6-9cf4e300ea0f.aspx. More...

List of all members.

Public Member Functions

delegate TResult | Accumulator< TSource, TResult > (TSource x, TResult y)
delegate T | Function< T > ()
delegate TResult | Func2< TArg1, TArg2, TResult > (TArg1 a, TArg2 b)

Static Public Member Functions

static TResult | Reduce< TSource, TResult > (IEnumerable< TSource > source, TResult startValue, Accumulator< TSource, TResult > accumulator)
static IEnumerable< TSource > | Filter< TSource > (IEnumerable< TSource > source, Predicate< TSource > predicate)
static bool | IsEmpty (IEnumerable e)
static T | First< T > (IEnumerable< T > e)
static T | FirstOrDefault< T > (IEnumerable< T > e)
static T | FirstOrDefault< T > (IEnumerable< T > e, Predicate< T > condition)
static IEnumerable< R > | Convert< R > (IEnumerable e)
This is a conversion cast, unlike LINQ's Cast()
static IEnumerable< R > | Cast< R > (IEnumerable e)
static string | Join< T > (string separator, IEnumerable< T > list)
static string | Join< T > (string separator, IEnumerable< T > list, Converter< T, string > converter)
static string | Join< T > (IEnumerable< T > list)
static string | Join< T > (string separator, IEnumerable< T > list, Converter< T, string > converter, bool ignoreNulls)
static IEnumerable< T > | Take< T > (IEnumerable< T > l, int count)
static IEnumerable< R > | Select< T, R > (IEnumerable< T > l, Converter< T, R > f)
static T[] | ToArray< T > (IEnumerable< T > l)
static bool | Any< T > (IEnumerable< T > l, Converter< T, bool > condition)
static IEnumerable< T > | Distinct< T > (IEnumerable< T > l)
static IEnumerable< T > | Skip< T > (IEnumerable< T > l, int skipCount)
static IEnumerable< T > | Tail< T > (IEnumerable< T > l)

Detailed Description

Functional utilities Mostly from http://diditwith.net/PermaLink,guid,a1a76478-03d2-428f-9db6-9cf4e300ea0f.aspx.

Member Function Documentation

static IEnumerable<R> SolrNet.Utils.Func.Convert< R > ( IEnumerable e ) [static]

This is a conversion cast, unlike LINQ's Cast()

Template Parameters:
R
Parameters:
e
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Utils/Func.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor Class Reference

  • SolrNet
  • Impl
  • DocumentPropertyVisitors
  • GenericDictionaryDocumentVisitor
Public Member Functions

SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor Class Reference

Document visitor that handles generic dictionary properties. More...

Inheritance diagram for SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor:
SolrNet.Impl.ISolrDocumentPropertyVisitor

List of all members.

Public Member Functions

GenericDictionaryDocumentVisitor (IReadOnlyMappingManager mapper, ISolrFieldParser parser)
Document visitor that handles generic dictionary properties.
bool | CanHandleType (Type t)
True if this visitor can handle this Type.
object | NewDictionary (Type[] typeArgs)
Creates a new Dictionary{TKey,TValue}
void | SetKV (object dict, object key, object value)
Sets a key/value in a generic dictionary.
object | ConvertTo (string s, Type t)
SolrFieldModel | GetThisField (Type t, string fieldName)
string | GetKeyToUse (string k, string fieldName)
void | Visit (object doc, string fieldName, XmlNode field)
Visits a document with a raw xml Solr response field.

Detailed Description

Document visitor that handles generic dictionary properties.

Constructor & Destructor Documentation

SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor.GenericDictionaryDocumentVisitor | ( | IReadOnlyMappingManager | mapper,
 |  | ISolrFieldParser | parser
 | ) |  |

Document visitor that handles generic dictionary properties.

Parameters:
mapper
parser

Member Function Documentation

bool SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor.CanHandleType ( Type t )

True if this visitor can handle this Type.

Parameters:
t
Returns:
object SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor.NewDictionary ( Type[] typeArgs )

Creates a new Dictionary{TKey,TValue}

Parameters:
typeArgs Key and Value type parameters
Returns:
void SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor.SetKV | ( | object | dict,
 |  | object | key,
 |  | object | value
 | ) |  |

Sets a key/value in a generic dictionary.

Parameters:
dict | Dictionary{TKey,TValue} instance
key | Key value
value | Value value
void SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor.Visit | ( | object | doc,
 |  | string | fieldName,
 |  | XmlNode | field
 | ) |  |

Visits a document with a raw xml Solr response field.

Parameters:
doc | Document object
fieldName | Solr field name
field | Raw XML Solr field

Implements SolrNet.Impl.ISolrDocumentPropertyVisitor.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/DocumentPropertyVisitors/GenericDictionaryDocumentVisitor.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • GenericDictionaryFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer Class Reference

Serializes IDictionary{TKey,TValue} properties. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

GenericDictionaryFieldSerializer (ISolrFieldSerializer serializer)
bool | CanHandleType (Type t)
True if this serializer can handle the type.
string | KVKey (object kv)
Gets the key from a KeyValuePair{TKey,TValue}
object | KVValue (object kv)
Gets the value from a KeyValuePair{TKey,TValue}
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Serializes IDictionary{TKey,TValue} properties.

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

string SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer.KVKey ( object kv )

Gets the key from a KeyValuePair{TKey,TValue}

Parameters:
kv
Returns:
object SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer.KVValue ( object kv )

Gets the value from a KeyValuePair{TKey,TValue}

Parameters:
kv
Returns:
IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/GenericDictionaryFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.GetSchemaCommand Class Reference

  • SolrNet
  • Commands
  • GetSchemaCommand
Public Member Functions

SolrNet.Commands.GetSchemaCommand Class Reference

Gets the raw Solr schema. More...

Inheritance diagram for SolrNet.Commands.GetSchemaCommand:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

string Execute (ISolrConnection connection)
Gets the raw Solr schema.

Detailed Description

Gets the raw Solr schema.

Member Function Documentation

string SolrNet.Commands.GetSchemaCommand.Execute ( ISolrConnection connection )

Gets the raw Solr schema.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/GetSchemaCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.GuidFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • GuidFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.GuidFieldParser Class Reference

Inheritance diagram for SolrNet.Impl.FieldParsers.GuidFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.GuidFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.GuidFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.GuidFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/GuidFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.HasValueQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • HasValueQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.HasValueQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.HasValueQuerySerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

HasValueQuerySerializer (ISolrQuerySerializer serializer)
override string Serialize (SolrHasValueQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/HasValueQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • HeaderResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > Class Template Reference

Parses header (status, QTime, etc) from a query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T > SolrNet.Impl.ISolrHeaderResponseParser

List of all members.

Public Member Functions

void | Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
ResponseHeader | ParseHeader (XmlNode node)
Parses response header.
ResponseHeader | Parse (XmlDocument response)

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::HeaderResponseParser< T >

Parses header (status, QTime, etc) from a query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
ResponseHeader SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >.ParseHeader ( XmlNode node )

Parses response header.

Parameters:
node
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/HeaderResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.HighlightingParameters Class Reference

  • SolrNet
  • Commands
  • Parameters
  • HighlightingParameters
Properties

SolrNet.Commands.Parameters.HighlightingParameters Class Reference

Highlighting parameters. More...

List of all members.

Properties

ICollection< string > | Fields [get, set]
List of fields to generate highlighted snippets for. If left blank, the fields highlighted for the StandardRequestHandler are the defaultSearchField (or the df param if used) and for the DisMaxRequestHandler the qf fields are used.
int | Snippets [get, set]
The maximum number of highlighted snippets to generate per field. It is possible for any number of snippets from zero to this value to be generated. If left null, it will use whatever default Solr sets (1 for Solr 1.3)
int | Fragsize [get, set]
The size, in characters, of fragments to consider for highlighting. 0 indicates that the whole field value should be used (no fragmenting). If left null, it will use whatever default Solr sets (100 for Solr 1.3)
bool | RequireFieldMatch [get, set]
If true, then a field will only be highlighted if the query matched in this particular field (normally, terms are highlighted in all requested fields regardless of which field matched the query). If left null, it will use whatever default Solr sets (false for Solr 1.3)
string | AlternateField [get, set]
If a snippet cannot be generated (due to no terms matching), you can specify a field to use as the backup/default summary. The default value is to not have a default summary.
string | BeforeTerm [get, set]
The text which appears before a highlighted term. The default value is "&lt;em&gt;".
string | AfterTerm [get, set]
The text which appears after a highlighted term.
double | RegexSlop [get, set]
Factor by which the regex fragmenter can stray from the ideal fragment size (given by hl.fragsize) to accomodate the regular expression. For instance, a slop of 0.2 with fragsize of 100 should yield fragments between 80 and 120 characters in length. It is usually good to provide a slightly smaller fragsize when using the regex fragmenter. The default value is ".6".
string | RegexPattern [get, set]
The regular expression for fragmenting. This could be used to extract sentences.
int | RegexMaxAnalyzedChars [get, set]
Only analyze this many characters from a field when using the regex fragmenter (after which, the fragmenter produces fixed-sized fragments). Applying a complicated regex to a huge field is expensive. The default value is "10000".

Detailed Description

Highlighting parameters.

Property Documentation

string SolrNet.Commands.Parameters.HighlightingParameters.AfterTerm [get, set]

The text which appears after a highlighted term.

The default value is "&lt;/em&gt;"

string SolrNet.Commands.Parameters.HighlightingParameters.AlternateField [get, set]

If a snippet cannot be generated (due to no terms matching), you can specify a field to use as the backup/default summary. The default value is to not have a default summary.

string SolrNet.Commands.Parameters.HighlightingParameters.BeforeTerm [get, set]

The text which appears before a highlighted term. The default value is "&lt;em&gt;".

ICollection<string> SolrNet.Commands.Parameters.HighlightingParameters.Fields [get, set]

List of fields to generate highlighted snippets for. If left blank, the fields highlighted for the StandardRequestHandler are the defaultSearchField (or the df param if used) and for the DisMaxRequestHandler the qf fields are used.

int SolrNet.Commands.Parameters.HighlightingParameters.Fragsize [get, set]

The size, in characters, of fragments to consider for highlighting. 0 indicates that the whole field value should be used (no fragmenting). If left null, it will use whatever default Solr sets (100 for Solr 1.3)

int SolrNet.Commands.Parameters.HighlightingParameters.RegexMaxAnalyzedChars [get, set]

Only analyze this many characters from a field when using the regex fragmenter (after which, the fragmenter produces fixed-sized fragments). Applying a complicated regex to a huge field is expensive. The default value is "10000".

string SolrNet.Commands.Parameters.HighlightingParameters.RegexPattern [get, set]

The regular expression for fragmenting. This could be used to extract sentences.

double SolrNet.Commands.Parameters.HighlightingParameters.RegexSlop [get, set]

Factor by which the regex fragmenter can stray from the ideal fragment size (given by hl.fragsize) to accomodate the regular expression. For instance, a slop of 0.2 with fragsize of 100 should yield fragments between 80 and 120 characters in length. It is usually good to provide a slightly smaller fragsize when using the regex fragmenter. The default value is ".6".

bool SolrNet.Commands.Parameters.HighlightingParameters.RequireFieldMatch [get, set]

If true, then a field will only be highlighted if the query matched in this particular field (normally, terms are highlighted in all requested fields regardless of which field matched the query). If left null, it will use whatever default Solr sets (false for Solr 1.3)

int SolrNet.Commands.Parameters.HighlightingParameters.Snippets [get, set]

The maximum number of highlighted snippets to generate per field. It is possible for any number of snippets from zero to this value to be generated. If left null, it will use whatever default Solr sets (1 for Solr 1.3)

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/HighlightingParameters.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • HighlightingResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > Class Template Reference

Parses highlighting results from a query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

void Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
IDictionary< string,
IDictionary< string,
ICollection< string > > > 		ParseHighlighting (IEnumerable< T > results, XmlNode node)
Parses highlighting results.
IDictionary< string,
ICollection< string > > 		ParseHighlightingFields (XmlNodeList nodes)
Parses highlighting results.

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::HighlightingResponseParser< T >

Parses highlighting results from a query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
IDictionary<string, IDictionary<string, ICollection<string> > > SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >.ParseHighlighting | ( | IEnumerable< T > | results,
 |  | XmlNode | node
 | ) |  |

Parses highlighting results.

Parameters:
results
node
Returns:
template<T >
IDictionary<string, ICollection<string> > SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >.ParseHighlightingFields ( XmlNodeList nodes )

Parses highlighting results.

Parameters:
nodes
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/HighlightingResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.HttpRuntimeCache Class Reference

  • SolrNet
  • Impl
  • HttpRuntimeCache
Public Member Functions | Properties

SolrNet.Impl.HttpRuntimeCache Class Reference

Uses the HttpRuntime (ASP.NET) cache. More...

Inheritance diagram for SolrNet.Impl.HttpRuntimeCache:
SolrNet.Impl.ISolrCache

List of all members.

Public Member Functions

string | CacheKey (string url)
void | Add (SolrCacheEntity e)
Adds a Solr response to the cache.

Properties

int | SlidingMinutes [get, set]
Cache sliding minutes. By default 10 minutes.
SolrCacheEntity | this [string url] [get]
Gets a cached Solr response. Returns null if there is no cached response for this URL.

Detailed Description

Uses the HttpRuntime (ASP.NET) cache.

Member Function Documentation

void SolrNet.Impl.HttpRuntimeCache.Add ( SolrCacheEntity e )

Adds a Solr response to the cache.

Parameters:
e

Implements SolrNet.Impl.ISolrCache.

Property Documentation

int SolrNet.Impl.HttpRuntimeCache.SlidingMinutes [get, set]

Cache sliding minutes. By default 10 minutes.

SolrCacheEntity SolrNet.Impl.HttpRuntimeCache.this[string url] [get]

Gets a cached Solr response. Returns null if there is no cached response for this URL.

Parameters:
url Full Solr query URL (including all querystring parameters)
Returns:

Implements SolrNet.Impl.ISolrCache.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/HttpRuntimeCache.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.Adapters.HttpWebRequestAdapter Class Reference

  • HttpWebAdapters
  • Adapters
  • HttpWebRequestAdapter
Public Member Functions | Properties

HttpWebAdapters.Adapters.HttpWebRequestAdapter Class Reference

Inheritance diagram for HttpWebAdapters.Adapters.HttpWebRequestAdapter:
HttpWebAdapters.IHttpWebRequest

List of all members.

Public Member Functions

HttpWebRequestAdapter (HttpWebRequest request)
IHttpWebResponse | GetResponse ()
IAsyncResult | BeginGetResponse (AsyncCallback callback, object state)
IHttpWebResponse | EndGetResponse (IAsyncResult result)
IAsyncResult | BeginGetRequestStream (AsyncCallback callback, object state)
Stream | EndGetRequestStream (IAsyncResult result)
Stream | GetRequestStream ()
void | Abort ()
void | AddRange (int from, int to)
void | AddRange (int range)
void | AddRange (string rangeSpecifier, int from, int to)
void | AddRange (string rangeSpecifier, int range)

Properties

HttpWebRequestMethod | Method [get, set]
bool | AllowAutoRedirect [get, set]
bool | AllowWriteStreamBuffering [get, set]
bool | HaveResponse [get]
bool | KeepAlive [get, set]
bool | Pipelined [get, set]
bool | PreAuthenticate [get, set]
bool | UnsafeAuthenticatedConnectionSharing [get, set]
bool | SendChunked [get, set]
DecompressionMethods | AutomaticDecompression [get, set]
int | MaximumResponseHeadersLength [get, set]
X509CertificateCollection | ClientCertificates [get, set]
CookieContainer | CookieContainer [get, set]
Uri | RequestUri [get]
long | ContentLength [get, set]
int | Timeout [get, set]
int | ReadWriteTimeout [get, set]
Uri | Address [get]
ServicePoint | ServicePoint [get]
int | MaximumAutomaticRedirections [get, set]
ICredentials | Credentials [get, set]
bool | UseDefaultCredentials [get, set]
string | ConnectionGroupName [get, set]
WebHeaderCollection | Headers [get, set]
IWebProxy | Proxy [get, set]
Version | ProtocolVersion [get, set]
string | ContentType [get, set]
string | MediaType [get, set]
string | TransferEncoding [get, set]
string | Connection [get, set]
string | Accept [get, set]
string | Referer [get, set]
string | UserAgent [get, set]
string | Expect [get, set]
DateTime | IfModifiedSince [get, set]
Gets or sets the value of the If-Modified-Since HTTP header.

Member Function Documentation

void HttpWebAdapters.Adapters.HttpWebRequestAdapter.Abort ( )

summary> Adds a byte range header to the request for a specified range. /summary>

param name="to">The position at which to stop sending data.

param name="from">The position at which to start sending data.

exception cref="T:System.ArgumentException">rangeSpecifier is invalid.

exception cref="T:System.ArgumentOutOfRangeException">from is greater than to-or- from or to is less than 0.

exception cref="T:System.InvalidOperationException">The range header could not be added.

Implements HttpWebAdapters.IHttpWebRequest.

void HttpWebAdapters.Adapters.HttpWebRequestAdapter.AddRange | ( | string | rangeSpecifier,
 |  | int | range
 | ) |  |

summary> Gets or sets a value that indicates whether the request should follow redirection responses. /summary>

returns> true if the request should automatically follow redirection responses from the Internet resource; otherwise, false. The default value is true. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

void HttpWebAdapters.Adapters.HttpWebRequestAdapter.AddRange | ( | int | from,
 |  | int | to
 | ) |  |

summary> Adds a byte range header to a request for a specific range from the beginning or end of the requested data. /summary>

param name="range">The starting or ending point of the range.

exception cref="T:System.ArgumentException">rangeSpecifier is invalid.

exception cref="T:System.InvalidOperationException">The range header could not be added.

Implements HttpWebAdapters.IHttpWebRequest.

void HttpWebAdapters.Adapters.HttpWebRequestAdapter.AddRange ( int range )

summary> Adds a range header to a request for a specified range. /summary>

param name="from">The position at which to start sending data.

param name="to">The position at which to stop sending data.

param name="rangeSpecifier">The description of the range.

exception cref="T:System.ArgumentException">rangeSpecifier is invalid.

exception cref="T:System.ArgumentNullException">rangeSpecifier is null.

exception cref="T:System.ArgumentOutOfRangeException">from is greater than to-or- from or to is less than 0.

exception cref="T:System.InvalidOperationException">The range header could not be added.

Implements HttpWebAdapters.IHttpWebRequest.

void HttpWebAdapters.Adapters.HttpWebRequestAdapter.AddRange | ( | string | rangeSpecifier,
 |  | int | from,
 |  | int | to
 | ) |  |

summary> Adds a range header to a request for a specific range from the beginning or end of the requested data. /summary>

param name="range">The starting or ending point of the range.

param name="rangeSpecifier">The description of the range.

exception cref="T:System.ArgumentException">rangeSpecifier is invalid.

exception cref="T:System.ArgumentNullException">rangeSpecifier is null.

exception cref="T:System.InvalidOperationException">The range header could not be added.

Implements HttpWebAdapters.IHttpWebRequest.

Stream HttpWebAdapters.Adapters.HttpWebRequestAdapter.EndGetRequestStream ( IAsyncResult result )

summary> Gets a T:System.IO.Stream object to use to write request data. /summary>

returns> A T:System.IO.Stream to use to write request data. /returns>

exception cref="T:System.InvalidOperationException">The M:System.Net.HttpWebRequest.GetRequestStream method is called more than once.-or- P:System.Net.HttpWebRequest.TransferEncoding is set to a value and P:System.Net.HttpWebRequest.SendChunked is false.

exception cref="T:System.ObjectDisposedException">In a .NET Compact Framework application, a request stream with zero content length was not obtained and closed correctly. For more information about handling zero content length requests, see Network Programming in the .NET Compact Framework.

exception cref="T:System.Net.WebException">M:System.Net.HttpWebRequest.Abort was previously called.-or- The time-out period for the request expired.-or- An error occurred while processing the request.

exception cref="T:System.NotSupportedException">The request cache validator indicated that the response for this request can be served from the cache; however, requests that write data must not use the cache. This exception can occur if you are using a custom cache validator that is incorrectly implemented.

exception cref="T:System.Net.ProtocolViolationException">The P:System.Net.HttpWebRequest.Method property is GET or HEAD.-or- P:System.Net.HttpWebRequest.KeepAlive is true, P:System.Net.HttpWebRequest.AllowWriteStreamBuffering is false, P:System.Net.HttpWebRequest.ContentLength is -1, P:System.Net.HttpWebRequest.SendChunked is false, and P:System.Net.HttpWebRequest.Method is POST or PUT.

<PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Net.DnsPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Net.WebPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Diagnostics.PerformanceCounterPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

Stream HttpWebAdapters.Adapters.HttpWebRequestAdapter.GetRequestStream ( )

summary> Cancels a request to an Internet resource. /summary> PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

Property Documentation

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.Accept [get, set]

summary> Gets or sets the value of the Referer HTTP header. /summary>

returns> The value of the Referer HTTP header. The default value is null. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

Uri HttpWebAdapters.Adapters.HttpWebRequestAdapter.Address [get]

summary> Gets the service point to use for the request. /summary>

returns> A T:System.Net.ServicePoint that represents the network connection to the Internet resource. /returns> PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.AllowAutoRedirect [get, set]

summary> Gets or sets a value that indicates whether to buffer the data sent to the Internet resource. /summary>

returns> true to enable buffering of the data sent to the Internet resource; false to disable buffering. The default is true. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.AllowWriteStreamBuffering [get, set]

summary> Gets a value that indicates whether a response has been received from an Internet resource. /summary>

returns> true if a response has been received; otherwise, false. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

DecompressionMethods HttpWebAdapters.Adapters.HttpWebRequestAdapter.AutomaticDecompression [get, set]

summary> Gets or sets the maximum allowed length of the response headers. /summary>

returns> The length, in kilobytes (1024 bytes), of the response headers. /returns>

exception cref="T:System.InvalidOperationException">The property is set after the request has already been submitted.

exception cref="T:System.ArgumentOutOfRangeException">The value is less than 0 and is not equal to -1.

Implements HttpWebAdapters.IHttpWebRequest.

X509CertificateCollection HttpWebAdapters.Adapters.HttpWebRequestAdapter.ClientCertificates [get, set]

summary> Gets or sets the cookies associated with the request. /summary>

returns> A T:System.Net.CookieContainer that contains the cookies associated with this request. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.Connection [get, set]

summary> Gets or sets the value of the Accept HTTP header. /summary>

returns> The value of the Accept HTTP header. The default value is null. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.ConnectionGroupName [get, set]

summary> Specifies a collection of the name/value pairs that make up the HTTP headers. /summary>

returns> A T:System.Net.WebHeaderCollection that contains the name/value pairs that make up the headers for the HTTP request. /returns>

exception cref="T:System.InvalidOperationException">The request has been started by calling the M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object) method.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

long HttpWebAdapters.Adapters.HttpWebRequestAdapter.ContentLength [get, set]

summary> Gets or sets the time-out value for the M:System.Net.HttpWebRequest.GetResponse and M:System.Net.HttpWebRequest.GetRequestStream methods. /summary>

returns> The number of milliseconds to wait before the request times out. The default is 100,000 milliseconds (100 seconds). /returns>

exception cref="T:System.ArgumentOutOfRangeException">The value specified is less than zero and is not F:System.Threading.Timeout.Infinite.

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.ContentType [get, set]

summary> Gets or sets the media type of the request. /summary>

returns> The media type of the request. The default value is null. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

CookieContainer HttpWebAdapters.Adapters.HttpWebRequestAdapter.CookieContainer [get, set]

summary> Gets the original Uniform Resource Identifier (URI) of the request. /summary>

returns> A T:System.Uri that contains the URI of the Internet resource passed to the M:System.Net.WebRequest.Create(System.String) method. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

ICredentials HttpWebAdapters.Adapters.HttpWebRequestAdapter.Credentials [get, set]

summary> Gets or sets a T:System.Boolean value that controls whether default credentials are sent with requests. /summary>

returns> true if the default credentials are used; otherwise false. The default value is false. /returns>

exception cref="T:System.InvalidOperationException">You attempted to set this property after the request was sent.

<PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" read="USERNAME"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.Expect [get, set]

summary> Gets or sets the value of the If-Modified-Since HTTP header. /summary>

returns> A T:System.DateTime that contains the contents of the If-Modified-Since HTTP header. The default value is the current date and time. /returns> PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.HaveResponse [get]

summary> Gets or sets a value that indicates whether to make a persistent connection to the Internet resource. /summary>

returns> true if the request to the Internet resource should contain a Connection HTTP header with the value Keep-alive; otherwise, false. The default is true. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

WebHeaderCollection HttpWebAdapters.Adapters.HttpWebRequestAdapter.Headers [get, set]

summary> Gets or sets proxy information for the request. /summary>

returns> The T:System.Net.IWebProxy object to use to proxy the request. The default value is set by calling the P:System.Net.GlobalProxySelection.Select property. /returns>

exception cref="T:System.Security.SecurityException">The caller does not have permission for the requested operation.

exception cref="T:System.ArgumentNullException">P:System.Net.HttpWebRequest.Proxy is set to null.

exception cref="T:System.InvalidOperationException">The request has been started by calling M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object).

<PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"><IPermission class="System.Net.WebPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

DateTime HttpWebAdapters.Adapters.HttpWebRequestAdapter.IfModifiedSince [get, set]

Gets or sets the value of the If-Modified-Since HTTP header.

Returns:
A T:System.DateTime that contains the contents of the If-Modified-Since HTTP header. The default value is the current date and time.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.KeepAlive [get, set]

summary> Gets or sets a value that indicates whether to pipeline the request to the Internet resource. /summary>

returns> true if the request should be pipelined; otherwise, false. The default is true. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

int HttpWebAdapters.Adapters.HttpWebRequestAdapter.MaximumAutomaticRedirections [get, set]

summary> Gets or sets authentication information for the request. /summary>

returns> An T:System.Net.ICredentials that contains the authentication credentials associated with the request. The default is null. /returns> PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

int HttpWebAdapters.Adapters.HttpWebRequestAdapter.MaximumResponseHeadersLength [get, set]

summary> Gets or sets the collection of security certificates that are associated with this request. /summary>

returns> The T:System.Security.Cryptography.X509Certificates.X509CertificateCollection that contains the security certificates associated with this request. /returns>

exception cref="T:System.ArgumentNullException">The value specified for a set operation is null.

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.MediaType [get, set]

summary> Gets or sets the value of the Transfer-encoding HTTP header. /summary>

returns> The value of the Transfer-encoding HTTP header. The default value is null. /returns>

exception cref="T:System.InvalidOperationException">P:System.Net.HttpWebRequest.TransferEncoding is set when P:System.Net.HttpWebRequest.SendChunked is false.

exception cref="T:System.ArgumentException">P:System.Net.HttpWebRequest.TransferEncoding is set to the value "Chunked".

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.Pipelined [get, set]

summary> Gets or sets a value that indicates whether to send an authenticate header with the request. /summary>

returns> true to send a WWW-authenticate HTTP header with requests after authentication has taken place; otherwise, false. The default is false. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.PreAuthenticate [get, set]

summary> Gets or sets a value that indicates whether to allow high-speed NTLM-authenticated connection sharing. /summary>

returns> true to keep the authenticated connection open; otherwise, false. /returns> PermissionSet><IPermission class="System.Net.WebPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"></PermissionSet>

Implements HttpWebAdapters.IHttpWebRequest.

Version HttpWebAdapters.Adapters.HttpWebRequestAdapter.ProtocolVersion [get, set]

summary> Gets or sets the value of the Content-type HTTP header. /summary>

returns> The value of the Content-type HTTP header. The default value is null. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

IWebProxy HttpWebAdapters.Adapters.HttpWebRequestAdapter.Proxy [get, set]

summary> Gets or sets the version of HTTP to use for the request. /summary>

returns> The HTTP version to use for the request. The default is F:System.Net.HttpVersion.Version11. /returns>

exception cref="T:System.ArgumentException">The HTTP version is set to a value other than 1.0 or 1.1.

Implements HttpWebAdapters.IHttpWebRequest.

int HttpWebAdapters.Adapters.HttpWebRequestAdapter.ReadWriteTimeout [get, set]

summary> Gets the Uniform Resource Identifier (URI) of the Internet resource that actually responds to the request. /summary>

returns> A T:System.Uri that identifies the Internet resource that actually responds to the request. The default is the URI used by the M:System.Net.WebRequest.Create(System.String) method to initialize the request. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.Referer [get, set]

summary> Gets or sets the value of the User-agent HTTP header. /summary>

returns> The value of the User-agent HTTP header. The default value is null.The value for this property is stored in T:System.Net.WebHeaderCollection. If WebHeaderCollection is set, the property value is lost. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

Uri HttpWebAdapters.Adapters.HttpWebRequestAdapter.RequestUri [get]

summary> Gets or sets the Content-length HTTP header. /summary>

returns> The number of bytes of data to send to the Internet resource. The default is -1, which indicates the property has not been set and that there is no request data to send. /returns>

exception cref="T:System.ArgumentOutOfRangeException">The new P:System.Net.HttpWebRequest.ContentLength value is less than 0.

exception cref="T:System.InvalidOperationException">The request has been started by calling the M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object) method.

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.SendChunked [get, set]

summary> Gets or sets the type of decompression that is used. /summary>

returns> A T:System.Net.DecompressionMethods object that indicates the type of decompression that is used. /returns>

exception cref="T:System.InvalidOperationException">The object's current state does not allow this property to be set.

Implements HttpWebAdapters.IHttpWebRequest.

ServicePoint HttpWebAdapters.Adapters.HttpWebRequestAdapter.ServicePoint [get]

summary> Gets or sets the maximum number of redirects that the request follows. /summary>

returns> The maximum number of redirection responses that the request follows. The default value is 50. /returns>

exception cref="T:System.ArgumentException">The value is set to 0 or less.

Implements HttpWebAdapters.IHttpWebRequest.

int HttpWebAdapters.Adapters.HttpWebRequestAdapter.Timeout [get, set]

summary> Gets or sets a time-out when writing to or reading from a stream. /summary>

returns> The number of milliseconds before the writing or reading times out. The default value is 300,000 milliseconds (5 minutes). /returns>

exception cref="T:System.ArgumentOutOfRangeException">The value specified for a set operation is less than or equal to zero and is not equal to F:System.Threading.Timeout.Infinite

exception cref="T:System.InvalidOperationException">The request has already been sent.

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.TransferEncoding [get, set]

summary> Gets or sets the value of the Connection HTTP header. /summary>

returns> The value of the Connection HTTP header. The default value is null. /returns>

exception cref="T:System.ArgumentException">The value of P:System.Net.HttpWebRequest.Connection is set to Keep-alive or Close.

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.UnsafeAuthenticatedConnectionSharing [get, set]

summary> Gets or sets a value that indicates whether to send data in segments to the Internet resource. /summary>

returns> true to send data to the Internet resource in segments; otherwise, false. The default value is false. /returns>

exception cref="T:System.InvalidOperationException">The request has been started by calling the M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object) method.

Implements HttpWebAdapters.IHttpWebRequest.

bool HttpWebAdapters.Adapters.HttpWebRequestAdapter.UseDefaultCredentials [get, set]

summary> Gets or sets the name of the connection group for the request. /summary>

returns> The name of the connection group for this request. The default value is null. /returns>

Implements HttpWebAdapters.IHttpWebRequest.

string HttpWebAdapters.Adapters.HttpWebRequestAdapter.UserAgent [get, set]

summary> Gets or sets the value of the Expect HTTP header. /summary>

returns> The contents of the Expect HTTP header. The default value is null.The value for this property is stored in T:System.Net.WebHeaderCollection. If WebHeaderCollection is set, the property value is lost. /returns>

exception cref="T:System.ArgumentException">Expect is set to a string that contains "100-continue" as a substring.

Implements HttpWebAdapters.IHttpWebRequest.

The documentation for this class was generated from the following file:
  • HttpWebAdapters/Impl/HttpWebRequestAdapter.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.HttpWebRequestFactory Class Reference

  • HttpWebAdapters
  • HttpWebRequestFactory
Public Member Functions

HttpWebAdapters.HttpWebRequestFactory Class Reference

Inheritance diagram for HttpWebAdapters.HttpWebRequestFactory:
HttpWebAdapters.IHttpWebRequestFactory

List of all members.

Public Member Functions

IHttpWebRequest | Create (string url)
IHttpWebRequest | Create (Uri url)
The documentation for this class was generated from the following file:
  • HttpWebAdapters/Impl/HttpWebRequestFactory.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.HttpWebRequestMethod Class Reference

  • HttpWebAdapters
  • HttpWebRequestMethod
Public Member Functions | Static Public Member Functions | Static Public Attributes

HttpWebAdapters.HttpWebRequestMethod Class Reference

List of all members.

Public Member Functions

override string | ToString ()

Static Public Member Functions

static HttpWebRequestMethod | Parse (string s)

Static Public Attributes

static readonly
HttpWebRequestMethod 		GET = new HttpWebRequestMethod(SGET)
static readonly
HttpWebRequestMethod 		POST = new HttpWebRequestMethod(SPOST)
The documentation for this class was generated from the following file:
  • HttpWebAdapters/Impl/HttpWebRequestMethod.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.Adapters.HttpWebResponseAdapter Class Reference

  • HttpWebAdapters
  • Adapters
  • HttpWebResponseAdapter
Public Member Functions | Properties

HttpWebAdapters.Adapters.HttpWebResponseAdapter Class Reference

Inheritance diagram for HttpWebAdapters.Adapters.HttpWebResponseAdapter:
HttpWebAdapters.IHttpWebResponse

List of all members.

Public Member Functions

HttpWebResponseAdapter (WebResponse response)
string | GetResponseHeader (string headerName)
Gets the contents of a header that was returned with the response.
void | Close ()
When overridden by a descendant class, closes the response stream.
Stream | GetResponseStream ()
When overridden in a descendant class, returns the data stream from the Internet resource.
void | Dispose ()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Properties

CookieCollection | Cookies [get, set]
Gets or sets the cookies that are associated with this response.
string | ContentEncoding [get]
Gets the method that is used to encode the body of the response.
string | CharacterSet [get]
Gets the character set of the response.
string | Server [get]
Gets the name of the server that sent the response.
DateTime | LastModified [get]
Gets the last date and time that the contents of the response were modified.
HttpStatusCode | StatusCode [get]
Gets the status of the response.
string | StatusDescription [get]
Gets the status description returned with the response.
Version | ProtocolVersion [get]
Gets the version of the HTTP protocol that is used in the response.
string | Method [get]
Gets the method that is used to return the response.
bool | IsFromCache [get]
Gets a T:System.Boolean value that indicates whether this response was obtained from the cache.
bool | IsMutuallyAuthenticated [get]
Gets a T:System.Boolean value that indicates whether mutual authentication occurred.
long | ContentLength [get, set]
When overridden in a descendant class, gets or sets the content length of data being received.
string | ContentType [get, set]
When overridden in a derived class, gets or sets the content type of the data being received.
Uri | ResponseUri [get]
When overridden in a derived class, gets the URI of the Internet resource that actually responded to the request.
WebHeaderCollection | Headers [get]
When overridden in a derived class, gets a collection of header name-value pairs associated with this request.

Member Function Documentation

void HttpWebAdapters.Adapters.HttpWebResponseAdapter.Close ( )

When overridden by a descendant class, closes the response stream.

Exceptions:
T:System.NotSupportedException Any attempt is made to access the method, when the method is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

void HttpWebAdapters.Adapters.HttpWebResponseAdapter.Dispose ( )

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

<filterpriority>2</filterpriority>

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.GetResponseHeader ( string headerName )

Gets the contents of a header that was returned with the response.

Returns:
The contents of the specified header.
Parameters:
headerName The header value to return.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

Stream HttpWebAdapters.Adapters.HttpWebResponseAdapter.GetResponseStream ( )

When overridden in a descendant class, returns the data stream from the Internet resource.

Returns:
An instance of the T:System.IO.Stream class for reading data from the Internet resource.
Exceptions:
T:System.NotSupportedException Any attempt is made to access the method, when the method is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

Property Documentation

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.CharacterSet [get]

Gets the character set of the response.

Returns:
A string that contains the character set of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.ContentEncoding [get]

Gets the method that is used to encode the body of the response.

Returns:
A string that describes the method that is used to encode the body of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

long HttpWebAdapters.Adapters.HttpWebResponseAdapter.ContentLength [get, set]

When overridden in a descendant class, gets or sets the content length of data being received.

Returns:
The number of bytes returned from the Internet resource.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.ContentType [get, set]

When overridden in a derived class, gets or sets the content type of the data being received.

Returns:
A string that contains the content type of the response.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

CookieCollection HttpWebAdapters.Adapters.HttpWebResponseAdapter.Cookies [get, set]

Gets or sets the cookies that are associated with this response.

Returns:
A T:System.Net.CookieCollection that contains the cookies that are associated with this response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

WebHeaderCollection HttpWebAdapters.Adapters.HttpWebResponseAdapter.Headers [get]

When overridden in a derived class, gets a collection of header name-value pairs associated with this request.

Returns:
An instance of the T:System.Net.WebHeaderCollection class that contains header values associated with this response.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

bool HttpWebAdapters.Adapters.HttpWebResponseAdapter.IsFromCache [get]

Gets a T:System.Boolean value that indicates whether this response was obtained from the cache.

Returns:
true if the response was taken from the cache; otherwise, false.

Implements HttpWebAdapters.IHttpWebResponse.

bool HttpWebAdapters.Adapters.HttpWebResponseAdapter.IsMutuallyAuthenticated [get]

Gets a T:System.Boolean value that indicates whether mutual authentication occurred.

Returns:
true if both client and server were authenticated; otherwise, false.

Implements HttpWebAdapters.IHttpWebResponse.

DateTime HttpWebAdapters.Adapters.HttpWebResponseAdapter.LastModified [get]

Gets the last date and time that the contents of the response were modified.

Returns:
A T:System.DateTime that contains the date and time that the contents of the response were modified.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.Method [get]

Gets the method that is used to return the response.

Returns:
A string that contains the HTTP method that is used to return the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

Version HttpWebAdapters.Adapters.HttpWebResponseAdapter.ProtocolVersion [get]

Gets the version of the HTTP protocol that is used in the response.

Returns:
A T:System.Version that contains the HTTP protocol version of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

Uri HttpWebAdapters.Adapters.HttpWebResponseAdapter.ResponseUri [get]

When overridden in a derived class, gets the URI of the Internet resource that actually responded to the request.

Returns:
An instance of the T:System.Uri class that contains the URI of the Internet resource that actually responded to the request.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.Server [get]

Gets the name of the server that sent the response.

Returns:
A string that contains the name of the server that sent the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

HttpStatusCode HttpWebAdapters.Adapters.HttpWebResponseAdapter.StatusCode [get]

Gets the status of the response.

Returns:
One of the T:System.Net.HttpStatusCode values.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.Adapters.HttpWebResponseAdapter.StatusDescription [get]

Gets the status description returned with the response.

Returns:
A string that describes the status of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

The documentation for this class was generated from the following file:
  • HttpWebAdapters/Impl/HttpWebResponseAdapter.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.Impl.ICommitSetting Interface Reference

  • NHibernate
  • SolrNet
  • Impl
  • ICommitSetting
Properties

NHibernate.SolrNet.Impl.ICommitSetting Interface Reference

Inheritance diagram for NHibernate.SolrNet.Impl.ICommitSetting:
NHibernate.SolrNet.Impl.SolrNetListener< T >

List of all members.

Properties

bool Commit [get, set]
Automatically commit Solr after each update.

Property Documentation

bool NHibernate.SolrNet.Impl.ICommitSetting.Commit [get, set]

Automatically commit Solr after each update.

Implemented in NHibernate.SolrNet.Impl.SolrNetListener< T >.

The documentation for this interface was generated from the following file:
  • NHibernate.SolrNet/Impl/ICommitSetting.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Utils.IContainer Interface Reference

  • SolrNet
  • Utils
  • IContainer
Public Member Functions

SolrNet.Utils.IContainer Interface Reference

Interface for the built-in DI container. More...

Inheritance diagram for SolrNet.Utils.IContainer:
SolrNet.Utils.Container

List of all members.

Public Member Functions

void | Register< T > (Converter< IContainer, T > factory)
Adds a component implementing T Component key is T 's Type.FullName
void | Register< T > (string key, Converter< IContainer, T > factory)
Adds a component implementing T with the specified key.
void | Register (string key, Type serviceType, Converter< IContainer, object > factory)
Adds a component.
void | RemoveAll< T > ()
Removes all components with service type T
void | Remove< T > ()
Removes the default component for service type T
void | Remove< T > (string key)
Removes the component with key key implementing service type T
void | Remove (string key, Type serviceType)
Removes the component with key key implementing service type serviceType

Detailed Description

Interface for the built-in DI container.

Member Function Documentation

void SolrNet.Utils.IContainer.Register | ( | string | key,
 |  | Type | serviceType,
 |  | Converter< IContainer, object > | factory
 | ) |  |

Adds a component.

Parameters:
key | Component key
serviceType | Component service type
factory | Component factory method. Must return serviceType or a descendant

Implemented in SolrNet.Utils.Container.

void SolrNet.Utils.IContainer.Register< T > | ( | string | key,
 |  | Converter< IContainer, T > | factory
 | ) |  |

Adds a component implementing T with the specified key.

Template Parameters:
T Service type
Parameters:
factory | Component factory method
key | Component key

Implemented in SolrNet.Utils.Container.

void SolrNet.Utils.IContainer.Register< T > ( Converter< IContainer, T > factory )

Adds a component implementing T Component key is T 's Type.FullName

Template Parameters:
T Service type
Parameters:
factory Component factory method

Implemented in SolrNet.Utils.Container.

void SolrNet.Utils.IContainer.Remove | ( | string | key,
 |  | Type | serviceType
 | ) |  |

Removes the component with key key implementing service type serviceType

Parameters:
key | Component key
serviceType | Service type

Implemented in SolrNet.Utils.Container.

void SolrNet.Utils.IContainer.Remove< T > ( )

Removes the default component for service type T

Template Parameters:
T Service type

Implemented in SolrNet.Utils.Container.

void SolrNet.Utils.IContainer.Remove< T > ( string key )

Removes the component with key key implementing service type T

Template Parameters:
T Service type
Parameters:
key Component key

Implemented in SolrNet.Utils.Container.

void SolrNet.Utils.IContainer.RemoveAll< T > ( )

Removes all components with service type T

Template Parameters:
T Service type

Implemented in SolrNet.Utils.Container.

The documentation for this interface was generated from the following file:
  • SolrNet/Utils/IContainer.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > Interface Template Reference

  • SolrNet
  • DSL
  • Impl
  • IDSLFacetFieldOptions
Public Member Functions

SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > Interface Template Reference

Inheritance diagram for SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >:
SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.DSLFacetFieldOptions< T >

List of all members.

Public Member Functions

IDSLFacetFieldOptions< T > | LimitTo (int limit)
Maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.
IDSLFacetFieldOptions< T > | DontSortByCount ()
Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.
IDSLFacetFieldOptions< T > | WithPrefix (string prefix)
Limits the terms on which to facet to those starting with the given string prefix.
IDSLFacetFieldOptions< T > | WithMinCount (int count)
Minimum counts for facet fields that should be included in the response. The default value is 0.
IDSLFacetFieldOptions< T > | StartingAt (int offset)
Indicates an offset into the list of constraints to allow paging. The default value is 0.
IDSLFacetFieldOptions< T > | IncludeMissing ()
Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.

template<T>
interface SolrNet::DSL::Impl::IDSLFacetFieldOptions< T >

Member Function Documentation

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.DontSortByCount ( )

Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.

Implemented in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.IncludeMissing ( )

Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.

Implemented in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.LimitTo ( int limit )

Maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.

Implemented in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.StartingAt ( int offset )

Indicates an offset into the list of constraints to allow paging. The default value is 0.

Implemented in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.WithMinCount ( int count )

Minimum counts for facet fields that should be included in the response. The default value is 0.

Implemented in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.

template<T >
IDSLFacetFieldOptions<T> SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >.WithPrefix ( string prefix )

Limits the terms on which to facet to those starting with the given string prefix.

Implemented in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >.

The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Impl/IDSLFacetFieldOptions.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.IDSLQuery< T > Interface Template Reference

  • SolrNet
  • DSL
  • Impl
  • IDSLQuery
Public Member Functions

SolrNet.DSL.Impl.IDSLQuery< T > Interface Template Reference

Inheritance diagram for SolrNet.DSL.Impl.IDSLQuery< T >:
SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.DSLQuery< T > SolrNet.DSL.Impl.IDSLQueryRange< T > SolrNet.DSL.Impl.DSLQueryRange< T, RT > SolrNet.DSL.Impl.DSLQueryRange< T, RT >

List of all members.

Public Member Functions

IDSLQueryRange< T > | ByRange< RT > (string fieldName, RT from, RT to)
IDSLQueryBy< T > | By (string fieldName)

template<T>
interface SolrNet::DSL::Impl::IDSLQuery< T >

The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Impl/IDSLQuery.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.IDSLQueryBetween< T, RT > Interface Template Reference

  • SolrNet
  • DSL
  • Impl
  • IDSLQueryBetween
Public Member Functions

SolrNet.DSL.Impl.IDSLQueryBetween< T, RT > Interface Template Reference

Inheritance diagram for SolrNet.DSL.Impl.IDSLQueryBetween< T, RT >:
SolrNet.DSL.Impl.DSLQueryBetween< T, RT >

List of all members.

Public Member Functions

IDSLQuery< T > And (RT i)

template<T, RT>
interface SolrNet::DSL::Impl::IDSLQueryBetween< T, RT >

The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Impl/IDSLQueryBetween.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.IDSLQueryBy< T > Interface Template Reference

  • SolrNet
  • DSL
  • Impl
  • IDSLQueryBy
Public Member Functions

SolrNet.DSL.Impl.IDSLQueryBy< T > Interface Template Reference

Inheritance diagram for SolrNet.DSL.Impl.IDSLQueryBy< T >:
SolrNet.DSL.Impl.DSLQueryBy< T >

List of all members.

Public Member Functions

IDSLQuery< T > | Is (string s)
IDSLQueryBetween< T, RT > | Between< RT > (RT i)

template<T>
interface SolrNet::DSL::Impl::IDSLQueryBy< T >

The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Impl/IDSLQueryBy.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.IDSLQueryRange< T > Interface Template Reference

  • SolrNet
  • DSL
  • Impl
  • IDSLQueryRange
Public Member Functions

SolrNet.DSL.Impl.IDSLQueryRange< T > Interface Template Reference

Inheritance diagram for SolrNet.DSL.Impl.IDSLQueryRange< T >:
SolrNet.DSL.Impl.IDSLQuery< T > SolrNet.DSL.Impl.IDSLRun< T > SolrNet.DSL.Impl.DSLQueryRange< T, RT >

List of all members.

Public Member Functions

IDSLQuery< T > | Exclusive ()
IDSLQuery< T > | Inclusive ()

template<T>
interface SolrNet::DSL::Impl::IDSLQueryRange< T >

The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Impl/IDSLQueryRange.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.IDSLRun< T > Interface Template Reference

  • SolrNet
  • DSL
  • Impl
  • IDSLRun
Public Member Functions

SolrNet.DSL.Impl.IDSLRun< T > Interface Template Reference

Inheritance diagram for SolrNet.DSL.Impl.IDSLRun< T >:
SolrNet.DSL.Impl.DSLRun< T > SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > SolrNet.DSL.Impl.IDSLQuery< T > SolrNet.DSL.Impl.DSLFacetFieldOptions< T > SolrNet.DSL.Impl.DSLQuery< T > SolrNet.DSL.Impl.DSLFacetFieldOptions< T > SolrNet.DSL.Impl.DSLQuery< T > SolrNet.DSL.Impl.IDSLQueryRange< T > SolrNet.DSL.Impl.DSLQueryRange< T, RT > SolrNet.DSL.Impl.DSLQueryRange< T, RT > SolrNet.DSL.Impl.DSLQueryRange< T, RT >

List of all members.

Public Member Functions

ISolrQueryResults< T > | Run ()
ISolrQueryResults< T > | Run (int start, int rows)
IDSLRun< T > | OrderBy (string fieldName)
IDSLRun< T > | OrderBy (string fieldName, Order o)
IDSLFacetFieldOptions< T > | WithFacetField (string fieldName)
IDSLRun< T > | WithFacetQuery (string query)
IDSLRun< T > | WithFacetQuery (ISolrQuery query)
IDSLRun< T > | WithHighlighting (HighlightingParameters parameters)
IDSLRun< T > | WithHighlightingFields (params string[] fields)

template<T>
interface SolrNet::DSL::Impl::IDSLRun< T >

The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Impl/IDSLRun.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.IHttpWebRequest Interface Reference

  • HttpWebAdapters
  • IHttpWebRequest
Public Member Functions | Properties

HttpWebAdapters.IHttpWebRequest Interface Reference

Inheritance diagram for HttpWebAdapters.IHttpWebRequest:
HttpWebAdapters.Adapters.HttpWebRequestAdapter

List of all members.

Public Member Functions

IHttpWebResponse | GetResponse ()
Stream | GetRequestStream ()
Gets a Stream object to use to write request data.
void | Abort ()
Cancels a request to an Internet resource.
void | AddRange (int from, int to)
Adds a byte range header to the request for a specified range.
void | AddRange (int range)
Adds a byte range header to a request for a specific range from the beginning or end of the requested data.
void | AddRange (string rangeSpecifier, int from, int to)
Adds a range header to a request for a specified range.
void | AddRange (string rangeSpecifier, int range)
Adds a range header to a request for a specific range from the beginning or end of the requested data.
IAsyncResult | BeginGetResponse (AsyncCallback callback, object state)
IHttpWebResponse | EndGetResponse (IAsyncResult result)
IAsyncResult | BeginGetRequestStream (AsyncCallback callback, object state)
Stream | EndGetRequestStream (IAsyncResult result)

Properties

HttpWebRequestMethod | Method [get, set]
bool | AllowAutoRedirect [get, set]
Gets or sets a value that indicates whether the request should follow redirection responses.
bool | AllowWriteStreamBuffering [get, set]
Gets or sets a value that indicates whether to buffer the data sent to the Internet resource.
bool | HaveResponse [get]
Gets a value that indicates whether a response has been received from an Internet resource.
bool | KeepAlive [get, set]
Gets or sets a value that indicates whether to make a persistent connection to the Internet resource.
bool | Pipelined [get, set]
Gets or sets a value that indicates whether to pipeline the request to the Internet resource.
bool | PreAuthenticate [get, set]
Gets or sets a value that indicates whether to send an authenticate header with the request.
bool | UnsafeAuthenticatedConnectionSharing [get, set]
Gets or sets a value that indicates whether to allow high-speed NTLM-authenticated connection sharing.
bool | SendChunked [get, set]
Gets or sets a value that indicates whether to send data in segments to the Internet resource.
DecompressionMethods | AutomaticDecompression [get, set]
Gets or sets the type of decompression that is used.
int | MaximumResponseHeadersLength [get, set]
Gets or sets the maximum allowed length of the response headers.
X509CertificateCollection | ClientCertificates [get, set]
Gets or sets the collection of security certificates that are associated with this request.
CookieContainer | CookieContainer [get, set]
Gets or sets the cookies associated with the request.
Uri | RequestUri [get]
Gets the original Uniform Resource Identifier (URI) of the request.
long | ContentLength [get, set]
Gets or sets the Content-length HTTP header.
int | Timeout [get, set]
Gets or sets the time-out value for the M:System.Net.HttpWebRequest.GetResponse and M:System.Net.HttpWebRequest.GetRequestStream methods.
int | ReadWriteTimeout [get, set]
Gets or sets a time-out when writing to or reading from a stream.
Uri | Address [get]
Gets the Uniform Resource Identifier (URI) of the Internet resource that actually responds to the request.
ServicePoint | ServicePoint [get]
Gets the service point to use for the request.
int | MaximumAutomaticRedirections [get, set]
Gets or sets the maximum number of redirects that the request follows.
ICredentials | Credentials [get, set]
Gets or sets authentication information for the request.
bool | UseDefaultCredentials [get, set]
Gets or sets a T:System.Boolean value that controls whether default credentials are sent with requests.
string | ConnectionGroupName [get, set]
Gets or sets the name of the connection group for the request.
WebHeaderCollection | Headers [get, set]
Specifies a collection of the name/value pairs that make up the HTTP headers.
IWebProxy | Proxy [get, set]
Gets or sets proxy information for the request.
Version | ProtocolVersion [get, set]
Gets or sets the version of HTTP to use for the request.
string | ContentType [get, set]
Gets or sets the value of the Content-type HTTP header.
string | MediaType [get, set]
Gets or sets the media type of the request.
string | TransferEncoding [get, set]
Gets or sets the value of the Transfer-encoding HTTP header.
string | Connection [get, set]
Gets or sets the value of the Connection HTTP header.
string | Accept [get, set]
Gets or sets the value of the Accept HTTP header.
string | Referer [get, set]
Gets or sets the value of the Referer HTTP header.
string | UserAgent [get, set]
Gets or sets the value of the User-agent HTTP header.
string | Expect [get, set]
Gets or sets the value of the Expect HTTP header.
DateTime | IfModifiedSince [get, set]
Gets or sets the value of the If-Modified-Since HTTP header.

Member Function Documentation

void HttpWebAdapters.IHttpWebRequest.Abort ( )

Cancels a request to an Internet resource.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

void HttpWebAdapters.IHttpWebRequest.AddRange | ( | int | from,
 |  | int | to
 | ) |  |

Adds a byte range header to the request for a specified range.

Parameters:
to | The position at which to stop sending data.
from | The position at which to start sending data.
Exceptions:
ArgumentException | rangeSpecifier is invalid.
ArgumentOutOfRangeException | from is greater than to-or- from or to is less than 0.
InvalidOperationException | The range header could not be added.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

void HttpWebAdapters.IHttpWebRequest.AddRange ( int range )

Adds a byte range header to a request for a specific range from the beginning or end of the requested data.

Parameters:
range The starting or ending point of the range.
Exceptions:
T:System.ArgumentException | rangeSpecifier is invalid.
T:System.InvalidOperationException | The range header could not be added.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

void HttpWebAdapters.IHttpWebRequest.AddRange | ( | string | rangeSpecifier,
 |  | int | from,
 |  | int | to
 | ) |  |

Adds a range header to a request for a specified range.

Parameters:
from | The position at which to start sending data.
to | The position at which to stop sending data.
rangeSpecifier | The description of the range.
Exceptions:
T:System.ArgumentException | rangeSpecifier is invalid.
T:System.ArgumentNullException | rangeSpecifier is null.
T:System.ArgumentOutOfRangeException | from is greater than to-or- from or to is less than 0.
T:System.InvalidOperationException | The range header could not be added.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

void HttpWebAdapters.IHttpWebRequest.AddRange | ( | string | rangeSpecifier,
 |  | int | range
 | ) |  |

Adds a range header to a request for a specific range from the beginning or end of the requested data.

Parameters:
range | The starting or ending point of the range.
rangeSpecifier | The description of the range.
Exceptions:
T:System.ArgumentException | rangeSpecifier is invalid.
T:System.ArgumentNullException | rangeSpecifier is null.
T:System.InvalidOperationException | The range header could not be added.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

Stream HttpWebAdapters.IHttpWebRequest.GetRequestStream ( )

Gets a Stream object to use to write request data.

Returns:
A Stream to use to write request data.
Exceptions:
InvalidOperationException | The GetRequestStream method is called more than once.-or- TransferEncoding is set to a value and SendChunked is false.
ObjectDisposedException | In a .NET Compact Framework application, a request stream with zero content length was not obtained and closed correctly. For more information about handling zero content length requests, see Network Programming in the .NET Compact Framework.
WebException | Abort was previously called.-or- The time-out period for the request expired.-or- An error occurred while processing the request.
NotSupportedException | The request cache validator indicated that the response for this request can be served from the cache; however, requests that write data must not use the cache. This exception can occur if you are using a custom cache validator that is incorrectly implemented.
ProtocolViolationException | The Method property is GET or HEAD.-or- KeepAlive is true, AllowWriteStreamBuffering is false, ContentLength is -1, SendChunked is false, and Method is POST or PUT.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

Property Documentation

string HttpWebAdapters.IHttpWebRequest.Accept [get, set]

Gets or sets the value of the Accept HTTP header.

Returns:
The value of the Accept HTTP header. The default value is null.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

Uri HttpWebAdapters.IHttpWebRequest.Address [get]

Gets the Uniform Resource Identifier (URI) of the Internet resource that actually responds to the request.

Returns:
A T:System.Uri that identifies the Internet resource that actually responds to the request. The default is the URI used by the M:System.Net.WebRequest.Create(System.String) method to initialize the request.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.AllowAutoRedirect [get, set]

Gets or sets a value that indicates whether the request should follow redirection responses.

Returns:
true if the request should automatically follow redirection responses from the Internet resource; otherwise, false. The default value is true.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.AllowWriteStreamBuffering [get, set]

Gets or sets a value that indicates whether to buffer the data sent to the Internet resource.

Returns:
true to enable buffering of the data sent to the Internet resource; false to disable buffering. The default is true.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

DecompressionMethods HttpWebAdapters.IHttpWebRequest.AutomaticDecompression [get, set]

Gets or sets the type of decompression that is used.

Returns:
A T:System.Net.DecompressionMethods object that indicates the type of decompression that is used.
Exceptions:
T:System.InvalidOperationException The object's current state does not allow this property to be set.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

X509CertificateCollection HttpWebAdapters.IHttpWebRequest.ClientCertificates [get, set]

Gets or sets the collection of security certificates that are associated with this request.

Returns:
The T:System.Security.Cryptography.X509Certificates.X509CertificateCollection that contains the security certificates associated with this request.
Exceptions:
T:System.ArgumentNullException The value specified for a set operation is null.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.Connection [get, set]

Gets or sets the value of the Connection HTTP header.

Returns:
The value of the Connection HTTP header. The default value is null.
Exceptions:
T:System.ArgumentException The value of P:System.Net.HttpWebRequest.Connection is set to Keep-alive or Close.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.ConnectionGroupName [get, set]

Gets or sets the name of the connection group for the request.

Returns:
The name of the connection group for this request. The default value is null.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

long HttpWebAdapters.IHttpWebRequest.ContentLength [get, set]

Gets or sets the Content-length HTTP header.

Returns:
The number of bytes of data to send to the Internet resource. The default is -1, which indicates the property has not been set and that there is no request data to send.
Exceptions:
T:System.ArgumentOutOfRangeException | The new P:System.Net.HttpWebRequest.ContentLength value is less than 0.
T:System.InvalidOperationException | The request has been started by calling the M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object) method.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.ContentType [get, set]

Gets or sets the value of the Content-type HTTP header.

Returns:
The value of the Content-type HTTP header. The default value is null.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

CookieContainer HttpWebAdapters.IHttpWebRequest.CookieContainer [get, set]

Gets or sets the cookies associated with the request.

Returns:
A T:System.Net.CookieContainer that contains the cookies associated with this request.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

ICredentials HttpWebAdapters.IHttpWebRequest.Credentials [get, set]

Gets or sets authentication information for the request.

Returns:
An T:System.Net.ICredentials that contains the authentication credentials associated with the request. The default is null.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.Expect [get, set]

Gets or sets the value of the Expect HTTP header.

Returns:
The contents of the Expect HTTP header. The default value is null.The value for this property is stored in T:System.Net.WebHeaderCollection. If WebHeaderCollection is set, the property value is lost.
Exceptions:
T:System.ArgumentException Expect is set to a string that contains "100-continue" as a substring.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.HaveResponse [get]

Gets a value that indicates whether a response has been received from an Internet resource.

Returns:
true if a response has been received; otherwise, false.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

WebHeaderCollection HttpWebAdapters.IHttpWebRequest.Headers [get, set]

Specifies a collection of the name/value pairs that make up the HTTP headers.

Returns:
A T:System.Net.WebHeaderCollection that contains the name/value pairs that make up the headers for the HTTP request.
Exceptions:
T:System.InvalidOperationException The request has been started by calling the M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object) method.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

DateTime HttpWebAdapters.IHttpWebRequest.IfModifiedSince [get, set]

Gets or sets the value of the If-Modified-Since HTTP header.

Returns:
A T:System.DateTime that contains the contents of the If-Modified-Since HTTP header. The default value is the current date and time.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.KeepAlive [get, set]

Gets or sets a value that indicates whether to make a persistent connection to the Internet resource.

Returns:
true if the request to the Internet resource should contain a Connection HTTP header with the value Keep-alive; otherwise, false. The default is true.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

int HttpWebAdapters.IHttpWebRequest.MaximumAutomaticRedirections [get, set]

Gets or sets the maximum number of redirects that the request follows.

Returns:
The maximum number of redirection responses that the request follows. The default value is 50.
Exceptions:
T:System.ArgumentException The value is set to 0 or less.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

int HttpWebAdapters.IHttpWebRequest.MaximumResponseHeadersLength [get, set]

Gets or sets the maximum allowed length of the response headers.

Returns:
The length, in kilobytes (1024 bytes), of the response headers.
Exceptions:
T:System.InvalidOperationException | The property is set after the request has already been submitted.
T:System.ArgumentOutOfRangeException | The value is less than 0 and is not equal to -1.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.MediaType [get, set]

Gets or sets the media type of the request.

Returns:
The media type of the request. The default value is null.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.Pipelined [get, set]

Gets or sets a value that indicates whether to pipeline the request to the Internet resource.

Returns:
true if the request should be pipelined; otherwise, false. The default is true.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.PreAuthenticate [get, set]

Gets or sets a value that indicates whether to send an authenticate header with the request.

Returns:
true to send a WWW-authenticate HTTP header with requests after authentication has taken place; otherwise, false. The default is false.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

Version HttpWebAdapters.IHttpWebRequest.ProtocolVersion [get, set]

Gets or sets the version of HTTP to use for the request.

Returns:
The HTTP version to use for the request. The default is F:System.Net.HttpVersion.Version11.
Exceptions:
T:System.ArgumentException The HTTP version is set to a value other than 1.0 or 1.1.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

IWebProxy HttpWebAdapters.IHttpWebRequest.Proxy [get, set]

Gets or sets proxy information for the request.

Returns:
The T:System.Net.IWebProxy object to use to proxy the request. The default value is set by calling the P:System.Net.GlobalProxySelection.Select property.
Exceptions:
T:System.Security.SecurityException | The caller does not have permission for the requested operation.
T:System.ArgumentNullException | P:System.Net.HttpWebRequest.Proxy is set to null.
T:System.InvalidOperationException | The request has been started by calling M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object).

<PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"><IPermission class="System.Net.WebPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

int HttpWebAdapters.IHttpWebRequest.ReadWriteTimeout [get, set]

Gets or sets a time-out when writing to or reading from a stream.

Returns:
The number of milliseconds before the writing or reading times out. The default value is 300,000 milliseconds (5 minutes).
Exceptions:
T:System.ArgumentOutOfRangeException | The value specified for a set operation is less than or equal to zero and is not equal to F:System.Threading.Timeout.Infinite
T:System.InvalidOperationException | The request has already been sent.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.Referer [get, set]

Gets or sets the value of the Referer HTTP header.

Returns:
The value of the Referer HTTP header. The default value is null.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

Uri HttpWebAdapters.IHttpWebRequest.RequestUri [get]

Gets the original Uniform Resource Identifier (URI) of the request.

Returns:
A T:System.Uri that contains the URI of the Internet resource passed to the M:System.Net.WebRequest.Create(System.String) method.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.SendChunked [get, set]

Gets or sets a value that indicates whether to send data in segments to the Internet resource.

Returns:
true to send data to the Internet resource in segments; otherwise, false. The default value is false.
Exceptions:
T:System.InvalidOperationException The request has been started by calling the M:System.Net.HttpWebRequest.GetRequestStream, M:System.Net.HttpWebRequest.BeginGetRequestStream(System.AsyncCallback,System.Object), M:System.Net.HttpWebRequest.GetResponse, or M:System.Net.HttpWebRequest.BeginGetResponse(System.AsyncCallback,System.Object) method.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

ServicePoint HttpWebAdapters.IHttpWebRequest.ServicePoint [get]

Gets the service point to use for the request.

Returns:
A T:System.Net.ServicePoint that represents the network connection to the Internet resource.

<PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

int HttpWebAdapters.IHttpWebRequest.Timeout [get, set]

Gets or sets the time-out value for the M:System.Net.HttpWebRequest.GetResponse and M:System.Net.HttpWebRequest.GetRequestStream methods.

Returns:
The number of milliseconds to wait before the request times out. The default is 100,000 milliseconds (100 seconds).
Exceptions:
T:System.ArgumentOutOfRangeException The value specified is less than zero and is not F:System.Threading.Timeout.Infinite.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.TransferEncoding [get, set]

Gets or sets the value of the Transfer-encoding HTTP header.

Returns:
The value of the Transfer-encoding HTTP header. The default value is null.
Exceptions:
T:System.InvalidOperationException | P:System.Net.HttpWebRequest.TransferEncoding is set when P:System.Net.HttpWebRequest.SendChunked is false.
T:System.ArgumentException | P:System.Net.HttpWebRequest.TransferEncoding is set to the value "Chunked".

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.UnsafeAuthenticatedConnectionSharing [get, set]

Gets or sets a value that indicates whether to allow high-speed NTLM-authenticated connection sharing.

Returns:
true to keep the authenticated connection open; otherwise, false.

<PermissionSet><IPermission class="System.Net.WebPermission, System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" unrestricted="true"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

bool HttpWebAdapters.IHttpWebRequest.UseDefaultCredentials [get, set]

Gets or sets a T:System.Boolean value that controls whether default credentials are sent with requests.

Returns:
true if the default credentials are used; otherwise false. The default value is false.
Exceptions:
T:System.InvalidOperationException You attempted to set this property after the request was sent.

<PermissionSet><IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" read="USERNAME"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

string HttpWebAdapters.IHttpWebRequest.UserAgent [get, set]

Gets or sets the value of the User-agent HTTP header.

Returns:
The value of the User-agent HTTP header. The default value is null.The value for this property is stored in T:System.Net.WebHeaderCollection. If WebHeaderCollection is set, the property value is lost.

Implemented in HttpWebAdapters.Adapters.HttpWebRequestAdapter.

The documentation for this interface was generated from the following file:
  • HttpWebAdapters/IHttpWebRequest.cs
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.IHttpWebRequestFactory Interface Reference

  • HttpWebAdapters
  • IHttpWebRequestFactory
Public Member Functions

HttpWebAdapters.IHttpWebRequestFactory Interface Reference

Inheritance diagram for HttpWebAdapters.IHttpWebRequestFactory:
HttpWebAdapters.HttpWebRequestFactory

List of all members.

Public Member Functions

IHttpWebRequest Create (Uri url)
The documentation for this interface was generated from the following file:
  • HttpWebAdapters/IHttpWebRequestFactory.cs
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.IHttpWebResponse Interface Reference

  • HttpWebAdapters
  • IHttpWebResponse
Public Member Functions | Properties

HttpWebAdapters.IHttpWebResponse Interface Reference

Inheritance diagram for HttpWebAdapters.IHttpWebResponse:
HttpWebAdapters.Adapters.HttpWebResponseAdapter HttpWebAdapters.WebResponseStub

List of all members.

Public Member Functions

string | GetResponseHeader (string headerName)
Gets the contents of a header that was returned with the response.
void | Close ()
When overridden by a descendant class, closes the response stream.
Stream | GetResponseStream ()
When overridden in a descendant class, returns the data stream from the Internet resource.

Properties

CookieCollection | Cookies [get, set]
Gets or sets the cookies that are associated with this response.
string | ContentEncoding [get]
Gets the method that is used to encode the body of the response.
string | CharacterSet [get]
Gets the character set of the response.
string | Server [get]
Gets the name of the server that sent the response.
DateTime | LastModified [get]
Gets the last date and time that the contents of the response were modified.
HttpStatusCode | StatusCode [get]
Gets the status of the response.
string | StatusDescription [get]
Gets the status description returned with the response.
Version | ProtocolVersion [get]
Gets the version of the HTTP protocol that is used in the response.
string | Method [get]
Gets the method that is used to return the response.
bool | IsFromCache [get]
Gets a T:System.Boolean value that indicates whether this response was obtained from the cache.
bool | IsMutuallyAuthenticated [get]
Gets a T:System.Boolean value that indicates whether mutual authentication occurred.
long | ContentLength [get, set]
When overridden in a descendant class, gets or sets the content length of data being received.
string | ContentType [get, set]
When overridden in a derived class, gets or sets the content type of the data being received.
Uri | ResponseUri [get]
When overridden in a derived class, gets the URI of the Internet resource that actually responded to the request.
WebHeaderCollection | Headers [get]
When overridden in a derived class, gets a collection of header name-value pairs associated with this request.

Member Function Documentation

void HttpWebAdapters.IHttpWebResponse.Close ( )

When overridden by a descendant class, closes the response stream.

Exceptions:
T:System.NotSupportedException Any attempt is made to access the method, when the method is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

string HttpWebAdapters.IHttpWebResponse.GetResponseHeader ( string headerName )

Gets the contents of a header that was returned with the response.

Returns:
The contents of the specified header.
Parameters:
headerName The header value to return.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

Stream HttpWebAdapters.IHttpWebResponse.GetResponseStream ( )

When overridden in a descendant class, returns the data stream from the Internet resource.

Returns:
An instance of the T:System.IO.Stream class for reading data from the Internet resource.
Exceptions:
T:System.NotSupportedException Any attempt is made to access the method, when the method is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

Property Documentation

string HttpWebAdapters.IHttpWebResponse.CharacterSet [get]

Gets the character set of the response.

Returns:
A string that contains the character set of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

string HttpWebAdapters.IHttpWebResponse.ContentEncoding [get]

Gets the method that is used to encode the body of the response.

Returns:
A string that describes the method that is used to encode the body of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

long HttpWebAdapters.IHttpWebResponse.ContentLength [get, set]

When overridden in a descendant class, gets or sets the content length of data being received.

Returns:
The number of bytes returned from the Internet resource.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

string HttpWebAdapters.IHttpWebResponse.ContentType [get, set]

When overridden in a derived class, gets or sets the content type of the data being received.

Returns:
A string that contains the content type of the response.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

CookieCollection HttpWebAdapters.IHttpWebResponse.Cookies [get, set]

Gets or sets the cookies that are associated with this response.

Returns:
A T:System.Net.CookieCollection that contains the cookies that are associated with this response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

WebHeaderCollection HttpWebAdapters.IHttpWebResponse.Headers [get]

When overridden in a derived class, gets a collection of header name-value pairs associated with this request.

Returns:
An instance of the T:System.Net.WebHeaderCollection class that contains header values associated with this response.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

bool HttpWebAdapters.IHttpWebResponse.IsFromCache [get]

Gets a T:System.Boolean value that indicates whether this response was obtained from the cache.

Returns:
true if the response was taken from the cache; otherwise, false.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

bool HttpWebAdapters.IHttpWebResponse.IsMutuallyAuthenticated [get]

Gets a T:System.Boolean value that indicates whether mutual authentication occurred.

Returns:
true if both client and server were authenticated; otherwise, false.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

DateTime HttpWebAdapters.IHttpWebResponse.LastModified [get]

Gets the last date and time that the contents of the response were modified.

Returns:
A T:System.DateTime that contains the date and time that the contents of the response were modified.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

string HttpWebAdapters.IHttpWebResponse.Method [get]

Gets the method that is used to return the response.

Returns:
A string that contains the HTTP method that is used to return the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

Version HttpWebAdapters.IHttpWebResponse.ProtocolVersion [get]

Gets the version of the HTTP protocol that is used in the response.

Returns:
A T:System.Version that contains the HTTP protocol version of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

Uri HttpWebAdapters.IHttpWebResponse.ResponseUri [get]

When overridden in a derived class, gets the URI of the Internet resource that actually responded to the request.

Returns:
An instance of the T:System.Uri class that contains the URI of the Internet resource that actually responded to the request.
Exceptions:
T:System.NotSupportedException Any attempt is made to get or set the property, when the property is not overridden in a descendant class.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter.

string HttpWebAdapters.IHttpWebResponse.Server [get]

Gets the name of the server that sent the response.

Returns:
A string that contains the name of the server that sent the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

HttpStatusCode HttpWebAdapters.IHttpWebResponse.StatusCode [get]

Gets the status of the response.

Returns:
One of the T:System.Net.HttpStatusCode values.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

string HttpWebAdapters.IHttpWebResponse.StatusDescription [get]

Gets the status description returned with the response.

Returns:
A string that describes the status of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implemented in HttpWebAdapters.Adapters.HttpWebResponseAdapter, and HttpWebAdapters.WebResponseStub.

The documentation for this interface was generated from the following file:
  • HttpWebAdapters/IHttpWebResponse.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Rhino.Commons.LocalDataImpl.ILocalData Interface Reference

  • Rhino
  • Commons
  • LocalDataImpl
  • ILocalData
Public Member Functions | Properties

Rhino.Commons.LocalDataImpl.ILocalData Interface Reference

Inherited by Rhino.Commons.Local.LocalData.

List of all members.

Public Member Functions

void | Clear ()

Properties

object | this [object key] [get, set]
The documentation for this interface was generated from the following file:
  • SolrNet.DSL/Utils/ILocalData.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.IMappingManager Interface Reference

  • SolrNet
  • Mapping
  • IMappingManager
Public Member Functions

SolrNet.Mapping.IMappingManager Interface Reference

Mapping manager abstraction. More...

Inheritance diagram for SolrNet.Mapping.IMappingManager:
SolrNet.IReadOnlyMappingManager SolrNet.Mapping.MappingManager

List of all members.

Public Member Functions

void | Add (PropertyInfo property)
Maps a property with the property name as Solr field name.
void | Add (PropertyInfo property, string fieldName)
Maps a property.
void | Add (PropertyInfo property, string fieldName, float?boost)
Maps a property.
void | SetUniqueKey (PropertyInfo property)
Sets unique key for a document type.

Detailed Description

Mapping manager abstraction.

Member Function Documentation

void SolrNet.Mapping.IMappingManager.Add ( PropertyInfo property )

Maps a property with the property name as Solr field name.

Parameters:
property Document type property

Implemented in SolrNet.Mapping.MappingManager.

void SolrNet.Mapping.IMappingManager.Add | ( | PropertyInfo | property,
 |  | string | fieldName
 | ) |  |

Maps a property.

Parameters:
property | Document type property
fieldName | Solr field name

Implemented in SolrNet.Mapping.MappingManager.

void SolrNet.Mapping.IMappingManager.Add | ( | PropertyInfo | property,
 |  | string | fieldName,
 |  | float? | boost
 | ) |  |

Maps a property.

Parameters:
property | Document type property
fieldName | Solr field name
boost | Index-time boosting

Implemented in SolrNet.Mapping.MappingManager.

void SolrNet.Mapping.IMappingManager.SetUniqueKey ( PropertyInfo property )

Sets unique key for a document type.

Parameters:
property Document type property

Implemented in SolrNet.Mapping.MappingManager.

The documentation for this interface was generated from the following file:
  • SolrNet/Mapping/IMappingManager.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.IMappingValidator Interface Reference

  • SolrNet
  • Mapping
  • Validation
  • IMappingValidator
Public Member Functions

SolrNet.Mapping.Validation.IMappingValidator Interface Reference

Provides an interface to validation a Solr schema against a type's mapping. More...

Inheritance diagram for SolrNet.Mapping.Validation.IMappingValidator:
SolrNet.Mapping.Validation.MappingValidator

List of all members.

Public Member Functions

IEnumerable< ValidationResult > EnumerateValidationResults (Type documentType, SolrSchema schema)
Validates the specified validation rules.

Detailed Description

Provides an interface to validation a Solr schema against a type's mapping.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.IMappingValidator.EnumerateValidationResults | ( | Type | documentType,
 |  | SolrSchema | schema
 | ) |  |

Validates the specified validation rules.

Parameters:
documentType | The document type which needs to be validated
schema | The Solr schema.
Returns:
A collection of ValidationResult objects with the problems found during validation. If Any.

Implemented in SolrNet.Mapping.Validation.MappingValidator.

The documentation for this interface was generated from the following file:
  • SolrNet/Mapping/Validation/IMappingValidator.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.InferringFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • InferringFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.InferringFieldParser Class Reference

Parser that infers .net type based on solr type. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.InferringFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

InferringFieldParser (ISolrFieldParser parser)
bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parser that infers .net type based on solr type.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.InferringFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.InferringFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.InferringFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/InferringFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.INHSolrQuery Interface Reference

  • NHibernate
  • SolrNet
  • INHSolrQuery
Public Member Functions

NHibernate.SolrNet.INHSolrQuery Interface Reference

NHibernate IQuery for SolrNet queries. More...

Inheritance diagram for NHibernate.SolrNet.INHSolrQuery:
NHibernate.SolrNet.Impl.NHSolrQueryImpl

List of all members.

Public Member Functions

new INHSolrQuery | SetMaxResults (int maxResults)
Set the maximum number of rows to retrieve.
new INHSolrQuery | SetFirstResult (int firstResult)
Sets the first row to retrieve.
INHSolrQuery | SetSort (Order o)
Sets sort order.

Detailed Description

NHibernate IQuery for SolrNet queries.

Member Function Documentation

new INHSolrQuery NHibernate.SolrNet.INHSolrQuery.SetFirstResult ( int firstResult )

Sets the first row to retrieve.

Parameters:
firstResult The first row to retreive.
Returns:
this

Implemented in NHibernate.SolrNet.Impl.NHSolrQueryImpl.

new INHSolrQuery NHibernate.SolrNet.INHSolrQuery.SetMaxResults ( int maxResults )

Set the maximum number of rows to retrieve.

Parameters:
maxResults The maximum number of rows to retreive
Returns:
this

Implemented in NHibernate.SolrNet.Impl.NHSolrQueryImpl.

INHSolrQuery NHibernate.SolrNet.INHSolrQuery.SetSort ( Order o )

Sets sort order.

Parameters:
o Sort order
Returns:
this
The documentation for this interface was generated from the following file:
  • NHibernate.SolrNet/INHSolrQuery.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.IntFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • IntFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.IntFieldParser Class Reference

Parses int values. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.IntFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses int values.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.IntFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.IntFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.IntFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/IntFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • IntSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker Class Reference

Checks schema type of properties with int type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

IntSolrFieldTypeChecker ()
Checks schema type of properties with int type.

Detailed Description

Checks schema type of properties with int type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker.IntSolrFieldTypeChecker ( )

Checks schema type of properties with int type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/IntSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Exceptions.InvalidFieldException Class Reference

  • SolrNet
  • Exceptions
  • InvalidFieldException
Public Member Functions | Protected Member Functions

SolrNet.Exceptions.InvalidFieldException Class Reference

Solr did not understand one the specified fields. More...

Inheritance diagram for SolrNet.Exceptions.InvalidFieldException:
SolrNet.Exceptions.SolrNetException

List of all members.

Public Member Functions

InvalidFieldException (Exception innerException)
Solr did not understand one the specified fields.
InvalidFieldException (string message)
Solr did not understand one the specified fields.
InvalidFieldException (string message, Exception innerException)
Solr did not understand one the specified fields.
InvalidFieldException ()
Solr did not understand one the specified fields.

Protected Member Functions

InvalidFieldException (SerializationInfo info, StreamingContext context)

Detailed Description

Solr did not understand one the specified fields.

Constructor & Destructor Documentation

SolrNet.Exceptions.InvalidFieldException.InvalidFieldException ( Exception innerException )

Solr did not understand one the specified fields.

Parameters:
innerException
SolrNet.Exceptions.InvalidFieldException.InvalidFieldException ( string message )

Solr did not understand one the specified fields.

Parameters:
message
SolrNet.Exceptions.InvalidFieldException.InvalidFieldException | ( | string | message,
 |  | Exception | innerException
 | ) |  |

Solr did not understand one the specified fields.

Parameters:
message
innerException
SolrNet.Exceptions.InvalidFieldException.InvalidFieldException ( )

Solr did not understand one the specified fields.

The documentation for this class was generated from the following file:
  • SolrNet/Exceptions/InvalidFieldException.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Exceptions.InvalidSortOrderException Class Reference

  • SolrNet
  • Exceptions
  • InvalidSortOrderException
Public Member Functions | Protected Member Functions

SolrNet.Exceptions.InvalidSortOrderException Class Reference

Error parsing SortOrder More...

Inheritance diagram for SolrNet.Exceptions.InvalidSortOrderException:
SolrNet.Exceptions.SolrNetException

List of all members.

Public Member Functions

InvalidSortOrderException (string message)
InvalidSortOrderException (string message, Exception innerException)
InvalidSortOrderException (Exception innerException)

Protected Member Functions

InvalidSortOrderException (SerializationInfo info, StreamingContext context)

Detailed Description

Error parsing SortOrder

The documentation for this class was generated from the following file:
  • SolrNet/Exceptions/InvalidSortOrderException.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Exceptions.InvalidURLException Class Reference

  • SolrNet
  • Exceptions
  • InvalidURLException
Public Member Functions | Protected Member Functions

SolrNet.Exceptions.InvalidURLException Class Reference

Invalid URL specified. More...

Inheritance diagram for SolrNet.Exceptions.InvalidURLException:
SolrNet.Exceptions.SolrNetException

List of all members.

Public Member Functions

InvalidURLException (Exception innerException)
Invalid URL specified.
InvalidURLException (string message)
Invalid URL specified.
InvalidURLException (string message, Exception innerException)
Invalid URL specified.
InvalidURLException ()
Invalid URL specified.

Protected Member Functions

InvalidURLException (SerializationInfo info, StreamingContext context)

Detailed Description

Invalid URL specified.

Constructor & Destructor Documentation

SolrNet.Exceptions.InvalidURLException.InvalidURLException ( Exception innerException )

Invalid URL specified.

Parameters:
innerException
SolrNet.Exceptions.InvalidURLException.InvalidURLException ( string message )

Invalid URL specified.

Parameters:
message
SolrNet.Exceptions.InvalidURLException.InvalidURLException | ( | string | message,
 |  | Exception | innerException
 | ) |  |

Invalid URL specified.

Parameters:
message
innerException
SolrNet.Exceptions.InvalidURLException.InvalidURLException ( )

Invalid URL specified.

The documentation for this class was generated from the following file:
  • SolrNet/Exceptions/InvalidURLException.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.IReadOnlyMappingManager Interface Reference

  • SolrNet
  • IReadOnlyMappingManager
Public Member Functions

SolrNet.IReadOnlyMappingManager Interface Reference

Service interface for mapping Solr fields to object properties. More...

Inheritance diagram for SolrNet.IReadOnlyMappingManager:
SolrNet.Mapping.AllPropertiesMappingManager SolrNet.Mapping.AttributesMappingManager SolrNet.Mapping.IMappingManager SolrNet.Mapping.MemoizingMappingManager SolrNet.Mapping.MappingManager

List of all members.

Public Member Functions

ICollection< SolrFieldModel > | GetFields (Type type)
Gets fields mapped for this type.
SolrFieldModel | GetUniqueKey (Type type)
Gets unique key for the type.
ICollection< Type > | GetRegisteredTypes ()

Detailed Description

Service interface for mapping Solr fields to object properties.

Member Function Documentation

ICollection<SolrFieldModel> SolrNet.IReadOnlyMappingManager.GetFields ( Type type )

Gets fields mapped for this type.

Parameters:
type
Returns:
Empty collection if type is not mapped

Implemented in SolrNet.Mapping.AllPropertiesMappingManager, SolrNet.Mapping.AttributesMappingManager, SolrNet.Mapping.MappingManager, and SolrNet.Mapping.MemoizingMappingManager.

SolrFieldModel SolrNet.IReadOnlyMappingManager.GetUniqueKey ( Type type )

Gets unique key for the type.

Parameters:
type
Returns:

Implemented in SolrNet.Mapping.AllPropertiesMappingManager, SolrNet.Mapping.AttributesMappingManager, SolrNet.Mapping.MappingManager, and SolrNet.Mapping.MemoizingMappingManager.

The documentation for this interface was generated from the following file:
  • SolrNet/IReadOnlyMappingManager.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISelfSerializingQuery Interface Reference

  • SolrNet
  • Impl
  • ISelfSerializingQuery
Properties

SolrNet.Impl.ISelfSerializingQuery Interface Reference

Inheritance diagram for SolrNet.Impl.ISelfSerializingQuery:
SolrNet.ISolrQuery SolrNet.SolrQuery

List of all members.

Properties

string Query [get]
The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISelfSerializingQuery.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrBasicOperations< T > Interface Template Reference

  • SolrNet
  • ISolrBasicOperations
Public Member Functions

SolrNet.ISolrBasicOperations< T > Interface Template Reference

Solr operations without convenience overloads. More...

Inheritance diagram for SolrNet.ISolrBasicOperations< T >:
SolrNet.ISolrBasicReadOnlyOperations< T > SolrNet.Impl.SolrBasicServer< T >

List of all members.

Public Member Functions

ResponseHeader | Commit (CommitOptions options)
Commits posted documents.
ResponseHeader | Optimize (CommitOptions options)
Optimizes Solr's index.
ResponseHeader Rollback ()
Rollbacks all add/deletes made to the index since the last commit.
ResponseHeader | AddWithBoost (IEnumerable< KeyValuePair< T, double?>> docs)
Adds / updates several documents with index-time boost.
ResponseHeader | Delete (IEnumerable< string > ids, ISolrQuery q)
Deletes all documents that match the given id's or the query.
string | Send (ISolrCommand cmd)
Sends a custom command.
ResponseHeader | SendAndParseHeader (ISolrCommand cmd)
Sends a custom command, returns parsed header from xml response.

Detailed Description

template<T>
interface SolrNet::ISolrBasicOperations< T >

Solr operations without convenience overloads.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ResponseHeader SolrNet.ISolrBasicOperations< T >.AddWithBoost ( IEnumerable< KeyValuePair< T, double?>> docs )

Adds / updates several documents with index-time boost.

Parameters:
docs
Returns:

Implemented in SolrNet.Impl.SolrBasicServer< T >.

template<T >
ResponseHeader SolrNet.ISolrBasicOperations< T >.Commit ( CommitOptions options )

Commits posted documents.

Parameters:
options Commit options

Implemented in SolrNet.Impl.SolrBasicServer< T >.

template<T >
ResponseHeader SolrNet.ISolrBasicOperations< T >.Delete | ( | IEnumerable< string > | ids,
 |  | ISolrQuery | q
 | ) |  |

Deletes all documents that match the given id's or the query.

Parameters:
ids | document ids to delete
q | query to match
Returns:

Implemented in SolrNet.Impl.SolrBasicServer< T >.

template<T >
ResponseHeader SolrNet.ISolrBasicOperations< T >.Optimize ( CommitOptions options )

Optimizes Solr's index.

Parameters:
options Optimization options

Implemented in SolrNet.Impl.SolrBasicServer< T >.

template<T >
ResponseHeader SolrNet.ISolrBasicOperations< T >.Rollback ( )

Rollbacks all add/deletes made to the index since the last commit.

Implemented in SolrNet.Impl.SolrBasicServer< T >.

template<T >
string SolrNet.ISolrBasicOperations< T >.Send ( ISolrCommand cmd )

Sends a custom command.

Parameters:
cmd command to send
Returns:
solr response

Implemented in SolrNet.Impl.SolrBasicServer< T >.

template<T >
ResponseHeader SolrNet.ISolrBasicOperations< T >.SendAndParseHeader ( ISolrCommand cmd )

Sends a custom command, returns parsed header from xml response.

Parameters:
cmd
Returns:

Implemented in SolrNet.Impl.SolrBasicServer< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrBasicOperations.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrBasicReadOnlyOperations< T > Interface Template Reference

  • SolrNet
  • ISolrBasicReadOnlyOperations
Public Member Functions

SolrNet.ISolrBasicReadOnlyOperations< T > Interface Template Reference

Read-only operations without convenience overloads. More...

Inheritance diagram for SolrNet.ISolrBasicReadOnlyOperations< T >:
SolrNet.ISolrBasicOperations< T > SolrNet.ISolrReadOnlyOperations< T > SolrNet.Impl.SolrBasicServer< T > SolrNet.ISolrOperations< T > SolrNet.Impl.SolrServer< T >

List of all members.

Public Member Functions

ISolrQueryResults< T > Query (ISolrQuery query, QueryOptions options)
Executes a query.
ResponseHeader Ping ()
Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. See http://wiki.apache.org/solr/SolrConfigXml for more information.
SolrSchema GetSchema ()
Gets the schema.

Detailed Description

template<T>
interface SolrNet::ISolrBasicReadOnlyOperations< T >

Read-only operations without convenience overloads.

Template Parameters:
T

Member Function Documentation

template<T >
SolrSchema SolrNet.ISolrBasicReadOnlyOperations< T >.GetSchema ( )

Gets the schema.

Returns:
A XmlDocument containing the Solr schema XML.

Implemented in SolrNet.Impl.SolrBasicServer< T >, and SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrBasicReadOnlyOperations< T >.Ping ( )

Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. See http://wiki.apache.org/solr/SolrConfigXml for more information.

Implemented in SolrNet.Impl.SolrBasicServer< T >, and SolrNet.Impl.SolrServer< T >.

template<T >
ISolrQueryResults<T> SolrNet.ISolrBasicReadOnlyOperations< T >.Query | ( | ISolrQuery | query,
 |  | QueryOptions | options
 | ) |  |

Executes a query.

Parameters:
query
options
Returns:

Implemented in SolrNet.Impl.SolrBasicServer< T >, and SolrNet.Impl.SolrServer< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrBasicReadOnlyOperations.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrCache Interface Reference

  • SolrNet
  • Impl
  • ISolrCache
Public Member Functions | Properties

SolrNet.Impl.ISolrCache Interface Reference

HTTP-level cache for Solr responses. More...

Inheritance diagram for SolrNet.Impl.ISolrCache:
SolrNet.Impl.HttpRuntimeCache SolrNet.Impl.NullCache

List of all members.

Public Member Functions

void | Add (SolrCacheEntity e)
Adds a Solr response to the cache.

Properties

SolrCacheEntity | this [string url] [get]
Gets a cached Solr response. Returns null if there is no cached response for this URL.

Detailed Description

HTTP-level cache for Solr responses.

Member Function Documentation

void SolrNet.Impl.ISolrCache.Add ( SolrCacheEntity e )

Adds a Solr response to the cache.

Parameters:
e

Implemented in SolrNet.Impl.HttpRuntimeCache, and SolrNet.Impl.NullCache.

Property Documentation

SolrCacheEntity SolrNet.Impl.ISolrCache.this[string url] [get]

Gets a cached Solr response. Returns null if there is no cached response for this URL.

Parameters:
url Full Solr query URL (including all querystring parameters)
Returns:

Implemented in SolrNet.Impl.HttpRuntimeCache, and SolrNet.Impl.NullCache.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrCache.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrCommand Interface Reference

  • SolrNet
  • ISolrCommand
Public Member Functions

SolrNet.ISolrCommand Interface Reference

Command interface. More...

Inheritance diagram for SolrNet.ISolrCommand:
SolrNet.Commands.AddCommand< T > SolrNet.Commands.CommitCommand SolrNet.Commands.DeleteCommand SolrNet.Commands.GetSchemaCommand SolrNet.Commands.OptimizeCommand SolrNet.Commands.PingCommand SolrNet.Commands.RollbackCommand

List of all members.

Public Member Functions

string Execute (ISolrConnection connection)
Executes this command.

Detailed Description

Command interface.

Member Function Documentation

string SolrNet.ISolrCommand.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implemented in SolrNet.Commands.AddCommand< T >, SolrNet.Commands.CommitCommand, SolrNet.Commands.DeleteCommand, SolrNet.Commands.GetSchemaCommand, SolrNet.Commands.OptimizeCommand, SolrNet.Commands.PingCommand, and SolrNet.Commands.RollbackCommand.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrCommand.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrConnection Interface Reference

  • SolrNet
  • ISolrConnection
Public Member Functions

SolrNet.ISolrConnection Interface Reference

Manages HTTP connection with Solr. More...

Inheritance diagram for SolrNet.ISolrConnection:
SolrNet.Impl.SolrConnection

List of all members.

Public Member Functions

string | Post (string relativeUrl, string s)
POSTs to Solr.
string | Get (string relativeUrl, IEnumerable< KeyValuePair< string, string >> parameters)
GETs from Solr.

Detailed Description

Manages HTTP connection with Solr.

Member Function Documentation

string SolrNet.ISolrConnection.Get | ( | string | relativeUrl,
 |  | IEnumerable< KeyValuePair< string, string >> | parameters
 | ) |  |

GETs from Solr.

Parameters:
relativeUrl | Path to get from
parameters | Query string parameters
Returns:

Implemented in SolrNet.Impl.SolrConnection.

string SolrNet.ISolrConnection.Post | ( | string | relativeUrl,
 |  | string | s
 | ) |  |

POSTs to Solr.

Parameters:
relativeUrl | Path to post to
s | POST content
Returns:

Implemented in SolrNet.Impl.SolrConnection.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrConnection.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.ISolrDeleteParam Interface Reference

  • SolrNet
  • Commands
  • Parameters
  • ISolrDeleteParam
Public Member Functions

SolrNet.Commands.Parameters.ISolrDeleteParam Interface Reference

Delete command parameter. More...

Inheritance diagram for SolrNet.Commands.Parameters.ISolrDeleteParam:
SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam

List of all members.

Public Member Functions

IEnumerable< XmlNode > ToXmlNode ()
Converts this parameter to xml representation.

Detailed Description

Delete command parameter.

Member Function Documentation

IEnumerable<XmlNode> SolrNet.Commands.Parameters.ISolrDeleteParam.ToXmlNode ( )

Converts this parameter to xml representation.

Returns:

Implemented in SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam.

The documentation for this interface was generated from the following file:
  • SolrNet/Commands/Parameters/ISolrDeleteParam.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrDocumentActivator< T > Interface Template Reference

  • SolrNet
  • Impl
  • ISolrDocumentActivator
Public Member Functions

SolrNet.Impl.ISolrDocumentActivator< T > Interface Template Reference

Instantiates a new document instance of type T More...

Inheritance diagram for SolrNet.Impl.ISolrDocumentActivator< T >:
SolrNet.Impl.SolrDocumentActivator< T >

List of all members.

Public Member Functions

T Create ()
Instantiates a new document instance of type T

Detailed Description

template<T>
interface SolrNet::Impl::ISolrDocumentActivator< T >

Instantiates a new document instance of type T

Template Parameters:
T Document type

Member Function Documentation

template<T >
T SolrNet.Impl.ISolrDocumentActivator< T >.Create ( )

Instantiates a new document instance of type T

Returns:

Implemented in SolrNet.Impl.SolrDocumentActivator< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrDocumentActivator.cs
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrDocumentPropertyVisitor Interface Reference

  • SolrNet
  • Impl
  • ISolrDocumentPropertyVisitor
Public Member Functions

SolrNet.Impl.ISolrDocumentPropertyVisitor Interface Reference

Visits a document with a raw xml Solr response field. More...

Inheritance diagram for SolrNet.Impl.ISolrDocumentPropertyVisitor:
SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor

List of all members.

Public Member Functions

void Visit (object doc, string fieldName, XmlNode field)
Visits a document with a raw xml Solr response field.

Detailed Description

Visits a document with a raw xml Solr response field.

Member Function Documentation

void SolrNet.Impl.ISolrDocumentPropertyVisitor.Visit | ( | object | doc,
 |  | string | fieldName,
 |  | XmlNode | field
 | ) |  |

Visits a document with a raw xml Solr response field.

Parameters:
doc | Document object
fieldName | Solr field name
field | Raw XML Solr field

Implemented in SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor, SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor, SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor, and SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrDocumentPropertyVisitor.cs
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrDocumentResponseParser< T > Interface Template Reference

  • SolrNet
  • Impl
  • ISolrDocumentResponseParser
Public Member Functions

SolrNet.Impl.ISolrDocumentResponseParser< T > Interface Template Reference

Parses documents from query response. More...

Inheritance diagram for SolrNet.Impl.ISolrDocumentResponseParser< T >:
SolrNet.Impl.SolrDocumentResponseParser< T >

List of all members.

Public Member Functions

IList< T > ParseResults (XmlNode parentNode)
Parses documents from query response.

Detailed Description

template<T>
interface SolrNet::Impl::ISolrDocumentResponseParser< T >

Parses documents from query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
IList<T> SolrNet.Impl.ISolrDocumentResponseParser< T >.ParseResults ( XmlNode parentNode )

Parses documents from query response.

Parameters:
parentNode
Returns:

Implemented in SolrNet.Impl.SolrDocumentResponseParser< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrDocumentResponseParser.cs
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrDocumentSerializer< T > Interface Template Reference

  • SolrNet
  • ISolrDocumentSerializer
Public Member Functions

SolrNet.ISolrDocumentSerializer< T > Interface Template Reference

Serializes a solr document to xml. More...

Inheritance diagram for SolrNet.ISolrDocumentSerializer< T >:
SolrNet.Impl.SolrDocumentSerializer< T >

List of all members.

Public Member Functions

XmlDocument Serialize (T doc, double?boost)

Detailed Description

template<T>
interface SolrNet::ISolrDocumentSerializer< T >

Serializes a solr document to xml.

Template Parameters:
T document type

Member Function Documentation

template<T >
XmlDocument SolrNet.ISolrDocumentSerializer< T >.Serialize | ( | T | doc,
 |  | double? | boost
 | ) |  |

Serializes a Solr document to xml, applying an index-time boost

Parameters:
doc document to serialize
boost
Returns:
serialized document

Implemented in SolrNet.Impl.SolrDocumentSerializer< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrDocumentSerializer.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrFacetQuery Interface Reference

  • SolrNet
  • ISolrFacetQuery

SolrNet.ISolrFacetQuery Interface Reference

Facet query interface. More...

Inheritance diagram for SolrNet.ISolrFacetQuery:
SolrNet.SolrFacetDateQuery SolrNet.SolrFacetFieldQuery SolrNet.SolrFacetQuery

Detailed Description

Facet query interface.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrFacetQuery.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrFacetQuerySerializer Interface Reference

  • SolrNet
  • Impl
  • ISolrFacetQuerySerializer
Public Member Functions

SolrNet.Impl.ISolrFacetQuerySerializer Interface Reference

Inheritance diagram for SolrNet.Impl.ISolrFacetQuerySerializer:
SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer

List of all members.

Public Member Functions

bool CanHandleType (Type t)
IEnumerable< KeyValuePair
< string, string > > 		Serialize (object q)
The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrFacetQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrFieldParser Interface Reference

  • SolrNet
  • Impl
  • ISolrFieldParser
Public Member Functions

SolrNet.Impl.ISolrFieldParser Interface Reference

Parses a single Solr XML result node. More...

Inheritance diagram for SolrNet.Impl.ISolrFieldParser:
SolrNet.Impl.FieldParsers.AggregateFieldParser SolrNet.Impl.FieldParsers.CollectionFieldParser SolrNet.Impl.FieldParsers.DateTimeFieldParser SolrNet.Impl.FieldParsers.DecimalFieldParser SolrNet.Impl.FieldParsers.DefaultFieldParser SolrNet.Impl.FieldParsers.DoubleFieldParser SolrNet.Impl.FieldParsers.EnumFieldParser SolrNet.Impl.FieldParsers.FloatFieldParser SolrNet.Impl.FieldParsers.GuidFieldParser SolrNet.Impl.FieldParsers.InferringFieldParser SolrNet.Impl.FieldParsers.IntFieldParser SolrNet.Impl.FieldParsers.LongFieldParser SolrNet.Impl.FieldParsers.NullableFieldParser SolrNet.Impl.FieldParsers.TypeConvertingFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses a single Solr XML result node.

Member Function Documentation

bool SolrNet.Impl.ISolrFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implemented in SolrNet.Impl.FieldParsers.AggregateFieldParser, SolrNet.Impl.FieldParsers.CollectionFieldParser, SolrNet.Impl.FieldParsers.DateTimeFieldParser, SolrNet.Impl.FieldParsers.DecimalFieldParser, SolrNet.Impl.FieldParsers.DefaultFieldParser, SolrNet.Impl.FieldParsers.DoubleFieldParser, SolrNet.Impl.FieldParsers.EnumFieldParser, SolrNet.Impl.FieldParsers.FloatFieldParser, SolrNet.Impl.FieldParsers.GuidFieldParser, SolrNet.Impl.FieldParsers.InferringFieldParser, SolrNet.Impl.FieldParsers.IntFieldParser, SolrNet.Impl.FieldParsers.LongFieldParser, SolrNet.Impl.FieldParsers.NullableFieldParser, and SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.

bool SolrNet.Impl.ISolrFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implemented in SolrNet.Impl.FieldParsers.AggregateFieldParser, SolrNet.Impl.FieldParsers.CollectionFieldParser, SolrNet.Impl.FieldParsers.DateTimeFieldParser, SolrNet.Impl.FieldParsers.DecimalFieldParser, SolrNet.Impl.FieldParsers.DefaultFieldParser, SolrNet.Impl.FieldParsers.DoubleFieldParser, SolrNet.Impl.FieldParsers.EnumFieldParser, SolrNet.Impl.FieldParsers.FloatFieldParser, SolrNet.Impl.FieldParsers.GuidFieldParser, SolrNet.Impl.FieldParsers.InferringFieldParser, SolrNet.Impl.FieldParsers.IntFieldParser, SolrNet.Impl.FieldParsers.LongFieldParser, SolrNet.Impl.FieldParsers.NullableFieldParser, and SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.

object SolrNet.Impl.ISolrFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implemented in SolrNet.Impl.FieldParsers.AggregateFieldParser, SolrNet.Impl.FieldParsers.CollectionFieldParser, SolrNet.Impl.FieldParsers.DateTimeFieldParser, SolrNet.Impl.FieldParsers.DecimalFieldParser, SolrNet.Impl.FieldParsers.DefaultFieldParser, SolrNet.Impl.FieldParsers.DoubleFieldParser, SolrNet.Impl.FieldParsers.EnumFieldParser, SolrNet.Impl.FieldParsers.FloatFieldParser, SolrNet.Impl.FieldParsers.GuidFieldParser, SolrNet.Impl.FieldParsers.InferringFieldParser, SolrNet.Impl.FieldParsers.IntFieldParser, SolrNet.Impl.FieldParsers.LongFieldParser, SolrNet.Impl.FieldParsers.NullableFieldParser, and SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrFieldParser.cs
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrFieldSerializer Interface Reference

  • SolrNet
  • Impl
  • ISolrFieldSerializer
Public Member Functions

SolrNet.Impl.ISolrFieldSerializer Interface Reference

Serializes a value to be consumed by the Solr update handler. More...

Inheritance diagram for SolrNet.Impl.ISolrFieldSerializer:
SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > SolrNet.Impl.FieldSerializers.AggregateFieldSerializer SolrNet.Impl.FieldSerializers.CollectionFieldSerializer SolrNet.Impl.FieldSerializers.DefaultFieldSerializer SolrNet.Impl.FieldSerializers.FormattableFieldSerializer SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer SolrNet.Impl.FieldSerializers.NullableFieldSerializer SolrNet.Impl.FieldSerializers.ToStringFieldSerializer SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Serializes a value to be consumed by the Solr update handler.

Member Function Documentation

bool SolrNet.Impl.ISolrFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implemented in SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >, SolrNet.Impl.FieldSerializers.AggregateFieldSerializer, SolrNet.Impl.FieldSerializers.CollectionFieldSerializer, SolrNet.Impl.FieldSerializers.DefaultFieldSerializer, SolrNet.Impl.FieldSerializers.FormattableFieldSerializer, SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer, SolrNet.Impl.FieldSerializers.NullableFieldSerializer, SolrNet.Impl.FieldSerializers.ToStringFieldSerializer, and SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.ISolrFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implemented in SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >, SolrNet.Impl.FieldSerializers.AggregateFieldSerializer, SolrNet.Impl.FieldSerializers.CollectionFieldSerializer, SolrNet.Impl.FieldSerializers.DefaultFieldSerializer, SolrNet.Impl.FieldSerializers.FormattableFieldSerializer, SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer, SolrNet.Impl.FieldSerializers.NullableFieldSerializer, SolrNet.Impl.FieldSerializers.ToStringFieldSerializer, and SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker Interface Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • ISolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker Interface Reference

Validates a mapped document property against a Solr field type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker

List of all members.

Public Member Functions

ValidationResult | Validate (SolrFieldType solrFieldType, string propertyName, Type propertyType)
Validates a mapped document property against a Solr field type.
bool | CanHandleType (Type propertyType)

Detailed Description

Validates a mapped document property against a Solr field type.

Member Function Documentation

ValidationResult SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker.Validate | ( | SolrFieldType | solrFieldType,
 |  | string | propertyName,
 |  | Type | propertyType
 | ) |  |

Validates a mapped document property against a Solr field type.

Parameters:
solrFieldType
propertyName
propertyType
Returns:

Implemented in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker, and SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker.

The documentation for this interface was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/ISolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrHeaderResponseParser Interface Reference

  • SolrNet
  • Impl
  • ISolrHeaderResponseParser
Public Member Functions

SolrNet.Impl.ISolrHeaderResponseParser Interface Reference

Inheritance diagram for SolrNet.Impl.ISolrHeaderResponseParser:
SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >

List of all members.

Public Member Functions

ResponseHeader Parse (XmlDocument response)
The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrHeaderResponseParser.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrOperations< T > Interface Template Reference

  • SolrNet
  • ISolrOperations
Public Member Functions

SolrNet.ISolrOperations< T > Interface Template Reference

Consolidating interface, exposes all operations. More...

Inheritance diagram for SolrNet.ISolrOperations< T >:
SolrNet.ISolrReadOnlyOperations< T > SolrNet.ISolrBasicReadOnlyOperations< T > SolrNet.Impl.SolrServer< T >

List of all members.

Public Member Functions

ResponseHeader Commit ()
Commits posted documents, blocking until index changes are flushed to disk and blocking until a new searcher is opened and registered as the main query searcher, making the changes visible.
ResponseHeader Optimize ()
Optimizes Solr's index.
ResponseHeader | Add (T doc)
Adds / updates a document.
ResponseHeader | AddWithBoost (T doc, double boost)
Adds / updates a document with index-time boost.
ResponseHeader | Add (IEnumerable< T > docs)
Adds / updates several documents at once.
ResponseHeader | AddWithBoost (IEnumerable< KeyValuePair< T, double?>> docs)
Adds / updates documents with index-time boost.
ResponseHeader | Delete (T doc)
Deletes a document (requires the document to have a unique key defined with non-null value)
ResponseHeader | Delete (IEnumerable< T > docs)
Deletes several documents (requires the document type to have a unique key defined with non-null value)
ResponseHeader | Delete (ISolrQuery q)
Deletes all documents that match a query.
ResponseHeader | Delete (string id)
Deletes a document by its id (unique key)
ResponseHeader | Delete (IEnumerable< string > ids)
Deletes several documents by their id (unique key)
ResponseHeader | Delete (IEnumerable< string > ids, ISolrQuery q)
Deletes all documents that match the given id's or the query.
ResponseHeader BuildSpellCheckDictionary ()
Create the dictionary for use by the SolrSpellChecker. In typical applications, one needs to build the dictionary before using it. However, it may not always be necessary as it is possible to setup the spellchecker with a dictionary that already exists.
IEnumerable< ValidationResult > | EnumerateValidationResults ()

Detailed Description

template<T>
interface SolrNet::ISolrOperations< T >

Consolidating interface, exposes all operations.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Add ( T doc )

Adds / updates a document.

Parameters:
doc document to add/update
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Add ( IEnumerable< T > docs )

Adds / updates several documents at once.

Parameters:
docs documents to add/update
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.AddWithBoost | ( | T | doc,
 |  | double | boost
 | ) |  |

Adds / updates a document with index-time boost.

Parameters:
doc
boost
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.AddWithBoost ( IEnumerable< KeyValuePair< T, double?>> docs )

Adds / updates documents with index-time boost.

Parameters:
docs List of docs / boost. If boost is null, no boost is applied
Returns:
template<T >
ResponseHeader SolrNet.ISolrOperations< T >.BuildSpellCheckDictionary ( )

Create the dictionary for use by the SolrSpellChecker. In typical applications, one needs to build the dictionary before using it. However, it may not always be necessary as it is possible to setup the spellchecker with a dictionary that already exists.

summary> Validates the mapping of the type T against the Solr schema XML document. /summary> returns> A collection of ValidationResult objects containing warnings and error found validating the type's mapping against the Solr schema if any.

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Commit ( )

Commits posted documents, blocking until index changes are flushed to disk and blocking until a new searcher is opened and registered as the main query searcher, making the changes visible.

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Delete ( IEnumerable< T > docs )

Deletes several documents (requires the document type to have a unique key defined with non-null value)

Parameters:
docs
Returns:
Exceptions:
SolrNetException throws if document type doesn't have a unique key or document has null unique key

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Delete ( ISolrQuery q )

Deletes all documents that match a query.

Parameters:
q query to match
Returns:
template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Delete ( T doc )

Deletes a document (requires the document to have a unique key defined with non-null value)

Parameters:
doc document to delete
Returns:
Exceptions:
SolrNetException throws if document type doesn't have a unique key or document has null unique key

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Delete | ( | IEnumerable< string > | ids,
 |  | ISolrQuery | q
 | ) |  |

Deletes all documents that match the given id's or the query.

Parameters:
ids | document unique keys
q | query to match
Returns:
template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Delete ( string id )

Deletes a document by its id (unique key)

Parameters:
id document key
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Delete ( IEnumerable< string > ids )

Deletes several documents by their id (unique key)

Parameters:
ids document unique keys
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ResponseHeader SolrNet.ISolrOperations< T >.Optimize ( )

Optimizes Solr's index.

Implemented in SolrNet.Impl.SolrServer< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrOperations.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrQuery Interface Reference

  • SolrNet
  • ISolrQuery

SolrNet.ISolrQuery Interface Reference

Base query interface. More...

Inheritance diagram for SolrNet.ISolrQuery:
SolrNet.AbstractSolrQuery SolrNet.Impl.ISelfSerializingQuery SolrNet.LocalParams.LocalParamsQuery SolrNet.SolrHasValueQuery SolrNet.SolrMultipleCriteriaQuery SolrNet.SolrNotQuery SolrNet.SolrQuery SolrNet.SolrQueryBoost SolrNet.SolrQueryByField SolrNet.SolrQueryByRange< RT > SolrNet.SolrQueryInList SolrNet.SolrQuery

Detailed Description

Base query interface.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrQueryByRange Interface Reference

  • SolrNet
  • Impl
  • ISolrQueryByRange
Properties

SolrNet.Impl.ISolrQueryByRange Interface Reference

Inheritance diagram for SolrNet.Impl.ISolrQueryByRange:
SolrNet.SolrQueryByRange< RT >

List of all members.

Properties

string | FieldName [get]
object | From [get]
object | To [get]
bool | Inclusive [get]
The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrQueryByRange.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrQueryExecuter< T > Interface Template Reference

  • SolrNet
  • ISolrQueryExecuter
Public Member Functions

SolrNet.ISolrQueryExecuter< T > Interface Template Reference

Executable query. More...

Inheritance diagram for SolrNet.ISolrQueryExecuter< T >:
SolrNet.Impl.SolrQueryExecuter< T >

List of all members.

Public Member Functions

ISolrQueryResults< T > Execute (ISolrQuery q, QueryOptions options)
Executes the query and returns results.

Detailed Description

template<T>
interface SolrNet::ISolrQueryExecuter< T >

Executable query.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ISolrQueryResults<T> SolrNet.ISolrQueryExecuter< T >.Execute | ( | ISolrQuery | q,
 |  | QueryOptions | options
 | ) |  |

Executes the query and returns results.

Returns:
query results

Implemented in SolrNet.Impl.SolrQueryExecuter< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrQueryExecuter.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrQueryResultParser< T > Interface Template Reference

  • SolrNet
  • ISolrQueryResultParser
Public Member Functions

SolrNet.ISolrQueryResultParser< T > Interface Template Reference

Query results parser interface. More...

Inheritance diagram for SolrNet.ISolrQueryResultParser< T >:
SolrNet.Impl.SolrQueryResultParser< T >

List of all members.

Public Member Functions

ISolrQueryResults< T > Parse (string r)
Parses solr's response.

Detailed Description

template<T>
interface SolrNet::ISolrQueryResultParser< T >

Query results parser interface.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ISolrQueryResults<T> SolrNet.ISolrQueryResultParser< T >.Parse ( string r )

Parses solr's response.

Parameters:
r solr response
Returns:
query results

Implemented in SolrNet.Impl.SolrQueryResultParser< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrQueryResultParser.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrQueryResults< T > Interface Template Reference

  • SolrNet
  • ISolrQueryResults
Properties

SolrNet.ISolrQueryResults< T > Interface Template Reference

Query results. More...

Inheritance diagram for SolrNet.ISolrQueryResults< T >:
SolrNet.Impl.SolrQueryResults< T >

List of all members.

Properties

int | NumFound [get]
Total documents found.
double | MaxScore [get]
Max score in these results.
IDictionary< string, int > | FacetQueries [get, set]
Facet queries results.
IDictionary< string,
ICollection< KeyValuePair
< string, int > > > 		FacetFields [get, set]
Facet field queries results.
ResponseHeader | Header [get, set]
Query response header.
IDictionary< string,
IDictionary< string,
ICollection< string > > > 		Highlights [get, set]
Highlight results.
SpellCheckResults | SpellChecking [get, set]
Spell checking results.
IDictionary< string, IList< T > > | SimilarResults [get, set]
More-like-this results.
IDictionary< string, StatsResult > | Stats [get, set]
Stats results.
CollapseResults | Collapsing [get, set]
Collapse results.
IDictionary< string,
DateFacetingResult > 		FacetDates [get, set]
Date faceting results.

Detailed Description

template<T>
interface SolrNet::ISolrQueryResults< T >

Query results.

Template Parameters:
T Document type

Property Documentation

template<T >
CollapseResults SolrNet.ISolrQueryResults< T >.Collapsing [get, set]

Collapse results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
IDictionary<string, DateFacetingResult> SolrNet.ISolrQueryResults< T >.FacetDates [get, set]

Date faceting results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
IDictionary<string, ICollection<KeyValuePair<string, int> > > SolrNet.ISolrQueryResults< T >.FacetFields [get, set]

Facet field queries results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
IDictionary<string, int> SolrNet.ISolrQueryResults< T >.FacetQueries [get, set]

Facet queries results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
ResponseHeader SolrNet.ISolrQueryResults< T >.Header [get, set]

Query response header.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
IDictionary<string, IDictionary<string, ICollection<string> > > SolrNet.ISolrQueryResults< T >.Highlights [get, set]

Highlight results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
double SolrNet.ISolrQueryResults< T >.MaxScore [get]

Max score in these results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
int SolrNet.ISolrQueryResults< T >.NumFound [get]

Total documents found.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
IDictionary<string, IList<T> > SolrNet.ISolrQueryResults< T >.SimilarResults [get, set]

More-like-this results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
SpellCheckResults SolrNet.ISolrQueryResults< T >.SpellChecking [get, set]

Spell checking results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

template<T >
IDictionary<string, StatsResult> SolrNet.ISolrQueryResults< T >.Stats [get, set]

Stats results.

Implemented in SolrNet.Impl.SolrQueryResults< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrQueryResults.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrQuerySerializer Interface Reference

  • SolrNet
  • Impl
  • ISolrQuerySerializer
Public Member Functions

SolrNet.Impl.ISolrQuerySerializer Interface Reference

Inheritance diagram for SolrNet.Impl.ISolrQuerySerializer:
SolrNet.Impl.QuerySerializers.AggregateQuerySerializer SolrNet.Impl.QuerySerializers.DefaultQuerySerializer SolrNet.Impl.QuerySerializers.RangeQuerySerializer SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.QuerySerializers.BoostQuerySerializer SolrNet.Impl.QuerySerializers.HasValueQuerySerializer SolrNet.Impl.QuerySerializers.LocalParamsSerializer SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer SolrNet.Impl.QuerySerializers.NotQuerySerializer SolrNet.Impl.QuerySerializers.QueryByFieldSerializer SolrNet.Impl.QuerySerializers.QueryInListSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
string | Serialize (object q)
The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ISolrReadOnlyOperations< T > Interface Template Reference

  • SolrNet
  • ISolrReadOnlyOperations
Public Member Functions

SolrNet.ISolrReadOnlyOperations< T > Interface Template Reference

Read-only operations. More...

Inheritance diagram for SolrNet.ISolrReadOnlyOperations< T >:
SolrNet.ISolrBasicReadOnlyOperations< T > SolrNet.ISolrOperations< T > SolrNet.Impl.SolrServer< T >

List of all members.

Public Member Functions

ISolrQueryResults< T > | Query (string q)
Executes a query.
ISolrQueryResults< T > | Query (string q, ICollection< SortOrder > orders)
Executes a query.
ISolrQueryResults< T > | Query (string q, QueryOptions options)
Executes a query.
ISolrQueryResults< T > | Query (ISolrQuery q)
Executes a query.
ISolrQueryResults< T > | Query (ISolrQuery query, ICollection< SortOrder > orders)
Executes a query.
ICollection< KeyValuePair
< string, int > > 		FacetFieldQuery (SolrFacetFieldQuery facets)
Executes a single facet field query.

Detailed Description

template<T>
interface SolrNet::ISolrReadOnlyOperations< T >

Read-only operations.

Template Parameters:
T

Member Function Documentation

template<T >
ICollection<KeyValuePair<string, int> > SolrNet.ISolrReadOnlyOperations< T >.FacetFieldQuery ( SolrFacetFieldQuery facets )

Executes a single facet field query.

Parameters:
facets
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ISolrQueryResults<T> SolrNet.ISolrReadOnlyOperations< T >.Query | ( | string | q,
 |  | QueryOptions | options
 | ) |  |

Executes a query.

Parameters:
q
options
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ISolrQueryResults<T> SolrNet.ISolrReadOnlyOperations< T >.Query | ( | ISolrQuery | query,
 |  | ICollection< SortOrder > | orders
 | ) |  |

Executes a query.

Parameters:
query
orders
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ISolrQueryResults<T> SolrNet.ISolrReadOnlyOperations< T >.Query ( ISolrQuery q )

Executes a query.

Parameters:
q
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ISolrQueryResults<T> SolrNet.ISolrReadOnlyOperations< T >.Query ( string q )

Executes a query.

Parameters:
q query to execute
Returns:
query results

Implemented in SolrNet.Impl.SolrServer< T >.

template<T >
ISolrQueryResults<T> SolrNet.ISolrReadOnlyOperations< T >.Query | ( | string | q,
 |  | ICollection< SortOrder > | orders
 | ) |  |

Executes a query.

Parameters:
q
orders
Returns:

Implemented in SolrNet.Impl.SolrServer< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/ISolrReadOnlyOperations.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ISolrResponseParser< T > Interface Template Reference

  • SolrNet
  • Impl
  • ISolrResponseParser
Public Member Functions

SolrNet.Impl.ISolrResponseParser< T > Interface Template Reference

Parses a chunk of a query response. More...

Inheritance diagram for SolrNet.Impl.ISolrResponseParser< T >:
SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > SolrNet.Impl.ResponseParsers.StatsResponseParser< T >

List of all members.

Public Member Functions

void Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.

Detailed Description

template<T>
interface SolrNet::Impl::ISolrResponseParser< T >

Parses a chunk of a query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ISolrResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implemented in SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >, SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >, SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >, SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >, SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >, SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >, SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >, and SolrNet.Impl.ResponseParsers.StatsResponseParser< T >.

The documentation for this interface was generated from the following file:
  • SolrNet/Impl/ISolrResponseParser.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.ISolrSchemaParser Interface Reference

  • SolrNet
  • Schema
  • ISolrSchemaParser
Public Member Functions

SolrNet.Schema.ISolrSchemaParser Interface Reference

Provides an interface to parsing a solr schema xml document into a SolrSchema object. More...

Inheritance diagram for SolrNet.Schema.ISolrSchemaParser:
SolrNet.Schema.SolrSchemaParser

List of all members.

Public Member Functions

SolrSchema Parse (XmlDocument solrSchemaXml)
Parses the specified solr schema XML.

Detailed Description

Provides an interface to parsing a solr schema xml document into a SolrSchema object.

Member Function Documentation

SolrSchema SolrNet.Schema.ISolrSchemaParser.Parse ( XmlDocument solrSchemaXml )

Parses the specified solr schema XML.

Parameters:
solrSchemaXml The solr schema XML.
Returns:
a object model of the solr schema.

Implemented in SolrNet.Schema.SolrSchemaParser.

The documentation for this interface was generated from the following file:
  • SolrNet/Schema/ISolrSchemaParser.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.ISolrSession Interface Reference

  • NHibernate
  • SolrNet
  • ISolrSession
Public Member Functions

NHibernate.SolrNet.ISolrSession Interface Reference

NHibernate ISession with SolrNet extensions for querying. More...

Inheritance diagram for NHibernate.SolrNet.ISolrSession:
NHibernate.SolrNet.SolrSession

List of all members.

Public Member Functions

INHSolrQuery | CreateSolrQuery (string query)
Creates a Solr query.
INHSolrQuery | CreateSolrQuery (ISolrQuery query)
Creates a Solr query.

Detailed Description

NHibernate ISession with SolrNet extensions for querying.

Member Function Documentation

INHSolrQuery NHibernate.SolrNet.ISolrSession.CreateSolrQuery ( string query )

Creates a Solr query.

Parameters:
query Solr query
Returns:
query object

Implemented in NHibernate.SolrNet.SolrSession.

INHSolrQuery NHibernate.SolrNet.ISolrSession.CreateSolrQuery ( ISolrQuery query )

Creates a Solr query.

Parameters:
query Solr query
Returns:
query object

Implemented in NHibernate.SolrNet.SolrSession.

The documentation for this interface was generated from the following file:
  • NHibernate.SolrNet/ISolrSession.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.IValidationRule Interface Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • IValidationRule
Public Member Functions

SolrNet.Mapping.Validation.Rules.IValidationRule Interface Reference

Provides a interface to schema mapping validation rules. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.IValidationRule:
SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule

List of all members.

Public Member Functions

IEnumerable< ValidationResult > Validate (Type propertyType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager)
Validates the specified solr schema.

Detailed Description

Provides a interface to schema mapping validation rules.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.Rules.IValidationRule.Validate | ( | Type | propertyType,
 |  | SolrSchema | solrSchema,
 |  | IReadOnlyMappingManager | mappingManager
 | ) |  |

Validates the specified solr schema.

Parameters:
propertyType | The type which mappings will be validated.
solrSchema | The solr schema.
mappingManager | The mapping manager.
Returns:
A collection of ValidationResult objects with any issues found during validation.

Implemented in SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule, SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule, SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule, SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule, and SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule.

The documentation for this interface was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/IValidationRule.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Rhino.Commons.Local Class Reference

  • Rhino
  • Commons
  • Local
Classes | Properties

Rhino.Commons.Local Class Reference

List of all members.

Classes

class | LocalData

Properties

static ILocalData | Data [get]
static bool | RunningInWeb [get]
The documentation for this class was generated from the following file:
  • SolrNet.DSL/Utils/LocalData.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.LocalParams Class Reference

  • SolrNet
  • LocalParams
Classes | Public Member Functions | Static Public Member Functions

SolrNet.LocalParams Class Reference

Provides a way to "localize" information about a specific argument that is being sent to Solr. In other words, it provides a way to add meta-data to certain argument types such as query strings. More...

List of all members.

Classes

class | LocalParamsQuery

Public Member Functions

LocalParams (IDictionary< string, string > dictionary)
override string | ToString ()

Static Public Member Functions

static ISolrQuery | operator+ (LocalParams p, ISolrQuery q)

Detailed Description

Provides a way to "localize" information about a specific argument that is being sent to Solr. In other words, it provides a way to add meta-data to certain argument types such as query strings.

The documentation for this class was generated from the following file:
  • SolrNet/LocalParams.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.LocalParams.LocalParamsQuery Class Reference

  • SolrNet
  • LocalParams
  • LocalParamsQuery
Public Member Functions | Properties

SolrNet.LocalParams.LocalParamsQuery Class Reference

Inheritance diagram for SolrNet.LocalParams.LocalParamsQuery:
SolrNet.ISolrQuery

List of all members.

Public Member Functions

LocalParamsQuery (ISolrQuery query, LocalParams local)

Properties

ISolrQuery | Query [get]
LocalParams | Local [get]
The documentation for this class was generated from the following file:
  • SolrNet/LocalParams.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.LocalParamsSerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • LocalParamsSerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.LocalParamsSerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.LocalParamsSerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

LocalParamsSerializer (ISolrQuerySerializer serializer)
override string Serialize (LocalParams.LocalParamsQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/LocalParamsSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.LongFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • LongFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.LongFieldParser Class Reference

Parses long fields. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.LongFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses long fields.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.LongFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.LongFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.LongFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/LongFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • LongSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker Class Reference

Checks schema type of properties with long type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

LongSolrFieldTypeChecker ()
Checks schema type of properties with long type.

Detailed Description

Checks schema type of properties with long type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker.LongSolrFieldTypeChecker ( )

Checks schema type of properties with long type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/LongSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • MappedPropertiesIsInSolrSchemaRule
Public Member Functions | Properties

SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule Class Reference

Represents a rule validation that all properties in the mapping are present in the Solr schema as either a SolrField or a DynamicField. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule:
SolrNet.Mapping.Validation.Rules.IValidationRule

List of all members.

Public Member Functions

IEnumerable< ValidationResult > | Validate (Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager)
Validates that all properties in the mapping are present in the Solr schema as either a SolrField or a DynamicField.

Properties

ICollection< string > | IgnoredFieldNames [get, set]
Field names to be ignored. These fields are never checked.

Detailed Description

Represents a rule validation that all properties in the mapping are present in the Solr schema as either a SolrField or a DynamicField.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule.Validate | ( | Type | documentType,
 |  | SolrSchema | solrSchema,
 |  | IReadOnlyMappingManager | mappingManager
 | ) |  |

Validates that all properties in the mapping are present in the Solr schema as either a SolrField or a DynamicField.

Parameters:
documentType | Document type
solrSchema | The solr schema.
mappingManager | The mapping manager.
Returns:
A collection of ValidationResult objects with any issues found during validation.

Implements SolrNet.Mapping.Validation.Rules.IValidationRule.

Property Documentation

ICollection<string> SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule.IgnoredFieldNames [get, set]

Field names to be ignored. These fields are never checked.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/MappedPropertiesIsInSolrSchemaRule.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.MappingManager Class Reference

  • SolrNet
  • Mapping
  • MappingManager
Public Member Functions

SolrNet.Mapping.MappingManager Class Reference

Manual mapping manager. More...

Inheritance diagram for SolrNet.Mapping.MappingManager:
SolrNet.Mapping.IMappingManager SolrNet.IReadOnlyMappingManager

List of all members.

Public Member Functions

void | Add (PropertyInfo property)
Maps a property with the property name as Solr field name.
void | Add (PropertyInfo property, string fieldName)
Maps a property.
void | Add (PropertyInfo property, string fieldName, float?boost)
Maps a property.
ICollection< SolrFieldModel > | GetFields (Type type)
Gets fields mapped for this type.
void | SetUniqueKey (PropertyInfo property)
Sets unique key for a document type.
SolrFieldModel | GetUniqueKey (Type type)
Gets unique key for the type.
ICollection< Type > | GetRegisteredTypes ()

Detailed Description

Manual mapping manager.

Member Function Documentation

void SolrNet.Mapping.MappingManager.Add ( PropertyInfo property )

Maps a property with the property name as Solr field name.

Parameters:
property Document type property

Implements SolrNet.Mapping.IMappingManager.

void SolrNet.Mapping.MappingManager.Add | ( | PropertyInfo | property,
 |  | string | fieldName
 | ) |  |

Maps a property.

Parameters:
property | Document type property
fieldName | Solr field name

Implements SolrNet.Mapping.IMappingManager.

void SolrNet.Mapping.MappingManager.Add | ( | PropertyInfo | property,
 |  | string | fieldName,
 |  | float? | boost
 | ) |  |

Maps a property.

Parameters:
property | Document type property
fieldName | Solr field name
boost | Index-time boosting

Implements SolrNet.Mapping.IMappingManager.

ICollection<SolrFieldModel> SolrNet.Mapping.MappingManager.GetFields ( Type type )

Gets fields mapped for this type.

Parameters:
type Document type
Returns:
Null if type is not mapped

Implements SolrNet.IReadOnlyMappingManager.

SolrFieldModel SolrNet.Mapping.MappingManager.GetUniqueKey ( Type type )

Gets unique key for the type.

Parameters:
type
Returns:

Implements SolrNet.IReadOnlyMappingManager.

void SolrNet.Mapping.MappingManager.SetUniqueKey ( PropertyInfo property )

Sets unique key for a document type.

Parameters:
property Document type property

Implements SolrNet.Mapping.IMappingManager.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/MappingManager.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • MappingTypesAreCompatibleWithSolrTypesRule
Public Member Functions

SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule Class Reference

Inheritance diagram for SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule:
SolrNet.Mapping.Validation.Rules.IValidationRule

List of all members.

Public Member Functions

MappingTypesAreCompatibleWithSolrTypesRule (ISolrFieldTypeChecker[] fieldTypeCheckers)
IEnumerable< ValidationResult > Validate (Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager)
Validates the specified solr schema.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule.Validate | ( | Type | propertyType,
 |  | SolrSchema | solrSchema,
 |  | IReadOnlyMappingManager | mappingManager
 | ) |  |

Validates the specified solr schema.

Parameters:
propertyType | The type which mappings will be validated.
solrSchema | The solr schema.
mappingManager | The mapping manager.
Returns:
A collection of ValidationResult objects with any issues found during validation.

Implements SolrNet.Mapping.Validation.Rules.IValidationRule.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/MappingTypesAreCompatibleWithSolrTypesRule.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.MappingValidator Class Reference

  • SolrNet
  • Mapping
  • Validation
  • MappingValidator
Public Member Functions

SolrNet.Mapping.Validation.MappingValidator Class Reference

Manages the validation of a mapping against a solr schema XML document. More...

Inheritance diagram for SolrNet.Mapping.Validation.MappingValidator:
SolrNet.Mapping.Validation.IMappingValidator

List of all members.

Public Member Functions

MappingValidator (IReadOnlyMappingManager mappingManager, IValidationRule[] rules)
Initializes a new instance of the MappingValidator class.
IEnumerable< ValidationResult > EnumerateValidationResults (Type documentType, SolrSchema schema)
Validates the specified validation rules.

Detailed Description

Manages the validation of a mapping against a solr schema XML document.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.MappingValidator.MappingValidator | ( | IReadOnlyMappingManager | mappingManager,
 |  | IValidationRule[] | rules
 | ) |  |

Initializes a new instance of the MappingValidator class.

Parameters:
mappingManager | The mapping manager that is used to map types to and from their Solr representation.
rules | Validation rules

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.MappingValidator.EnumerateValidationResults | ( | Type | documentType,
 |  | SolrSchema | schema
 | ) |  |

Validates the specified validation rules.

Parameters:
documentType | The document type which needs to be validated
schema | The Solr schema.
Returns:
A collection of ValidationResult objects with the problems found during validation. If Any.

Implements SolrNet.Mapping.Validation.IMappingValidator.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/MappingValidator.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Utils.Memoizer Class Reference

  • SolrNet
  • Utils
  • Memoizer
Classes | Static Public Member Functions

SolrNet.Utils.Memoizer Class Reference

Function memoizer From http://blogs.msdn.com/wesdyer/archive/2007/01/26/function-memoization.aspx. More...

List of all members.

Classes

struct | Tuple2

Static Public Member Functions

static Converter< TArg, TResult > | Memoize< TArg, TResult > (Converter< TArg, TResult > function)
Function memoizer From http://blogs.msdn.com/wesdyer/archive/2007/01/26/function-memoization.aspx.
static Func.Func2< TArg1,
TArg2, TResult > 		Memoize2< TArg1, TArg2, TResult > (Func.Func2< TArg1, TArg2, TResult > function)

Detailed Description

Function memoizer From http://blogs.msdn.com/wesdyer/archive/2007/01/26/function-memoization.aspx.

Member Function Documentation

static Converter<TArg, TResult> SolrNet.Utils.Memoizer.Memoize< TArg, TResult > ( Converter< TArg, TResult > function ) [static]

Function memoizer From http://blogs.msdn.com/wesdyer/archive/2007/01/26/function-memoization.aspx.

The documentation for this class was generated from the following file:
  • SolrNet/Utils/Memoizer.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.MemoizingMappingManager Class Reference

  • SolrNet
  • Mapping
  • MemoizingMappingManager
Public Member Functions

SolrNet.Mapping.MemoizingMappingManager Class Reference

Memoizing decorator for a mapping manager. More...

Inheritance diagram for SolrNet.Mapping.MemoizingMappingManager:
SolrNet.IReadOnlyMappingManager

List of all members.

Public Member Functions

MemoizingMappingManager (IReadOnlyMappingManager mapper)
ICollection< SolrFieldModel > | GetFields (Type type)
Gets fields mapped for this type.
SolrFieldModel | GetUniqueKey (Type type)
Gets unique key for the type.
ICollection< Type > | GetRegisteredTypes ()

Detailed Description

Memoizing decorator for a mapping manager.

Member Function Documentation

ICollection<SolrFieldModel> SolrNet.Mapping.MemoizingMappingManager.GetFields ( Type type )

Gets fields mapped for this type.

Parameters:
type
Returns:
Null if type is not mapped

Implements SolrNet.IReadOnlyMappingManager.

SolrFieldModel SolrNet.Mapping.MemoizingMappingManager.GetUniqueKey ( Type type )

Gets unique key for the type.

Parameters:
type
Returns:

Implements SolrNet.IReadOnlyMappingManager.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/MemoizingMappingManager.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.MoreLikeThisParameters Class Reference

  • SolrNet
  • Commands
  • Parameters
  • MoreLikeThisParameters
Public Member Functions | Properties

SolrNet.Commands.Parameters.MoreLikeThisParameters Class Reference

More-like-this parameters See http://wiki.apache.org/solr/MoreLikeThis. More...

List of all members.

Public Member Functions

MoreLikeThisParameters (IEnumerable< string > fields)
Creates more-like-this parameters.

Properties

IEnumerable< string > | Fields [get]
The fields to use for similarity. NOTE: if possible, these should have a stored TermVector.
int | MinTermFreq [get, set]
Minimum Term Frequency - the frequency below which terms will be ignored in the source doc.
int | MinDocFreq [get, set]
Minimum Document Frequency - the frequency at which words will be ignored which do not occur in at least this many docs.
int | MinWordLength [get, set]
Minimum word length below which words will be ignored.
int | MaxWordLength [get, set]
Maximum word length above which words will be ignored.
int | MaxQueryTerms [get, set]
Maximum number of query terms that will be included in any generated query.
int | MaxTokens [get, set]
Maximum number of tokens to parse in each example doc field that is not stored with TermVector support.
bool | Boost [get, set]
Set if the query will be boosted by the interesting term relevance.
ICollection< string > | QueryFields [get, set]
Query fields and their boosts using the same format as that used in DisMaxRequestHandler. These fields must also be specified in Fields
int | Count [get, set]
The number of similar documents to return for each result.

Detailed Description

More-like-this parameters See http://wiki.apache.org/solr/MoreLikeThis.

Constructor & Destructor Documentation

SolrNet.Commands.Parameters.MoreLikeThisParameters.MoreLikeThisParameters ( IEnumerable< string > fields )

Creates more-like-this parameters.

Parameters:
fields The fields to use for similarity.

Property Documentation

bool SolrNet.Commands.Parameters.MoreLikeThisParameters.Boost [get, set]

Set if the query will be boosted by the interesting term relevance.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.Count [get, set]

The number of similar documents to return for each result.

IEnumerable<string> SolrNet.Commands.Parameters.MoreLikeThisParameters.Fields [get]

The fields to use for similarity. NOTE: if possible, these should have a stored TermVector.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.MaxQueryTerms [get, set]

Maximum number of query terms that will be included in any generated query.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.MaxTokens [get, set]

Maximum number of tokens to parse in each example doc field that is not stored with TermVector support.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.MaxWordLength [get, set]

Maximum word length above which words will be ignored.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.MinDocFreq [get, set]

Minimum Document Frequency - the frequency at which words will be ignored which do not occur in at least this many docs.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.MinTermFreq [get, set]

Minimum Term Frequency - the frequency below which terms will be ignored in the source doc.

int SolrNet.Commands.Parameters.MoreLikeThisParameters.MinWordLength [get, set]

Minimum word length below which words will be ignored.

ICollection<string> SolrNet.Commands.Parameters.MoreLikeThisParameters.QueryFields [get, set]

Query fields and their boosts using the same format as that used in DisMaxRequestHandler. These fields must also be specified in Fields

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/MoreLikeThisParameters.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • MoreLikeThisResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > Class Template Reference

Parses more-like-this results from a query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

MoreLikeThisResponseParser (ISolrDocumentResponseParser< T > docParser)
void | Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
IDictionary< string, IList< T > > | ParseMoreLikeThis (IEnumerable< T > results, XmlNode node)
Parses more-like-this results.

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::MoreLikeThisResponseParser< T >

Parses more-like-this results from a query response.

Template Parameters:
T

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
IDictionary<string, IList<T> > SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >.ParseMoreLikeThis | ( | IEnumerable< T > | results,
 |  | XmlNode | node
 | ) |  |

Parses more-like-this results.

Parameters:
results
node
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/MoreLikeThisResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • MultipleCriteriaQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

MultipleCriteriaQuerySerializer (ISolrQuerySerializer serializer)
override string Serialize (SolrMultipleCriteriaQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/MultipleCriteriaQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • MultivaluedMappedToCollectionRule
Public Member Functions

SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule Class Reference

Represents a rule that validates that fields mapped to a solr field with mutilvalued set to true are of a type that implements IEnumerable{T}. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule:
SolrNet.Mapping.Validation.Rules.IValidationRule

List of all members.

Public Member Functions

IEnumerable< ValidationResult > Validate (Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager)
Validates the specified the mapped document against the solr schema.

Detailed Description

Represents a rule that validates that fields mapped to a solr field with mutilvalued set to true are of a type that implements IEnumerable{T}.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule.Validate | ( | Type | documentType,
 |  | SolrSchema | solrSchema,
 |  | IReadOnlyMappingManager | mappingManager
 | ) |  |

Validates the specified the mapped document against the solr schema.

Parameters:
documentType | Document type
solrSchema | The solr schema.
mappingManager | The mapping manager.
Returns:
A collection of ValidationResult objects with any issues found during validation.

Implements SolrNet.Mapping.Validation.Rules.IValidationRule.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/MultivaluedMappedToCollectionRule.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.Impl.NHHelper Class Reference

  • NHibernate
  • SolrNet
  • Impl
  • NHHelper
Classes | Static Public Member Functions

NHibernate.SolrNet.Impl.NHHelper Class Reference

List of all members.

Classes

struct | NHListenerInfo

Static Public Member Functions

static void | SetListener (Configuration config, object listener)
static object[] | AppendToArray (Array currentListeners, object listener)
The documentation for this class was generated from the following file:
  • NHibernate.SolrNet/Impl/NHHelper.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.Impl.NHSolrQueryImpl Class Reference

  • NHibernate
  • SolrNet
  • Impl
  • NHSolrQueryImpl
Public Member Functions | Properties

NHibernate.SolrNet.Impl.NHSolrQueryImpl Class Reference

NHibernate IQuery for SolrNet queries. More...

Inheritance diagram for NHibernate.SolrNet.Impl.NHSolrQueryImpl:
NHibernate.SolrNet.INHSolrQuery

List of all members.

Public Member Functions

NHSolrQueryImpl (IServiceProvider provider, string queryString, FlushMode flushMode, ISessionImplementor session, ParameterMetadata parameterMetadata)
override IQuery | SetLockMode (string alias, LockMode lockMode)
Ignored.
override int | ExecuteUpdate ()
Operation not supported. For Solr updates use the SolrNet interfaces.
override IEnumerable | Enumerable ()
Operation not supported. Please use Enumerable{T} instead.
override IEnumerable< T > | Enumerable< T > ()
Return the query results as an System.Collections.Generic.IEnumerable{T}
override IList | List ()
Operation not supported. Please use List{T} instead.
override void | List (IList results)
Operation not supported. Please use List{T} instead.
override IList< T > | List< T > ()
Return the query results as an System.Collections.Generic.List{T}
new INHSolrQuery | SetMaxResults (int maxResults)
Set the maximum number of rows to retrieve.
new INHSolrQuery | SetFirstResult (int firstResult)
Sets the first row to retrieve.
INHSolrQuery | SetSort (Order o)
Sets sort order.

Properties

override IDictionary< string,
LockMode > 		LockModes [get]
Null.

Detailed Description

NHibernate IQuery for SolrNet queries.

Member Function Documentation

override IEnumerable NHibernate.SolrNet.Impl.NHSolrQueryImpl.Enumerable ( )

Operation not supported. Please use Enumerable{T} instead.

Returns:
override IEnumerable<T> NHibernate.SolrNet.Impl.NHSolrQueryImpl.Enumerable< T > ( )

Return the query results as an System.Collections.Generic.IEnumerable{T}

Template Parameters:
T
Returns:

This is not a lazy IEnumerable

override int NHibernate.SolrNet.Impl.NHSolrQueryImpl.ExecuteUpdate ( )

Operation not supported. For Solr updates use the SolrNet interfaces.

Returns:
override IList NHibernate.SolrNet.Impl.NHSolrQueryImpl.List ( )

Operation not supported. Please use List{T} instead.

Returns:
override void NHibernate.SolrNet.Impl.NHSolrQueryImpl.List ( IList results )

Operation not supported. Please use List{T} instead.

Parameters:
results
override IList<T> NHibernate.SolrNet.Impl.NHSolrQueryImpl.List< T > ( )

Return the query results as an System.Collections.Generic.List{T}

Template Parameters:
T
Returns:
new INHSolrQuery NHibernate.SolrNet.Impl.NHSolrQueryImpl.SetFirstResult ( int firstResult )

Sets the first row to retrieve.

Parameters:
firstResult The first row to retreive.
Returns:
this

Implements NHibernate.SolrNet.INHSolrQuery.

override IQuery NHibernate.SolrNet.Impl.NHSolrQueryImpl.SetLockMode | ( | string | alias,
 |  | LockMode | lockMode
 | ) |  |

Ignored.

Parameters:
alias
lockMode
Returns:
this
new INHSolrQuery NHibernate.SolrNet.Impl.NHSolrQueryImpl.SetMaxResults ( int maxResults )

Set the maximum number of rows to retrieve.

Parameters:
maxResults The maximum number of rows to retreive
Returns:
this

Implements NHibernate.SolrNet.INHSolrQuery.

INHSolrQuery NHibernate.SolrNet.Impl.NHSolrQueryImpl.SetSort ( Order o )

Sets sort order.

Parameters:
o Sort order
Returns:
this

Property Documentation

override IDictionary<string, LockMode> NHibernate.SolrNet.Impl.NHSolrQueryImpl.LockModes [get, protected]

Null.

The documentation for this class was generated from the following file:
  • NHibernate.SolrNet/Impl/NHSolrQueryImpl.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.NotQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • NotQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.NotQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.NotQuerySerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

NotQuerySerializer (ISolrQuerySerializer serializer)
override string Serialize (SolrNotQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/NotQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • NullableDateTimeRangeQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer Class Reference

List of all members.

Public Member Functions

NullableDateTimeRangeQuerySerializer (ISolrFieldSerializer fieldSerializer)
string | SerializeSingle (object o)
override string | Serialize (SolrQueryByRange< DateTime?> q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/NullableDateTimeRangeQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.NullableFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • NullableFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.NullableFieldParser Class Reference

Wraps a ISolrFieldParser making it support the corresponding Nullable{T} type. More...

Inheritance diagram for SolrNet.Impl.FieldParsers.NullableFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

NullableFieldParser (ISolrFieldParser parser)
bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Wraps a ISolrFieldParser making it support the corresponding Nullable{T} type.

Member Function Documentation

bool SolrNet.Impl.FieldParsers.NullableFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.NullableFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

object SolrNet.Impl.FieldParsers.NullableFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/NullableFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.NullableFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • NullableFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.NullableFieldSerializer Class Reference

Wraps a ISolrFieldSerializer making it support the corresponding Nullable{T} type. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.NullableFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

NullableFieldSerializer (ISolrFieldSerializer serializer)
bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Wraps a ISolrFieldSerializer making it support the corresponding Nullable{T} type.

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.NullableFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.NullableFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/NullableFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.NullCache Class Reference

  • SolrNet
  • Impl
  • NullCache
Public Member Functions | Properties

SolrNet.Impl.NullCache Class Reference

Cache implementation that doesn't cache anything. Use it when you want to disable http caching. More...

Inheritance diagram for SolrNet.Impl.NullCache:
SolrNet.Impl.ISolrCache

List of all members.

Public Member Functions

void | Add (SolrCacheEntity e)
Adds a Solr response to the cache.

Properties

SolrCacheEntity | this [string url] [get]
Gets a cached Solr response. Returns null if there is no cached response for this URL.

Detailed Description

Cache implementation that doesn't cache anything. Use it when you want to disable http caching.

Member Function Documentation

void SolrNet.Impl.NullCache.Add ( SolrCacheEntity e )

Adds a Solr response to the cache.

Parameters:
e

Implements SolrNet.Impl.ISolrCache.

Property Documentation

SolrCacheEntity SolrNet.Impl.NullCache.this[string url] [get]

Gets a cached Solr response. Returns null if there is no cached response for this URL.

Parameters:
url Full Solr query URL (including all querystring parameters)
Returns:

Implements SolrNet.Impl.ISolrCache.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/NullCache.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrMultipleCriteriaQuery.Operator Class Reference

  • SolrNet
  • SolrMultipleCriteriaQuery
  • Operator
Public Attributes

SolrNet.SolrMultipleCriteriaQuery.Operator Class Reference

Operator to apply to the included queries. More...

List of all members.

Public Attributes

const string | OR = "OR"
const string | AND = "AND"

Detailed Description

Operator to apply to the included queries.

The documentation for this class was generated from the following file:
  • SolrNet/SolrMultipleCriteriaQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.OptimizeCommand Class Reference

  • SolrNet
  • Commands
  • OptimizeCommand
Public Member Functions | Properties

SolrNet.Commands.OptimizeCommand Class Reference

Optimizes Solr's index. More...

Inheritance diagram for SolrNet.Commands.OptimizeCommand:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

string | Execute (ISolrConnection connection)
Executes this command.

Properties

bool | WaitFlush [get, set]
Block until index changes are flushed to disk Default is true.
bool | WaitSearcher [get, set]
Block until a new searcher is opened and registered as the main query searcher, making the changes visible. Default is true.
bool | ExpungeDeletes [get, set]
Merge segments with deletes away Default is false.
int | MaxSegments [get, set]
Optimizes down to, at most, this number of segments Default is 1.

Detailed Description

Optimizes Solr's index.

Lucene FAQ

Member Function Documentation

string SolrNet.Commands.OptimizeCommand.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

Property Documentation

bool SolrNet.Commands.OptimizeCommand.ExpungeDeletes [get, set]

Merge segments with deletes away Default is false.

int SolrNet.Commands.OptimizeCommand.MaxSegments [get, set]

Optimizes down to, at most, this number of segments Default is 1.

bool SolrNet.Commands.OptimizeCommand.WaitFlush [get, set]

Block until index changes are flushed to disk Default is true.

bool SolrNet.Commands.OptimizeCommand.WaitSearcher [get, set]

Block until a new searcher is opened and registered as the main query searcher, making the changes visible. Default is true.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/OptimizeCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.PingCommand Class Reference

  • SolrNet
  • Commands
  • PingCommand
Public Member Functions

SolrNet.Commands.PingCommand Class Reference

Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. More...

Inheritance diagram for SolrNet.Commands.PingCommand:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

string Execute (ISolrConnection connection)
Executes this command.

Detailed Description

Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing.

Member Function Documentation

string SolrNet.Commands.PingCommand.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/PingCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.PropertyNode Class Reference

  • SolrNet
  • Impl
  • PropertyNode
Properties

SolrNet.Impl.PropertyNode Class Reference

Models a XML node for update consumption. More...

List of all members.

Properties

string | FieldValue [get, set]
Serialized field value.
string | FieldNameSuffix [get, set]
Optional field name suffix.

Detailed Description

Models a XML node for update consumption.

Property Documentation

string SolrNet.Impl.PropertyNode.FieldNameSuffix [get, set]

Optional field name suffix.

string SolrNet.Impl.PropertyNode.FieldValue [get, set]

Serialized field value.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/PropertyNode.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.QueryByFieldSerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • QueryByFieldSerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.QueryByFieldSerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.QueryByFieldSerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

override string | Serialize (SolrQueryByField q)
string | quote (string value)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/QueryByFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.QueryInListSerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • QueryInListSerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.QueryInListSerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.QueryInListSerializer:
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

QueryInListSerializer (ISolrQuerySerializer serializer)
override string Serialize (SolrQueryInList q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/QueryInListSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.QueryOptions Class Reference

  • SolrNet
  • Commands
  • Parameters
  • QueryOptions
Public Member Functions | Properties

SolrNet.Commands.Parameters.QueryOptions Class Reference

Query options. More...

List of all members.

Public Member Functions

QueryOptions | AddFields (params string[] fields)
QueryOptions | AddOrder (params SortOrder[] order)
QueryOptions | AddFilterQueries (params ISolrQuery[] queries)
QueryOptions | AddFacets (params ISolrFacetQuery[] queries)

Properties

ICollection< string > | Fields [get, set]
int | Start [get, set]
Offset in the complete result set for the queries where the set of returned documents should begin Default is 0.
int | Rows [get, set]
Maximum number of documents from the complete result set to return to the client for every request. Default is 10.
ICollection< SortOrder > | OrderBy [get, set]
Sort order. By default, it's "score desc".
HighlightingParameters | Highlight [get, set]
Highlighting parameters.
FacetParameters | Facet [get, set]
Facet parameters.
SpellCheckingParameters | SpellCheck [get, set]
Spell-checking parameters.
MoreLikeThisParameters | MoreLikeThis [get, set]
More-like-this parameters.
ICollection< ISolrQuery > | FilterQueries [get, set]
This parameter can be used to specify a query that can be used to restrict the super set of documents that can be returned, without influencing score. It can be very useful for speeding up complex queries since the queries specified with fq are cached independently from the main query. This assumes the same Filter is used again for a latter query (i.e. there's a cache hit)
StatsParameters | Stats [get, set]
This parameter can be used to return the stats for a specific query on top of the results that are normally returned. Included in the stats are min, max, sum, count, missing, sumOfSquares, mean, and stddev values.
CollapseParameters | Collapse [get, set]
This parameter can be used to collapse - or group - documents by the unique values of a specified field. Included in the results are the number of records by document key and by field value.
IEnumerable< KeyValuePair
< string, string > > 		ExtraParams [get, set]
Extra arbitrary parameters to be passed in the request querystring.

Detailed Description

Query options.

Property Documentation

CollapseParameters SolrNet.Commands.Parameters.QueryOptions.Collapse [get, set]

This parameter can be used to collapse - or group - documents by the unique values of a specified field. Included in the results are the number of records by document key and by field value.

IEnumerable<KeyValuePair<string, string> > SolrNet.Commands.Parameters.QueryOptions.ExtraParams [get, set]

Extra arbitrary parameters to be passed in the request querystring.

FacetParameters SolrNet.Commands.Parameters.QueryOptions.Facet [get, set]

Facet parameters.

ICollection<string> SolrNet.Commands.Parameters.QueryOptions.Fields [get, set]

Fields to retrieve. By default, all stored fields are returned

ICollection<ISolrQuery> SolrNet.Commands.Parameters.QueryOptions.FilterQueries [get, set]

This parameter can be used to specify a query that can be used to restrict the super set of documents that can be returned, without influencing score. It can be very useful for speeding up complex queries since the queries specified with fq are cached independently from the main query. This assumes the same Filter is used again for a latter query (i.e. there's a cache hit)

HighlightingParameters SolrNet.Commands.Parameters.QueryOptions.Highlight [get, set]

Highlighting parameters.

MoreLikeThisParameters SolrNet.Commands.Parameters.QueryOptions.MoreLikeThis [get, set]

More-like-this parameters.

ICollection<SortOrder> SolrNet.Commands.Parameters.QueryOptions.OrderBy [get, set]

Sort order. By default, it's "score desc".

int SolrNet.Commands.Parameters.QueryOptions.Rows [get, set]

Maximum number of documents from the complete result set to return to the client for every request. Default is 10.

SpellCheckingParameters SolrNet.Commands.Parameters.QueryOptions.SpellCheck [get, set]

Spell-checking parameters.

int SolrNet.Commands.Parameters.QueryOptions.Start [get, set]

Offset in the complete result set for the queries where the set of returned documents should begin Default is 0.

StatsParameters SolrNet.Commands.Parameters.QueryOptions.Stats [get, set]

This parameter can be used to return the stats for a specific query on top of the results that are normally returned. Included in the stats are min, max, sum, count, missing, sumOfSquares, mean, and stddev values.

The documentation for this class was generated from the following files:
  • SolrNet/Commands/Parameters/QueryOptions.cs
  • SolrNet/Commands/Parameters/QueryOptions_Fluent.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.RandomSortOrder Class Reference

  • SolrNet
  • RandomSortOrder
Public Member Functions

SolrNet.RandomSortOrder Class Reference

Random sorting of results Requires Solr 1.3+. More...

Inheritance diagram for SolrNet.RandomSortOrder:
SolrNet.SortOrder

List of all members.

Public Member Functions

RandomSortOrder (string fieldName)
Random sorting with random seed.
RandomSortOrder (string fieldName, Order order)
Random sorting with random seed, with specified order.
RandomSortOrder (string fieldName, string seed)
Random sorting with specified seed.
RandomSortOrder (string fieldName, string seed, Order order)
Random sorting with specified seed, with specified order.

Detailed Description

Random sorting of results Requires Solr 1.3+.

Constructor & Destructor Documentation

SolrNet.RandomSortOrder.RandomSortOrder ( string fieldName )

Random sorting with random seed.

Parameters:
fieldName Random sorting field as defined in schema.xml
SolrNet.RandomSortOrder.RandomSortOrder | ( | string | fieldName,
 |  | Order | order
 | ) |  |

Random sorting with random seed, with specified order.

Parameters:
fieldName | Random sorting field as defined in schema.xml
order | Sort order (asc/desc)
SolrNet.RandomSortOrder.RandomSortOrder | ( | string | fieldName,
 |  | string | seed
 | ) |  |

Random sorting with specified seed.

Parameters:
fieldName | Random sorting field as defined in schema.xml
seed | Random seed
SolrNet.RandomSortOrder.RandomSortOrder | ( | string | fieldName,
 |  | string | seed,
 |  | Order | order
 | ) |  |

Random sorting with specified seed, with specified order.

Parameters:
fieldName | Random sorting field as defined in schema.xml
seed | Random seed
order | Sort order (asc/desc)
The documentation for this class was generated from the following file:
  • SolrNet/RandomSortOrder.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.DSL.Impl.RangeDefinition< T > Class Template Reference

  • SolrNet
  • DSL
  • Impl
  • RangeDefinition
Public Member Functions

SolrNet.DSL.Impl.RangeDefinition< T > Class Template Reference

List of all members.

Public Member Functions

RangeDefinition (string fieldName, T from)
SolrQueryByRange< T > To (T to)

template<T>
class SolrNet::DSL::Impl::RangeDefinition< T >

The documentation for this class was generated from the following file:
  • SolrNet.DSL/Impl/RangeDefinition.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.RangeQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • RangeQuerySerializer
Public Member Functions | Static Public Member Functions

SolrNet.Impl.QuerySerializers.RangeQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.RangeQuerySerializer:
SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

RangeQuerySerializer (ISolrFieldSerializer fieldSerializer)
bool | CanHandleType (Type t)
string | SerializeValue (object o)
string | Serialize (object q)

Static Public Member Functions

static string | BuildRange (string fieldName, string @from, string @to, bool inclusive)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/RangeQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor Class Reference

  • SolrNet
  • Impl
  • DocumentPropertyVisitors
  • RegularDocumentVisitor
Public Member Functions

SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor Class Reference

Pass-through document visitor. More...

Inheritance diagram for SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor:
SolrNet.Impl.ISolrDocumentPropertyVisitor

List of all members.

Public Member Functions

RegularDocumentVisitor (ISolrFieldParser parser, IReadOnlyMappingManager mapper)
Pass-through document visitor.
void Visit (object doc, string fieldName, XmlNode field)
Visits a document with a raw xml Solr response field.

Detailed Description

Pass-through document visitor.

Constructor & Destructor Documentation

SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor.RegularDocumentVisitor | ( | ISolrFieldParser | parser,
 |  | IReadOnlyMappingManager | mapper
 | ) |  |

Pass-through document visitor.

Parameters:
parser
mapper

Member Function Documentation

void SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor.Visit | ( | object | doc,
 |  | string | fieldName,
 |  | XmlNode | field
 | ) |  |

Visits a document with a raw xml Solr response field.

Parameters:
doc | Document object
fieldName | Solr field name
field | Raw XML Solr field

Implements SolrNet.Impl.ISolrDocumentPropertyVisitor.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/DocumentPropertyVisitors/RegularDocumentVisitor.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • RequiredFieldsAreMappedRule
Public Member Functions

SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule Class Reference

Represents a rule validating that all SolrFields in the SolrSchema which are required are either present in the mapping or as a CopyField. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule:
SolrNet.Mapping.Validation.Rules.IValidationRule

List of all members.

Public Member Functions

IEnumerable< ValidationResult > Validate (Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager)
Validates that all SolrFields in the SolrSchema which are required are either present in the mapping or as a CopyField.

Detailed Description

Represents a rule validating that all SolrFields in the SolrSchema which are required are either present in the mapping or as a CopyField.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule.Validate | ( | Type | documentType,
 |  | SolrSchema | solrSchema,
 |  | IReadOnlyMappingManager | mappingManager
 | ) |  |

Validates that all SolrFields in the SolrSchema which are required are either present in the mapping or as a CopyField.

Parameters:
documentType | Document type
solrSchema | The solr schema.
mappingManager | The mapping manager.
Returns:
A collection of ValidationResult objects with any issues found during validation.

Implements SolrNet.Mapping.Validation.Rules.IValidationRule.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/RequiredFieldsAreMappedRule.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.ResponseHeader Class Reference

  • SolrNet
  • ResponseHeader
Properties

SolrNet.ResponseHeader Class Reference

Operation response header. More...

List of all members.

Properties

int | Status [get, set]
Result status (0 is OK)
int | QTime [get, set]
Time this operation took in ms.
IDictionary< string, string > | Params [get, set]
Parameters defined in this operation.

Detailed Description

Operation response header.

Property Documentation

IDictionary<string, string> SolrNet.ResponseHeader.Params [get, set]

Parameters defined in this operation.

int SolrNet.ResponseHeader.QTime [get, set]

Time this operation took in ms.

int SolrNet.ResponseHeader.Status [get, set]

Result status (0 is OK)

The documentation for this class was generated from the following file:
  • SolrNet/ResponseHeader.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • ResultsResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > Class Template Reference

Parses documents from a query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

ResultsResponseParser (ISolrDocumentResponseParser< T > docParser)
void Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::ResultsResponseParser< T >

Parses documents from a query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/ResultsResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.RollbackCommand Class Reference

  • SolrNet
  • Commands
  • RollbackCommand
Public Member Functions

SolrNet.Commands.RollbackCommand Class Reference

Rollbacks all add/deletes made to the index since the last commit. More...

Inheritance diagram for SolrNet.Commands.RollbackCommand:
SolrNet.ISolrCommand

List of all members.

Public Member Functions

string Execute (ISolrConnection connection)
Executes this command.

Detailed Description

Rollbacks all add/deletes made to the index since the last commit.

Member Function Documentation

string SolrNet.Commands.RollbackCommand.Execute ( ISolrConnection connection )

Executes this command.

Parameters:
connection
Returns:

Implements SolrNet.ISolrCommand.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/RollbackCommand.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer Class Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • SelfSerializingQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer:
SolrNet.Impl.ISolrQuerySerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
string | Serialize (object q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/SelfSerializingQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > Class Template Reference

  • SolrNet
  • Impl
  • FacetQuerySerializers
  • SingleTypeFacetQuerySerializer
Public Member Functions

SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > Class Template Reference

Inheritance diagram for SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >:
SolrNet.Impl.ISolrFacetQuerySerializer SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer

List of all members.

Public Member Functions

bool CanHandleType (Type t)
IEnumerable< KeyValuePair
< string, string > > 		Serialize (object q)
abstract IEnumerable
< KeyValuePair< string, string > > 		Serialize (T q)

template<T>
class SolrNet::Impl::FacetQuerySerializers::SingleTypeFacetQuerySerializer< T >

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FacetQuerySerializers/SingleTypeFacetQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > Class Template Reference

  • SolrNet
  • Impl
  • QuerySerializers
  • SingleTypeQuerySerializer
Public Member Functions

SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > Class Template Reference

Inheritance diagram for SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >:
SolrNet.Impl.ISolrQuerySerializer SolrNet.Impl.QuerySerializers.BoostQuerySerializer SolrNet.Impl.QuerySerializers.HasValueQuerySerializer SolrNet.Impl.QuerySerializers.LocalParamsSerializer SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer SolrNet.Impl.QuerySerializers.NotQuerySerializer SolrNet.Impl.QuerySerializers.QueryByFieldSerializer SolrNet.Impl.QuerySerializers.QueryInListSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
string | Serialize (object q)
abstract string | Serialize (T q)

template<T>
class SolrNet::Impl::QuerySerializers::SingleTypeQuerySerializer< T >

The documentation for this class was generated from the following file:
  • SolrNet/Impl/QuerySerializers/SingleTypeQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrBasicServer< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrBasicServer
Public Member Functions

SolrNet.Impl.SolrBasicServer< T > Class Template Reference

Implements the basic Solr operations. More...

Inheritance diagram for SolrNet.Impl.SolrBasicServer< T >:
SolrNet.ISolrBasicOperations< T > SolrNet.ISolrBasicReadOnlyOperations< T >

List of all members.

Public Member Functions

SolrBasicServer (ISolrConnection connection, ISolrQueryExecuter< T > queryExecuter, ISolrDocumentSerializer< T > documentSerializer, ISolrSchemaParser schemaParser, ISolrHeaderResponseParser headerParser, ISolrQuerySerializer querySerializer)
ResponseHeader | Commit (CommitOptions options)
Commits posted documents.
ResponseHeader | Optimize (CommitOptions options)
Optimizes Solr's index.
ResponseHeader Rollback ()
Rollbacks all add/deletes made to the index since the last commit.
ResponseHeader | AddWithBoost (IEnumerable< KeyValuePair< T, double?>> docs)
Adds / updates several documents with index-time boost.
ResponseHeader | Delete (IEnumerable< string > ids, ISolrQuery q)
Deletes all documents that match the given id's or the query.
ISolrQueryResults< T > | Query (ISolrQuery query, QueryOptions options)
Executes a query.
string | Send (ISolrCommand cmd)
Sends a custom command.
ResponseHeader | SendAndParseHeader (ISolrCommand cmd)
Sends a custom command, returns parsed header from xml response.
ResponseHeader Ping ()
Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. See http://wiki.apache.org/solr/SolrConfigXml for more information.
SolrSchema GetSchema ()
Gets the schema.

Detailed Description

template<T>
class SolrNet::Impl::SolrBasicServer< T >

Implements the basic Solr operations.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.AddWithBoost ( IEnumerable< KeyValuePair< T, double?>> docs )

Adds / updates several documents with index-time boost.

Parameters:
docs
Returns:

Implements SolrNet.ISolrBasicOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.Commit ( CommitOptions options )

Commits posted documents.

Parameters:
options Commit options

Implements SolrNet.ISolrBasicOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.Delete | ( | IEnumerable< string > | ids,
 |  | ISolrQuery | q
 | ) |  |

Deletes all documents that match the given id's or the query.

Parameters:
ids | document ids to delete
q | query to match
Returns:

Implements SolrNet.ISolrBasicOperations< T >.

template<T >
SolrSchema SolrNet.Impl.SolrBasicServer< T >.GetSchema ( )

Gets the schema.

Returns:
A XmlDocument containing the Solr schema XML.

Implements SolrNet.ISolrBasicReadOnlyOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.Optimize ( CommitOptions options )

Optimizes Solr's index.

Parameters:
options Optimization options

Implements SolrNet.ISolrBasicOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.Ping ( )

Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. See http://wiki.apache.org/solr/SolrConfigXml for more information.

Implements SolrNet.ISolrBasicReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrBasicServer< T >.Query | ( | ISolrQuery | query,
 |  | QueryOptions | options
 | ) |  |

Executes a query.

Parameters:
query
options
Returns:

Implements SolrNet.ISolrBasicReadOnlyOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.Rollback ( )

Rollbacks all add/deletes made to the index since the last commit.

Implements SolrNet.ISolrBasicOperations< T >.

template<T >
string SolrNet.Impl.SolrBasicServer< T >.Send ( ISolrCommand cmd )

Sends a custom command.

Parameters:
cmd command to send
Returns:
solr response

Implements SolrNet.ISolrBasicOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrBasicServer< T >.SendAndParseHeader ( ISolrCommand cmd )

Sends a custom command, returns parsed header from xml response.

Parameters:
cmd
Returns:

Implements SolrNet.ISolrBasicOperations< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrBasicServer.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrCacheEntity Class Reference

  • SolrNet
  • Impl
  • SolrCacheEntity
Public Member Functions | Properties

SolrNet.Impl.SolrCacheEntity Class Reference

HTTP-level Solr cache entry. More...

List of all members.

Public Member Functions

SolrCacheEntity (string url, string eTag, string data)
HTTP-level Solr cache entry.

Properties

string | Url [get, set]
Full Solr query URL.
string | ETag [get, set]
Response ETag.
string | Data [get, set]
Response data.

Detailed Description

HTTP-level Solr cache entry.

Constructor & Destructor Documentation

SolrNet.Impl.SolrCacheEntity.SolrCacheEntity | ( | string | url,
 |  | string | eTag,
 |  | string | data
 | ) |  |

HTTP-level Solr cache entry.

Parameters:
url | Full Solr query URL
eTag | Response ETag
data | Response data

Property Documentation

string SolrNet.Impl.SolrCacheEntity.Data [get, set]

Response data.

string SolrNet.Impl.SolrCacheEntity.ETag [get, set]

Response ETag.

string SolrNet.Impl.SolrCacheEntity.Url [get, set]

Full Solr query URL.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrCacheEntity.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: StructureMap.SolrNetIntegration.Config.SolrConfigurationSection Class Reference

  • StructureMap
  • SolrNetIntegration
  • Config
  • SolrConfigurationSection
Properties

StructureMap.SolrNetIntegration.Config.SolrConfigurationSection Class Reference

List of all members.

Properties

SolrServers SolrServers [get]
The documentation for this class was generated from the following file:
  • StructureMap.SolrNetIntegration/Config/SolrConfigurationSection.cs
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrConnection Class Reference

  • SolrNet
  • Impl
  • SolrConnection
Classes | Public Member Functions | Properties

SolrNet.Impl.SolrConnection Class Reference

Manages HTTP connection with Solr. More...

Inheritance diagram for SolrNet.Impl.SolrConnection:
SolrNet.ISolrConnection

List of all members.

Classes

struct | SolrResponse

Public Member Functions

SolrConnection (string serverURL)
string | Post (string relativeUrl, string s)
POSTs to Solr.
KeyValuePair< T1, T2 > | KVP< T1, T2 > (T1 a, T2 b)
string | Get (string relativeUrl, IEnumerable< KeyValuePair< string, string >> parameters)
GETs from Solr.

Properties

ISolrCache | Cache [get, set]
HTTP cache implementation.
IHttpWebRequestFactory | HttpWebRequestFactory [get, set]
HTTP request factory.
string | ServerURL [get, set]
string | Version [get, set]
Solr XML response syntax version.
int | Timeout [get, set]
HTTP connection timeout.

Detailed Description

Manages HTTP connection with Solr.

Member Function Documentation

string SolrNet.Impl.SolrConnection.Get | ( | string | relativeUrl,
 |  | IEnumerable< KeyValuePair< string, string >> | parameters
 | ) |  |

GETs from Solr.

Parameters:
relativeUrl | Path to get from
parameters | Query string parameters
Returns:

Implements SolrNet.ISolrConnection.

string SolrNet.Impl.SolrConnection.Post | ( | string | relativeUrl,
 |  | string | s
 | ) |  |

POSTs to Solr.

Parameters:
relativeUrl | Path to post to
s | POST content
Returns:

Implements SolrNet.ISolrConnection.

Property Documentation

ISolrCache SolrNet.Impl.SolrConnection.Cache [get, set]

HTTP cache implementation.

IHttpWebRequestFactory SolrNet.Impl.SolrConnection.HttpWebRequestFactory [get, set]

HTTP request factory.

int SolrNet.Impl.SolrConnection.Timeout [get, set]

HTTP connection timeout.

string SolrNet.Impl.SolrConnection.Version [get, set]

Solr XML response syntax version.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrConnection.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Exceptions.SolrConnectionException Class Reference

  • SolrNet
  • Exceptions
  • SolrConnectionException
Public Member Functions | Protected Member Functions

SolrNet.Exceptions.SolrConnectionException Class Reference

Error connecting to Solr. See inner exception for more information. More...

Inheritance diagram for SolrNet.Exceptions.SolrConnectionException:
SolrNet.Exceptions.SolrNetException

List of all members.

Public Member Functions

SolrConnectionException (string message)
Error connecting to Solr.
SolrConnectionException (Exception innerException)
Error connecting to Solr.
SolrConnectionException (string message, Exception innerException)
Error connecting to Solr.
SolrConnectionException ()
Error connecting to Solr.

Protected Member Functions

SolrConnectionException (SerializationInfo info, StreamingContext context)

Detailed Description

Error connecting to Solr. See inner exception for more information.

Constructor & Destructor Documentation

SolrNet.Exceptions.SolrConnectionException.SolrConnectionException ( string message )

Error connecting to Solr.

Parameters:
message
SolrNet.Exceptions.SolrConnectionException.SolrConnectionException ( Exception innerException )

Error connecting to Solr.

Parameters:
innerException
SolrNet.Exceptions.SolrConnectionException.SolrConnectionException | ( | string | message,
 |  | Exception | innerException
 | ) |  |

Error connecting to Solr.

Parameters:
message
innerException
SolrNet.Exceptions.SolrConnectionException.SolrConnectionException ( )

Error connecting to Solr.

The documentation for this class was generated from the following file:
  • SolrNet/Exceptions/SolrConnectionException.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.SolrCopyField Class Reference

  • SolrNet
  • Schema
  • SolrCopyField
Public Member Functions | Properties

SolrNet.Schema.SolrCopyField Class Reference

Represents a Solr copy field. More...

List of all members.

Public Member Functions

SolrCopyField (string source, string destination)

Properties

string | Source [get, set]
Gets or sets the source.
string | Destination [get, set]
Gets or sets the destination.

Detailed Description

Represents a Solr copy field.

Property Documentation

string SolrNet.Schema.SolrCopyField.Destination [get, set]

Gets or sets the destination.

The destination.

string SolrNet.Schema.SolrCopyField.Source [get, set]

Gets or sets the source.

The source.

The documentation for this class was generated from the following file:
  • SolrNet/Schema/SolrCopyField.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: StructureMap.SolrNetIntegration.SolrCore Class Reference

  • StructureMap
  • SolrNetIntegration
  • SolrCore
Public Member Functions | Properties

StructureMap.SolrNetIntegration.SolrCore Class Reference

List of all members.

Public Member Functions

SolrCore (string id, Type documentType, string url)

Properties

string | Id [get, set]
Type | DocumentType [get, set]
string | Url [get, set]
The documentation for this class was generated from the following file:
  • StructureMap.SolrNetIntegration/SolrCore.cs
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Castle.Facilities.SolrNetIntegration.SolrCore Class Reference

  • Castle
  • Facilities
  • SolrNetIntegration
  • SolrCore
Public Member Functions | Properties

Castle.Facilities.SolrNetIntegration.SolrCore Class Reference

Represents a Solr core for configuration. More...

List of all members.

Public Member Functions

SolrCore (string id, Type documentType, string url)
Creates a new Solr core for configuration.
SolrCore (Type documentType, string url)
Creates a new Solr core for configuration.

Properties

string | Id [get, set]
Type | DocumentType [get, set]
string | Url [get, set]

Detailed Description

Represents a Solr core for configuration.

Constructor & Destructor Documentation

Castle.Facilities.SolrNetIntegration.SolrCore.SolrCore | ( | string | id,
 |  | Type | documentType,
 |  | string | url
 | ) |  |

Creates a new Solr core for configuration.

Parameters:
id | Component name for ISolrOperations{T}
documentType | Document type
url | Core url
Castle.Facilities.SolrNetIntegration.SolrCore.SolrCore | ( | Type | documentType,
 |  | string | url
 | ) |  |

Creates a new Solr core for configuration.

Parameters:
documentType | Document type
url | Core url
The documentation for this class was generated from the following file:
  • Castle.Facilities.SolrNetIntegration/SolrCore.cs
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrDictionaryDocumentResponseParser Class Reference

  • SolrNet
  • Impl
  • SolrDictionaryDocumentResponseParser
Public Member Functions

SolrNet.Impl.SolrDictionaryDocumentResponseParser Class Reference

Parses a solr result into a dictionary of (string, object) More...

List of all members.

Public Member Functions

SolrDictionaryDocumentResponseParser (ISolrFieldParser fieldParser)
IList< Dictionary< string,
object > > 		ParseResults (XmlNode parentNode)
Dictionary< string, object > ParseDocument (XmlNode node)

Detailed Description

Parses a solr result into a dictionary of (string, object)

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrDictionaryDocumentResponseParser.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrDictionarySerializer Class Reference

  • SolrNet
  • Impl
  • SolrDictionarySerializer
Public Member Functions

SolrNet.Impl.SolrDictionarySerializer Class Reference

Serializes a dictionary document. More...

List of all members.

Public Member Functions

SolrDictionarySerializer (ISolrFieldSerializer serializer)
XmlDocument Serialize (Dictionary< string, object > doc, double?boost)

Detailed Description

Serializes a dictionary document.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrDictionarySerializer.cs
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrDocumentActivator< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrDocumentActivator
Public Member Functions

SolrNet.Impl.SolrDocumentActivator< T > Class Template Reference

Creates a new instance of document type T using Activator More...

Inheritance diagram for SolrNet.Impl.SolrDocumentActivator< T >:
SolrNet.Impl.ISolrDocumentActivator< T >

List of all members.

Public Member Functions

T Create ()
Instantiates a new document instance of type T

Detailed Description

template<T>
class SolrNet::Impl::SolrDocumentActivator< T >

Creates a new instance of document type T using Activator

Template Parameters:
T document type

Member Function Documentation

template<T >
T SolrNet.Impl.SolrDocumentActivator< T >.Create ( )

Instantiates a new document instance of type T

Returns:

Implements SolrNet.Impl.ISolrDocumentActivator< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrDocumentActivator.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrDocumentResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrDocumentResponseParser
Public Member Functions

SolrNet.Impl.SolrDocumentResponseParser< T > Class Template Reference

Parses documents from query response. More...

Inheritance diagram for SolrNet.Impl.SolrDocumentResponseParser< T >:
SolrNet.Impl.ISolrDocumentResponseParser< T >

List of all members.

Public Member Functions

SolrDocumentResponseParser (IReadOnlyMappingManager mappingManager, ISolrDocumentPropertyVisitor propVisitor, ISolrDocumentActivator< T > activator)
IList< T > | ParseResults (XmlNode parentNode)
Parses documents results.
T | ParseDocument (XmlNode node, ICollection< SolrFieldModel > fields)
Builds a document from the corresponding response xml node.

Detailed Description

template<T>
class SolrNet::Impl::SolrDocumentResponseParser< T >

Parses documents from query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
T SolrNet.Impl.SolrDocumentResponseParser< T >.ParseDocument | ( | XmlNode | node,
 |  | ICollection< SolrFieldModel > | fields
 | ) |  |

Builds a document from the corresponding response xml node.

Parameters:
node | response xml node
fields | document fields
Returns:
populated document
template<T >
IList<T> SolrNet.Impl.SolrDocumentResponseParser< T >.ParseResults ( XmlNode parentNode )

Parses documents results.

Parameters:
parentNode
Returns:

Implements SolrNet.Impl.ISolrDocumentResponseParser< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrDocumentResponseParser.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrDocumentSerializer< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrDocumentSerializer
Public Member Functions

SolrNet.Impl.SolrDocumentSerializer< T > Class Template Reference

Serializes a Solr document to xml. More...

Inheritance diagram for SolrNet.Impl.SolrDocumentSerializer< T >:
SolrNet.ISolrDocumentSerializer< T >

List of all members.

Public Member Functions

SolrDocumentSerializer (IReadOnlyMappingManager mappingManager, ISolrFieldSerializer fieldSerializer)
XmlDocument Serialize (T doc, double?boost)

Detailed Description

template<T>
class SolrNet::Impl::SolrDocumentSerializer< T >

Serializes a Solr document to xml.

Template Parameters:
T Document type

Member Function Documentation

template<T >
XmlDocument SolrNet.Impl.SolrDocumentSerializer< T >.Serialize | ( | T | doc,
 |  | double? | boost
 | ) |  |

Serializes a Solr document to xml, applying an index-time boost

Parameters:
doc document to serialize
boost
Returns:
serialized document

Implements SolrNet.ISolrDocumentSerializer< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrDocumentSerializer.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.SolrDynamicField Class Reference

  • SolrNet
  • Schema
  • SolrDynamicField
Public Member Functions | Properties

SolrNet.Schema.SolrDynamicField Class Reference

Represents a Solr dynamic field. More...

List of all members.

Public Member Functions

SolrDynamicField (string name)

Properties

string Name [get, set]
Gets or sets the name.

Detailed Description

Represents a Solr dynamic field.

Property Documentation

string SolrNet.Schema.SolrDynamicField.Name [get, set]

Gets or sets the name.

The name.

The documentation for this class was generated from the following file:
  • SolrNet/Schema/SolrDynamicField.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrFacetDateQuery Class Reference

  • SolrNet
  • SolrFacetDateQuery
Public Member Functions | Properties

SolrNet.SolrFacetDateQuery Class Reference

Date facet query More...

Inheritance diagram for SolrNet.SolrFacetDateQuery:
SolrNet.ISolrFacetQuery

List of all members.

Public Member Functions

SolrFacetDateQuery (string field, DateTime start, DateTime end, string gap)
Creates a date facet query.

Properties

bool | HardEnd [get, set]
What to do in the event that the gap does not divide evenly between start and end. If this is true, the last date range constraint will have an upper bound of end; if false, the last date range will have the smallest possible upper bound greater then end such that the range is exactly gap wide. The default is false.
ICollection< FacetDateOther > | Other [get, set]
Indicates that in addition to the counts for each date range constraint between start and end, counts should also be computed for other.
string | Field [get]
DateTime | Start [get]
DateTime | End [get]
string | Gap [get]
IEnumerable< KeyValuePair
< string, string > > 		Query [get]

Detailed Description

Date facet query

Constructor & Destructor Documentation

SolrNet.SolrFacetDateQuery.SolrFacetDateQuery | ( | string | field,
 |  | DateTime | start,
 |  | DateTime | end,
 |  | string | gap
 | ) |  |

Creates a date facet query.

Parameters:
field | Field to facet
start | The lower bound for the first date range for all Date Faceting on this field
end | The minimum upper bound for the last date range for all Date Faceting on this field
gap | The size of each date range expressed as an interval to be added to the lower bound using the DateMathParser syntax.

Property Documentation

bool SolrNet.SolrFacetDateQuery.HardEnd [get, set]

What to do in the event that the gap does not divide evenly between start and end. If this is true, the last date range constraint will have an upper bound of end; if false, the last date range will have the smallest possible upper bound greater then end such that the range is exactly gap wide. The default is false.

ICollection<FacetDateOther> SolrNet.SolrFacetDateQuery.Other [get, set]

Indicates that in addition to the counts for each date range constraint between start and end, counts should also be computed for other.

The documentation for this class was generated from the following file:
  • SolrNet/SolrFacetDateQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer Class Reference

  • SolrNet
  • Impl
  • FacetQuerySerializers
  • SolrFacetDateQuerySerializer
Public Member Functions

SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer:
SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > SolrNet.Impl.ISolrFacetQuerySerializer

List of all members.

Public Member Functions

SolrFacetDateQuerySerializer (ISolrFieldSerializer fieldSerializer)
string SerializeSingle (object o)
override IEnumerable
< KeyValuePair< string, string > > 		Serialize (SolrFacetDateQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/FacetQuerySerializers/SolrFacetDateQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrFacetFieldQuery Class Reference

  • SolrNet
  • SolrFacetFieldQuery
Public Member Functions | Properties

SolrNet.SolrFacetFieldQuery Class Reference

Facet field query. More...

Inheritance diagram for SolrNet.SolrFacetFieldQuery:
SolrNet.ISolrFacetQuery

List of all members.

Public Member Functions

SolrFacetFieldQuery (string field)

Properties

string | Field [get]
Facet field.
string | Prefix [get, set]
bool | Sort [get, set]
Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.
int | Limit [get, set]
This param indicates the maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.
int | Offset [get, set]
This param indicates an offset into the list of constraints to allow paging. The default value is 0.
int | MinCount [get, set]
This param indicates the minimum counts for facet fields should be included in the response. The default value is 0.
bool | Missing [get, set]
Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.
int | EnumCacheMinDf [get, set]
This param indicates the minimum document frequency (number of documents matching a term) for which the filterCache should be used when determining the constraint count for that term. This is only used during the term enumeration method of faceting (field type faceting on multi-valued or full-text fields). A value greater than zero will decrease memory usage of the filterCache, but increase the query time. When faceting on a field with a very large number of terms, and you wish to decrease memory usage, try a low value of 25 to 50 first. The default value is 0, causing the filterCache to be used for all terms in the field.

Detailed Description

Facet field query.

Property Documentation

int SolrNet.SolrFacetFieldQuery.EnumCacheMinDf [get, set]

This param indicates the minimum document frequency (number of documents matching a term) for which the filterCache should be used when determining the constraint count for that term. This is only used during the term enumeration method of faceting (field type faceting on multi-valued or full-text fields). A value greater than zero will decrease memory usage of the filterCache, but increase the query time. When faceting on a field with a very large number of terms, and you wish to decrease memory usage, try a low value of 25 to 50 first. The default value is 0, causing the filterCache to be used for all terms in the field.

string SolrNet.SolrFacetFieldQuery.Field [get]

Facet field.

int SolrNet.SolrFacetFieldQuery.Limit [get, set]

This param indicates the maximum number of constraint counts that should be returned for the facet fields. A negative value means unlimited. The default value is 100.

int SolrNet.SolrFacetFieldQuery.MinCount [get, set]

This param indicates the minimum counts for facet fields should be included in the response. The default value is 0.

bool SolrNet.SolrFacetFieldQuery.Missing [get, set]

Set to true this param indicates that in addition to the Term based constraints of a facet field, a count of all matching results which have no value for the field should be computed Default is false.

int SolrNet.SolrFacetFieldQuery.Offset [get, set]

This param indicates an offset into the list of constraints to allow paging. The default value is 0.

string SolrNet.SolrFacetFieldQuery.Prefix [get, set]

Limits the terms on which to facet to those starting with the given string prefix.

bool SolrNet.SolrFacetFieldQuery.Sort [get, set]

Set to true, this parameter indicates that constraints should be sorted by their count. If false, facets will be in their natural index order (unicode). For terms in the ascii range, this will be alphabetically sorted. The default is true if Limit is greater than 0, false otherwise.

The documentation for this class was generated from the following file:
  • SolrNet/SolrFacetFieldQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer Class Reference

  • SolrNet
  • Impl
  • FacetQuerySerializers
  • SolrFacetFieldQuerySerializer
Public Member Functions

SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer:
SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > SolrNet.Impl.ISolrFacetQuerySerializer

List of all members.

Public Member Functions

override IEnumerable
< KeyValuePair< string, string > > 		Serialize (SolrFacetFieldQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/FacetQuerySerializers/SolrFacetFieldQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrFacetQuery Class Reference

  • SolrNet
  • SolrFacetQuery
Public Member Functions | Properties

SolrNet.SolrFacetQuery Class Reference

Arbitrary facet query. More...

Inheritance diagram for SolrNet.SolrFacetQuery:
SolrNet.ISolrFacetQuery

List of all members.

Public Member Functions

SolrFacetQuery (ISolrQuery q)

Properties

ISolrQuery Query [get]

Detailed Description

Arbitrary facet query.

The documentation for this class was generated from the following file:
  • SolrNet/SolrFacetQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer Class Reference

  • SolrNet
  • Impl
  • FacetQuerySerializers
  • SolrFacetQuerySerializer
Public Member Functions

SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer Class Reference

Inheritance diagram for SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer:
SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > SolrNet.Impl.ISolrFacetQuerySerializer

List of all members.

Public Member Functions

SolrFacetQuerySerializer (ISolrQuerySerializer serializer)
override IEnumerable
< KeyValuePair< string, string > > 		Serialize (SolrFacetQuery q)
The documentation for this class was generated from the following file:
  • SolrNet/Impl/FacetQuerySerializers/SolrFacetQuerySerializer.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.SolrField Class Reference

  • SolrNet
  • Schema
  • SolrField
Public Member Functions | Properties

SolrNet.Schema.SolrField Class Reference

Repesents a field in the Solr schema. More...

List of all members.

Public Member Functions

SolrField (string name, SolrFieldType type)
Repesents a field in the Solr schema.

Properties

string | Name [get, set]
Field name.
bool | IsRequired [get, set]
Gets or sets a value indicating whether this instance is required.
bool | IsMultiValued [get, set]
Gets or sets a value indicating whether this instance is multi valued.
SolrFieldType | Type [get, set]
Field type.

Detailed Description

Repesents a field in the Solr schema.

Constructor & Destructor Documentation

SolrNet.Schema.SolrField.SolrField | ( | string | name,
 |  | SolrFieldType | type
 | ) |  |

Repesents a field in the Solr schema.

Parameters:
name | Field name
type | Field type

Property Documentation

bool SolrNet.Schema.SolrField.IsMultiValued [get, set]

Gets or sets a value indicating whether this instance is multi valued.

true if this instance is multi valued; otherwise, false.

bool SolrNet.Schema.SolrField.IsRequired [get, set]

Gets or sets a value indicating whether this instance is required.

true if this instance is required; otherwise, false.

string SolrNet.Schema.SolrField.Name [get, set]

Field name.

The name.

SolrFieldType SolrNet.Schema.SolrField.Type [get, set]

Field type.

The type.

The documentation for this class was generated from the following file:
  • SolrNet/Schema/SolrField.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Attributes.SolrFieldAttribute Class Reference

  • SolrNet
  • Attributes
  • SolrFieldAttribute
Public Member Functions | Properties

SolrNet.Attributes.SolrFieldAttribute Class Reference

Marks a property as present on Solr. By default the field name is the property name. More...

Inheritance diagram for SolrNet.Attributes.SolrFieldAttribute:
SolrNet.Attributes.SolrUniqueKeyAttribute

List of all members.

Public Member Functions

SolrFieldAttribute ()
Marks a property as present on Solr. By default the field name is the property name.
SolrFieldAttribute (string fieldName)
Overrides field name.

Properties

string | FieldName [get, set]
Overrides field name.
float | Boost [get, set]
Adds an index time boost to a field.

Detailed Description

Marks a property as present on Solr. By default the field name is the property name.

Constructor & Destructor Documentation

SolrNet.Attributes.SolrFieldAttribute.SolrFieldAttribute ( )

Marks a property as present on Solr. By default the field name is the property name.

SolrNet.Attributes.SolrFieldAttribute.SolrFieldAttribute ( string fieldName )

Overrides field name.

Parameters:
fieldName

Property Documentation

float SolrNet.Attributes.SolrFieldAttribute.Boost [get, set]

Adds an index time boost to a field.

string SolrNet.Attributes.SolrFieldAttribute.FieldName [get, set]

Overrides field name.

The documentation for this class was generated from the following file:
  • SolrNet/Attributes/SolrFieldAttribute.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrFieldModel Class Reference

  • SolrNet
  • SolrFieldModel
Properties

SolrNet.SolrFieldModel Class Reference

Represents a Solr field mapping. /summary> More...

List of all members.

Properties

PropertyInfo | Property [get, set]
Class property where the field value is stored.
string | FieldName [get, set]
Named of the field in the Solr schema.
float | Boost [get, set]
Optional index-time field boosting.

Detailed Description

Represents a Solr field mapping. /summary>

Property Documentation

float SolrNet.SolrFieldModel.Boost [get, set]

Optional index-time field boosting.

string SolrNet.SolrFieldModel.FieldName [get, set]

Named of the field in the Solr schema.

PropertyInfo SolrNet.SolrFieldModel.Property [get, set]

Class property where the field value is stored.

The documentation for this class was generated from the following file:
  • SolrNet/SolrFieldModel.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.SolrFieldType Class Reference

  • SolrNet
  • Schema
  • SolrFieldType
Public Member Functions | Properties

SolrNet.Schema.SolrFieldType Class Reference

Represents a Solr field type. More...

List of all members.

Public Member Functions

SolrFieldType (string name, string type)
Represents a Solr field type.

Properties

string | Name [get, set]
Gets or sets the name.
string | Type [get, set]
Gets or sets the type.

Detailed Description

Represents a Solr field type.

Constructor & Destructor Documentation

SolrNet.Schema.SolrFieldType.SolrFieldType | ( | string | name,
 |  | string | type
 | ) |  |

Represents a Solr field type.

Parameters:
name | Solr field type name
type | Solr field type type (java class name)

Property Documentation

string SolrNet.Schema.SolrFieldType.Name [get, set]

Gets or sets the name.

The name.

string SolrNet.Schema.SolrFieldType.Type [get, set]

Gets or sets the type.

The type.

The documentation for this class was generated from the following file:
  • SolrNet/Schema/SolrFieldType.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrHasValueQuery Class Reference

  • SolrNet
  • SolrHasValueQuery
Public Member Functions | Properties

SolrNet.SolrHasValueQuery Class Reference

Queries documents that have any value in the specified field. More...

Inheritance diagram for SolrNet.SolrHasValueQuery:
SolrNet.AbstractSolrQuery SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrHasValueQuery (string field)

Properties

string Field [get]

Detailed Description

Queries documents that have any value in the specified field.

The documentation for this class was generated from the following file:
  • SolrNet/SolrHasValueQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrMultipleCriteriaQuery Class Reference

  • SolrNet
  • SolrMultipleCriteriaQuery
Classes | Public Member Functions | Static Public Member Functions | Properties

SolrNet.SolrMultipleCriteriaQuery Class Reference

Represents several queries as one. More...

Inheritance diagram for SolrNet.SolrMultipleCriteriaQuery:
SolrNet.AbstractSolrQuery SolrNet.ISolrQuery

List of all members.

Classes

class | Operator
Operator to apply to the included queries. More...

Public Member Functions

SolrMultipleCriteriaQuery (IEnumerable< ISolrQuery > queries)
SolrMultipleCriteriaQuery (IEnumerable< ISolrQuery > queries, string oper)

Static Public Member Functions

static SolrMultipleCriteriaQuery | Create (params ISolrQuery[] queries)
Static create helper.
static SolrMultipleCriteriaQuery | Create< T > (IEnumerable< T > queries)
Static create helper.

Properties

IEnumerable< ISolrQuery > | Queries [get]
Queries contained in this multiple criteria.
string | Oper [get]
Operator used for joining these queries.

Detailed Description

Represents several queries as one.

Member Function Documentation

static SolrMultipleCriteriaQuery SolrNet.SolrMultipleCriteriaQuery.Create ( params ISolrQuery[] queries ) [static]

Static create helper.

Parameters:
queries
Returns:
static SolrMultipleCriteriaQuery SolrNet.SolrMultipleCriteriaQuery.Create< T > ( IEnumerable< T > queries ) [static]

Static create helper.

Template Parameters:
T
Parameters:
queries
Returns:
Type Constraints
T : ISolrQuery

Property Documentation

string SolrNet.SolrMultipleCriteriaQuery.Oper [get]

Operator used for joining these queries.

IEnumerable<ISolrQuery> SolrNet.SolrMultipleCriteriaQuery.Queries [get]

Queries contained in this multiple criteria.

The documentation for this class was generated from the following file:
  • SolrNet/SolrMultipleCriteriaQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Exceptions.SolrNetException Class Reference

  • SolrNet
  • Exceptions
  • SolrNetException
Public Member Functions | Protected Member Functions

SolrNet.Exceptions.SolrNetException Class Reference

Base exception for all exceptions thrown by SolrNet. More...

Inheritance diagram for SolrNet.Exceptions.SolrNetException:
SolrNet.Exceptions.InvalidFieldException SolrNet.Exceptions.InvalidSortOrderException SolrNet.Exceptions.InvalidURLException SolrNet.Exceptions.SolrConnectionException SolrNet.Exceptions.TypeNotSupportedException

List of all members.

Public Member Functions

SolrNetException (Exception innerException)
Base exception for all exceptions thrown by SolrNet.
SolrNetException (string message)
Base exception for all exceptions thrown by SolrNet.
SolrNetException ()
Base exception for all exceptions thrown by SolrNet.
SolrNetException (string message, Exception innerException)
Base exception for all exceptions thrown by SolrNet.

Protected Member Functions

SolrNetException (SerializationInfo info, StreamingContext context)

Detailed Description

Base exception for all exceptions thrown by SolrNet.

Constructor & Destructor Documentation

SolrNet.Exceptions.SolrNetException.SolrNetException ( Exception innerException )

Base exception for all exceptions thrown by SolrNet.

Parameters:
innerException
SolrNet.Exceptions.SolrNetException.SolrNetException ( string message )

Base exception for all exceptions thrown by SolrNet.

Parameters:
message
SolrNet.Exceptions.SolrNetException.SolrNetException ( )

Base exception for all exceptions thrown by SolrNet.

SolrNet.Exceptions.SolrNetException.SolrNetException | ( | string | message,
 |  | Exception | innerException
 | ) |  |

Base exception for all exceptions thrown by SolrNet.

Parameters:
message
innerException
The documentation for this class was generated from the following file:
  • SolrNet/Exceptions/SolrNetException.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Castle.Facilities.SolrNetIntegration.SolrNetFacility Class Reference

  • Castle
  • Facilities
  • SolrNetIntegration
  • SolrNetFacility
Public Member Functions | Protected Member Functions | Properties

Castle.Facilities.SolrNetIntegration.SolrNetFacility Class Reference

Configures SolrNet in a Windsor container. More...

List of all members.

Public Member Functions

SolrNetFacility (string solrURL)
void | AddCore (Type documentType, string coreUrl)
Adds a new core configuration to the facility.
void | AddCore (string coreId, Type documentType, string coreUrl)
Adds a new core configuration to the facility.

Protected Member Functions

override void | Init ()

Properties

IReadOnlyMappingManager | Mapper [get, set]
Default mapper override.

Detailed Description

Configures SolrNet in a Windsor container.

Member Function Documentation

void Castle.Facilities.SolrNetIntegration.SolrNetFacility.AddCore | ( | Type | documentType,
 |  | string | coreUrl
 | ) |  |

Adds a new core configuration to the facility.

Parameters:
documentType
coreUrl
void Castle.Facilities.SolrNetIntegration.SolrNetFacility.AddCore | ( | string | coreId,
 |  | Type | documentType,
 |  | string | coreUrl
 | ) |  |

Adds a new core configuration to the facility.

Parameters:
coreId Component name for ISolrOperations{T}
documentType
coreUrl

Property Documentation

IReadOnlyMappingManager Castle.Facilities.SolrNetIntegration.SolrNetFacility.Mapper [get, set]

Default mapper override.

The documentation for this class was generated from the following file:
  • Castle.Facilities.SolrNetIntegration/SolrNetFacility.cs
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.Impl.SolrNetListener< T > Class Template Reference

  • NHibernate
  • SolrNet
  • Impl
  • SolrNetListener
Public Member Functions | Properties

NHibernate.SolrNet.Impl.SolrNetListener< T > Class Template Reference

NHibernate event listener for updating Solr index. More...

Inheritance diagram for NHibernate.SolrNet.Impl.SolrNetListener< T >:
NHibernate.SolrNet.Impl.ICommitSetting

List of all members.

Public Member Functions

SolrNetListener (ISolrOperations< T > solr)
virtual void | OnPostInsert (PostInsertEvent e)
virtual void | OnPostUpdate (PostUpdateEvent e)
bool | DeferAction (IEventSource e)
void | UpdateInternal (AbstractEvent e, T entity)
virtual void | OnPostDelete (PostDeleteEvent e)
bool | DoWithEntities (WeakHashtable entities, ITransaction s, Action< T > action)
void | OnFlush (FlushEvent e)
void | OnFlushInternal (AbstractEvent e)
void | OnAutoFlush (AutoFlushEvent e)

Properties

bool | Commit [get, set]
Automatically commit Solr after each update.

Detailed Description

template<T>
class NHibernate::SolrNet::Impl::SolrNetListener< T >

NHibernate event listener for updating Solr index.

Template Parameters:
T
Type Constraints
T : class

Property Documentation

template<T >
bool NHibernate.SolrNet.Impl.SolrNetListener< T >.Commit [get, set]

Automatically commit Solr after each update.

Implements NHibernate.SolrNet.Impl.ICommitSetting.

The documentation for this class was generated from the following file:
  • NHibernate.SolrNet/Impl/SolrNetListener.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Ninject.Integration.SolrNet.SolrNetModule Class Reference

  • Ninject
  • Integration
  • SolrNet
  • SolrNetModule
Public Member Functions | Properties

Ninject.Integration.SolrNet.SolrNetModule Class Reference

List of all members.

Public Member Functions

SolrNetModule (string serverURL)
override void | Load ()

Properties

IReadOnlyMappingManager | Mapper [get, set]
The documentation for this class was generated from the following file:
  • Ninject.Integration.SolrNet/SolrNetModule.cs
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: StructureMap.SolrNetIntegration.SolrNetRegistry Class Reference

  • StructureMap
  • SolrNetIntegration
  • SolrNetRegistry
Public Member Functions

StructureMap.SolrNetIntegration.SolrNetRegistry Class Reference

List of all members.

Public Member Functions

SolrNetRegistry (SolrServers solrServers)
The documentation for this class was generated from the following file:
  • StructureMap.SolrNetIntegration/SolrNetRegistry.cs
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrNotQuery Class Reference

  • SolrNet
  • SolrNotQuery
Public Member Functions | Properties

SolrNet.SolrNotQuery Class Reference

Negates a query. More...

Inheritance diagram for SolrNet.SolrNotQuery:
SolrNet.AbstractSolrQuery SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrNotQuery (ISolrQuery q)
Negates a query.

Properties

ISolrQuery Query [get]

Detailed Description

Negates a query.

Constructor & Destructor Documentation

SolrNet.SolrNotQuery.SolrNotQuery ( ISolrQuery q )

Negates a query.

Parameters:
q
The documentation for this class was generated from the following file:
  • SolrNet/SolrNotQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrQuery Class Reference

  • SolrNet
  • SolrQuery
Public Member Functions | Properties

SolrNet.SolrQuery Class Reference

Basic solr query. More...

Inheritance diagram for SolrNet.SolrQuery:
SolrNet.AbstractSolrQuery SolrNet.Impl.ISelfSerializingQuery SolrNet.ISolrQuery SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrQuery (string query)
Constructor.

Properties

string | Query [get]
query to execute
static ISolrQuery | All [get, set]
Represents a query for all documents ("*:*")

Detailed Description

Basic solr query.

Constructor & Destructor Documentation

SolrNet.SolrQuery.SolrQuery ( string query )

Constructor.

Parameters:
query solr query to execute

Property Documentation

ISolrQuery SolrNet.SolrQuery.All [static, get, set]

Represents a query for all documents ("*:*")

string SolrNet.SolrQuery.Query [get]

query to execute

Implements SolrNet.Impl.ISelfSerializingQuery.

The documentation for this class was generated from the following file:
  • SolrNet/SolrQuery.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrQueryBoost Class Reference

  • SolrNet
  • SolrQueryBoost
Public Member Functions | Properties

SolrNet.SolrQueryBoost Class Reference

Applies a boost to a query or query fragment. More...

Inheritance diagram for SolrNet.SolrQueryBoost:
SolrNet.AbstractSolrQuery SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrQueryBoost (ISolrQuery query, double factor)
Applies a boost to a query or query fragment.

Properties

double | Factor [get]
Boost factor.
ISolrQuery | Query [get]

Detailed Description

Applies a boost to a query or query fragment.

Constructor & Destructor Documentation

SolrNet.SolrQueryBoost.SolrQueryBoost | ( | ISolrQuery | query,
 |  | double | factor
 | ) |  |

Applies a boost to a query or query fragment.

Parameters:
query | Query to boost
factor | Boost factor

Property Documentation

double SolrNet.SolrQueryBoost.Factor [get]

Boost factor.

The documentation for this class was generated from the following file:
  • SolrNet/SolrQueryBoost.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrQueryByField Class Reference

  • SolrNet
  • SolrQueryByField
Public Member Functions | Properties

SolrNet.SolrQueryByField Class Reference

Queries a field for a value. More...

Inheritance diagram for SolrNet.SolrQueryByField:
SolrNet.AbstractSolrQuery SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrQueryByField (string fieldName, string fieldValue)
Queries a field for a value.

Properties

string | FieldName [get]
string | FieldValue [get]

Detailed Description

Queries a field for a value.

Constructor & Destructor Documentation

SolrNet.SolrQueryByField.SolrQueryByField | ( | string | fieldName,
 |  | string | fieldValue
 | ) |  |

Queries a field for a value.

Parameters:
fieldName | Field name
fieldValue | Field value
The documentation for this class was generated from the following file:
  • SolrNet/SolrQueryByField.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrQueryByRange< RT > Class Template Reference

  • SolrNet
  • SolrQueryByRange
Public Member Functions | Properties

SolrNet.SolrQueryByRange< RT > Class Template Reference

Queries a field for a range. More...

Inheritance diagram for SolrNet.SolrQueryByRange< RT >:
SolrNet.AbstractSolrQuery SolrNet.Impl.ISolrQueryByRange SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrQueryByRange (string fieldName, RT from, RT to)
SolrQueryByRange (string fieldName, RT @from, RT to, bool inclusive)

Properties

string | FieldName [get]
RT | From [get]
RT | To [get]
bool | Inclusive [get]

Detailed Description

template<RT>
class SolrNet::SolrQueryByRange< RT >

Queries a field for a range.

Template Parameters:
RT
The documentation for this class was generated from the following file:
  • SolrNet/SolrQueryByRange.cs
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrQueryExecuter< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrQueryExecuter
Public Member Functions | Static Public Attributes | Properties

SolrNet.Impl.SolrQueryExecuter< T > Class Template Reference

Executes queries. More...

Inheritance diagram for SolrNet.Impl.SolrQueryExecuter< T >:
SolrNet.ISolrQueryExecuter< T >

List of all members.

Public Member Functions

SolrQueryExecuter (ISolrQueryResultParser< T > resultParser, ISolrConnection connection, ISolrQuerySerializer querySerializer, ISolrFacetQuerySerializer facetQuerySerializer)
KeyValuePair< T1, T2 > | KVP< T1, T2 > (T1 a, T2 b)
IEnumerable< KeyValuePair
< string, string > > 		GetAllParameters (ISolrQuery Query, QueryOptions Options)
Gets Solr parameters for all defined query options.
IEnumerable< KeyValuePair
< string, string > > 		GetFacetFieldOptions (QueryOptions options)
Gets Solr parameters for facet queries.
IEnumerable< KeyValuePair
< string, string > > 		GetMoreLikeThisParameters (QueryOptions options)
Gets Solr parameters for defined more-like-this options.
IEnumerable< KeyValuePair
< string, string > > 		GetFilterQueries (QueryOptions options)
Gets Solr parameters for defined filter queries.
IDictionary< string, string > | GetHighlightingParameters (QueryOptions Options)
Gets Solr parameters for defined highlightings.
IEnumerable< KeyValuePair
< string, string > > 		GetSpellCheckingParameters (QueryOptions Options)
Gets solr parameters for defined spell-checking.
IEnumerable< KeyValuePair
< string, string > > 		GetStatsQueryOptions (QueryOptions options)
Gets the Solr parameters for stats queries.
IEnumerable< KeyValuePair
< string, string > > 		GetCollapseQueryOptions (QueryOptions options)
Gets the Solr parameters for collapse queries.
ISolrQueryResults< T > | Execute (ISolrQuery q, QueryOptions options)
Executes the query and returns results.

Static Public Attributes

static readonly int | ConstDefaultRows = 100000000

Properties

int | DefaultRows [get, set]
When the row count is not defined, use this row count by default.

Detailed Description

template<T>
class SolrNet::Impl::SolrQueryExecuter< T >

Executes queries.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrQueryExecuter< T >.Execute | ( | ISolrQuery | q,
 |  | QueryOptions | options
 | ) |  |

Executes the query and returns results.

Returns:
query results

Implements SolrNet.ISolrQueryExecuter< T >.

template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetAllParameters | ( | ISolrQuery | Query,
 |  | QueryOptions | Options
 | ) |  |

Gets Solr parameters for all defined query options.

Parameters:
Query
Options
Returns:
template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetCollapseQueryOptions ( QueryOptions options )

Gets the Solr parameters for collapse queries.

Parameters:
options
Returns:
template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetFacetFieldOptions ( QueryOptions options )

Gets Solr parameters for facet queries.

Parameters:
options
Returns:
template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetFilterQueries ( QueryOptions options )

Gets Solr parameters for defined filter queries.

Parameters:
options
Returns:
template<T >
IDictionary<string, string> SolrNet.Impl.SolrQueryExecuter< T >.GetHighlightingParameters ( QueryOptions Options )

Gets Solr parameters for defined highlightings.

Parameters:
Options
Returns:
template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetMoreLikeThisParameters ( QueryOptions options )

Gets Solr parameters for defined more-like-this options.

Parameters:
options
Returns:
template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetSpellCheckingParameters ( QueryOptions Options )

Gets solr parameters for defined spell-checking.

Parameters:
Options
Returns:
template<T >
IEnumerable<KeyValuePair<string, string> > SolrNet.Impl.SolrQueryExecuter< T >.GetStatsQueryOptions ( QueryOptions options )

Gets the Solr parameters for stats queries.

Parameters:
options
Returns:

Property Documentation

template<T >
int SolrNet.Impl.SolrQueryExecuter< T >.DefaultRows [get, set]

When the row count is not defined, use this row count by default.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrQueryExecuter.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SolrQueryInList Class Reference

  • SolrNet
  • SolrQueryInList
Public Member Functions | Properties

SolrNet.SolrQueryInList Class Reference

Queries a field for a list of possible values. More...

Inheritance diagram for SolrNet.SolrQueryInList:
SolrNet.AbstractSolrQuery SolrNet.ISolrQuery

List of all members.

Public Member Functions

SolrQueryInList (string fieldName, IEnumerable< string > list)
SolrQueryInList (string fieldName, params string[] values)

Properties

string | FieldName [get]
IEnumerable< string > | List [get]

Detailed Description

Queries a field for a list of possible values.

The documentation for this class was generated from the following file:
  • SolrNet/SolrQueryInList.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrQueryResultParser< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrQueryResultParser
Public Member Functions

SolrNet.Impl.SolrQueryResultParser< T > Class Template Reference

Default query results parser. Parses xml query results. More...

Inheritance diagram for SolrNet.Impl.SolrQueryResultParser< T >:
SolrNet.ISolrQueryResultParser< T >

List of all members.

Public Member Functions

SolrQueryResultParser (ISolrResponseParser< T >[] parsers)
ISolrQueryResults< T > Parse (string r)
Parses solr's xml response.

Detailed Description

template<T>
class SolrNet::Impl::SolrQueryResultParser< T >

Default query results parser. Parses xml query results.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrQueryResultParser< T >.Parse ( string r )

Parses solr's xml response.

Parameters:
r solr xml response
Returns:
query results

Implements SolrNet.ISolrQueryResultParser< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrQueryResultParser.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrQueryResults< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrQueryResults
Public Member Functions | Properties

SolrNet.Impl.SolrQueryResults< T > Class Template Reference

Query results. More...

Inheritance diagram for SolrNet.Impl.SolrQueryResults< T >:
SolrNet.ISolrQueryResults< T >

List of all members.

Public Member Functions

int | IndexOf (T item)
void | Insert (int index, T item)
void | RemoveAt (int index)
void | Add (T item)
void | Clear ()
bool | Contains (T item)
void | CopyTo (T[] array, int arrayIndex)
bool | Remove (T item)
IEnumerator | GetEnumerator ()
SolrQueryResults ()

Properties

T | this [int index] [get, set]
int | Count [get]
bool | IsReadOnly [get]
int | NumFound [get, set]
Total documents found.
double | MaxScore [get, set]
Max score in these results.
IDictionary< string, int > | FacetQueries [get, set]
Facet queries results.
IDictionary< string,
ICollection< KeyValuePair
< string, int > > > 		FacetFields [get, set]
Facet field queries results.
IDictionary< string,
DateFacetingResult > 		FacetDates [get, set]
Date faceting results.
ResponseHeader | Header [get, set]
Query response header.
IDictionary< string,
IDictionary< string,
ICollection< string > > > 		Highlights [get, set]
Highlight results.
SpellCheckResults | SpellChecking [get, set]
Spell checking results.
IDictionary< string, IList< T > > | SimilarResults [get, set]
More-like-this results.
IDictionary< string, StatsResult > | Stats [get, set]
Stats results.
CollapseResults | Collapsing [get, set]

Detailed Description

template<T>
class SolrNet::Impl::SolrQueryResults< T >

Query results.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.SolrQueryResults< T >.Add ( T item )

summary> Removes all items from the T:System.Collections.Generic.ICollection`1. /summary>

exception cref="T:System.NotSupportedException">The T:System.Collections.Generic.ICollection`1 is read-only.

template<T >
void SolrNet.Impl.SolrQueryResults< T >.Clear ( )

summary> Determines whether the T:System.Collections.Generic.ICollection`1 contains a specific value. /summary>

returns> true if item is found in the T:System.Collections.Generic.ICollection`1; otherwise, false. /returns>

param name="item">The object to locate in the T:System.Collections.Generic.ICollection`1.

template<T >
bool SolrNet.Impl.SolrQueryResults< T >.Contains ( T item )

summary> Copies the elements of the T:System.Collections.Generic.ICollection`1 to an T:System.Array, starting at a particular T:System.Array index. /summary>

param name="array">The one-dimensional T:System.Array that is the destination of the elements copied from T:System.Collections.Generic.ICollection`1. The T:System.Array must have zero-based indexing.

param name="arrayIndex">The zero-based index in array at which copying begins.

exception cref="T:System.ArgumentOutOfRangeException">arrayIndex is less than 0.

exception cref="T:System.ArgumentNullException">array is null.

exception cref="T:System.ArgumentException">array is multidimensional.-or-arrayIndex is equal to or greater than the length of array.-or-The number of elements in the source T:System.Collections.Generic.ICollection`1 is greater than the available space from arrayIndex to the end of the destination array.-or-Type T cannot be cast automatically to the type of the destination array.

template<T >
void SolrNet.Impl.SolrQueryResults< T >.CopyTo | ( | T[] | array,
 |  | int | arrayIndex
 | ) |  |

summary> Removes the first occurrence of a specific object from the T:System.Collections.Generic.ICollection`1. /summary>

returns> true if item was successfully removed from the T:System.Collections.Generic.ICollection`1; otherwise, false. This method also returns false if item is not found in the original T:System.Collections.Generic.ICollection`1. /returns>

param name="item">The object to remove from the T:System.Collections.Generic.ICollection`1.

exception cref="T:System.NotSupportedException">The T:System.Collections.Generic.ICollection`1 is read-only.

template<T >
int SolrNet.Impl.SolrQueryResults< T >.IndexOf ( T item )

summary> Inserts an item to the T:System.Collections.Generic.IList`1 at the specified index. /summary>

param name="item">The object to insert into the T:System.Collections.Generic.IList`1.

param name="index">The zero-based index at which item should be inserted.

exception cref="T:System.NotSupportedException">The T:System.Collections.Generic.IList`1 is read-only.

exception cref="T:System.ArgumentOutOfRangeException">index is not a valid index in the T:System.Collections.Generic.IList`1.

template<T >
void SolrNet.Impl.SolrQueryResults< T >.Insert | ( | int | index,
 |  | T | item
 | ) |  |

summary> Removes the T:System.Collections.Generic.IList`1 item at the specified index. /summary>

param name="index">The zero-based index of the item to remove.

exception cref="T:System.NotSupportedException">The T:System.Collections.Generic.IList`1 is read-only.

exception cref="T:System.ArgumentOutOfRangeException">index is not a valid index in the T:System.Collections.Generic.IList`1.

template<T >
bool SolrNet.Impl.SolrQueryResults< T >.Remove ( T item )

summary> Gets the number of elements contained in the T:System.Collections.Generic.ICollection`1. /summary>

returns> The number of elements contained in the T:System.Collections.Generic.ICollection`1. /returns>

template<T >
void SolrNet.Impl.SolrQueryResults< T >.RemoveAt ( int index )

summary> Gets or sets the element at the specified index. /summary>

returns> The element at the specified index. /returns>

param name="index">The zero-based index of the element to get or set.

exception cref="T:System.ArgumentOutOfRangeException">index is not a valid index in the T:System.Collections.Generic.IList`1.

exception cref="T:System.NotSupportedException">The property is set and the T:System.Collections.Generic.IList`1 is read-only.

Property Documentation

template<T >
CollapseResults SolrNet.Impl.SolrQueryResults< T >.Collapsing [get, set]

summary>

Implements SolrNet.ISolrQueryResults< T >.

template<T >
int SolrNet.Impl.SolrQueryResults< T >.Count [get]

summary> Gets a value indicating whether the T:System.Collections.Generic.ICollection`1 is read-only. /summary>

returns> true if the T:System.Collections.Generic.ICollection`1 is read-only; otherwise, false. /returns>

template<T >
IDictionary<string, DateFacetingResult> SolrNet.Impl.SolrQueryResults< T >.FacetDates [get, set]

Date faceting results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
IDictionary<string, ICollection<KeyValuePair<string, int> > > SolrNet.Impl.SolrQueryResults< T >.FacetFields [get, set]

Facet field queries results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
IDictionary<string, int> SolrNet.Impl.SolrQueryResults< T >.FacetQueries [get, set]

Facet queries results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrQueryResults< T >.Header [get, set]

Query response header.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
IDictionary<string, IDictionary<string, ICollection<string> > > SolrNet.Impl.SolrQueryResults< T >.Highlights [get, set]

Highlight results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
bool SolrNet.Impl.SolrQueryResults< T >.IsReadOnly [get]

summary> Returns an enumerator that iterates through a collection. /summary>

returns> An T:System.Collections.IEnumerator object that can be used to iterate through the collection. /returns> filterpriority>2</filterpriority>

template<T >
double SolrNet.Impl.SolrQueryResults< T >.MaxScore [get, set]

Max score in these results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
int SolrNet.Impl.SolrQueryResults< T >.NumFound [get, set]

Total documents found.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
IDictionary<string, IList<T> > SolrNet.Impl.SolrQueryResults< T >.SimilarResults [get, set]

More-like-this results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
SpellCheckResults SolrNet.Impl.SolrQueryResults< T >.SpellChecking [get, set]

Spell checking results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
IDictionary<string, StatsResult> SolrNet.Impl.SolrQueryResults< T >.Stats [get, set]

Stats results.

Implements SolrNet.ISolrQueryResults< T >.

template<T >
T SolrNet.Impl.SolrQueryResults< T >.this[int index] [get, set]

summary> Adds an item to the T:System.Collections.Generic.ICollection`1. /summary>

param name="item">The object to add to the T:System.Collections.Generic.ICollection`1.

exception cref="T:System.NotSupportedException">The T:System.Collections.Generic.ICollection`1 is read-only.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrQueryResults.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.SolrSchema Class Reference

  • SolrNet
  • Schema
  • SolrSchema
Public Member Functions | Properties

SolrNet.Schema.SolrSchema Class Reference

Represents a Solr schema. More...

List of all members.

Public Member Functions

SolrSchema ()
Initializes a new instance of the SolrSchema class.
SolrField | FindSolrFieldByName (string name)
Finds the solr field by name.
SolrFieldType | FindSolrFieldTypeByName (string name)

Properties

List< SolrFieldType > | SolrFieldTypes [get, set]
Gets or sets the solr fields types.
List< SolrField > | SolrFields [get, set]
Gets or sets the solr fields.
List< SolrDynamicField > | SolrDynamicFields [get, set]
Gets or sets the solr dynamic fields.
List< SolrCopyField > | SolrCopyFields [get, set]
Gets or sets the solr copy fields.
string | UniqueKey [get, set]
Gets or sets the unique key.

Detailed Description

Represents a Solr schema.

Constructor & Destructor Documentation

SolrNet.Schema.SolrSchema.SolrSchema ( )

Initializes a new instance of the SolrSchema class.

Member Function Documentation

SolrField SolrNet.Schema.SolrSchema.FindSolrFieldByName ( string name )

Finds the solr field by name.

Parameters:
name The name of the solr field to find.
Returns:
The solr field if found. Null otherwise.

Property Documentation

List<SolrCopyField> SolrNet.Schema.SolrSchema.SolrCopyFields [get, set]

Gets or sets the solr copy fields.

The solr copy fields.

List<SolrDynamicField> SolrNet.Schema.SolrSchema.SolrDynamicFields [get, set]

Gets or sets the solr dynamic fields.

The solr dynamic fields.

List<SolrField> SolrNet.Schema.SolrSchema.SolrFields [get, set]

Gets or sets the solr fields.

The solr fields.

List<SolrFieldType> SolrNet.Schema.SolrSchema.SolrFieldTypes [get, set]

Gets or sets the solr fields types.

The solr fields types.

string SolrNet.Schema.SolrSchema.UniqueKey [get, set]

Gets or sets the unique key.

The unique key.

The documentation for this class was generated from the following file:
  • SolrNet/Schema/SolrSchema.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Schema.SolrSchemaParser Class Reference

  • SolrNet
  • Schema
  • SolrSchemaParser
Public Member Functions

SolrNet.Schema.SolrSchemaParser Class Reference

Parses a Solr schema xml document into a strongly typed SolrSchema object. More...

Inheritance diagram for SolrNet.Schema.SolrSchemaParser:
SolrNet.Schema.ISolrSchemaParser

List of all members.

Public Member Functions

SolrSchema Parse (XmlDocument solrSchemaXml)
Parses the specified Solr schema xml.

Detailed Description

Parses a Solr schema xml document into a strongly typed SolrSchema object.

Member Function Documentation

SolrSchema SolrNet.Schema.SolrSchemaParser.Parse ( XmlDocument solrSchemaXml )

Parses the specified Solr schema xml.

Parameters:
solrSchemaXml The Solr schema xml to parse.
Returns:
A strongly styped representation of the Solr schema xml.

Implements SolrNet.Schema.ISolrSchemaParser.

The documentation for this class was generated from the following file:
  • SolrNet/Schema/SolrSchemaParser.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SolrServer< T > Class Template Reference

  • SolrNet
  • Impl
  • SolrServer
Public Member Functions

SolrNet.Impl.SolrServer< T > Class Template Reference

Main component to interact with Solr. More...

Inheritance diagram for SolrNet.Impl.SolrServer< T >:
SolrNet.ISolrOperations< T > SolrNet.ISolrReadOnlyOperations< T > SolrNet.ISolrBasicReadOnlyOperations< T >

List of all members.

Public Member Functions

SolrServer (ISolrBasicOperations< T > basicServer, IReadOnlyMappingManager mappingManager, IMappingValidator _schemaMappingValidator)
ISolrQueryResults< T > | Query (ISolrQuery query, QueryOptions options)
Executes a query.
ResponseHeader Ping ()
Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. See http://wiki.apache.org/solr/SolrConfigXml for more information.
ISolrQueryResults< T > | Query (string q)
Executes a query.
ISolrQueryResults< T > | Query (string q, ICollection< SortOrder > orders)
Executes a query.
ISolrQueryResults< T > | Query (string q, QueryOptions options)
Executes a query.
ISolrQueryResults< T > | Query (ISolrQuery q)
Executes a query.
ISolrQueryResults< T > | Query (ISolrQuery query, ICollection< SortOrder > orders)
Executes a query.
ICollection< KeyValuePair
< string, int > > 		FacetFieldQuery (SolrFacetFieldQuery facet)
Executes a facet field query only.
ResponseHeader BuildSpellCheckDictionary ()
Create the dictionary for use by the SolrSpellChecker. In typical applications, one needs to build the dictionary before using it. However, it may not always be necessary as it is possible to setup the spellchecker with a dictionary that already exists.
ResponseHeader | AddWithBoost (T doc, double boost)
Adds / updates a document with index-time boost.
ResponseHeader | Add (IEnumerable< T > docs)
Adds / updates several documents at once.
ResponseHeader | Delete (IEnumerable< string > ids)
Deletes several documents by their id (unique key)
ResponseHeader | Delete (T doc)
Deletes a document (requires the document to have a unique key defined with non-null value)
ResponseHeader | Delete (IEnumerable< T > docs)
Deletes several documents (requires the document type to have a unique key defined with non-null value)
ResponseHeader | Delete (string id)
Deletes a document by its id (unique key)
ResponseHeader Commit ()
Commits posted documents, blocking until index changes are flushed to disk and blocking until a new searcher is opened and registered as the main query searcher, making the changes visible.
ResponseHeader Optimize ()
Commits posts, blocking until index changes are flushed to disk and blocking until a new searcher is opened and registered as the main query searcher, making the changes visible.
ResponseHeader | Add (T doc)
Adds / updates a document.
SolrSchema GetSchema ()
Gets the schema.
IEnumerable< ValidationResult > | EnumerateValidationResults ()

Detailed Description

template<T>
class SolrNet::Impl::SolrServer< T >

Main component to interact with Solr.

Template Parameters:
T Document type

Member Function Documentation

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Add ( IEnumerable< T > docs )

Adds / updates several documents at once.

Parameters:
docs documents to add/update
Returns:

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Add ( T doc )

Adds / updates a document.

Parameters:
doc document to add/update
Returns:

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.AddWithBoost | ( | T | doc,
 |  | double | boost
 | ) |  |

Adds / updates a document with index-time boost.

Parameters:
doc
boost
Returns:

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.BuildSpellCheckDictionary ( )

Create the dictionary for use by the SolrSpellChecker. In typical applications, one needs to build the dictionary before using it. However, it may not always be necessary as it is possible to setup the spellchecker with a dictionary that already exists.

summary> Validates the mapping of the type T against the Solr schema XML document. /summary> returns> A collection of ValidationResult objects containing warnings and error found validating the type's mapping against the Solr schema if any.

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Commit ( )

Commits posted documents, blocking until index changes are flushed to disk and blocking until a new searcher is opened and registered as the main query searcher, making the changes visible.

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Delete ( string id )

Deletes a document by its id (unique key)

Parameters:
id document key
Returns:

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Delete ( IEnumerable< string > ids )

Deletes several documents by their id (unique key)

Parameters:
ids document unique keys
Returns:

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Delete ( T doc )

Deletes a document (requires the document to have a unique key defined with non-null value)

Parameters:
doc document to delete
Returns:
Exceptions:
SolrNetException throws if document type doesn't have a unique key or document has null unique key

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Delete ( IEnumerable< T > docs )

Deletes several documents (requires the document type to have a unique key defined with non-null value)

Parameters:
docs
Returns:
Exceptions:
SolrNetException throws if document type doesn't have a unique key or document has null unique key

Implements SolrNet.ISolrOperations< T >.

template<T >
ICollection<KeyValuePair<string, int> > SolrNet.Impl.SolrServer< T >.FacetFieldQuery ( SolrFacetFieldQuery facet )

Executes a facet field query only.

Parameters:
facet
Returns:

Implements SolrNet.ISolrReadOnlyOperations< T >.

template<T >
SolrSchema SolrNet.Impl.SolrServer< T >.GetSchema ( )

Gets the schema.

Returns:
A XmlDocument containing the Solr schema XML.

Implements SolrNet.ISolrBasicReadOnlyOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Optimize ( )

Commits posts, blocking until index changes are flushed to disk and blocking until a new searcher is opened and registered as the main query searcher, making the changes visible.

Implements SolrNet.ISolrOperations< T >.

template<T >
ResponseHeader SolrNet.Impl.SolrServer< T >.Ping ( )

Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. See http://wiki.apache.org/solr/SolrConfigXml for more information.

Implements SolrNet.ISolrBasicReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrServer< T >.Query | ( | ISolrQuery | query,
 |  | ICollection< SortOrder > | orders
 | ) |  |

Executes a query.

Parameters:
query
orders
Returns:

Implements SolrNet.ISolrReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrServer< T >.Query ( ISolrQuery q )

Executes a query.

Parameters:
q
Returns:

Implements SolrNet.ISolrReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrServer< T >.Query | ( | string | q,
 |  | QueryOptions | options
 | ) |  |

Executes a query.

Parameters:
q
options
Returns:

Implements SolrNet.ISolrReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrServer< T >.Query ( string q )

Executes a query.

Parameters:
q query to execute
Returns:
query results

Implements SolrNet.ISolrReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrServer< T >.Query | ( | ISolrQuery | query,
 |  | QueryOptions | options
 | ) |  |

Executes a query.

Parameters:
query
options
Returns:

Implements SolrNet.ISolrBasicReadOnlyOperations< T >.

template<T >
ISolrQueryResults<T> SolrNet.Impl.SolrServer< T >.Query | ( | string | q,
 |  | ICollection< SortOrder > | orders
 | ) |  |

Executes a query.

Parameters:
q
orders
Returns:

Implements SolrNet.ISolrReadOnlyOperations< T >.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SolrServer.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: StructureMap.SolrNetIntegration.Config.SolrServerElement Class Reference

  • StructureMap
  • SolrNetIntegration
  • Config
  • SolrServerElement
Public Member Functions | Properties

StructureMap.SolrNetIntegration.Config.SolrServerElement Class Reference

List of all members.

Public Member Functions

override string | ToString ()

Properties

string | Id [get, set]
string | Url [get, set]
string | DocumentType [get, set]
The documentation for this class was generated from the following file:
  • StructureMap.SolrNetIntegration/Config/SolrServerElement.cs
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: StructureMap.SolrNetIntegration.Config.SolrServers Class Reference

  • StructureMap
  • SolrNetIntegration
  • Config
  • SolrServers
Public Member Functions | Protected Member Functions | Properties

StructureMap.SolrNetIntegration.Config.SolrServers Class Reference

List of all members.

Public Member Functions

void | Add (SolrServerElement configurationElement)

Protected Member Functions

override ConfigurationElement | CreateNewElement ()
override object | GetElementKey (ConfigurationElement element)

Properties

override
ConfigurationElementCollectionType 		CollectionType [get]
override string | ElementName [get]
The documentation for this class was generated from the following file:
  • StructureMap.SolrNetIntegration/Config/SolrServers.cs
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: NHibernate.SolrNet.SolrSession Class Reference

  • NHibernate
  • SolrNet
  • SolrSession
Public Member Functions

NHibernate.SolrNet.SolrSession Class Reference

NHibernate ISession with SolrNet extensions for querying. More...

Inheritance diagram for NHibernate.SolrNet.SolrSession:
NHibernate.SolrNet.Impl.DelegatingSession NHibernate.SolrNet.ISolrSession

List of all members.

Public Member Functions

SolrSession (ISession session)
Creates a session using the current ServiceLocator
SolrSession (ISession session, IServiceProvider provider)
Creates a session using a defined IServiceProvider to fetch SolrNet components.
INHSolrQuery | CreateSolrQuery (string query)
Creates a Solr query.
INHSolrQuery | CreateSolrQuery (ISolrQuery query)
Creates a Solr query.

Detailed Description

NHibernate ISession with SolrNet extensions for querying.

Constructor & Destructor Documentation

NHibernate.SolrNet.SolrSession.SolrSession ( ISession session )

Creates a session using the current ServiceLocator

Parameters:
session NHibernate session to wrap

The wrapped session is owned by this session. It will be disposed when this session is disposed

NHibernate.SolrNet.SolrSession.SolrSession | ( | ISession | session,
 |  | IServiceProvider | provider
 | ) |  |

Creates a session using a defined IServiceProvider to fetch SolrNet components.

Parameters:
session | NHibernate session to wrap
provider | Used to fetch SolrNet components

The wrapped session is owned by this session. It will be disposed when this session is disposed

Member Function Documentation

INHSolrQuery NHibernate.SolrNet.SolrSession.CreateSolrQuery ( string query )

Creates a Solr query.

Parameters:
query Solr query
Returns:
query object

Implements NHibernate.SolrNet.ISolrSession.

INHSolrQuery NHibernate.SolrNet.SolrSession.CreateSolrQuery ( ISolrQuery query )

Creates a Solr query.

Parameters:
query Solr query
Returns:
query object

Implements NHibernate.SolrNet.ISolrSession.

The documentation for this class was generated from the following file:
  • NHibernate.SolrNet/SolrSession.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Attributes.SolrUniqueKeyAttribute Class Reference

  • SolrNet
  • Attributes
  • SolrUniqueKeyAttribute
Public Member Functions

SolrNet.Attributes.SolrUniqueKeyAttribute Class Reference

Marks a property as unique key. By default the field name is the property name. More...

Inheritance diagram for SolrNet.Attributes.SolrUniqueKeyAttribute:
SolrNet.Attributes.SolrFieldAttribute

List of all members.

Public Member Functions

SolrUniqueKeyAttribute ()
Marks a property as unique key. By default the field name is the property name.
SolrUniqueKeyAttribute (string fieldName)
Marks a property as unique key.

Detailed Description

Marks a property as unique key. By default the field name is the property name.

Constructor & Destructor Documentation

SolrNet.Attributes.SolrUniqueKeyAttribute.SolrUniqueKeyAttribute ( )

Marks a property as unique key. By default the field name is the property name.

SolrNet.Attributes.SolrUniqueKeyAttribute.SolrUniqueKeyAttribute ( string fieldName )

Marks a property as unique key.

Parameters:
fieldName
The documentation for this class was generated from the following file:
  • SolrNet/Attributes/SolrUniqueKeyAttribute.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.SortOrder Class Reference

  • SolrNet
  • SortOrder
Public Member Functions | Static Public Member Functions

SolrNet.SortOrder Class Reference

Sorting order. More...

Inheritance diagram for SolrNet.SortOrder:
SolrNet.RandomSortOrder

List of all members.

Public Member Functions

SortOrder (string fieldName)
SortOrder (string fieldName, Order order)
override string | ToString ()

Static Public Member Functions

static SortOrder | Parse (string s)

Detailed Description

Sorting order.

The documentation for this class was generated from the following file:
  • SolrNet/SortOrder.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.SpellCheckingParameters Class Reference

  • SolrNet
  • Commands
  • Parameters
  • SpellCheckingParameters
Properties

SolrNet.Commands.Parameters.SpellCheckingParameters Class Reference

Spell checking parameters. More...

List of all members.

Properties

string | Query [get, set]
The query to spellcheck. If spellcheck.q is defined, then it is used, otherwise the original input query is used. The spellcheck.q parameter is intended to be the original query, minus any extra markup like field names, boosts, etc. If the q parameter is specified, then the SpellingQueryConverter class is used to parse it into tokens, otherwise the WhitesepaceTokenizer is used. The choice of which one to use is up to the application. Essentially, if you have a spelling "ready" version in your application, then it is probably better to send spellcheck.q, otherwise, if you just want Solr to do the job, use the q parameter.
bool | Build [get, set]
Create the dictionary for use by the SolrSpellChecker. In typical applications, one needs to build the dictionary before using it. However, it may not always be necessary as it is possible to setup the spellchecker with a dictionary that already exists.
bool | Reload [get, set]
Reload the spell checker. Depends on the implementation of SolrSpellChecker.reload() but usually means reloading the dictionary.
int | Count [get, set]
The maximum number of suggestions to return.
bool | OnlyMorePopular [get, set]
Only return suggestions that result in more hits for the query than the existing query.
bool | Collate [get, set]
Take the best suggestion for each token (if it exists) and construct a new query from the suggestions.
string | Dictionary [get, set]
The name of the spellchecker to use. This defaults to "default". Can be used to invoke a specific spellchecker on a per request basis.

Detailed Description

Spell checking parameters.

Property Documentation

bool SolrNet.Commands.Parameters.SpellCheckingParameters.Build [get, set]

Create the dictionary for use by the SolrSpellChecker. In typical applications, one needs to build the dictionary before using it. However, it may not always be necessary as it is possible to setup the spellchecker with a dictionary that already exists.

bool SolrNet.Commands.Parameters.SpellCheckingParameters.Collate [get, set]

Take the best suggestion for each token (if it exists) and construct a new query from the suggestions.

int SolrNet.Commands.Parameters.SpellCheckingParameters.Count [get, set]

The maximum number of suggestions to return.

string SolrNet.Commands.Parameters.SpellCheckingParameters.Dictionary [get, set]

The name of the spellchecker to use. This defaults to "default". Can be used to invoke a specific spellchecker on a per request basis.

bool SolrNet.Commands.Parameters.SpellCheckingParameters.OnlyMorePopular [get, set]

Only return suggestions that result in more hits for the query than the existing query.

string SolrNet.Commands.Parameters.SpellCheckingParameters.Query [get, set]

The query to spellcheck. If spellcheck.q is defined, then it is used, otherwise the original input query is used. The spellcheck.q parameter is intended to be the original query, minus any extra markup like field names, boosts, etc. If the q parameter is specified, then the SpellingQueryConverter class is used to parse it into tokens, otherwise the WhitesepaceTokenizer is used. The choice of which one to use is up to the application. Essentially, if you have a spelling "ready" version in your application, then it is probably better to send spellcheck.q, otherwise, if you just want Solr to do the job, use the q parameter.

bool SolrNet.Commands.Parameters.SpellCheckingParameters.Reload [get, set]

Reload the spell checker. Depends on the implementation of SolrSpellChecker.reload() but usually means reloading the dictionary.

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/SpellCheckingParameters.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • SpellCheckResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > Class Template Reference

Parses spell-checking results from a query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

void | Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
SpellCheckResults | ParseSpellChecking (XmlNode node)
Parses spell-checking results.

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::SpellCheckResponseParser< T >

Parses spell-checking results from a query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
SpellCheckResults SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >.ParseSpellChecking ( XmlNode node )

Parses spell-checking results.

Parameters:
node
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/SpellCheckResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SpellCheckResult Class Reference

  • SolrNet
  • Impl
  • SpellCheckResult
Properties

SolrNet.Impl.SpellCheckResult Class Reference

Spell-checking results. More...

List of all members.

Properties

string | Query [get, set]
Original query term.
int | NumFound [get, set]
Result count for original term.
int | StartOffset [get, set]
Start offset.
int | EndOffset [get, set]
End offset.
ICollection< string > | Suggestions [get, set]
Spelling suggestions.

Detailed Description

Spell-checking results.

Property Documentation

int SolrNet.Impl.SpellCheckResult.EndOffset [get, set]

End offset.

int SolrNet.Impl.SpellCheckResult.NumFound [get, set]

Result count for original term.

string SolrNet.Impl.SpellCheckResult.Query [get, set]

Original query term.

int SolrNet.Impl.SpellCheckResult.StartOffset [get, set]

Start offset.

ICollection<string> SolrNet.Impl.SpellCheckResult.Suggestions [get, set]

Spelling suggestions.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SpellCheckResult.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.SpellCheckResults Class Reference

  • SolrNet
  • Impl
  • SpellCheckResults
Public Member Functions | Properties

SolrNet.Impl.SpellCheckResults Class Reference

Spell-checking query results. More...

List of all members.

Public Member Functions

IEnumerator< SpellCheckResult > | GetEnumerator ()
void | Add (SpellCheckResult item)
void | Clear ()
bool | Contains (SpellCheckResult item)
void | CopyTo (SpellCheckResult[] array, int arrayIndex)
bool | Remove (SpellCheckResult item)

Properties

string | Collation [get, set]
Suggestion query from spell-checking.
int | Count [get]
bool | IsReadOnly [get]

Detailed Description

Spell-checking query results.

Property Documentation

string SolrNet.Impl.SpellCheckResults.Collation [get, set]

Suggestion query from spell-checking.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/SpellCheckResults.cs
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Commands.Parameters.StatsParameters Class Reference

  • SolrNet
  • Commands
  • Parameters
  • StatsParameters
Public Member Functions | Properties

SolrNet.Commands.Parameters.StatsParameters Class Reference

Parameters to query stats More...

List of all members.

Public Member Functions

StatsParameters | AddFacet (string facet)
Adds a facet to the Facets collection.
StatsParameters | AddField (string field)
Adds a field (without facets) to the FieldsWithFacets collection.
StatsParameters | AddFieldWithFacet (string field, string facet)
Adds a field with a related facet to the FieldsWithFacets collection.
StatsParameters | AddFieldWithFacets (string field, IEnumerable< string > facets)
Adds a field with related facets to the FieldsWithFacets collection.
StatsParameters | AddFieldWithFacets (string field, params string[] facets)
Adds a field with related facets to the FieldsWithFacets collection.

Properties

IDictionary< string,
ICollection< string > > 		FieldsWithFacets [get, set]
Dictionary of fields to get stats, and their associated facets (if any)
ICollection< string > | Facets [get, set]
Global facets: get these facets' stats for all fields requested in FieldsWithFacets

Detailed Description

Parameters to query stats

Member Function Documentation

StatsParameters SolrNet.Commands.Parameters.StatsParameters.AddFacet ( string facet )

Adds a facet to the Facets collection.

Parameters:
facet
Returns:
StatsParameters SolrNet.Commands.Parameters.StatsParameters.AddField ( string field )

Adds a field (without facets) to the FieldsWithFacets collection.

Parameters:
field
Returns:
StatsParameters SolrNet.Commands.Parameters.StatsParameters.AddFieldWithFacet | ( | string | field,
 |  | string | facet
 | ) |  |

Adds a field with a related facet to the FieldsWithFacets collection.

Parameters:
field
facet
Returns:
StatsParameters SolrNet.Commands.Parameters.StatsParameters.AddFieldWithFacets | ( | string | field,
 |  | IEnumerable< string > | facets
 | ) |  |

Adds a field with related facets to the FieldsWithFacets collection.

Parameters:
field
facets
Returns:
StatsParameters SolrNet.Commands.Parameters.StatsParameters.AddFieldWithFacets | ( | string | field,
 |  | params string[] | facets
 | ) |  |

Adds a field with related facets to the FieldsWithFacets collection.

Parameters:
field
facets
Returns:

Property Documentation

ICollection<string> SolrNet.Commands.Parameters.StatsParameters.Facets [get, set]

Global facets: get these facets' stats for all fields requested in FieldsWithFacets

IDictionary<string, ICollection<string> > SolrNet.Commands.Parameters.StatsParameters.FieldsWithFacets [get, set]

Dictionary of fields to get stats, and their associated facets (if any)

The documentation for this class was generated from the following file:
  • SolrNet/Commands/Parameters/StatsParameters.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.ResponseParsers.StatsResponseParser< T > Class Template Reference

  • SolrNet
  • Impl
  • ResponseParsers
  • StatsResponseParser
Public Member Functions

SolrNet.Impl.ResponseParsers.StatsResponseParser< T > Class Template Reference

Parses stats results from a query response. More...

Inheritance diagram for SolrNet.Impl.ResponseParsers.StatsResponseParser< T >:
SolrNet.Impl.ISolrResponseParser< T >

List of all members.

Public Member Functions

void | Parse (XmlDocument xml, SolrQueryResults< T > results)
Parses a chunk of a query response into the results object.
Dictionary< string, StatsResult > | ParseStats (XmlNode node, string selector)
Parses the stats results and uses recursion to get any facet results.
IDictionary< string,
Dictionary< string,
StatsResult > > 		ParseFacetNode (XmlNode node)
StatsResult | ParseStatsNode (XmlNode node)

Detailed Description

template<T>
class SolrNet::Impl::ResponseParsers::StatsResponseParser< T >

Parses stats results from a query response.

Template Parameters:
T Document type

Member Function Documentation

template<T >
void SolrNet.Impl.ResponseParsers.StatsResponseParser< T >.Parse | ( | XmlDocument | xml,
 |  | SolrQueryResults< T > | results
 | ) |  |

Parses a chunk of a query response into the results object.

Parameters:
xml | query response
results | results object

Implements SolrNet.Impl.ISolrResponseParser< T >.

template<T >
Dictionary<string, StatsResult> SolrNet.Impl.ResponseParsers.StatsResponseParser< T >.ParseStats | ( | XmlNode | node,
 |  | string | selector
 | ) |  |

Parses the stats results and uses recursion to get any facet results.

Parameters:
node
selector Start with 'stats_fields'
Returns:
The documentation for this class was generated from the following file:
  • SolrNet/Impl/ResponseParsers/StatsResponseParser.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.StatsResult Class Reference

  • SolrNet
  • StatsResult
Properties

SolrNet.StatsResult Class Reference

Stats results More...

List of all members.

Properties

double | Min [get, set]
Minimum value.
double | Max [get, set]
Maximum value.
double | Sum [get, set]
Sum of all values.
long | Count [get, set]
How many (non-null) values.
long | Missing [get, set]
How many null values.
double | SumOfSquares [get, set]
Sum of all values squared (useful for stddev)
double | Mean [get, set]
The average (v1+v2...+vN)/N.
double | StdDev [get, set]
Standard deviation.
IDictionary< string,
Dictionary< string,
StatsResult > > 		FacetResults [get, set]
Facet results.

  • Key is the facet field
  • Value is a dictionary where:
    • Key is the facet value
    • Value is the stats for the facet value

Detailed Description

Stats results

Property Documentation

long SolrNet.StatsResult.Count [get, set]

How many (non-null) values.

IDictionary<string, Dictionary<string, StatsResult> > SolrNet.StatsResult.FacetResults [get, set]

Facet results.

  • Key is the facet field
  • Value is a dictionary where:
    • Key is the facet value
    • Value is the stats for the facet value

double SolrNet.StatsResult.Max [get, set]

Maximum value.

double SolrNet.StatsResult.Mean [get, set]

The average (v1+v2...+vN)/N.

double SolrNet.StatsResult.Min [get, set]

Minimum value.

long SolrNet.StatsResult.Missing [get, set]

How many null values.

double SolrNet.StatsResult.StdDev [get, set]

Standard deviation.

double SolrNet.StatsResult.Sum [get, set]

Sum of all values.

double SolrNet.StatsResult.SumOfSquares [get, set]

Sum of all values squared (useful for stddev)

The documentation for this class was generated from the following file:
  • SolrNet/StatsResult.cs
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Castle.Facilities.SolrNetIntegration.StrictArrayResolver Class Reference

  • Castle
  • Facilities
  • SolrNetIntegration
  • StrictArrayResolver
Public Member Functions

Castle.Facilities.SolrNetIntegration.StrictArrayResolver Class Reference

List of all members.

Public Member Functions

StrictArrayResolver (IKernel kernel)
object | Resolve (CreationContext context, ISubDependencyResolver contextHandlerResolver, ComponentModel model, DependencyModel dependency)
bool | CanResolve (CreationContext context, ISubDependencyResolver contextHandlerResolver, ComponentModel model, DependencyModel dependency)
The documentation for this class was generated from the following file:
  • Castle.Facilities.SolrNetIntegration/StrictArrayResolver.cs
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • StringSolrFieldTypeChecker
Public Member Functions

SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker Class Reference

Checks schema type of properties with string type. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker:
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker

List of all members.

Public Member Functions

StringSolrFieldTypeChecker ()
Checks schema type of properties with string type.

Detailed Description

Checks schema type of properties with string type.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker.StringSolrFieldTypeChecker ( )

Checks schema type of properties with string type.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/StringSolrFieldTypeChecker.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.ToStringFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • ToStringFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.ToStringFieldSerializer Class Reference

Serializes using .ToString() More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.ToStringFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Serializes using .ToString()

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.ToStringFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.ToStringFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/ToStringFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldParsers.TypeConvertingFieldParser Class Reference

  • SolrNet
  • Impl
  • FieldParsers
  • TypeConvertingFieldParser
Public Member Functions

SolrNet.Impl.FieldParsers.TypeConvertingFieldParser Class Reference

Parses using TypeConverter More...

Inheritance diagram for SolrNet.Impl.FieldParsers.TypeConvertingFieldParser:
SolrNet.Impl.ISolrFieldParser

List of all members.

Public Member Functions

bool | CanHandleSolrType (string solrType)
True if this parser can handle the solrType (int, bool, str, ...)
bool | CanHandleType (Type t)
True if this parser can handle a type.
Type | GetUnderlyingType (XmlNode field, Type t)
Gets the corresponding CLR Type to a solr type.
object | Parse (XmlNode field, Type t)
Parses a single Solr XML result node.

Detailed Description

Parses using TypeConverter

Member Function Documentation

bool SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.CanHandleSolrType ( string solrType )

True if this parser can handle the solrType (int, bool, str, ...)

Parameters:
solrType
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

bool SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.CanHandleType ( Type t )

True if this parser can handle a type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldParser.

Type SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.GetUnderlyingType | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Gets the corresponding CLR Type to a solr type.

Parameters:
field
t
Returns:
object SolrNet.Impl.FieldParsers.TypeConvertingFieldParser.Parse | ( | XmlNode | field,
 |  | Type | t
 | ) |  |

Parses a single Solr XML result node.

Parameters:
field | Solr XML result node
t | Type the node value should be converted to
Returns:
Parsed value

Implements SolrNet.Impl.ISolrFieldParser.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldParsers/TypeConvertingFieldParser.cs
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer Class Reference

  • SolrNet
  • Impl
  • FieldSerializers
  • TypeConvertingFieldSerializer
Public Member Functions

SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer Class Reference

Serializes using TypeConverters. More...

Inheritance diagram for SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer:
SolrNet.Impl.ISolrFieldSerializer

List of all members.

Public Member Functions

bool | CanHandleType (Type t)
True if this serializer can handle the type.
IEnumerable< PropertyNode > | Serialize (object obj)
Serializes a value to be consumed by the Solr update handler.

Detailed Description

Serializes using TypeConverters.

Member Function Documentation

bool SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer.CanHandleType ( Type t )

True if this serializer can handle the type.

Parameters:
t
Returns:

Implements SolrNet.Impl.ISolrFieldSerializer.

IEnumerable<PropertyNode> SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer.Serialize ( object obj )

Serializes a value to be consumed by the Solr update handler.

Parameters:
obj object to serialize
Returns:
List of PropertyNodes, each represents a XML node to be passed to the Solr update handler

Implements SolrNet.Impl.ISolrFieldSerializer.

The documentation for this class was generated from the following file:
  • SolrNet/Impl/FieldSerializers/TypeConvertingFieldSerializer.cs
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Exceptions.TypeNotSupportedException Class Reference

  • SolrNet
  • Exceptions
  • TypeNotSupportedException
Public Member Functions | Protected Member Functions

SolrNet.Exceptions.TypeNotSupportedException Class Reference

Inheritance diagram for SolrNet.Exceptions.TypeNotSupportedException:
SolrNet.Exceptions.SolrNetException

List of all members.

Public Member Functions

TypeNotSupportedException (Exception innerException)
TypeNotSupportedException (string message)
TypeNotSupportedException (string message, Exception innerException)

Protected Member Functions

TypeNotSupportedException (SerializationInfo info, StreamingContext context)
The documentation for this class was generated from the following file:
  • SolrNet/Exceptions/TypeNotSupportedException.cs
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule Class Reference

  • SolrNet
  • Mapping
  • Validation
  • Rules
  • UniqueKeyMatchesMappingRule
Public Member Functions

SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule Class Reference

Validation rule for making sure the uniqueKey mapped in the type is the same as in the Solr schema. More...

Inheritance diagram for SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule:
SolrNet.Mapping.Validation.Rules.IValidationRule

List of all members.

Public Member Functions

IEnumerable< ValidationResult > Validate (Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager)
Validates that the uniqueKey mapped in the type is the same as in the Solr schema.

Detailed Description

Validation rule for making sure the uniqueKey mapped in the type is the same as in the Solr schema.

Member Function Documentation

IEnumerable<ValidationResult> SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule.Validate | ( | Type | documentType,
 |  | SolrSchema | solrSchema,
 |  | IReadOnlyMappingManager | mappingManager
 | ) |  |

Validates that the uniqueKey mapped in the type is the same as in the Solr schema.

Parameters:
documentType | Document type
solrSchema | The solr schema.
mappingManager | The mapping manager.
Returns:
A collection of ValidationResult objects with any issues found during validation.

Implements SolrNet.Mapping.Validation.Rules.IValidationRule.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/Rules/UniqueKeyMatchesMappingRule.cs
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.ValidationError Class Reference

  • SolrNet
  • Mapping
  • Validation
  • ValidationError
Public Member Functions

SolrNet.Mapping.Validation.ValidationError Class Reference

Represents a Solr schema mapping validation error. More...

Inheritance diagram for SolrNet.Mapping.Validation.ValidationError:
SolrNet.Mapping.Validation.ValidationResult

List of all members.

Public Member Functions

ValidationError (string message)
Initializes a new instance of the ValidationError class.

Detailed Description

Represents a Solr schema mapping validation error.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.ValidationError.ValidationError ( string message )

Initializes a new instance of the ValidationError class.

Parameters:
message The error message.
The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/ValidationError.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.ValidationResult Class Reference

  • SolrNet
  • Mapping
  • Validation
  • ValidationResult
Protected Member Functions | Properties

SolrNet.Mapping.Validation.ValidationResult Class Reference

Represents a Solr schema mapping validation issue. More...

Inheritance diagram for SolrNet.Mapping.Validation.ValidationResult:
SolrNet.Mapping.Validation.ValidationError SolrNet.Mapping.Validation.ValidationWarning

List of all members.

Protected Member Functions

ValidationResult (string message)
Initializes a new instance of the ValidationResult class.

Properties

string Message [get]
Gets the message.

Detailed Description

Represents a Solr schema mapping validation issue.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.ValidationResult.ValidationResult ( string message ) [protected]

Initializes a new instance of the ValidationResult class.

Parameters:
message The message.

Property Documentation

string SolrNet.Mapping.Validation.ValidationResult.Message [get]

Gets the message.

The message.

The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/ValidationResult.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: SolrNet.Mapping.Validation.ValidationWarning Class Reference

  • SolrNet
  • Mapping
  • Validation
  • ValidationWarning
Public Member Functions

SolrNet.Mapping.Validation.ValidationWarning Class Reference

Represents a Solr schema mapping validation warning. More...

Inheritance diagram for SolrNet.Mapping.Validation.ValidationWarning:
SolrNet.Mapping.Validation.ValidationResult

List of all members.

Public Member Functions

ValidationWarning (string message)
Initializes a new instance of the ValidationWarning class.

Detailed Description

Represents a Solr schema mapping validation warning.

Constructor & Destructor Documentation

SolrNet.Mapping.Validation.ValidationWarning.ValidationWarning ( string message )

Initializes a new instance of the ValidationWarning class.

Parameters:
message The warning message.
The documentation for this class was generated from the following file:
  • SolrNet/Mapping/Validation/ValidationWarning.cs
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: HttpWebAdapters.WebResponseStub Class Reference

  • HttpWebAdapters
  • WebResponseStub
Public Member Functions | Properties

HttpWebAdapters.WebResponseStub Class Reference

Inheritance diagram for HttpWebAdapters.WebResponseStub:
HttpWebAdapters.IHttpWebResponse

List of all members.

Public Member Functions

string | GetResponseHeader (string headerName)
Gets the contents of a header that was returned with the response.

Properties

CookieCollection | Cookies [get, set]
Gets or sets the cookies that are associated with this response.
string | ContentEncoding [get, set]
Gets the method that is used to encode the body of the response.
string | CharacterSet [get, set]
Gets the character set of the response.
string | Server [get, set]
Gets the name of the server that sent the response.
DateTime | LastModified [get, set]
Gets the last date and time that the contents of the response were modified.
HttpStatusCode | StatusCode [get, set]
Gets the status of the response.
string | StatusDescription [get, set]
Gets the status description returned with the response.
Version | ProtocolVersion [get, set]
Gets the version of the HTTP protocol that is used in the response.
string | Method [get, set]
Gets the method that is used to return the response.

Member Function Documentation

string HttpWebAdapters.WebResponseStub.GetResponseHeader ( string headerName )

Gets the contents of a header that was returned with the response.

Returns:
The contents of the specified header.
Parameters:
headerName The header value to return.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

Property Documentation

string HttpWebAdapters.WebResponseStub.CharacterSet [get, set]

Gets the character set of the response.

Returns:
A string that contains the character set of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.WebResponseStub.ContentEncoding [get, set]

Gets the method that is used to encode the body of the response.

Returns:
A string that describes the method that is used to encode the body of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

CookieCollection HttpWebAdapters.WebResponseStub.Cookies [get, set]

Gets or sets the cookies that are associated with this response.

Returns:
A T:System.Net.CookieCollection that contains the cookies that are associated with this response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

DateTime HttpWebAdapters.WebResponseStub.LastModified [get, set]

Gets the last date and time that the contents of the response were modified.

Returns:
A T:System.DateTime that contains the date and time that the contents of the response were modified.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

<PermissionSet><IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" flags="UnmanagedCode, ControlEvidence"></PermissionSet>

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.WebResponseStub.Method [get, set]

Gets the method that is used to return the response.

Returns:
A string that contains the HTTP method that is used to return the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

Version HttpWebAdapters.WebResponseStub.ProtocolVersion [get, set]

Gets the version of the HTTP protocol that is used in the response.

Returns:
A T:System.Version that contains the HTTP protocol version of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.WebResponseStub.Server [get, set]

Gets the name of the server that sent the response.

Returns:
A string that contains the name of the server that sent the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

HttpStatusCode HttpWebAdapters.WebResponseStub.StatusCode [get, set]

Gets the status of the response.

Returns:
One of the T:System.Net.HttpStatusCode values.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

string HttpWebAdapters.WebResponseStub.StatusDescription [get, set]

Gets the status description returned with the response.

Returns:
A string that describes the status of the response.
Exceptions:
T:System.ObjectDisposedException The current instance has been disposed.

Implements HttpWebAdapters.IHttpWebResponse.

The documentation for this class was generated from the following file:
  • HttpWebAdapters/WebResponseStub.cs
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Abort() : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Accept : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • Add() : SolrNet.Impl.SolrQueryResults< T > , SolrNet.Mapping.MappingManager , SolrNet.Impl.SolrServer< T > , SolrNet.Mapping.MappingManager , SolrNet.Impl.HttpRuntimeCache , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.ISolrCache , SolrNet.ISolrOperations< T > , SolrNet.Mapping.IMappingManager , SolrNet.Impl.NullCache , SolrNet.Mapping.IMappingManager
  • AddCore() : Castle.Facilities.SolrNetIntegration.SolrNetFacility
  • AddFacet() : SolrNet.Commands.Parameters.StatsParameters
  • AddField() : SolrNet.Commands.Parameters.StatsParameters
  • AddFieldWithFacet() : SolrNet.Commands.Parameters.StatsParameters
  • AddFieldWithFacets() : SolrNet.Commands.Parameters.StatsParameters
  • AddRange() : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Address : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • AddWithBoost() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrBasicOperations< T > , SolrNet.ISolrOperations< T >
  • After : SolrNet.FacetDateOther
  • AfterTerm : SolrNet.Commands.Parameters.HighlightingParameters
  • AggregateDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor
  • AggregateFieldParser() : SolrNet.Impl.FieldParsers.AggregateFieldParser
  • All : SolrNet.SolrQuery , SolrNet.FacetDateOther
  • AllowAutoRedirect : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • AllowWriteStreamBuffering : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • AlternateField : SolrNet.Commands.Parameters.HighlightingParameters
  • AutomaticDecompression : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Package Castle.Facilities.SolrNetIntegration

  • Package Functions
  • Castle
  • Facilities
  • SolrNetIntegration
Classes

Package Castle.Facilities.SolrNetIntegration

Classes

class | SolrCore
Represents a Solr core for configuration. More...
class | SolrNetFacility
Configures SolrNet in a Windsor container. More...
class | StrictArrayResolver
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Package HttpWebAdapters

  • Package Functions
Packages | Classes

Package HttpWebAdapters

Packages

package | Adapters

Classes

interface | IHttpWebRequest
interface | IHttpWebRequestFactory
interface | IHttpWebResponse
class | HttpWebRequestFactory
class | HttpWebRequestMethod
class | WebResponseStub
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Package HttpWebAdapters.Adapters

  • Package Functions
  • HttpWebAdapters
  • Adapters
Classes

Package HttpWebAdapters.Adapters

Classes

class | HttpWebRequestAdapter
class | HttpWebResponseAdapter
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Package NHibernate.SolrNet

  • Package Functions
  • NHibernate
  • SolrNet
Packages | Classes

Package NHibernate.SolrNet

Packages

package | Impl

Classes

class | CfgHelper
Helper class to configure NHibernate-SolrNet integration. More...
interface | INHSolrQuery
NHibernate IQuery for SolrNet queries. More...
interface | ISolrSession
NHibernate ISession with SolrNet extensions for querying. More...
class | SolrSession
NHibernate ISession with SolrNet extensions for querying. More...
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Package NHibernate.SolrNet.Impl

  • Package Functions
  • NHibernate
  • SolrNet
  • Impl
Classes

Package NHibernate.SolrNet.Impl

Classes

class | DelegatingSession
interface | ICommitSetting
class | NHHelper
class | NHSolrQueryImpl
NHibernate IQuery for SolrNet queries. More...
class | SolrNetListener
NHibernate event listener for updating Solr index. More...
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Package Ninject.Integration.SolrNet

  • Package Functions
  • Ninject
  • Integration
  • SolrNet
Classes

Package Ninject.Integration.SolrNet

Classes

class SolrNetModule
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Package Rhino.Commons.LocalDataImpl

  • Package Functions
  • Rhino
  • Commons
  • LocalDataImpl
Classes

Package Rhino.Commons.LocalDataImpl

Classes

interface ILocalData
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet

  • Package Functions
Packages | Classes | Enumerations

Package SolrNet

Packages

package | Attributes
package | Commands
package | Exceptions
package | Mapping
package | Schema
package | Utils

Classes

class | AbstractSolrQuery
Abstract Solr query, used to define operator overloading. More...
class | CollapsedDocument
Field collapsing result. More...
class | CollapseResults
Collapse results More...
class | DateFacetingResult
Date faceting result. More...
class | FacetDateOther
Indicates that in addition to the counts for each date range constraint between facet.date.start and facet.date.end, counts should also be computed for other. More...
interface | IReadOnlyMappingManager
Service interface for mapping Solr fields to object properties. More...
interface | ISolrBasicOperations
Solr operations without convenience overloads. More...
interface | ISolrBasicReadOnlyOperations
Read-only operations without convenience overloads. More...
interface | ISolrCommand
Command interface. More...
interface | ISolrConnection
Manages HTTP connection with Solr. More...
interface | ISolrDocumentSerializer
Serializes a solr document to xml. More...
interface | ISolrFacetQuery
Facet query interface. More...
interface | ISolrOperations
Consolidating interface, exposes all operations. More...
interface | ISolrQuery
Base query interface. More...
interface | ISolrQueryExecuter
Executable query. More...
interface | ISolrQueryResultParser
Query results parser interface. More...
interface | ISolrQueryResults
Query results. More...
interface | ISolrReadOnlyOperations
Read-only operations. More...
class | LocalParams
Provides a way to "localize" information about a specific argument that is being sent to Solr. In other words, it provides a way to add meta-data to certain argument types such as query strings. More...
class | RandomSortOrder
Random sorting of results Requires Solr 1.3+. More...
class | ResponseHeader
Operation response header. More...
class | SolrFacetDateQuery
Date facet query More...
class | SolrFacetFieldQuery
Facet field query. More...
class | SolrFacetQuery
Arbitrary facet query. More...
class | SolrFieldModel
Represents a Solr field mapping. /summary> More...
class | SolrHasValueQuery
Queries documents that have any value in the specified field. More...
class | SolrMultipleCriteriaQuery
Represents several queries as one. More...
class | SolrNotQuery
Negates a query. More...
class | SolrQuery
Basic solr query. More...
class | SolrQueryBoost
Applies a boost to a query or query fragment. More...
class | SolrQueryByField
Queries a field for a value. More...
class | SolrQueryByRange
Queries a field for a range. More...
class | SolrQueryInList
Queries a field for a list of possible values. More...
class | SortOrder
Sorting order. More...
class | Startup
SolrNet initialization manager.
class | StatsResult
Stats results More...

Enumerations

enum | Order { ASC, DESC }

Sort order.

More...

Enumeration Type Documentation

enum SolrNet::Order

Sort order.

Enumerator:
ASC

Ascending sort order.

DESC

Descending sort order.

Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Attributes

  • Package Functions
  • SolrNet
  • Attributes
Classes

Package SolrNet.Attributes

Classes

class | SolrFieldAttribute
Marks a property as present on Solr. By default the field name is the property name. More...
class | SolrUniqueKeyAttribute
Marks a property as unique key. By default the field name is the property name. More...
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Commands

  • Package Functions
  • SolrNet
  • Commands
Packages | Classes

Package SolrNet.Commands

Packages

package | Parameters

Classes

class | AddCommand
Adds / updates documents to solr. More...
class | CommitCommand
Commits updates. More...
class | DeleteCommand
Deletes document(s), either by id or by query. More...
class | GetSchemaCommand
Gets the raw Solr schema. More...
class | OptimizeCommand
Optimizes Solr's index. More...
class | PingCommand
Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing. More...
class | RollbackCommand
Rollbacks all add/deletes made to the index since the last commit. More...
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Commands.Parameters

  • Package Functions
  • SolrNet
  • Commands
  • Parameters
Classes | Enumerations

Package SolrNet.Commands.Parameters

Classes

class | CollapseParameters
Parameters to query collapse https://issues.apache.org/jira/browse/SOLR-236 More...
class | CommitOptions
Commit/optimize options. More...
class | DeleteByIdAndOrQueryParam
Parameter to delete document(s) by one or more ids and or a query parameters. More...
class | FacetParameters
Faceting parameters. More...
class | HighlightingParameters
Highlighting parameters. More...
interface | ISolrDeleteParam
Delete command parameter. More...
class | MoreLikeThisParameters
More-like-this parameters See http://wiki.apache.org/solr/MoreLikeThis. More...
class | QueryOptions
Query options. More...
class | SpellCheckingParameters
Spell checking parameters. More...
class | StatsParameters
Parameters to query stats More...

Enumerations

enum | CollapseType { Normal, Adjacent }

Parameters to query collapse

More...
enum | CollapseFacetMode { Before, After }

Controls if collapsing happens before or after faceting.

More...

Enumeration Type Documentation

enum SolrNet::Commands::Parameters::CollapseFacetMode

Controls if collapsing happens before or after faceting.

Enumerator:
Before

Faceting happens before collapsing.

After

Faceting happens after collapsing.

enum SolrNet::Commands::Parameters::CollapseType

Parameters to query collapse

Enumerator:
Normal

Collapse all documents having equal collapsing field.

Adjacent

Collapse only consecutive documents.

Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.DSL.Impl

  • Package Functions
  • SolrNet
  • DSL
  • Impl
Classes

Package SolrNet.DSL.Impl

Classes

class | DeleteBy
class | DSLFacetFieldOptions
class | DSLQuery
class | DSLQueryBetween
class | DSLQueryBy
class | DSLQueryRange
class | DSLRun
class | FieldDefinition
interface | IDSLFacetFieldOptions
interface | IDSLQuery
interface | IDSLQueryBetween
interface | IDSLQueryBy
interface | IDSLQueryRange
interface | IDSLRun
class | RangeDefinition
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Exceptions

  • Package Functions
  • SolrNet
  • Exceptions
Classes

Package SolrNet.Exceptions

Classes

class | InvalidFieldException
Solr did not understand one the specified fields. More...
class | InvalidSortOrderException
Error parsing SortOrder More...
class | InvalidURLException
Invalid URL specified. More...
class | SolrConnectionException
Error connecting to Solr. See inner exception for more information. More...
class | SolrNetException
Base exception for all exceptions thrown by SolrNet. More...
class | TypeNotSupportedException
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Impl.DocumentPropertyVisitors

  • Package Functions
  • SolrNet
  • Impl
  • DocumentPropertyVisitors
Classes

Package SolrNet.Impl.DocumentPropertyVisitors

Classes

class | AggregateDocumentVisitor
Aggregate document visitor. More...
class | DefaultDocumentVisitor
Default document visitor. More...
class | GenericDictionaryDocumentVisitor
Document visitor that handles generic dictionary properties. More...
class | RegularDocumentVisitor
Pass-through document visitor. More...
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Impl.FacetQuerySerializers

  • Package Functions
  • SolrNet
  • Impl
  • FacetQuerySerializers
Classes

Package SolrNet.Impl.FacetQuerySerializers

Classes

class | AggregateFacetQuerySerializer
class | DefaultFacetQuerySerializer
class | SingleTypeFacetQuerySerializer
class | SolrFacetDateQuerySerializer
class | SolrFacetFieldQuerySerializer
class | SolrFacetQuerySerializer
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Impl.FieldParsers

  • Package Functions
  • SolrNet
  • Impl
  • FieldParsers
Classes

Package SolrNet.Impl.FieldParsers

Classes

class | AggregateFieldParser
Aggregates ISolrFieldParsers. More...
class | CollectionFieldParser
Parses 1-dimensional fields. More...
class | DateTimeFieldParser
Parses datetime fields. More...
class | DecimalFieldParser
Parses decimal fields. More...
class | DefaultFieldParser
Default field parser. More...
class | DoubleFieldParser
Parses double fields. More...
class | EnumFieldParser
class | FloatFieldParser
Parses float values. More...
class | GuidFieldParser
class | InferringFieldParser
Parser that infers .net type based on solr type. More...
class | IntFieldParser
Parses int values. More...
class | LongFieldParser
Parses long fields. More...
class | NullableFieldParser
Wraps a ISolrFieldParser making it support the corresponding Nullable{T} type. More...
class | TypeConvertingFieldParser
Parses using TypeConverter More...
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Impl.FieldSerializers

  • Package Functions
  • SolrNet
  • Impl
  • FieldSerializers
Classes

Package SolrNet.Impl.FieldSerializers

Classes

class | AbstractFieldSerializer
Strongly-typed abstract field parser. More...
class | AggregateFieldSerializer
Aggregates ISolrFieldSerializers. More...
class | BoolFieldSerializer
Parses bool values. More...
class | CollectionFieldSerializer
Serializes 1-dimensional collections. More...
class | DateTimeFieldSerializer
Serializes datetime fields. More...
class | DefaultFieldSerializer
Aggregates the default ISolrFieldSerializers. More...
class | FormattableFieldSerializer
Serializes objects that implement IFormattable More...
class | GenericDictionaryFieldSerializer
Serializes IDictionary{TKey,TValue} properties. More...
class | NullableFieldSerializer
Wraps a ISolrFieldSerializer making it support the corresponding Nullable{T} type. More...
class | ToStringFieldSerializer
Serializes using .ToString() More...
class | TypeConvertingFieldSerializer
Serializes using TypeConverters. More...
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Impl.QuerySerializers

  • Package Functions
  • SolrNet
  • Impl
  • QuerySerializers
Classes

Package SolrNet.Impl.QuerySerializers

Classes

class | AggregateQuerySerializer
class | BoostQuerySerializer
class | DateTimeRangeQuerySerializer
class | DefaultQuerySerializer
class | HasValueQuerySerializer
class | LocalParamsSerializer
class | MultipleCriteriaQuerySerializer
class | NotQuerySerializer
class | NullableDateTimeRangeQuerySerializer
class | QueryByFieldSerializer
class | QueryInListSerializer
class | RangeQuerySerializer
class | SelfSerializingQuerySerializer
class | SingleTypeQuerySerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Impl.ResponseParsers

  • Package Functions
  • SolrNet
  • Impl
  • ResponseParsers
Classes

Package SolrNet.Impl.ResponseParsers

Classes

class | CollapseResponseParser
Parses collapse_counts from query response. More...
class | FacetsResponseParser
Parses facets from query response. More...
class | HeaderResponseParser
Parses header (status, QTime, etc) from a query response. More...
class | HighlightingResponseParser
Parses highlighting results from a query response. More...
class | MoreLikeThisResponseParser
Parses more-like-this results from a query response. More...
class | ResultsResponseParser
Parses documents from a query response. More...
class | SpellCheckResponseParser
Parses spell-checking results from a query response. More...
class | StatsResponseParser
Parses stats results from a query response. More...
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Mapping

  • Package Functions
  • SolrNet
  • Mapping
Packages | Classes

Package SolrNet.Mapping

Packages

package | Validation

Classes

class | AllPropertiesMappingManager
Maps all properties in the class, with the same field name as the property. Note that unique keys must be added manually. More...
class | AttributesMappingManager
Gets mapping info from attributes like SolrFieldAttribute and SolrUniqueKeyAttribute More...
interface | IMappingManager
Mapping manager abstraction. More...
class | MappingManager
Manual mapping manager. More...
class | MemoizingMappingManager
Memoizing decorator for a mapping manager. More...
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Mapping.Validation

  • Package Functions
  • SolrNet
  • Mapping
  • Validation
Packages | Classes

Package SolrNet.Mapping.Validation

Packages

package | Rules

Classes

interface | IMappingValidator
Provides an interface to validation a Solr schema against a type's mapping. More...
class | MappingValidator
Manages the validation of a mapping against a solr schema XML document. More...
class | ValidationError
Represents a Solr schema mapping validation error. More...
class | ValidationResult
Represents a Solr schema mapping validation issue. More...
class | ValidationWarning
Represents a Solr schema mapping validation warning. More...
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Mapping.Validation.Rules

  • Package Functions
  • SolrNet
  • Mapping
  • Validation
  • Rules
Classes

Package SolrNet.Mapping.Validation.Rules

Classes

class | AbstractSolrFieldTypeChecker
Abstract schema type checker. Uses a list of "safe" types and a list of "warning" types. More...
class | BoolSolrFieldTypeChecker
Checks schema type of properties with bool type. More...
class | DateTimeSolrFieldTypeChecker
Checks schema type of properties with DateTime type. More...
class | DecimalSolrFieldTypeChecker
Checks schema type of properties with decimal type. More...
class | DoubleSolrFieldTypeChecker
Checks schema type of properties with double type. More...
class | FloatSolrFieldTypeChecker
Checks schema type of properties with float type. More...
class | IntSolrFieldTypeChecker
Checks schema type of properties with int type. More...
interface | ISolrFieldTypeChecker
Validates a mapped document property against a Solr field type. More...
interface | IValidationRule
Provides a interface to schema mapping validation rules. More...
class | LongSolrFieldTypeChecker
Checks schema type of properties with long type. More...
class | MappedPropertiesIsInSolrSchemaRule
Represents a rule validation that all properties in the mapping are present in the Solr schema as either a SolrField or a DynamicField. More...
class | MappingTypesAreCompatibleWithSolrTypesRule
class | MultivaluedMappedToCollectionRule
Represents a rule that validates that fields mapped to a solr field with mutilvalued set to true are of a type that implements IEnumerable{T}. More...
class | RequiredFieldsAreMappedRule
Represents a rule validating that all SolrFields in the SolrSchema which are required are either present in the mapping or as a CopyField. More...
class | StringSolrFieldTypeChecker
Checks schema type of properties with string type. More...
class | UniqueKeyMatchesMappingRule
Validation rule for making sure the uniqueKey mapped in the type is the same as in the Solr schema. More...
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Schema

  • Package Functions
  • SolrNet
  • Schema
Classes

Package SolrNet.Schema

Classes

interface | ISolrSchemaParser
Provides an interface to parsing a solr schema xml document into a SolrSchema object. More...
class | SolrCopyField
Represents a Solr copy field. More...
class | SolrDynamicField
Represents a Solr dynamic field. More...
class | SolrField
Repesents a field in the Solr schema. More...
class | SolrFieldType
Represents a Solr field type. More...
class | SolrSchema
Represents a Solr schema. More...
class | SolrSchemaParser
Parses a Solr schema xml document into a strongly typed SolrSchema object. More...
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Package SolrNet.Utils

  • Package Functions
  • SolrNet
  • Utils
Classes

Package SolrNet.Utils

Classes

class | Container
Basic built-in dependency-injection container. More...
class | Func
Functional utilities Mostly from http://diditwith.net/PermaLink,guid,a1a76478-03d2-428f-9db6-9cf4e300ea0f.aspx. More...
interface | IContainer
Interface for the built-in DI container. More...
class | Memoizer
Function memoizer From http://blogs.msdn.com/wesdyer/archive/2007/01/26/function-memoization.aspx. More...
class | TypeHelper
Type-related helper functions
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Package StructureMap.SolrNetIntegration.Config

  • Package Functions
  • StructureMap
  • SolrNetIntegration
  • Config
Classes

Package StructureMap.SolrNetIntegration.Config

Classes

class | SolrConfigurationSection
class | SolrServerElement
class | SolrServers
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • Package Functions
  • All
  • Enumerations
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • CollapseFacetMode : SolrNet::Commands::Parameters
  • CollapseType : SolrNet::Commands::Parameters
  • Order : SolrNet
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Class List

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > | Strongly-typed abstract field parser
SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | Abstract schema type checker. Uses a list of "safe" types and a list of "warning" types
SolrNet.AbstractSolrQuery | Abstract Solr query, used to define operator overloading
SolrNet.Commands.AddCommand< T > | Adds / updates documents to solr
SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor | Aggregate document visitor
SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer |
SolrNet.Impl.FieldParsers.AggregateFieldParser | Aggregates ISolrFieldParsers
SolrNet.Impl.FieldSerializers.AggregateFieldSerializer | Aggregates ISolrFieldSerializers
SolrNet.Impl.QuerySerializers.AggregateQuerySerializer |
SolrNet.Mapping.AllPropertiesMappingManager | Maps all properties in the class, with the same field name as the property. Note that unique keys must be added manually
SolrNet.Mapping.AttributesMappingManager | Gets mapping info from attributes like SolrFieldAttribute and SolrUniqueKeyAttribute
SolrNet.Impl.FieldSerializers.BoolFieldSerializer | Parses bool values
SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker | Checks schema type of properties with bool type
SolrNet.Impl.QuerySerializers.BoostQuerySerializer |
NHibernate.SolrNet.CfgHelper | Helper class to configure NHibernate-SolrNet integration
SolrNet.CollapsedDocument | Field collapsing result
SolrNet.Commands.Parameters.CollapseParameters | Parameters to query collapse https://issues.apache.org/jira/browse/SOLR-236
SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > | Parses collapse_counts from query response
SolrNet.CollapseResults | Collapse results
SolrNet.Impl.FieldParsers.CollectionFieldParser | Parses 1-dimensional fields
SolrNet.Impl.FieldSerializers.CollectionFieldSerializer | Serializes 1-dimensional collections
SolrNet.Commands.CommitCommand | Commits updates
SolrNet.Commands.Parameters.CommitOptions | Commit/optimize options
SolrNet.Utils.Container | Basic built-in dependency-injection container
SolrNet.DateFacetingResult | Date faceting result
SolrNet.Impl.FieldParsers.DateTimeFieldParser | Parses datetime fields
SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer | Serializes datetime fields
SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer |
SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker | Checks schema type of properties with DateTime type
SolrNet.Impl.FieldParsers.DecimalFieldParser | Parses decimal fields
SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker | Checks schema type of properties with decimal type
SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor | Default document visitor
SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer |
SolrNet.Impl.FieldParsers.DefaultFieldParser | Default field parser
SolrNet.Impl.FieldSerializers.DefaultFieldSerializer | Aggregates the default ISolrFieldSerializers
SolrNet.Impl.QuerySerializers.DefaultQuerySerializer |
NHibernate.SolrNet.Impl.DelegatingSession |
SolrNet.DSL.Impl.DeleteBy |
SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam | Parameter to delete document(s) by one or more ids and or a query parameters
SolrNet.Commands.DeleteCommand | Deletes document(s), either by id or by query
SolrNet.Impl.FieldParsers.DoubleFieldParser | Parses double fields
SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker | Checks schema type of properties with double type
SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
SolrNet.DSL.Impl.DSLQuery< T > |
SolrNet.DSL.Impl.DSLQueryBetween< T, RT > |
SolrNet.DSL.Impl.DSLQueryBy< T > |
SolrNet.DSL.Impl.DSLQueryRange< T, RT > |
SolrNet.DSL.Impl.DSLRun< T > |
SolrNet.Impl.FieldParsers.EnumFieldParser |
SolrNet.FacetDateOther | Indicates that in addition to the counts for each date range constraint between facet.date.start and facet.date.end, counts should also be computed for other
SolrNet.Commands.Parameters.FacetParameters | Faceting parameters
SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > | Parses facets from query response
SolrNet.DSL.Impl.FieldDefinition |
SolrNet.Impl.FieldParsers.FloatFieldParser | Parses float values
SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker | Checks schema type of properties with float type
SolrNet.Impl.FieldSerializers.FormattableFieldSerializer | Serializes objects that implement IFormattable
SolrNet.Utils.Func | Functional utilities Mostly from http://diditwith.net/PermaLink,guid,a1a76478-03d2-428f-9db6-9cf4e300ea0f.aspx
SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor | Document visitor that handles generic dictionary properties
SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer | Serializes IDictionary{TKey,TValue} properties
SolrNet.Commands.GetSchemaCommand | Gets the raw Solr schema
SolrNet.Impl.FieldParsers.GuidFieldParser |
SolrNet.Impl.QuerySerializers.HasValueQuerySerializer |
SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > | Parses header (status, QTime, etc) from a query response
SolrNet.Commands.Parameters.HighlightingParameters | Highlighting parameters
SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > | Parses highlighting results from a query response
SolrNet.Impl.HttpRuntimeCache | Uses the HttpRuntime (ASP.NET) cache
HttpWebAdapters.Adapters.HttpWebRequestAdapter |
HttpWebAdapters.HttpWebRequestFactory |
HttpWebAdapters.HttpWebRequestMethod |
HttpWebAdapters.Adapters.HttpWebResponseAdapter |
NHibernate.SolrNet.Impl.ICommitSetting |
SolrNet.Utils.IContainer | Interface for the built-in DI container
SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > |
SolrNet.DSL.Impl.IDSLQuery< T > |
SolrNet.DSL.Impl.IDSLQueryBetween< T, RT > |
SolrNet.DSL.Impl.IDSLQueryBy< T > |
SolrNet.DSL.Impl.IDSLQueryRange< T > |
SolrNet.DSL.Impl.IDSLRun< T > |
HttpWebAdapters.IHttpWebRequest |
HttpWebAdapters.IHttpWebRequestFactory |
HttpWebAdapters.IHttpWebResponse |
Rhino.Commons.LocalDataImpl.ILocalData |
SolrNet.Mapping.IMappingManager | Mapping manager abstraction
SolrNet.Mapping.Validation.IMappingValidator | Provides an interface to validation a Solr schema against a type's mapping
SolrNet.Impl.FieldParsers.InferringFieldParser | Parser that infers .net type based on solr type
NHibernate.SolrNet.INHSolrQuery | NHibernate IQuery for SolrNet queries
SolrNet.Impl.FieldParsers.IntFieldParser | Parses int values
SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker | Checks schema type of properties with int type
SolrNet.Exceptions.InvalidFieldException | Solr did not understand one the specified fields
SolrNet.Exceptions.InvalidSortOrderException | Error parsing SortOrder
SolrNet.Exceptions.InvalidURLException | Invalid URL specified
SolrNet.IReadOnlyMappingManager | Service interface for mapping Solr fields to object properties
SolrNet.Impl.ISelfSerializingQuery |
SolrNet.ISolrBasicOperations< T > | Solr operations without convenience overloads
SolrNet.ISolrBasicReadOnlyOperations< T > | Read-only operations without convenience overloads
SolrNet.Impl.ISolrCache | HTTP-level cache for Solr responses
SolrNet.ISolrCommand | Command interface
SolrNet.ISolrConnection | Manages HTTP connection with Solr
SolrNet.Commands.Parameters.ISolrDeleteParam | Delete command parameter
SolrNet.Impl.ISolrDocumentActivator< T > | Instantiates a new document instance of type T
SolrNet.Impl.ISolrDocumentPropertyVisitor | Visits a document with a raw xml Solr response field
SolrNet.Impl.ISolrDocumentResponseParser< T > | Parses documents from query response
SolrNet.ISolrDocumentSerializer< T > | Serializes a solr document to xml
SolrNet.ISolrFacetQuery | Facet query interface
SolrNet.Impl.ISolrFacetQuerySerializer |
SolrNet.Impl.ISolrFieldParser | Parses a single Solr XML result node
SolrNet.Impl.ISolrFieldSerializer | Serializes a value to be consumed by the Solr update handler
SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker | Validates a mapped document property against a Solr field type
SolrNet.Impl.ISolrHeaderResponseParser |
SolrNet.ISolrOperations< T > | Consolidating interface, exposes all operations
SolrNet.ISolrQuery | Base query interface
SolrNet.Impl.ISolrQueryByRange |
SolrNet.ISolrQueryExecuter< T > | Executable query
SolrNet.ISolrQueryResultParser< T > | Query results parser interface
SolrNet.ISolrQueryResults< T > | Query results
SolrNet.Impl.ISolrQuerySerializer |
SolrNet.ISolrReadOnlyOperations< T > | Read-only operations
SolrNet.Impl.ISolrResponseParser< T > | Parses a chunk of a query response
SolrNet.Schema.ISolrSchemaParser | Provides an interface to parsing a solr schema xml document into a SolrSchema object
NHibernate.SolrNet.ISolrSession | NHibernate ISession with SolrNet extensions for querying
SolrNet.Mapping.Validation.Rules.IValidationRule | Provides a interface to schema mapping validation rules
Rhino.Commons.Local |
SolrNet.LocalParams | Provides a way to "localize" information about a specific argument that is being sent to Solr. In other words, it provides a way to add meta-data to certain argument types such as query strings
SolrNet.LocalParams.LocalParamsQuery |
SolrNet.Impl.QuerySerializers.LocalParamsSerializer |
SolrNet.Impl.FieldParsers.LongFieldParser | Parses long fields
SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker | Checks schema type of properties with long type
SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule | Represents a rule validation that all properties in the mapping are present in the Solr schema as either a SolrField or a DynamicField
SolrNet.Mapping.MappingManager | Manual mapping manager
SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule |
SolrNet.Mapping.Validation.MappingValidator | Manages the validation of a mapping against a solr schema XML document
SolrNet.Utils.Memoizer | Function memoizer From http://blogs.msdn.com/wesdyer/archive/2007/01/26/function-memoization.aspx
SolrNet.Mapping.MemoizingMappingManager | Memoizing decorator for a mapping manager
SolrNet.Commands.Parameters.MoreLikeThisParameters | More-like-this parameters See http://wiki.apache.org/solr/MoreLikeThis
SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > | Parses more-like-this results from a query response
SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer |
SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule | Represents a rule that validates that fields mapped to a solr field with mutilvalued set to true are of a type that implements IEnumerable{T}
NHibernate.SolrNet.Impl.NHHelper |
NHibernate.SolrNet.Impl.NHSolrQueryImpl | NHibernate IQuery for SolrNet queries
SolrNet.Impl.QuerySerializers.NotQuerySerializer |
SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer |
SolrNet.Impl.FieldParsers.NullableFieldParser | Wraps a ISolrFieldParser making it support the corresponding Nullable{T} type
SolrNet.Impl.FieldSerializers.NullableFieldSerializer | Wraps a ISolrFieldSerializer making it support the corresponding Nullable{T} type
SolrNet.Impl.NullCache | Cache implementation that doesn't cache anything. Use it when you want to disable http caching
SolrNet.SolrMultipleCriteriaQuery.Operator | Operator to apply to the included queries
SolrNet.Commands.OptimizeCommand | Optimizes Solr's index
SolrNet.Commands.PingCommand | Pings the Solr server. It can be used by a load balancer in front of a set of Solr servers to check response time of all the Solr servers in order to do response time based load balancing
SolrNet.Impl.PropertyNode | Models a XML node for update consumption
SolrNet.Impl.QuerySerializers.QueryByFieldSerializer |
SolrNet.Impl.QuerySerializers.QueryInListSerializer |
SolrNet.Commands.Parameters.QueryOptions | Query options
SolrNet.RandomSortOrder | Random sorting of results Requires Solr 1.3+
SolrNet.DSL.Impl.RangeDefinition< T > |
SolrNet.Impl.QuerySerializers.RangeQuerySerializer |
SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor | Pass-through document visitor
SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule | Represents a rule validating that all SolrFields in the SolrSchema which are required are either present in the mapping or as a CopyField
SolrNet.ResponseHeader | Operation response header
SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > | Parses documents from a query response
SolrNet.Commands.RollbackCommand | Rollbacks all add/deletes made to the index since the last commit
SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer |
SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
SolrNet.Impl.SolrBasicServer< T > | Implements the basic Solr operations
SolrNet.Impl.SolrCacheEntity | HTTP-level Solr cache entry
StructureMap.SolrNetIntegration.Config.SolrConfigurationSection |
SolrNet.Impl.SolrConnection | Manages HTTP connection with Solr
SolrNet.Exceptions.SolrConnectionException | Error connecting to Solr. See inner exception for more information
SolrNet.Schema.SolrCopyField | Represents a Solr copy field
StructureMap.SolrNetIntegration.SolrCore |
Castle.Facilities.SolrNetIntegration.SolrCore | Represents a Solr core for configuration
SolrNet.Impl.SolrDictionaryDocumentResponseParser | Parses a solr result into a dictionary of (string, object)
SolrNet.Impl.SolrDictionarySerializer | Serializes a dictionary document
SolrNet.Impl.SolrDocumentActivator< T > | Creates a new instance of document type T using Activator
SolrNet.Impl.SolrDocumentResponseParser< T > | Parses documents from query response
SolrNet.Impl.SolrDocumentSerializer< T > | Serializes a Solr document to xml
SolrNet.Schema.SolrDynamicField | Represents a Solr dynamic field
SolrNet.SolrFacetDateQuery | Date facet query
SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer |
SolrNet.SolrFacetFieldQuery | Facet field query
SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer |
SolrNet.SolrFacetQuery | Arbitrary facet query
SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer |
SolrNet.Schema.SolrField | Repesents a field in the Solr schema
SolrNet.Attributes.SolrFieldAttribute | Marks a property as present on Solr. By default the field name is the property name
SolrNet.SolrFieldModel | Represents a Solr field mapping. /summary>
SolrNet.Schema.SolrFieldType | Represents a Solr field type
SolrNet.SolrHasValueQuery | Queries documents that have any value in the specified field
SolrNet.SolrMultipleCriteriaQuery | Represents several queries as one
SolrNet.Exceptions.SolrNetException | Base exception for all exceptions thrown by SolrNet
Castle.Facilities.SolrNetIntegration.SolrNetFacility | Configures SolrNet in a Windsor container
NHibernate.SolrNet.Impl.SolrNetListener< T > | NHibernate event listener for updating Solr index
Ninject.Integration.SolrNet.SolrNetModule |
StructureMap.SolrNetIntegration.SolrNetRegistry |
SolrNet.SolrNotQuery | Negates a query
SolrNet.SolrQuery | Basic solr query
SolrNet.SolrQueryBoost | Applies a boost to a query or query fragment
SolrNet.SolrQueryByField | Queries a field for a value
SolrNet.SolrQueryByRange< RT > | Queries a field for a range
SolrNet.Impl.SolrQueryExecuter< T > | Executes queries
SolrNet.SolrQueryInList | Queries a field for a list of possible values
SolrNet.Impl.SolrQueryResultParser< T > | Default query results parser. Parses xml query results
SolrNet.Impl.SolrQueryResults< T > | Query results
SolrNet.Schema.SolrSchema | Represents a Solr schema
SolrNet.Schema.SolrSchemaParser | Parses a Solr schema xml document into a strongly typed SolrSchema object
SolrNet.Impl.SolrServer< T > | Main component to interact with Solr
StructureMap.SolrNetIntegration.Config.SolrServerElement |
StructureMap.SolrNetIntegration.Config.SolrServers |
NHibernate.SolrNet.SolrSession | NHibernate ISession with SolrNet extensions for querying
SolrNet.Attributes.SolrUniqueKeyAttribute | Marks a property as unique key. By default the field name is the property name
SolrNet.SortOrder | Sorting order
SolrNet.Commands.Parameters.SpellCheckingParameters | Spell checking parameters
SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > | Parses spell-checking results from a query response
SolrNet.Impl.SpellCheckResult | Spell-checking results
SolrNet.Impl.SpellCheckResults | Spell-checking query results
SolrNet.Commands.Parameters.StatsParameters | Parameters to query stats
SolrNet.Impl.ResponseParsers.StatsResponseParser< T > | Parses stats results from a query response
SolrNet.StatsResult | Stats results
Castle.Facilities.SolrNetIntegration.StrictArrayResolver |
SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker | Checks schema type of properties with string type
SolrNet.Impl.FieldSerializers.ToStringFieldSerializer | Serializes using .ToString()
SolrNet.Impl.FieldParsers.TypeConvertingFieldParser | Parses using TypeConverter
SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer | Serializes using TypeConverters
SolrNet.Exceptions.TypeNotSupportedException |
SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule | Validation rule for making sure the uniqueKey mapped in the type is the same as in the Solr schema
SolrNet.Mapping.Validation.ValidationError | Represents a Solr schema mapping validation error
SolrNet.Mapping.Validation.ValidationResult | Represents a Solr schema mapping validation issue
SolrNet.Mapping.Validation.ValidationWarning | Represents a Solr schema mapping validation warning
HttpWebAdapters.WebResponseStub |
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

Castle.Facilities.SolrNetIntegration.SolrCore Member List

This is the complete list of members for Castle.Facilities.SolrNetIntegration.SolrCore, including all inherited members.
DocumentType (defined in Castle.Facilities.SolrNetIntegration.SolrCore) | Castle.Facilities.SolrNetIntegration.SolrCore
Id (defined in Castle.Facilities.SolrNetIntegration.SolrCore) | Castle.Facilities.SolrNetIntegration.SolrCore
SolrCore(string id, Type documentType, string url) | Castle.Facilities.SolrNetIntegration.SolrCore
SolrCore(Type documentType, string url) | Castle.Facilities.SolrNetIntegration.SolrCore
Url (defined in Castle.Facilities.SolrNetIntegration.SolrCore) | Castle.Facilities.SolrNetIntegration.SolrCore
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

Castle.Facilities.SolrNetIntegration.SolrNetFacility Member List

This is the complete list of members for Castle.Facilities.SolrNetIntegration.SolrNetFacility, including all inherited members.
AddCore(Type documentType, string coreUrl) | Castle.Facilities.SolrNetIntegration.SolrNetFacility |
AddCore(string coreId, Type documentType, string coreUrl) | Castle.Facilities.SolrNetIntegration.SolrNetFacility |
Init() (defined in Castle.Facilities.SolrNetIntegration.SolrNetFacility) | Castle.Facilities.SolrNetIntegration.SolrNetFacility | [protected]
Mapper | Castle.Facilities.SolrNetIntegration.SolrNetFacility |
SolrNetFacility() (defined in Castle.Facilities.SolrNetIntegration.SolrNetFacility) | Castle.Facilities.SolrNetIntegration.SolrNetFacility |
SolrNetFacility(string solrURL) (defined in Castle.Facilities.SolrNetIntegration.SolrNetFacility) | Castle.Facilities.SolrNetIntegration.SolrNetFacility |
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

Castle.Facilities.SolrNetIntegration.StrictArrayResolver Member List

This is the complete list of members for Castle.Facilities.SolrNetIntegration.StrictArrayResolver, including all inherited members.
CanResolve(CreationContext context, ISubDependencyResolver contextHandlerResolver, ComponentModel model, DependencyModel dependency) (defined in Castle.Facilities.SolrNetIntegration.StrictArrayResolver) | Castle.Facilities.SolrNetIntegration.StrictArrayResolver
Resolve(CreationContext context, ISubDependencyResolver contextHandlerResolver, ComponentModel model, DependencyModel dependency) (defined in Castle.Facilities.SolrNetIntegration.StrictArrayResolver) | Castle.Facilities.SolrNetIntegration.StrictArrayResolver
StrictArrayResolver(IKernel kernel) (defined in Castle.Facilities.SolrNetIntegration.StrictArrayResolver) | Castle.Facilities.SolrNetIntegration.StrictArrayResolver
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.Adapters.HttpWebRequestAdapter Member List

This is the complete list of members for HttpWebAdapters.Adapters.HttpWebRequestAdapter, including all inherited members.
Abort() | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Accept | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AddRange(int from, int to) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AddRange(int range) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AddRange(string rangeSpecifier, int from, int to) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AddRange(string rangeSpecifier, int range) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Address | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AllowAutoRedirect | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AllowWriteStreamBuffering | HttpWebAdapters.Adapters.HttpWebRequestAdapter
AutomaticDecompression | HttpWebAdapters.Adapters.HttpWebRequestAdapter
BeginGetRequestStream(AsyncCallback callback, object state) (defined in HttpWebAdapters.Adapters.HttpWebRequestAdapter) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
BeginGetResponse(AsyncCallback callback, object state) (defined in HttpWebAdapters.Adapters.HttpWebRequestAdapter) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ClientCertificates | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Connection | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ConnectionGroupName | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ContentLength | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ContentType | HttpWebAdapters.Adapters.HttpWebRequestAdapter
CookieContainer | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Credentials | HttpWebAdapters.Adapters.HttpWebRequestAdapter
EndGetRequestStream(IAsyncResult result) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
EndGetResponse(IAsyncResult result) (defined in HttpWebAdapters.Adapters.HttpWebRequestAdapter) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Expect | HttpWebAdapters.Adapters.HttpWebRequestAdapter
GetRequestStream() | HttpWebAdapters.Adapters.HttpWebRequestAdapter
GetResponse() (defined in HttpWebAdapters.Adapters.HttpWebRequestAdapter) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
HaveResponse | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Headers | HttpWebAdapters.Adapters.HttpWebRequestAdapter
HttpWebRequestAdapter(HttpWebRequest request) (defined in HttpWebAdapters.Adapters.HttpWebRequestAdapter) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
IfModifiedSince | HttpWebAdapters.Adapters.HttpWebRequestAdapter
KeepAlive | HttpWebAdapters.Adapters.HttpWebRequestAdapter
MaximumAutomaticRedirections | HttpWebAdapters.Adapters.HttpWebRequestAdapter
MaximumResponseHeadersLength | HttpWebAdapters.Adapters.HttpWebRequestAdapter
MediaType | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Method (defined in HttpWebAdapters.Adapters.HttpWebRequestAdapter) | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Pipelined | HttpWebAdapters.Adapters.HttpWebRequestAdapter
PreAuthenticate | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ProtocolVersion | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Proxy | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ReadWriteTimeout | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Referer | HttpWebAdapters.Adapters.HttpWebRequestAdapter
RequestUri | HttpWebAdapters.Adapters.HttpWebRequestAdapter
SendChunked | HttpWebAdapters.Adapters.HttpWebRequestAdapter
ServicePoint | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Timeout | HttpWebAdapters.Adapters.HttpWebRequestAdapter
TransferEncoding | HttpWebAdapters.Adapters.HttpWebRequestAdapter
UnsafeAuthenticatedConnectionSharing | HttpWebAdapters.Adapters.HttpWebRequestAdapter
UseDefaultCredentials | HttpWebAdapters.Adapters.HttpWebRequestAdapter
UserAgent | HttpWebAdapters.Adapters.HttpWebRequestAdapter
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.Adapters.HttpWebResponseAdapter Member List

This is the complete list of members for HttpWebAdapters.Adapters.HttpWebResponseAdapter, including all inherited members.
CharacterSet | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Close() | HttpWebAdapters.Adapters.HttpWebResponseAdapter
ContentEncoding | HttpWebAdapters.Adapters.HttpWebResponseAdapter
ContentLength | HttpWebAdapters.Adapters.HttpWebResponseAdapter
ContentType | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Cookies | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Dispose() | HttpWebAdapters.Adapters.HttpWebResponseAdapter
GetResponseHeader(string headerName) | HttpWebAdapters.Adapters.HttpWebResponseAdapter
GetResponseStream() | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Headers | HttpWebAdapters.Adapters.HttpWebResponseAdapter
HttpWebResponseAdapter(WebResponse response) (defined in HttpWebAdapters.Adapters.HttpWebResponseAdapter) | HttpWebAdapters.Adapters.HttpWebResponseAdapter
IsFromCache | HttpWebAdapters.Adapters.HttpWebResponseAdapter
IsMutuallyAuthenticated | HttpWebAdapters.Adapters.HttpWebResponseAdapter
LastModified | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Method | HttpWebAdapters.Adapters.HttpWebResponseAdapter
ProtocolVersion | HttpWebAdapters.Adapters.HttpWebResponseAdapter
ResponseUri | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Server | HttpWebAdapters.Adapters.HttpWebResponseAdapter
StatusCode | HttpWebAdapters.Adapters.HttpWebResponseAdapter
StatusDescription | HttpWebAdapters.Adapters.HttpWebResponseAdapter
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.HttpWebRequestFactory Member List

This is the complete list of members for HttpWebAdapters.HttpWebRequestFactory, including all inherited members.
Create(string url) (defined in HttpWebAdapters.HttpWebRequestFactory) | HttpWebAdapters.HttpWebRequestFactory
Create(Uri url) (defined in HttpWebAdapters.HttpWebRequestFactory) | HttpWebAdapters.HttpWebRequestFactory
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.HttpWebRequestMethod Member List

This is the complete list of members for HttpWebAdapters.HttpWebRequestMethod, including all inherited members.
GET (defined in HttpWebAdapters.HttpWebRequestMethod) | HttpWebAdapters.HttpWebRequestMethod | [static]
Parse(string s) (defined in HttpWebAdapters.HttpWebRequestMethod) | HttpWebAdapters.HttpWebRequestMethod | [static]
POST (defined in HttpWebAdapters.HttpWebRequestMethod) | HttpWebAdapters.HttpWebRequestMethod | [static]
ToString() (defined in HttpWebAdapters.HttpWebRequestMethod) | HttpWebAdapters.HttpWebRequestMethod |
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.WebResponseStub Member List

This is the complete list of members for HttpWebAdapters.WebResponseStub, including all inherited members.
CharacterSet | HttpWebAdapters.WebResponseStub
Close() | HttpWebAdapters.IHttpWebResponse
ContentEncoding | HttpWebAdapters.WebResponseStub
ContentLength | HttpWebAdapters.IHttpWebResponse
ContentType | HttpWebAdapters.IHttpWebResponse
Cookies | HttpWebAdapters.WebResponseStub
GetResponseHeader(string headerName) | HttpWebAdapters.WebResponseStub
GetResponseStream() | HttpWebAdapters.IHttpWebResponse
Headers | HttpWebAdapters.IHttpWebResponse
IsFromCache | HttpWebAdapters.IHttpWebResponse
IsMutuallyAuthenticated | HttpWebAdapters.IHttpWebResponse
LastModified | HttpWebAdapters.WebResponseStub
Method | HttpWebAdapters.WebResponseStub
ProtocolVersion | HttpWebAdapters.WebResponseStub
ResponseUri | HttpWebAdapters.IHttpWebResponse
Server | HttpWebAdapters.WebResponseStub
StatusCode | HttpWebAdapters.WebResponseStub
StatusDescription | HttpWebAdapters.WebResponseStub
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.CfgHelper Member List

This is the complete list of members for NHibernate.SolrNet.CfgHelper, including all inherited members.
CfgHelper(IReadOnlyMappingManager mapper, IServiceProvider provider) | NHibernate.SolrNet.CfgHelper
CfgHelper(IServiceProvider provider) | NHibernate.SolrNet.CfgHelper
CfgHelper() | NHibernate.SolrNet.CfgHelper
Configure(Configuration config, bool autoCommit) | NHibernate.SolrNet.CfgHelper
OpenSession(ISession session) | NHibernate.SolrNet.CfgHelper
OpenSession(ISessionFactory sessionFactory) | NHibernate.SolrNet.CfgHelper
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.Impl.DelegatingSession Member List

This is the complete list of members for NHibernate.SolrNet.Impl.DelegatingSession, including all inherited members.
ActiveEntityMode (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
BeginTransaction() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
BeginTransaction(IsolationLevel isolationLevel) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CacheMode (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CancelQuery() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Clear() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Close() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Connection (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Contains(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(System.Type persistentClass) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(System.Type persistentClass, string alias) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(string entityName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(string entityName, string alias) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria< T >() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria< T >(string alias) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateFilter(object collection, string queryString) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateMultiCriteria() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateMultiQuery() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateQuery(string queryString) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateSQLQuery(string sql, string returnAlias, System.Type returnClass) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateSQLQuery(string sql, string[] returnAliases, System.Type[] returnClasses) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateSQLQuery(string queryString) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
DelegatingSession(ISession session) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string query) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string query, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string query, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
DisableFilter(string filterName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Disconnect() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Dispose() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
EnableFilter(string filterName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Enumerable(string query) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Enumerable(string query, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Enumerable(string query, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Evict(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Filter(object collection, string filter) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Filter(object collection, string filter, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Filter(object collection, string filter, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Find(string query) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Find(string query, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Find(string query, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Flush() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
FlushMode (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get(System.Type clazz, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get(System.Type clazz, object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get(string entityName, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get< T >(object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get< T >(object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetCurrentLockMode(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetEnabledFilter(string filterName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetEntityName(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetIdentifier(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetNamedQuery(string queryName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetSession(EntityMode entityMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetSessionImplementation() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
IsConnected (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
IsDirty() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
IsOpen (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(System.Type theType, object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(string entityName, object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(System.Type theType, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(string entityName, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load< T >(object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load< T >(object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Lock(object obj, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Lock(string entityName, object obj, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Merge(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Merge(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Persist(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Persist(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Reconnect() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Reconnect(IDbConnection connection) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Refresh(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Refresh(object obj, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Replicate(object obj, ReplicationMode replicationMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Replicate(string entityName, object obj, ReplicationMode replicationMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Save(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Save(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Save(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdate(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdate(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdateCopy(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdateCopy(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SessionFactory (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SetBatchSize(int batchSize) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Statistics (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Transaction (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Update(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Update(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Update(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.Impl.NHHelper Member List

This is the complete list of members for NHibernate.SolrNet.Impl.NHHelper, including all inherited members.
AppendToArray(Array currentListeners, object listener) (defined in NHibernate.SolrNet.Impl.NHHelper) | NHibernate.SolrNet.Impl.NHHelper | [static]
SetListener(Configuration config, object listener) (defined in NHibernate.SolrNet.Impl.NHHelper) | NHibernate.SolrNet.Impl.NHHelper | [static]
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.Impl.NHSolrQueryImpl Member List

This is the complete list of members for NHibernate.SolrNet.Impl.NHSolrQueryImpl, including all inherited members.
Enumerable() | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
Enumerable< T >() | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
ExecuteUpdate() | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
List() | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
List(IList results) | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
List< T >() | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
LockModes | NHibernate.SolrNet.Impl.NHSolrQueryImpl | [protected]
NHSolrQueryImpl(IServiceProvider provider, string queryString, FlushMode flushMode, ISessionImplementor session, ParameterMetadata parameterMetadata) (defined in NHibernate.SolrNet.Impl.NHSolrQueryImpl) | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
SetFirstResult(int firstResult) | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
SetLockMode(string alias, LockMode lockMode) | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
SetMaxResults(int maxResults) | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
SetSort(Order o) | NHibernate.SolrNet.Impl.NHSolrQueryImpl |
NHibernate::SolrNet::INHSolrQuery.SetSort(Order o) | NHibernate.SolrNet.INHSolrQuery |
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.Impl.SolrNetListener< T > Member List

This is the complete list of members for NHibernate.SolrNet.Impl.SolrNetListener< T >, including all inherited members.
Commit | NHibernate.SolrNet.Impl.SolrNetListener< T > |
DeferAction(IEventSource e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
DoWithEntities(WeakHashtable entities, ITransaction s, Action< T > action) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
OnAutoFlush(AutoFlushEvent e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
OnFlush(FlushEvent e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
OnFlushInternal(AbstractEvent e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
OnPostDelete(PostDeleteEvent e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > | [virtual]
OnPostInsert(PostInsertEvent e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > | [virtual]
OnPostUpdate(PostUpdateEvent e) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > | [virtual]
SolrNetListener(ISolrOperations< T > solr) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
UpdateInternal(AbstractEvent e, T entity) (defined in NHibernate.SolrNet.Impl.SolrNetListener< T >) | NHibernate.SolrNet.Impl.SolrNetListener< T > |
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.SolrSession Member List

This is the complete list of members for NHibernate.SolrNet.SolrSession, including all inherited members.
ActiveEntityMode (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
BeginTransaction() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
BeginTransaction(IsolationLevel isolationLevel) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CacheMode (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CancelQuery() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Clear() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Close() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Connection (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Contains(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(System.Type persistentClass) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(System.Type persistentClass, string alias) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(string entityName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria(string entityName, string alias) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria< T >() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateCriteria< T >(string alias) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateFilter(object collection, string queryString) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateMultiCriteria() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateMultiQuery() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateQuery(string queryString) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateSolrQuery(string query) | NHibernate.SolrNet.SolrSession
CreateSolrQuery(ISolrQuery query) | NHibernate.SolrNet.SolrSession
CreateSQLQuery(string sql, string returnAlias, System.Type returnClass) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateSQLQuery(string sql, string[] returnAliases, System.Type[] returnClasses) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
CreateSQLQuery(string queryString) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
DelegatingSession(ISession session) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string query) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string query, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Delete(string query, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
DisableFilter(string filterName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Disconnect() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Dispose() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
EnableFilter(string filterName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Enumerable(string query) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Enumerable(string query, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Enumerable(string query, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Evict(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Filter(object collection, string filter) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Filter(object collection, string filter, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Filter(object collection, string filter, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Find(string query) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Find(string query, object value, IType type) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Find(string query, object[] values, IType[] types) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Flush() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
FlushMode (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get(System.Type clazz, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get(System.Type clazz, object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get(string entityName, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get< T >(object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Get< T >(object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetCurrentLockMode(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetEnabledFilter(string filterName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetEntityName(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetIdentifier(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetNamedQuery(string queryName) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetSession(EntityMode entityMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
GetSessionImplementation() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
IsConnected (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
IsDirty() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
IsOpen (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(System.Type theType, object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(string entityName, object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(System.Type theType, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(string entityName, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load< T >(object id, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Load< T >(object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Lock(object obj, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Lock(string entityName, object obj, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Merge(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Merge(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Persist(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Persist(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Reconnect() (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Reconnect(IDbConnection connection) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Refresh(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Refresh(object obj, LockMode lockMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Replicate(object obj, ReplicationMode replicationMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Replicate(string entityName, object obj, ReplicationMode replicationMode) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Save(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Save(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Save(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdate(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdate(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdateCopy(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SaveOrUpdateCopy(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SessionFactory (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SetBatchSize(int batchSize) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
SolrSession(ISession session) | NHibernate.SolrNet.SolrSession
SolrSession(ISession session, IServiceProvider provider) | NHibernate.SolrNet.SolrSession
Statistics (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Transaction (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Update(object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Update(object obj, object id) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Update(string entityName, object obj) (defined in NHibernate.SolrNet.Impl.DelegatingSession) | NHibernate.SolrNet.Impl.DelegatingSession
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

Ninject.Integration.SolrNet.SolrNetModule Member List

This is the complete list of members for Ninject.Integration.SolrNet.SolrNetModule, including all inherited members.
Load() (defined in Ninject.Integration.SolrNet.SolrNetModule) | Ninject.Integration.SolrNet.SolrNetModule
Mapper (defined in Ninject.Integration.SolrNet.SolrNetModule) | Ninject.Integration.SolrNet.SolrNetModule
SolrNetModule(string serverURL) (defined in Ninject.Integration.SolrNet.SolrNetModule) | Ninject.Integration.SolrNet.SolrNetModule
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

Rhino.Commons.Local Member List

This is the complete list of members for Rhino.Commons.Local, including all inherited members.
Data (defined in Rhino.Commons.Local) | Rhino.Commons.Local | [static]
RunningInWeb (defined in Rhino.Commons.Local) | Rhino.Commons.Local | [static]
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.AbstractSolrQuery Member List

This is the complete list of members for SolrNet.AbstractSolrQuery, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Attributes.SolrFieldAttribute Member List

This is the complete list of members for SolrNet.Attributes.SolrFieldAttribute, including all inherited members.
Boost | SolrNet.Attributes.SolrFieldAttribute
FieldName | SolrNet.Attributes.SolrFieldAttribute
SolrFieldAttribute() | SolrNet.Attributes.SolrFieldAttribute
SolrFieldAttribute(string fieldName) | SolrNet.Attributes.SolrFieldAttribute
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Attributes.SolrUniqueKeyAttribute Member List

This is the complete list of members for SolrNet.Attributes.SolrUniqueKeyAttribute, including all inherited members.
Boost | SolrNet.Attributes.SolrFieldAttribute
FieldName | SolrNet.Attributes.SolrFieldAttribute
SolrFieldAttribute() | SolrNet.Attributes.SolrFieldAttribute
SolrFieldAttribute(string fieldName) | SolrNet.Attributes.SolrFieldAttribute
SolrUniqueKeyAttribute() | SolrNet.Attributes.SolrUniqueKeyAttribute
SolrUniqueKeyAttribute(string fieldName) | SolrNet.Attributes.SolrUniqueKeyAttribute
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.CollapseResults Member List

This is the complete list of members for SolrNet.CollapseResults, including all inherited members.
CollapsedDocuments | SolrNet.CollapseResults
CollapseResults() (defined in SolrNet.CollapseResults) | SolrNet.CollapseResults
Field | SolrNet.CollapseResults
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.CollapsedDocument Member List

This is the complete list of members for SolrNet.CollapsedDocument, including all inherited members.
CollapseCount | SolrNet.CollapsedDocument
FieldValue (defined in SolrNet.CollapsedDocument) | SolrNet.CollapsedDocument
Id | SolrNet.CollapsedDocument
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.AddCommand< T > Member List

This is the complete list of members for SolrNet.Commands.AddCommand< T >, including all inherited members.
AddCommand(IEnumerable< KeyValuePair< T, double?>> documents, ISolrDocumentSerializer< T > serializer) (defined in SolrNet.Commands.AddCommand< T >) | SolrNet.Commands.AddCommand< T >
ConvertToXml() (defined in SolrNet.Commands.AddCommand< T >) | SolrNet.Commands.AddCommand< T >
Execute(ISolrConnection connection) | SolrNet.Commands.AddCommand< T >
RemoveControlCharacters(string xml) | SolrNet.Commands.AddCommand< T >
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.CommitCommand Member List

This is the complete list of members for SolrNet.Commands.CommitCommand, including all inherited members.
Execute(ISolrConnection connection) | SolrNet.Commands.CommitCommand
ExpungeDeletes | SolrNet.Commands.CommitCommand
MaxSegments | SolrNet.Commands.CommitCommand
WaitFlush | SolrNet.Commands.CommitCommand
WaitSearcher | SolrNet.Commands.CommitCommand
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.DeleteCommand Member List

This is the complete list of members for SolrNet.Commands.DeleteCommand, including all inherited members.
DeleteCommand(ISolrDeleteParam deleteParam) (defined in SolrNet.Commands.DeleteCommand) | SolrNet.Commands.DeleteCommand
DeleteParam (defined in SolrNet.Commands.DeleteCommand) | SolrNet.Commands.DeleteCommand
Execute(ISolrConnection connection) | SolrNet.Commands.DeleteCommand
FromCommitted | SolrNet.Commands.DeleteCommand
FromPending | SolrNet.Commands.DeleteCommand
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.GetSchemaCommand Member List

This is the complete list of members for SolrNet.Commands.GetSchemaCommand, including all inherited members.
Execute(ISolrConnection connection) SolrNet.Commands.GetSchemaCommand
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.OptimizeCommand Member List

This is the complete list of members for SolrNet.Commands.OptimizeCommand, including all inherited members.
Execute(ISolrConnection connection) | SolrNet.Commands.OptimizeCommand
ExpungeDeletes | SolrNet.Commands.OptimizeCommand
MaxSegments | SolrNet.Commands.OptimizeCommand
WaitFlush | SolrNet.Commands.OptimizeCommand
WaitSearcher | SolrNet.Commands.OptimizeCommand
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.CollapseParameters Member List

This is the complete list of members for SolrNet.Commands.Parameters.CollapseParameters, including all inherited members.
CollapseParameters(string field) (defined in SolrNet.Commands.Parameters.CollapseParameters) | SolrNet.Commands.Parameters.CollapseParameters
FacetMode | SolrNet.Commands.Parameters.CollapseParameters
Field | SolrNet.Commands.Parameters.CollapseParameters
MaxDocs | SolrNet.Commands.Parameters.CollapseParameters
Threshold | SolrNet.Commands.Parameters.CollapseParameters
Type | SolrNet.Commands.Parameters.CollapseParameters
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.CommitOptions Member List

This is the complete list of members for SolrNet.Commands.Parameters.CommitOptions, including all inherited members.
CommitOptions() | SolrNet.Commands.Parameters.CommitOptions
ExpungeDeletes | SolrNet.Commands.Parameters.CommitOptions
MaxSegments | SolrNet.Commands.Parameters.CommitOptions
WaitFlush | SolrNet.Commands.Parameters.CommitOptions
WaitSearcher | SolrNet.Commands.Parameters.CommitOptions
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam Member List

This is the complete list of members for SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam, including all inherited members.
DeleteByIdAndOrQueryParam(IEnumerable< string > ids, ISolrQuery query, ISolrQuerySerializer querySerializer) (defined in SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam) | SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam
ToXmlNode() | SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.FacetParameters Member List

This is the complete list of members for SolrNet.Commands.Parameters.FacetParameters, including all inherited members.
EnumCacheMinDf | SolrNet.Commands.Parameters.FacetParameters
FacetParameters() (defined in SolrNet.Commands.Parameters.FacetParameters) | SolrNet.Commands.Parameters.FacetParameters
Limit | SolrNet.Commands.Parameters.FacetParameters
MinCount | SolrNet.Commands.Parameters.FacetParameters
Missing | SolrNet.Commands.Parameters.FacetParameters
Offset | SolrNet.Commands.Parameters.FacetParameters
Prefix | SolrNet.Commands.Parameters.FacetParameters
Queries | SolrNet.Commands.Parameters.FacetParameters
Sort | SolrNet.Commands.Parameters.FacetParameters
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.HighlightingParameters Member List

This is the complete list of members for SolrNet.Commands.Parameters.HighlightingParameters, including all inherited members.
AfterTerm | SolrNet.Commands.Parameters.HighlightingParameters
AlternateField | SolrNet.Commands.Parameters.HighlightingParameters
BeforeTerm | SolrNet.Commands.Parameters.HighlightingParameters
Fields | SolrNet.Commands.Parameters.HighlightingParameters
Fragsize | SolrNet.Commands.Parameters.HighlightingParameters
RegexMaxAnalyzedChars | SolrNet.Commands.Parameters.HighlightingParameters
RegexPattern | SolrNet.Commands.Parameters.HighlightingParameters
RegexSlop | SolrNet.Commands.Parameters.HighlightingParameters
RequireFieldMatch | SolrNet.Commands.Parameters.HighlightingParameters
Snippets | SolrNet.Commands.Parameters.HighlightingParameters
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.MoreLikeThisParameters Member List

This is the complete list of members for SolrNet.Commands.Parameters.MoreLikeThisParameters, including all inherited members.
Boost | SolrNet.Commands.Parameters.MoreLikeThisParameters
Count | SolrNet.Commands.Parameters.MoreLikeThisParameters
Fields | SolrNet.Commands.Parameters.MoreLikeThisParameters
MaxQueryTerms | SolrNet.Commands.Parameters.MoreLikeThisParameters
MaxTokens | SolrNet.Commands.Parameters.MoreLikeThisParameters
MaxWordLength | SolrNet.Commands.Parameters.MoreLikeThisParameters
MinDocFreq | SolrNet.Commands.Parameters.MoreLikeThisParameters
MinTermFreq | SolrNet.Commands.Parameters.MoreLikeThisParameters
MinWordLength | SolrNet.Commands.Parameters.MoreLikeThisParameters
MoreLikeThisParameters(IEnumerable< string > fields) | SolrNet.Commands.Parameters.MoreLikeThisParameters
QueryFields | SolrNet.Commands.Parameters.MoreLikeThisParameters
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.QueryOptions Member List

This is the complete list of members for SolrNet.Commands.Parameters.QueryOptions, including all inherited members.
AddFacets(params ISolrFacetQuery[] queries) (defined in SolrNet.Commands.Parameters.QueryOptions) | SolrNet.Commands.Parameters.QueryOptions
AddFields(params string[] fields) (defined in SolrNet.Commands.Parameters.QueryOptions) | SolrNet.Commands.Parameters.QueryOptions
AddFilterQueries(params ISolrQuery[] queries) (defined in SolrNet.Commands.Parameters.QueryOptions) | SolrNet.Commands.Parameters.QueryOptions
AddOrder(params SortOrder[] order) (defined in SolrNet.Commands.Parameters.QueryOptions) | SolrNet.Commands.Parameters.QueryOptions
Collapse | SolrNet.Commands.Parameters.QueryOptions
ExtraParams | SolrNet.Commands.Parameters.QueryOptions
Facet | SolrNet.Commands.Parameters.QueryOptions
Fields | SolrNet.Commands.Parameters.QueryOptions
FilterQueries | SolrNet.Commands.Parameters.QueryOptions
Highlight | SolrNet.Commands.Parameters.QueryOptions
MoreLikeThis | SolrNet.Commands.Parameters.QueryOptions
OrderBy | SolrNet.Commands.Parameters.QueryOptions
QueryOptions() (defined in SolrNet.Commands.Parameters.QueryOptions) | SolrNet.Commands.Parameters.QueryOptions
Rows | SolrNet.Commands.Parameters.QueryOptions
SpellCheck | SolrNet.Commands.Parameters.QueryOptions
Start | SolrNet.Commands.Parameters.QueryOptions
Stats | SolrNet.Commands.Parameters.QueryOptions
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.SpellCheckingParameters Member List

This is the complete list of members for SolrNet.Commands.Parameters.SpellCheckingParameters, including all inherited members.
Build | SolrNet.Commands.Parameters.SpellCheckingParameters
Collate | SolrNet.Commands.Parameters.SpellCheckingParameters
Count | SolrNet.Commands.Parameters.SpellCheckingParameters
Dictionary | SolrNet.Commands.Parameters.SpellCheckingParameters
OnlyMorePopular | SolrNet.Commands.Parameters.SpellCheckingParameters
Query | SolrNet.Commands.Parameters.SpellCheckingParameters
Reload | SolrNet.Commands.Parameters.SpellCheckingParameters
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.StatsParameters Member List

This is the complete list of members for SolrNet.Commands.Parameters.StatsParameters, including all inherited members.
AddFacet(string facet) | SolrNet.Commands.Parameters.StatsParameters
AddField(string field) | SolrNet.Commands.Parameters.StatsParameters
AddFieldWithFacet(string field, string facet) | SolrNet.Commands.Parameters.StatsParameters
AddFieldWithFacets(string field, IEnumerable< string > facets) | SolrNet.Commands.Parameters.StatsParameters
AddFieldWithFacets(string field, params string[] facets) | SolrNet.Commands.Parameters.StatsParameters
Facets | SolrNet.Commands.Parameters.StatsParameters
FieldsWithFacets | SolrNet.Commands.Parameters.StatsParameters
StatsParameters() (defined in SolrNet.Commands.Parameters.StatsParameters) | SolrNet.Commands.Parameters.StatsParameters
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.PingCommand Member List

This is the complete list of members for SolrNet.Commands.PingCommand, including all inherited members.
Execute(ISolrConnection connection) SolrNet.Commands.PingCommand
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.RollbackCommand Member List

This is the complete list of members for SolrNet.Commands.RollbackCommand, including all inherited members.
Execute(ISolrConnection connection) SolrNet.Commands.RollbackCommand
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DSLFacetFieldOptions< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.DSLFacetFieldOptions< T >, including all inherited members.
connection (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
DontSortByCount() | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
DSLFacetFieldOptions(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, SolrFacetFieldQuery facetQuery) (defined in SolrNet.DSL.Impl.DSLFacetFieldOptions< T >) | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
DSLRun(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, HighlightingParameters highlight) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
facets (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
highlight (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
IncludeMissing() | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
LimitTo(int limit) | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
order (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
query (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
Run() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Run(int start, int rows) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
StartingAt(int offset) | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
ToString() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(string q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(ISolrQuery q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithMinCount(int count) | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
WithPrefix(string prefix) | SolrNet.DSL.Impl.DSLFacetFieldOptions< T > |
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DSLQuery< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.DSLQuery< T >, including all inherited members.
By(string fieldName) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
ByRange< RT >(string fieldName, RT from, RT to) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
connection (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
DSLQuery(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
DSLQuery(ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
DSLRun(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, HighlightingParameters highlight) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
facets (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
highlight (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
order (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
query (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
Run() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Run(int start, int rows) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
ToString() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(string q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(ISolrQuery q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DSLQueryBetween< T, RT > Member List

This is the complete list of members for SolrNet.DSL.Impl.DSLQueryBetween< T, RT >, including all inherited members.
And(RT i) (defined in SolrNet.DSL.Impl.DSLQueryBetween< T, RT >) | SolrNet.DSL.Impl.DSLQueryBetween< T, RT >
DSLQueryBetween(string fieldName, ISolrConnection connection, ISolrQuery query, RT from) (defined in SolrNet.DSL.Impl.DSLQueryBetween< T, RT >) | SolrNet.DSL.Impl.DSLQueryBetween< T, RT >
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DSLQueryBy< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.DSLQueryBy< T >, including all inherited members.
Between< RT >(RT i) (defined in SolrNet.DSL.Impl.DSLQueryBy< T >) | SolrNet.DSL.Impl.DSLQueryBy< T >
DSLQueryBy(string fieldName, ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLQueryBy< T >) | SolrNet.DSL.Impl.DSLQueryBy< T >
Is(string s) (defined in SolrNet.DSL.Impl.DSLQueryBy< T >) | SolrNet.DSL.Impl.DSLQueryBy< T >
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DSLQueryRange< T, RT > Member List

This is the complete list of members for SolrNet.DSL.Impl.DSLQueryRange< T, RT >, including all inherited members.
By(string fieldName) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
ByRange< RT >(string fieldName, RT from, RT to) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
connection (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
DSLQuery(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
DSLQuery(ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLQuery< T >) | SolrNet.DSL.Impl.DSLQuery< T > |
DSLQueryRange(ISolrConnection connection, ISolrQuery query, string fieldName, RT from, RT to) (defined in SolrNet.DSL.Impl.DSLQueryRange< T, RT >) | SolrNet.DSL.Impl.DSLQueryRange< T, RT > |
DSLRun(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, HighlightingParameters highlight) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Exclusive() (defined in SolrNet.DSL.Impl.DSLQueryRange< T, RT >) | SolrNet.DSL.Impl.DSLQueryRange< T, RT > |
facets (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
highlight (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
Inclusive() (defined in SolrNet.DSL.Impl.DSLQueryRange< T, RT >) | SolrNet.DSL.Impl.DSLQueryRange< T, RT > |
order (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
query (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
Run() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Run(int start, int rows) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
ToString() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(string q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(ISolrQuery q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DSLRun< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.DSLRun< T >, including all inherited members.
connection (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
DSLRun(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
DSLRun(ISolrConnection connection, ISolrQuery query, ICollection< SortOrder > order, ICollection< ISolrFacetQuery > facets, HighlightingParameters highlight) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
facets (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
highlight (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
order (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
query (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > | [protected]
Run() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Run(int start, int rows) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
ToString() (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(string q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithFacetQuery(ISolrQuery q) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.DSLRun< T >) | SolrNet.DSL.Impl.DSLRun< T > |
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.DeleteBy Member List

This is the complete list of members for SolrNet.DSL.Impl.DeleteBy, including all inherited members.
ById(string id) (defined in SolrNet.DSL.Impl.DeleteBy) | SolrNet.DSL.Impl.DeleteBy
ByIds(IEnumerable< string > ids) (defined in SolrNet.DSL.Impl.DeleteBy) | SolrNet.DSL.Impl.DeleteBy
ByQuery(ISolrQuery q) (defined in SolrNet.DSL.Impl.DeleteBy) | SolrNet.DSL.Impl.DeleteBy
ByQuery(string q) (defined in SolrNet.DSL.Impl.DeleteBy) | SolrNet.DSL.Impl.DeleteBy
DeleteBy(ISolrConnection connection) (defined in SolrNet.DSL.Impl.DeleteBy) | SolrNet.DSL.Impl.DeleteBy
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.FieldDefinition Member List

This is the complete list of members for SolrNet.DSL.Impl.FieldDefinition, including all inherited members.
FieldDefinition(string fieldName) (defined in SolrNet.DSL.Impl.FieldDefinition) | SolrNet.DSL.Impl.FieldDefinition
From< T >(T from) (defined in SolrNet.DSL.Impl.FieldDefinition) | SolrNet.DSL.Impl.FieldDefinition
HasAnyValue() (defined in SolrNet.DSL.Impl.FieldDefinition) | SolrNet.DSL.Impl.FieldDefinition
In< T >(params T[] values) (defined in SolrNet.DSL.Impl.FieldDefinition) | SolrNet.DSL.Impl.FieldDefinition
Is< T >(T value) (defined in SolrNet.DSL.Impl.FieldDefinition) | SolrNet.DSL.Impl.FieldDefinition
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.RangeDefinition< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.RangeDefinition< T >, including all inherited members.
RangeDefinition(string fieldName, T from) (defined in SolrNet.DSL.Impl.RangeDefinition< T >) | SolrNet.DSL.Impl.RangeDefinition< T >
To(T to) (defined in SolrNet.DSL.Impl.RangeDefinition< T >) | SolrNet.DSL.Impl.RangeDefinition< T >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DateFacetingResult Member List

This is the complete list of members for SolrNet.DateFacetingResult, including all inherited members.
DateFacetingResult() | SolrNet.DateFacetingResult
DateResults | SolrNet.DateFacetingResult
End | SolrNet.DateFacetingResult
Gap | SolrNet.DateFacetingResult
OtherResults | SolrNet.DateFacetingResult
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Exceptions.InvalidFieldException Member List

This is the complete list of members for SolrNet.Exceptions.InvalidFieldException, including all inherited members.
InvalidFieldException(Exception innerException) | SolrNet.Exceptions.InvalidFieldException |
InvalidFieldException(string message) | SolrNet.Exceptions.InvalidFieldException |
InvalidFieldException(string message, Exception innerException) | SolrNet.Exceptions.InvalidFieldException |
InvalidFieldException() | SolrNet.Exceptions.InvalidFieldException |
InvalidFieldException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.InvalidFieldException) | SolrNet.Exceptions.InvalidFieldException | [protected]
SolrNetException(Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message) | SolrNet.Exceptions.SolrNetException |
SolrNetException() | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message, Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrNetException) | SolrNet.Exceptions.SolrNetException | [protected]
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Exceptions.InvalidSortOrderException Member List

This is the complete list of members for SolrNet.Exceptions.InvalidSortOrderException, including all inherited members.
InvalidSortOrderException() (defined in SolrNet.Exceptions.InvalidSortOrderException) | SolrNet.Exceptions.InvalidSortOrderException |
InvalidSortOrderException(string message) (defined in SolrNet.Exceptions.InvalidSortOrderException) | SolrNet.Exceptions.InvalidSortOrderException |
InvalidSortOrderException(string message, Exception innerException) (defined in SolrNet.Exceptions.InvalidSortOrderException) | SolrNet.Exceptions.InvalidSortOrderException |
InvalidSortOrderException(Exception innerException) (defined in SolrNet.Exceptions.InvalidSortOrderException) | SolrNet.Exceptions.InvalidSortOrderException |
InvalidSortOrderException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.InvalidSortOrderException) | SolrNet.Exceptions.InvalidSortOrderException | [protected]
SolrNetException(Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message) | SolrNet.Exceptions.SolrNetException |
SolrNetException() | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message, Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrNetException) | SolrNet.Exceptions.SolrNetException | [protected]
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Exceptions.InvalidURLException Member List

This is the complete list of members for SolrNet.Exceptions.InvalidURLException, including all inherited members.
InvalidURLException(Exception innerException) | SolrNet.Exceptions.InvalidURLException |
InvalidURLException(string message) | SolrNet.Exceptions.InvalidURLException |
InvalidURLException(string message, Exception innerException) | SolrNet.Exceptions.InvalidURLException |
InvalidURLException() | SolrNet.Exceptions.InvalidURLException |
InvalidURLException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.InvalidURLException) | SolrNet.Exceptions.InvalidURLException | [protected]
SolrNetException(Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message) | SolrNet.Exceptions.SolrNetException |
SolrNetException() | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message, Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrNetException) | SolrNet.Exceptions.SolrNetException | [protected]
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Exceptions.SolrConnectionException Member List

This is the complete list of members for SolrNet.Exceptions.SolrConnectionException, including all inherited members.
SolrConnectionException(string message) | SolrNet.Exceptions.SolrConnectionException |
SolrConnectionException(Exception innerException) | SolrNet.Exceptions.SolrConnectionException |
SolrConnectionException(string message, Exception innerException) | SolrNet.Exceptions.SolrConnectionException |
SolrConnectionException() | SolrNet.Exceptions.SolrConnectionException |
SolrConnectionException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrConnectionException) | SolrNet.Exceptions.SolrConnectionException | [protected]
SolrNetException(Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message) | SolrNet.Exceptions.SolrNetException |
SolrNetException() | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message, Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrNetException) | SolrNet.Exceptions.SolrNetException | [protected]
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Exceptions.SolrNetException Member List

This is the complete list of members for SolrNet.Exceptions.SolrNetException, including all inherited members.
SolrNetException(Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message) | SolrNet.Exceptions.SolrNetException |
SolrNetException() | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message, Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrNetException) | SolrNet.Exceptions.SolrNetException | [protected]
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Exceptions.TypeNotSupportedException Member List

This is the complete list of members for SolrNet.Exceptions.TypeNotSupportedException, including all inherited members.
SolrNetException(Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message) | SolrNet.Exceptions.SolrNetException |
SolrNetException() | SolrNet.Exceptions.SolrNetException |
SolrNetException(string message, Exception innerException) | SolrNet.Exceptions.SolrNetException |
SolrNetException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.SolrNetException) | SolrNet.Exceptions.SolrNetException | [protected]
TypeNotSupportedException(Exception innerException) (defined in SolrNet.Exceptions.TypeNotSupportedException) | SolrNet.Exceptions.TypeNotSupportedException |
TypeNotSupportedException(string message) (defined in SolrNet.Exceptions.TypeNotSupportedException) | SolrNet.Exceptions.TypeNotSupportedException |
TypeNotSupportedException() (defined in SolrNet.Exceptions.TypeNotSupportedException) | SolrNet.Exceptions.TypeNotSupportedException |
TypeNotSupportedException(string message, Exception innerException) (defined in SolrNet.Exceptions.TypeNotSupportedException) | SolrNet.Exceptions.TypeNotSupportedException |
TypeNotSupportedException(SerializationInfo info, StreamingContext context) (defined in SolrNet.Exceptions.TypeNotSupportedException) | SolrNet.Exceptions.TypeNotSupportedException | [protected]
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.FacetDateOther Member List

This is the complete list of members for SolrNet.FacetDateOther, including all inherited members.
After | SolrNet.FacetDateOther | [static]
All | SolrNet.FacetDateOther | [static]
Before | SolrNet.FacetDateOther | [static]
Between | SolrNet.FacetDateOther | [static]
Equals(object obj) (defined in SolrNet.FacetDateOther) | SolrNet.FacetDateOther |
FacetDateOther(string value) (defined in SolrNet.FacetDateOther) | SolrNet.FacetDateOther | [protected]
GetHashCode() (defined in SolrNet.FacetDateOther) | SolrNet.FacetDateOther |
None | SolrNet.FacetDateOther | [static]
ToString() (defined in SolrNet.FacetDateOther) | SolrNet.FacetDateOther |
value (defined in SolrNet.FacetDateOther) | SolrNet.FacetDateOther | [protected]
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor Member List

This is the complete list of members for SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor, including all inherited members.
AggregateDocumentVisitor(IEnumerable< ISolrDocumentPropertyVisitor > visitors) | SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor
Visit(object doc, string fieldName, XmlNode field) | SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor Member List

This is the complete list of members for SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor, including all inherited members.
DefaultDocumentVisitor(IReadOnlyMappingManager mapper, ISolrFieldParser parser) | SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor
Visit(object doc, string fieldName, XmlNode field) | SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor Member List

This is the complete list of members for SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
ConvertTo(string s, Type t) (defined in SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
GenericDictionaryDocumentVisitor(IReadOnlyMappingManager mapper, ISolrFieldParser parser) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
GetKeyToUse(string k, string fieldName) (defined in SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
GetThisField(Type t, string fieldName) (defined in SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
NewDictionary(Type[] typeArgs) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
SetKV(object dict, object key, object value) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
Visit(object doc, string fieldName, XmlNode field) | SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor Member List

This is the complete list of members for SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor, including all inherited members.
RegularDocumentVisitor(ISolrFieldParser parser, IReadOnlyMappingManager mapper) | SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor
Visit(object doc, string fieldName, XmlNode field) | SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer, including all inherited members.
AggregateFacetQuerySerializer(ISolrFacetQuerySerializer[] serializers) (defined in SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer
CanHandleType(Type t) (defined in SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer
DefaultFacetQuerySerializer(ISolrQuerySerializer querySerializer, ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > Member List

This is the complete list of members for SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(object q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(SolrFacetDateQuery q) (defined in SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > | [pure virtual]
SerializeSingle(object o) (defined in SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer |
SolrFacetDateQuerySerializer(ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer |
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(SolrFacetFieldQuery q) (defined in SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(SolrFacetQuery q) (defined in SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >) | SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T > | [pure virtual]
SolrFacetQuerySerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer) | SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer |
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.AggregateFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.AggregateFieldParser, including all inherited members.
AggregateFieldParser(IEnumerable< ISolrFieldParser > parsers) | SolrNet.Impl.FieldParsers.AggregateFieldParser
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.AggregateFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.AggregateFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.AggregateFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.CollectionFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.CollectionFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.CollectionFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.CollectionFieldParser
CollectionFieldParser(ISolrFieldParser valueParser) (defined in SolrNet.Impl.FieldParsers.CollectionFieldParser) | SolrNet.Impl.FieldParsers.CollectionFieldParser
GetArrayProperty(XmlNode field, Type t) (defined in SolrNet.Impl.FieldParsers.CollectionFieldParser) | SolrNet.Impl.FieldParsers.CollectionFieldParser
GetGenericCollectionProperty(XmlNode field, Type[] genericTypes) (defined in SolrNet.Impl.FieldParsers.CollectionFieldParser) | SolrNet.Impl.FieldParsers.CollectionFieldParser
GetNonGenericCollectionProperty(XmlNode field) (defined in SolrNet.Impl.FieldParsers.CollectionFieldParser) | SolrNet.Impl.FieldParsers.CollectionFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.CollectionFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.DateTimeFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.DateTimeFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.DateTimeFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.DateTimeFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.DateTimeFieldParser
ParseDate(string s) (defined in SolrNet.Impl.FieldParsers.DateTimeFieldParser) | SolrNet.Impl.FieldParsers.DateTimeFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.DecimalFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.DecimalFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.DecimalFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.DecimalFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.DecimalFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.DefaultFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.DefaultFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.DefaultFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.DefaultFieldParser
DefaultFieldParser() | SolrNet.Impl.FieldParsers.DefaultFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.DefaultFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.DoubleFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.DoubleFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.DoubleFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.DoubleFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.DoubleFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.EnumFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.EnumFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.EnumFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.EnumFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.EnumFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.FloatFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.FloatFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.FloatFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.FloatFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.FloatFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.GuidFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.GuidFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.GuidFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.GuidFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.GuidFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.InferringFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.InferringFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.InferringFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.InferringFieldParser
InferringFieldParser(ISolrFieldParser parser) (defined in SolrNet.Impl.FieldParsers.InferringFieldParser) | SolrNet.Impl.FieldParsers.InferringFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.InferringFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.IntFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.IntFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.IntFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.IntFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.IntFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.LongFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.LongFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.LongFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.LongFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.LongFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.NullableFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.NullableFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.NullableFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.NullableFieldParser
NullableFieldParser(ISolrFieldParser parser) (defined in SolrNet.Impl.FieldParsers.NullableFieldParser) | SolrNet.Impl.FieldParsers.NullableFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.NullableFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldParsers.TypeConvertingFieldParser Member List

This is the complete list of members for SolrNet.Impl.FieldParsers.TypeConvertingFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
CanHandleType(Type t) | SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
GetUnderlyingType(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > |
Parse(T obj) (defined in SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > | [pure virtual]
Serialize(object obj) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > |
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.AggregateFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.AggregateFieldSerializer, including all inherited members.
AggregateFieldSerializer(IEnumerable< ISolrFieldSerializer > serializers) (defined in SolrNet.Impl.FieldSerializers.AggregateFieldSerializer) | SolrNet.Impl.FieldSerializers.AggregateFieldSerializer
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.AggregateFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.AggregateFieldSerializer
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.BoolFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.BoolFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > |
Parse(bool obj) (defined in SolrNet.Impl.FieldSerializers.BoolFieldSerializer) | SolrNet.Impl.FieldSerializers.BoolFieldSerializer |
Parse(T obj) (defined in SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > | [pure virtual]
Serialize(object obj) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > |
SerializeBool(bool o) (defined in SolrNet.Impl.FieldSerializers.BoolFieldSerializer) | SolrNet.Impl.FieldSerializers.BoolFieldSerializer |
Generated on Thu Mar 31 2011 17:06:12 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.CollectionFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.CollectionFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.CollectionFieldSerializer
CollectionFieldSerializer(ISolrFieldSerializer valueSerializer) (defined in SolrNet.Impl.FieldSerializers.CollectionFieldSerializer) | SolrNet.Impl.FieldSerializers.CollectionFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.CollectionFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > |
Parse(DateTime obj) (defined in SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer) | SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer |
Parse(T obj) (defined in SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > | [pure virtual]
Serialize(object obj) | SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > |
SerializeDate(DateTime dt) (defined in SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer) | SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer |
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.DefaultFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.DefaultFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.DefaultFieldSerializer
DefaultFieldSerializer() (defined in SolrNet.Impl.FieldSerializers.DefaultFieldSerializer) | SolrNet.Impl.FieldSerializers.DefaultFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.DefaultFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.FormattableFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.FormattableFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.FormattableFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.FormattableFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
GenericDictionaryFieldSerializer(ISolrFieldSerializer serializer) (defined in SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer) | SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
KVKey(object kv) | SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
KVValue(object kv) | SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.NullableFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.NullableFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.NullableFieldSerializer
NullableFieldSerializer(ISolrFieldSerializer serializer) (defined in SolrNet.Impl.FieldSerializers.NullableFieldSerializer) | SolrNet.Impl.FieldSerializers.NullableFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.NullableFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.ToStringFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.ToStringFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.ToStringFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.ToStringFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer
Serialize(object obj) | SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.HttpRuntimeCache Member List

This is the complete list of members for SolrNet.Impl.HttpRuntimeCache, including all inherited members.
Add(SolrCacheEntity e) | SolrNet.Impl.HttpRuntimeCache
CacheKey(string url) (defined in SolrNet.Impl.HttpRuntimeCache) | SolrNet.Impl.HttpRuntimeCache
HttpRuntimeCache() (defined in SolrNet.Impl.HttpRuntimeCache) | SolrNet.Impl.HttpRuntimeCache
SlidingMinutes | SolrNet.Impl.HttpRuntimeCache
this | SolrNet.Impl.HttpRuntimeCache
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.NullCache Member List

This is the complete list of members for SolrNet.Impl.NullCache, including all inherited members.
Add(SolrCacheEntity e) | SolrNet.Impl.NullCache
this | SolrNet.Impl.NullCache
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.PropertyNode Member List

This is the complete list of members for SolrNet.Impl.PropertyNode, including all inherited members.
FieldNameSuffix | SolrNet.Impl.PropertyNode
FieldValue | SolrNet.Impl.PropertyNode
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.AggregateQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.AggregateQuerySerializer, including all inherited members.
AggregateQuerySerializer(ISolrQuerySerializer[] serializers) (defined in SolrNet.Impl.QuerySerializers.AggregateQuerySerializer) | SolrNet.Impl.QuerySerializers.AggregateQuerySerializer
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.AggregateQuerySerializer) | SolrNet.Impl.QuerySerializers.AggregateQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.AggregateQuerySerializer) | SolrNet.Impl.QuerySerializers.AggregateQuerySerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.BoostQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.BoostQuerySerializer, including all inherited members.
BoostQuerySerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.QuerySerializers.BoostQuerySerializer) | SolrNet.Impl.QuerySerializers.BoostQuerySerializer |
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(SolrQueryBoost q) (defined in SolrNet.Impl.QuerySerializers.BoostQuerySerializer) | SolrNet.Impl.QuerySerializers.BoostQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer, including all inherited members.
DateTimeRangeQuerySerializer(ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer) | SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer
Serialize(SolrQueryByRange< DateTime > q) (defined in SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer) | SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer
SerializeSingle(object o) (defined in SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer) | SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.DefaultQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.DefaultQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.DefaultQuerySerializer) | SolrNet.Impl.QuerySerializers.DefaultQuerySerializer
DefaultQuerySerializer(ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.QuerySerializers.DefaultQuerySerializer) | SolrNet.Impl.QuerySerializers.DefaultQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.DefaultQuerySerializer) | SolrNet.Impl.QuerySerializers.DefaultQuerySerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.HasValueQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.HasValueQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
HasValueQuerySerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.QuerySerializers.HasValueQuerySerializer) | SolrNet.Impl.QuerySerializers.HasValueQuerySerializer |
Serialize(SolrHasValueQuery q) (defined in SolrNet.Impl.QuerySerializers.HasValueQuerySerializer) | SolrNet.Impl.QuerySerializers.HasValueQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.LocalParamsSerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.LocalParamsSerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
LocalParamsSerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.QuerySerializers.LocalParamsSerializer) | SolrNet.Impl.QuerySerializers.LocalParamsSerializer |
Serialize(LocalParams.LocalParamsQuery q) (defined in SolrNet.Impl.QuerySerializers.LocalParamsSerializer) | SolrNet.Impl.QuerySerializers.LocalParamsSerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
MultipleCriteriaQuerySerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer) | SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer |
Serialize(SolrMultipleCriteriaQuery q) (defined in SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer) | SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.NotQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.NotQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
NotQuerySerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.QuerySerializers.NotQuerySerializer) | SolrNet.Impl.QuerySerializers.NotQuerySerializer |
Serialize(SolrNotQuery q) (defined in SolrNet.Impl.QuerySerializers.NotQuerySerializer) | SolrNet.Impl.QuerySerializers.NotQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer, including all inherited members.
NullableDateTimeRangeQuerySerializer(ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer) | SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer
Serialize(SolrQueryByRange< DateTime?> q) (defined in SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer) | SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer
SerializeSingle(object o) (defined in SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer) | SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.QueryByFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.QueryByFieldSerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
quote(string value) (defined in SolrNet.Impl.QuerySerializers.QueryByFieldSerializer) | SolrNet.Impl.QuerySerializers.QueryByFieldSerializer |
Serialize(SolrQueryByField q) (defined in SolrNet.Impl.QuerySerializers.QueryByFieldSerializer) | SolrNet.Impl.QuerySerializers.QueryByFieldSerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.QueryInListSerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.QueryInListSerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
QueryInListSerializer(ISolrQuerySerializer serializer) (defined in SolrNet.Impl.QuerySerializers.QueryInListSerializer) | SolrNet.Impl.QuerySerializers.QueryInListSerializer |
Serialize(SolrQueryInList q) (defined in SolrNet.Impl.QuerySerializers.QueryInListSerializer) | SolrNet.Impl.QuerySerializers.QueryInListSerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.RangeQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.RangeQuerySerializer, including all inherited members.
BuildRange(string fieldName, string @from, string @to, bool inclusive) (defined in SolrNet.Impl.QuerySerializers.RangeQuerySerializer) | SolrNet.Impl.QuerySerializers.RangeQuerySerializer | [static]
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.RangeQuerySerializer) | SolrNet.Impl.QuerySerializers.RangeQuerySerializer |
RangeQuerySerializer(ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.QuerySerializers.RangeQuerySerializer) | SolrNet.Impl.QuerySerializers.RangeQuerySerializer |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.RangeQuerySerializer) | SolrNet.Impl.QuerySerializers.RangeQuerySerializer |
SerializeValue(object o) (defined in SolrNet.Impl.QuerySerializers.RangeQuerySerializer) | SolrNet.Impl.QuerySerializers.RangeQuerySerializer |
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer) | SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer) | SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer
Generated on Thu Mar 31 2011 17:06:13 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > Member List

This is the complete list of members for SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(object q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > |
Serialize(T q) (defined in SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >) | SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T > | [pure virtual]
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >
ParseCollapsedResults(XmlNode node) | SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >, including all inherited members.
KV< K, V >(K key, V value) (defined in SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >) | SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
ParseDateFacetingNode(XmlNode node) (defined in SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >) | SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
ParseFacetDates(XmlNode node) | SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
ParseFacetFields(XmlNode node) | SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
ParseFacetQueries(XmlNode node) | SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
Parse(XmlDocument response) (defined in SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >) | SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
ParseHeader(XmlNode node) | SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
ParseHighlighting(IEnumerable< T > results, XmlNode node) | SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
ParseHighlightingFields(XmlNodeList nodes) | SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >, including all inherited members.
MoreLikeThisResponseParser(ISolrDocumentResponseParser< T > docParser) (defined in SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >) | SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >
ParseMoreLikeThis(IEnumerable< T > results, XmlNode node) | SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >
ResultsResponseParser(ISolrDocumentResponseParser< T > docParser) (defined in SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >) | SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >
ParseSpellChecking(XmlNode node) | SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ResponseParsers.StatsResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ResponseParsers.StatsResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) | SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
ParseFacetNode(XmlNode node) (defined in SolrNet.Impl.ResponseParsers.StatsResponseParser< T >) | SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
ParseStats(XmlNode node, string selector) | SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
ParseStatsNode(XmlNode node) (defined in SolrNet.Impl.ResponseParsers.StatsResponseParser< T >) | SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrBasicServer< T > Member List

This is the complete list of members for SolrNet.Impl.SolrBasicServer< T >, including all inherited members.
AddWithBoost(IEnumerable< KeyValuePair< T, double?>> docs) | SolrNet.Impl.SolrBasicServer< T >
Commit(CommitOptions options) | SolrNet.Impl.SolrBasicServer< T >
Delete(IEnumerable< string > ids, ISolrQuery q) | SolrNet.Impl.SolrBasicServer< T >
GetSchema() | SolrNet.Impl.SolrBasicServer< T >
Optimize(CommitOptions options) | SolrNet.Impl.SolrBasicServer< T >
Ping() | SolrNet.Impl.SolrBasicServer< T >
Query(ISolrQuery query, QueryOptions options) | SolrNet.Impl.SolrBasicServer< T >
Rollback() | SolrNet.Impl.SolrBasicServer< T >
Send(ISolrCommand cmd) | SolrNet.Impl.SolrBasicServer< T >
SendAndParseHeader(ISolrCommand cmd) | SolrNet.Impl.SolrBasicServer< T >
SolrBasicServer(ISolrConnection connection, ISolrQueryExecuter< T > queryExecuter, ISolrDocumentSerializer< T > documentSerializer, ISolrSchemaParser schemaParser, ISolrHeaderResponseParser headerParser, ISolrQuerySerializer querySerializer) (defined in SolrNet.Impl.SolrBasicServer< T >) | SolrNet.Impl.SolrBasicServer< T >
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrCacheEntity Member List

This is the complete list of members for SolrNet.Impl.SolrCacheEntity, including all inherited members.
Data | SolrNet.Impl.SolrCacheEntity
ETag | SolrNet.Impl.SolrCacheEntity
SolrCacheEntity(string url, string eTag, string data) | SolrNet.Impl.SolrCacheEntity
Url | SolrNet.Impl.SolrCacheEntity
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrConnection Member List

This is the complete list of members for SolrNet.Impl.SolrConnection, including all inherited members.
Cache | SolrNet.Impl.SolrConnection
Get(string relativeUrl, IEnumerable< KeyValuePair< string, string >> parameters) | SolrNet.Impl.SolrConnection
HttpWebRequestFactory | SolrNet.Impl.SolrConnection
KVP< T1, T2 >(T1 a, T2 b) (defined in SolrNet.Impl.SolrConnection) | SolrNet.Impl.SolrConnection
Post(string relativeUrl, string s) | SolrNet.Impl.SolrConnection
ServerURL (defined in SolrNet.Impl.SolrConnection) | SolrNet.Impl.SolrConnection
SolrConnection(string serverURL) (defined in SolrNet.Impl.SolrConnection) | SolrNet.Impl.SolrConnection
Timeout | SolrNet.Impl.SolrConnection
Version | SolrNet.Impl.SolrConnection
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrDictionaryDocumentResponseParser Member List

This is the complete list of members for SolrNet.Impl.SolrDictionaryDocumentResponseParser, including all inherited members.
ParseDocument(XmlNode node) (defined in SolrNet.Impl.SolrDictionaryDocumentResponseParser) | SolrNet.Impl.SolrDictionaryDocumentResponseParser
ParseResults(XmlNode parentNode) (defined in SolrNet.Impl.SolrDictionaryDocumentResponseParser) | SolrNet.Impl.SolrDictionaryDocumentResponseParser
SolrDictionaryDocumentResponseParser(ISolrFieldParser fieldParser) (defined in SolrNet.Impl.SolrDictionaryDocumentResponseParser) | SolrNet.Impl.SolrDictionaryDocumentResponseParser
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrDictionarySerializer Member List

This is the complete list of members for SolrNet.Impl.SolrDictionarySerializer, including all inherited members.
Serialize(Dictionary< string, object > doc, double?boost) (defined in SolrNet.Impl.SolrDictionarySerializer) | SolrNet.Impl.SolrDictionarySerializer
SolrDictionarySerializer(ISolrFieldSerializer serializer) (defined in SolrNet.Impl.SolrDictionarySerializer) | SolrNet.Impl.SolrDictionarySerializer
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrDocumentActivator< T > Member List

This is the complete list of members for SolrNet.Impl.SolrDocumentActivator< T >, including all inherited members.
Create() SolrNet.Impl.SolrDocumentActivator< T >
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrDocumentResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.SolrDocumentResponseParser< T >, including all inherited members.
ParseDocument(XmlNode node, ICollection< SolrFieldModel > fields) | SolrNet.Impl.SolrDocumentResponseParser< T >
ParseResults(XmlNode parentNode) | SolrNet.Impl.SolrDocumentResponseParser< T >
SolrDocumentResponseParser(IReadOnlyMappingManager mappingManager, ISolrDocumentPropertyVisitor propVisitor, ISolrDocumentActivator< T > activator) (defined in SolrNet.Impl.SolrDocumentResponseParser< T >) | SolrNet.Impl.SolrDocumentResponseParser< T >
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrDocumentSerializer< T > Member List

This is the complete list of members for SolrNet.Impl.SolrDocumentSerializer< T >, including all inherited members.
Serialize(T doc, double?boost) | SolrNet.Impl.SolrDocumentSerializer< T >
SolrDocumentSerializer(IReadOnlyMappingManager mappingManager, ISolrFieldSerializer fieldSerializer) (defined in SolrNet.Impl.SolrDocumentSerializer< T >) | SolrNet.Impl.SolrDocumentSerializer< T >
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrQueryExecuter< T > Member List

This is the complete list of members for SolrNet.Impl.SolrQueryExecuter< T >, including all inherited members.
ConstDefaultRows (defined in SolrNet.Impl.SolrQueryExecuter< T >) | SolrNet.Impl.SolrQueryExecuter< T > | [static]
DefaultRows | SolrNet.Impl.SolrQueryExecuter< T > |
Execute(ISolrQuery q, QueryOptions options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetAllParameters(ISolrQuery Query, QueryOptions Options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetCollapseQueryOptions(QueryOptions options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetFacetFieldOptions(QueryOptions options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetFilterQueries(QueryOptions options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetHighlightingParameters(QueryOptions Options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetMoreLikeThisParameters(QueryOptions options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetSpellCheckingParameters(QueryOptions Options) | SolrNet.Impl.SolrQueryExecuter< T > |
GetStatsQueryOptions(QueryOptions options) | SolrNet.Impl.SolrQueryExecuter< T > |
KVP< T1, T2 >(T1 a, T2 b) (defined in SolrNet.Impl.SolrQueryExecuter< T >) | SolrNet.Impl.SolrQueryExecuter< T > |
SolrQueryExecuter(ISolrQueryResultParser< T > resultParser, ISolrConnection connection, ISolrQuerySerializer querySerializer, ISolrFacetQuerySerializer facetQuerySerializer) (defined in SolrNet.Impl.SolrQueryExecuter< T >) | SolrNet.Impl.SolrQueryExecuter< T > |
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrQueryResultParser< T > Member List

This is the complete list of members for SolrNet.Impl.SolrQueryResultParser< T >, including all inherited members.
Parse(string r) | SolrNet.Impl.SolrQueryResultParser< T >
SolrQueryResultParser(ISolrResponseParser< T >[] parsers) (defined in SolrNet.Impl.SolrQueryResultParser< T >) | SolrNet.Impl.SolrQueryResultParser< T >
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrQueryResults< T > Member List

This is the complete list of members for SolrNet.Impl.SolrQueryResults< T >, including all inherited members.
Add(T item) | SolrNet.Impl.SolrQueryResults< T >
Clear() | SolrNet.Impl.SolrQueryResults< T >
Collapsing | SolrNet.Impl.SolrQueryResults< T >
Contains(T item) | SolrNet.Impl.SolrQueryResults< T >
CopyTo(T[] array, int arrayIndex) | SolrNet.Impl.SolrQueryResults< T >
Count | SolrNet.Impl.SolrQueryResults< T >
FacetDates | SolrNet.Impl.SolrQueryResults< T >
FacetFields | SolrNet.Impl.SolrQueryResults< T >
FacetQueries | SolrNet.Impl.SolrQueryResults< T >
GetEnumerator() (defined in SolrNet.Impl.SolrQueryResults< T >) | SolrNet.Impl.SolrQueryResults< T >
Header | SolrNet.Impl.SolrQueryResults< T >
Highlights | SolrNet.Impl.SolrQueryResults< T >
IndexOf(T item) | SolrNet.Impl.SolrQueryResults< T >
Insert(int index, T item) | SolrNet.Impl.SolrQueryResults< T >
IsReadOnly | SolrNet.Impl.SolrQueryResults< T >
MaxScore | SolrNet.Impl.SolrQueryResults< T >
NumFound | SolrNet.Impl.SolrQueryResults< T >
Remove(T item) | SolrNet.Impl.SolrQueryResults< T >
RemoveAt(int index) | SolrNet.Impl.SolrQueryResults< T >
SimilarResults | SolrNet.Impl.SolrQueryResults< T >
SolrQueryResults() (defined in SolrNet.Impl.SolrQueryResults< T >) | SolrNet.Impl.SolrQueryResults< T >
SpellChecking | SolrNet.Impl.SolrQueryResults< T >
Stats | SolrNet.Impl.SolrQueryResults< T >
this | SolrNet.Impl.SolrQueryResults< T >
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SolrServer< T > Member List

This is the complete list of members for SolrNet.Impl.SolrServer< T >, including all inherited members.
Add(IEnumerable< T > docs) | SolrNet.Impl.SolrServer< T >
Add(T doc) | SolrNet.Impl.SolrServer< T >
AddWithBoost(T doc, double boost) | SolrNet.Impl.SolrServer< T >
BuildSpellCheckDictionary() | SolrNet.Impl.SolrServer< T >
Commit() | SolrNet.Impl.SolrServer< T >
Delete(IEnumerable< string > ids) | SolrNet.Impl.SolrServer< T >
Delete(T doc) | SolrNet.Impl.SolrServer< T >
Delete(IEnumerable< T > docs) | SolrNet.Impl.SolrServer< T >
Delete(string id) | SolrNet.Impl.SolrServer< T >
EnumerateValidationResults() (defined in SolrNet.Impl.SolrServer< T >) | SolrNet.Impl.SolrServer< T >
FacetFieldQuery(SolrFacetFieldQuery facet) | SolrNet.Impl.SolrServer< T >
GetSchema() | SolrNet.Impl.SolrServer< T >
Optimize() | SolrNet.Impl.SolrServer< T >
Ping() | SolrNet.Impl.SolrServer< T >
Query(ISolrQuery query, QueryOptions options) | SolrNet.Impl.SolrServer< T >
Query(string q) | SolrNet.Impl.SolrServer< T >
Query(string q, ICollection< SortOrder > orders) | SolrNet.Impl.SolrServer< T >
Query(string q, QueryOptions options) | SolrNet.Impl.SolrServer< T >
Query(ISolrQuery q) | SolrNet.Impl.SolrServer< T >
Query(ISolrQuery query, ICollection< SortOrder > orders) | SolrNet.Impl.SolrServer< T >
SolrServer(ISolrBasicOperations< T > basicServer, IReadOnlyMappingManager mappingManager, IMappingValidator _schemaMappingValidator) (defined in SolrNet.Impl.SolrServer< T >) | SolrNet.Impl.SolrServer< T >
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SpellCheckResult Member List

This is the complete list of members for SolrNet.Impl.SpellCheckResult, including all inherited members.
EndOffset | SolrNet.Impl.SpellCheckResult
NumFound | SolrNet.Impl.SpellCheckResult
Query | SolrNet.Impl.SpellCheckResult
StartOffset | SolrNet.Impl.SpellCheckResult
Suggestions | SolrNet.Impl.SpellCheckResult
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.SpellCheckResults Member List

This is the complete list of members for SolrNet.Impl.SpellCheckResults, including all inherited members.
Add(SpellCheckResult item) (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
Clear() (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
Collation | SolrNet.Impl.SpellCheckResults
Contains(SpellCheckResult item) (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
CopyTo(SpellCheckResult[] array, int arrayIndex) (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
Count (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
GetEnumerator() (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
IsReadOnly (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
Remove(SpellCheckResult item) (defined in SolrNet.Impl.SpellCheckResults) | SolrNet.Impl.SpellCheckResults
Generated on Thu Mar 31 2011 17:06:11 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.LocalParams Member List

This is the complete list of members for SolrNet.LocalParams, including all inherited members.
LocalParams() (defined in SolrNet.LocalParams) | SolrNet.LocalParams |
LocalParams(IDictionary< string, string > dictionary) (defined in SolrNet.LocalParams) | SolrNet.LocalParams |
operator+(LocalParams p, ISolrQuery q) (defined in SolrNet.LocalParams) | SolrNet.LocalParams | [static]
ToString() (defined in SolrNet.LocalParams) | SolrNet.LocalParams |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.LocalParams.LocalParamsQuery Member List

This is the complete list of members for SolrNet.LocalParams.LocalParamsQuery, including all inherited members.
Local (defined in SolrNet.LocalParams.LocalParamsQuery) | SolrNet.LocalParams.LocalParamsQuery
LocalParamsQuery(ISolrQuery query, LocalParams local) (defined in SolrNet.LocalParams.LocalParamsQuery) | SolrNet.LocalParams.LocalParamsQuery
Query (defined in SolrNet.LocalParams.LocalParamsQuery) | SolrNet.LocalParams.LocalParamsQuery
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.AllPropertiesMappingManager Member List

This is the complete list of members for SolrNet.Mapping.AllPropertiesMappingManager, including all inherited members.
GetFields(Type type) | SolrNet.Mapping.AllPropertiesMappingManager
GetRegisteredTypes() (defined in SolrNet.Mapping.AllPropertiesMappingManager) | SolrNet.Mapping.AllPropertiesMappingManager
GetUniqueKey(Type type) | SolrNet.Mapping.AllPropertiesMappingManager
SetUniqueKey(PropertyInfo property) | SolrNet.Mapping.AllPropertiesMappingManager
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.AttributesMappingManager Member List

This is the complete list of members for SolrNet.Mapping.AttributesMappingManager, including all inherited members.
GetCustomAttributes< T >(PropertyInfo prop) (defined in SolrNet.Mapping.AttributesMappingManager) | SolrNet.Mapping.AttributesMappingManager | [virtual]
GetFields(Type type) | SolrNet.Mapping.AttributesMappingManager |
GetPropertiesWithAttribute< T >(Type type) (defined in SolrNet.Mapping.AttributesMappingManager) | SolrNet.Mapping.AttributesMappingManager | [virtual]
GetRegisteredTypes() (defined in SolrNet.Mapping.AttributesMappingManager) | SolrNet.Mapping.AttributesMappingManager |
GetUniqueKey(Type type) | SolrNet.Mapping.AttributesMappingManager |
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.MappingManager Member List

This is the complete list of members for SolrNet.Mapping.MappingManager, including all inherited members.
Add(PropertyInfo property) | SolrNet.Mapping.MappingManager
Add(PropertyInfo property, string fieldName) | SolrNet.Mapping.MappingManager
Add(PropertyInfo property, string fieldName, float?boost) | SolrNet.Mapping.MappingManager
GetFields(Type type) | SolrNet.Mapping.MappingManager
GetRegisteredTypes() (defined in SolrNet.Mapping.MappingManager) | SolrNet.Mapping.MappingManager
GetUniqueKey(Type type) | SolrNet.Mapping.MappingManager
SetUniqueKey(PropertyInfo property) | SolrNet.Mapping.MappingManager
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.MemoizingMappingManager Member List

This is the complete list of members for SolrNet.Mapping.MemoizingMappingManager, including all inherited members.
GetFields(Type type) | SolrNet.Mapping.MemoizingMappingManager
GetRegisteredTypes() (defined in SolrNet.Mapping.MemoizingMappingManager) | SolrNet.Mapping.MemoizingMappingManager
GetUniqueKey(Type type) | SolrNet.Mapping.MemoizingMappingManager
MemoizingMappingManager(IReadOnlyMappingManager mapper) (defined in SolrNet.Mapping.MemoizingMappingManager) | SolrNet.Mapping.MemoizingMappingManager
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.MappingValidator Member List

This is the complete list of members for SolrNet.Mapping.Validation.MappingValidator, including all inherited members.
EnumerateValidationResults(Type documentType, SolrSchema schema) | SolrNet.Mapping.Validation.MappingValidator
MappingValidator(IReadOnlyMappingManager mappingManager, IValidationRule[] rules) | SolrNet.Mapping.Validation.MappingValidator
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
BoolSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker |
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
DateTimeSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker |
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker, including all inherited members.
CanHandleType(Type propertyType) (defined in SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
DoubleSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker |
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
FloatSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker |
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
IntSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker |
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
LongSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker |
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule, including all inherited members.
IgnoredFieldNames | SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule
MappedPropertiesIsInSolrSchemaRule() (defined in SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule) | SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule
Validate(Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager) | SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule, including all inherited members.
MappingTypesAreCompatibleWithSolrTypesRule(ISolrFieldTypeChecker[] fieldTypeCheckers) (defined in SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule) | SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule
Validate(Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager) | SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule, including all inherited members.
Validate(Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager) SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule, including all inherited members.
Validate(Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager) SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker, including all inherited members.
AbstractSolrFieldTypeChecker(ICollection< string > safeTypes, ICollection< string > warningTypes) (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
CanHandleType(Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [pure virtual]
safeTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
StringSolrFieldTypeChecker() | SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker |
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [virtual]
warningTypes (defined in SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker | [protected]
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule, including all inherited members.
Validate(Type documentType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager) SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.ValidationError Member List

This is the complete list of members for SolrNet.Mapping.Validation.ValidationError, including all inherited members.
Message | SolrNet.Mapping.Validation.ValidationResult |
ValidationError(string message) | SolrNet.Mapping.Validation.ValidationError |
ValidationResult(string message) | SolrNet.Mapping.Validation.ValidationResult | [protected]
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.ValidationResult Member List

This is the complete list of members for SolrNet.Mapping.Validation.ValidationResult, including all inherited members.
Message | SolrNet.Mapping.Validation.ValidationResult |
ValidationResult(string message) | SolrNet.Mapping.Validation.ValidationResult | [protected]
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.ValidationWarning Member List

This is the complete list of members for SolrNet.Mapping.Validation.ValidationWarning, including all inherited members.
Message | SolrNet.Mapping.Validation.ValidationResult |
ValidationResult(string message) | SolrNet.Mapping.Validation.ValidationResult | [protected]
ValidationWarning(string message) | SolrNet.Mapping.Validation.ValidationWarning |
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.RandomSortOrder Member List

This is the complete list of members for SolrNet.RandomSortOrder, including all inherited members.
Parse(string s) (defined in SolrNet.SortOrder) | SolrNet.SortOrder | [static]
RandomSortOrder(string fieldName) | SolrNet.RandomSortOrder |
RandomSortOrder(string fieldName, Order order) | SolrNet.RandomSortOrder |
RandomSortOrder(string fieldName, string seed) | SolrNet.RandomSortOrder |
RandomSortOrder(string fieldName, string seed, Order order) | SolrNet.RandomSortOrder |
SortOrder(string fieldName) (defined in SolrNet.SortOrder) | SolrNet.SortOrder |
SortOrder(string fieldName, Order order) (defined in SolrNet.SortOrder) | SolrNet.SortOrder |
ToString() (defined in SolrNet.SortOrder) | SolrNet.SortOrder |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ResponseHeader Member List

This is the complete list of members for SolrNet.ResponseHeader, including all inherited members.
Params | SolrNet.ResponseHeader
QTime | SolrNet.ResponseHeader
Status | SolrNet.ResponseHeader
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.SolrCopyField Member List

This is the complete list of members for SolrNet.Schema.SolrCopyField, including all inherited members.
Destination | SolrNet.Schema.SolrCopyField
SolrCopyField(string source, string destination) (defined in SolrNet.Schema.SolrCopyField) | SolrNet.Schema.SolrCopyField
Source | SolrNet.Schema.SolrCopyField
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.SolrDynamicField Member List

This is the complete list of members for SolrNet.Schema.SolrDynamicField, including all inherited members.
Name | SolrNet.Schema.SolrDynamicField
SolrDynamicField(string name) (defined in SolrNet.Schema.SolrDynamicField) | SolrNet.Schema.SolrDynamicField
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.SolrField Member List

This is the complete list of members for SolrNet.Schema.SolrField, including all inherited members.
IsMultiValued | SolrNet.Schema.SolrField
IsRequired | SolrNet.Schema.SolrField
Name | SolrNet.Schema.SolrField
SolrField(string name, SolrFieldType type) | SolrNet.Schema.SolrField
Type | SolrNet.Schema.SolrField
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.SolrFieldType Member List

This is the complete list of members for SolrNet.Schema.SolrFieldType, including all inherited members.
Name | SolrNet.Schema.SolrFieldType
SolrFieldType(string name, string type) | SolrNet.Schema.SolrFieldType
Type | SolrNet.Schema.SolrFieldType
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.SolrSchema Member List

This is the complete list of members for SolrNet.Schema.SolrSchema, including all inherited members.
FindSolrFieldByName(string name) | SolrNet.Schema.SolrSchema
FindSolrFieldTypeByName(string name) (defined in SolrNet.Schema.SolrSchema) | SolrNet.Schema.SolrSchema
SolrCopyFields | SolrNet.Schema.SolrSchema
SolrDynamicFields | SolrNet.Schema.SolrSchema
SolrFields | SolrNet.Schema.SolrSchema
SolrFieldTypes | SolrNet.Schema.SolrSchema
SolrSchema() | SolrNet.Schema.SolrSchema
UniqueKey | SolrNet.Schema.SolrSchema
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.SolrSchemaParser Member List

This is the complete list of members for SolrNet.Schema.SolrSchemaParser, including all inherited members.
Parse(XmlDocument solrSchemaXml) SolrNet.Schema.SolrSchemaParser
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrFacetDateQuery Member List

This is the complete list of members for SolrNet.SolrFacetDateQuery, including all inherited members.
End (defined in SolrNet.SolrFacetDateQuery) | SolrNet.SolrFacetDateQuery
Field (defined in SolrNet.SolrFacetDateQuery) | SolrNet.SolrFacetDateQuery
Gap (defined in SolrNet.SolrFacetDateQuery) | SolrNet.SolrFacetDateQuery
HardEnd | SolrNet.SolrFacetDateQuery
Other | SolrNet.SolrFacetDateQuery
Query (defined in SolrNet.SolrFacetDateQuery) | SolrNet.SolrFacetDateQuery
SolrFacetDateQuery(string field, DateTime start, DateTime end, string gap) | SolrNet.SolrFacetDateQuery
Start (defined in SolrNet.SolrFacetDateQuery) | SolrNet.SolrFacetDateQuery
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrFacetFieldQuery Member List

This is the complete list of members for SolrNet.SolrFacetFieldQuery, including all inherited members.
EnumCacheMinDf | SolrNet.SolrFacetFieldQuery
Field | SolrNet.SolrFacetFieldQuery
Limit | SolrNet.SolrFacetFieldQuery
MinCount | SolrNet.SolrFacetFieldQuery
Missing | SolrNet.SolrFacetFieldQuery
Offset | SolrNet.SolrFacetFieldQuery
Prefix | SolrNet.SolrFacetFieldQuery
SolrFacetFieldQuery(string field) (defined in SolrNet.SolrFacetFieldQuery) | SolrNet.SolrFacetFieldQuery
Sort | SolrNet.SolrFacetFieldQuery
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrFacetQuery Member List

This is the complete list of members for SolrNet.SolrFacetQuery, including all inherited members.
Query (defined in SolrNet.SolrFacetQuery) | SolrNet.SolrFacetQuery
SolrFacetQuery(ISolrQuery q) (defined in SolrNet.SolrFacetQuery) | SolrNet.SolrFacetQuery
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrFieldModel Member List

This is the complete list of members for SolrNet.SolrFieldModel, including all inherited members.
Boost | SolrNet.SolrFieldModel
FieldName | SolrNet.SolrFieldModel
Property | SolrNet.SolrFieldModel
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrHasValueQuery Member List

This is the complete list of members for SolrNet.SolrHasValueQuery, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
Field (defined in SolrNet.SolrHasValueQuery) | SolrNet.SolrHasValueQuery |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
SolrHasValueQuery(string field) (defined in SolrNet.SolrHasValueQuery) | SolrNet.SolrHasValueQuery |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrMultipleCriteriaQuery Member List

This is the complete list of members for SolrNet.SolrMultipleCriteriaQuery, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
Create(params ISolrQuery[] queries) | SolrNet.SolrMultipleCriteriaQuery | [static]
Create< T >(IEnumerable< T > queries) | SolrNet.SolrMultipleCriteriaQuery | [static]
Not() | SolrNet.AbstractSolrQuery |
Oper | SolrNet.SolrMultipleCriteriaQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
Queries | SolrNet.SolrMultipleCriteriaQuery |
SolrMultipleCriteriaQuery(IEnumerable< ISolrQuery > queries) (defined in SolrNet.SolrMultipleCriteriaQuery) | SolrNet.SolrMultipleCriteriaQuery |
SolrMultipleCriteriaQuery(IEnumerable< ISolrQuery > queries, string oper) (defined in SolrNet.SolrMultipleCriteriaQuery) | SolrNet.SolrMultipleCriteriaQuery |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrMultipleCriteriaQuery.Operator Member List

This is the complete list of members for SolrNet.SolrMultipleCriteriaQuery.Operator, including all inherited members.
AND (defined in SolrNet.SolrMultipleCriteriaQuery.Operator) | SolrNet.SolrMultipleCriteriaQuery.Operator
OR (defined in SolrNet.SolrMultipleCriteriaQuery.Operator) | SolrNet.SolrMultipleCriteriaQuery.Operator
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrNotQuery Member List

This is the complete list of members for SolrNet.SolrNotQuery, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
Query (defined in SolrNet.SolrNotQuery) | SolrNet.SolrNotQuery |
SolrNotQuery(ISolrQuery q) | SolrNet.SolrNotQuery |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrQuery Member List

This is the complete list of members for SolrNet.SolrQuery, including all inherited members.
All | SolrNet.SolrQuery | [static]
Boost(double factor) | SolrNet.AbstractSolrQuery |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
Query | SolrNet.SolrQuery |
SolrQuery(string query) | SolrNet.SolrQuery |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrQueryBoost Member List

This is the complete list of members for SolrNet.SolrQueryBoost, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
Factor | SolrNet.SolrQueryBoost |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
Query (defined in SolrNet.SolrQueryBoost) | SolrNet.SolrQueryBoost |
SolrQueryBoost(ISolrQuery query, double factor) | SolrNet.SolrQueryBoost |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrQueryByField Member List

This is the complete list of members for SolrNet.SolrQueryByField, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
FieldName (defined in SolrNet.SolrQueryByField) | SolrNet.SolrQueryByField |
FieldValue (defined in SolrNet.SolrQueryByField) | SolrNet.SolrQueryByField |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
SolrQueryByField(string fieldName, string fieldValue) | SolrNet.SolrQueryByField |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrQueryByRange< RT > Member List

This is the complete list of members for SolrNet.SolrQueryByRange< RT >, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
FieldName (defined in SolrNet.SolrQueryByRange< RT >) | SolrNet.SolrQueryByRange< RT > |
From (defined in SolrNet.SolrQueryByRange< RT >) | SolrNet.SolrQueryByRange< RT > |
Inclusive (defined in SolrNet.SolrQueryByRange< RT >) | SolrNet.SolrQueryByRange< RT > |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
SolrQueryByRange(string fieldName, RT from, RT to) (defined in SolrNet.SolrQueryByRange< RT >) | SolrNet.SolrQueryByRange< RT > |
SolrQueryByRange(string fieldName, RT @from, RT to, bool inclusive) (defined in SolrNet.SolrQueryByRange< RT >) | SolrNet.SolrQueryByRange< RT > |
To (defined in SolrNet.SolrQueryByRange< RT >) | SolrNet.SolrQueryByRange< RT > |
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SolrQueryInList Member List

This is the complete list of members for SolrNet.SolrQueryInList, including all inherited members.
Boost(double factor) | SolrNet.AbstractSolrQuery |
FieldName (defined in SolrNet.SolrQueryInList) | SolrNet.SolrQueryInList |
List (defined in SolrNet.SolrQueryInList) | SolrNet.SolrQueryInList |
Not() | SolrNet.AbstractSolrQuery |
operator false(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator true(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator!(AbstractSolrQuery a) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator&(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator+(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator-(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
operator|(AbstractSolrQuery a, AbstractSolrQuery b) (defined in SolrNet.AbstractSolrQuery) | SolrNet.AbstractSolrQuery | [static]
SolrQueryInList(string fieldName, IEnumerable< string > list) (defined in SolrNet.SolrQueryInList) | SolrNet.SolrQueryInList |
SolrQueryInList(string fieldName, params string[] values) (defined in SolrNet.SolrQueryInList) | SolrNet.SolrQueryInList |
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.SortOrder Member List

This is the complete list of members for SolrNet.SortOrder, including all inherited members.
Parse(string s) (defined in SolrNet.SortOrder) | SolrNet.SortOrder | [static]
SortOrder(string fieldName) (defined in SolrNet.SortOrder) | SolrNet.SortOrder |
SortOrder(string fieldName, Order order) (defined in SolrNet.SortOrder) | SolrNet.SortOrder |
ToString() (defined in SolrNet.SortOrder) | SolrNet.SortOrder |
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.StatsResult Member List

This is the complete list of members for SolrNet.StatsResult, including all inherited members.
Count | SolrNet.StatsResult
FacetResults | SolrNet.StatsResult
Max | SolrNet.StatsResult
Mean | SolrNet.StatsResult
Min | SolrNet.StatsResult
Missing | SolrNet.StatsResult
StatsResult() (defined in SolrNet.StatsResult) | SolrNet.StatsResult
StdDev | SolrNet.StatsResult
Sum | SolrNet.StatsResult
SumOfSquares | SolrNet.StatsResult
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Utils.Container Member List

This is the complete list of members for SolrNet.Utils.Container, including all inherited members.
Clear() | SolrNet.Utils.Container |
Container() (defined in SolrNet.Utils.Container) | SolrNet.Utils.Container |
Container(Container c) | SolrNet.Utils.Container |
DoGetAllInstances(Type serviceType) (defined in SolrNet.Utils.Container) | SolrNet.Utils.Container | [protected]
DoGetInstance(Type serviceType, string key) (defined in SolrNet.Utils.Container) | SolrNet.Utils.Container | [protected]
Register(string key, Type serviceType, Converter< IContainer, object > factory) | SolrNet.Utils.Container |
Register< T >(Converter< IContainer, T > factory) | SolrNet.Utils.Container |
Register< T >(string key, Converter< IContainer, T > factory) | SolrNet.Utils.Container |
Remove(string key, Type serviceType) | SolrNet.Utils.Container |
Remove< T >() | SolrNet.Utils.Container |
Remove< T >(string key) | SolrNet.Utils.Container |
RemoveAll< T >() | SolrNet.Utils.Container |
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Utils.Func Member List

This is the complete list of members for SolrNet.Utils.Func, including all inherited members.
Accumulator< TSource, TResult >(TSource x, TResult y) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func |
Any< T >(IEnumerable< T > l, Converter< T, bool > condition) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Cast< R >(IEnumerable e) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Convert< R >(IEnumerable e) | SolrNet.Utils.Func | [static]
Distinct< T >(IEnumerable< T > l) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Filter< TSource >(IEnumerable< TSource > source, Predicate< TSource > predicate) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
First< T >(IEnumerable< T > e) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
FirstOrDefault< T >(IEnumerable< T > e) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
FirstOrDefault< T >(IEnumerable< T > e, Predicate< T > condition) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Func2< TArg1, TArg2, TResult >(TArg1 a, TArg2 b) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func |
Function< T >() (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func |
IsEmpty(IEnumerable e) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Join< T >(string separator, IEnumerable< T > list) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Join< T >(string separator, IEnumerable< T > list, Converter< T, string > converter) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Join< T >(IEnumerable< T > list) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Join< T >(string separator, IEnumerable< T > list, Converter< T, string > converter, bool ignoreNulls) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Reduce< TSource, TResult >(IEnumerable< TSource > source, TResult startValue, Accumulator< TSource, TResult > accumulator) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Select< T, R >(IEnumerable< T > l, Converter< T, R > f) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Skip< T >(IEnumerable< T > l, int skipCount) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Tail< T >(IEnumerable< T > l) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Take< T >(IEnumerable< T > l, int count) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
ToArray< T >(IEnumerable< T > l) (defined in SolrNet.Utils.Func) | SolrNet.Utils.Func | [static]
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Utils.Memoizer Member List

This is the complete list of members for SolrNet.Utils.Memoizer, including all inherited members.
Memoize2< TArg1, TArg2, TResult >(Func.Func2< TArg1, TArg2, TResult > function) (defined in SolrNet.Utils.Memoizer) | SolrNet.Utils.Memoizer | [static]
Memoize< TArg, TResult >(Converter< TArg, TResult > function) | SolrNet.Utils.Memoizer | [static]
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

StructureMap.SolrNetIntegration.Config.SolrConfigurationSection Member List

This is the complete list of members for StructureMap.SolrNetIntegration.Config.SolrConfigurationSection, including all inherited members.
SolrServers (defined in StructureMap.SolrNetIntegration.Config.SolrConfigurationSection) StructureMap.SolrNetIntegration.Config.SolrConfigurationSection
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Member List

StructureMap.SolrNetIntegration.Config.SolrServerElement Member List

This is the complete list of members for StructureMap.SolrNetIntegration.Config.SolrServerElement, including all inherited members.
DocumentType (defined in StructureMap.SolrNetIntegration.Config.SolrServerElement) | StructureMap.SolrNetIntegration.Config.SolrServerElement
Id (defined in StructureMap.SolrNetIntegration.Config.SolrServerElement) | StructureMap.SolrNetIntegration.Config.SolrServerElement
ToString() (defined in StructureMap.SolrNetIntegration.Config.SolrServerElement) | StructureMap.SolrNetIntegration.Config.SolrServerElement
Url (defined in StructureMap.SolrNetIntegration.Config.SolrServerElement) | StructureMap.SolrNetIntegration.Config.SolrServerElement
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Member List

StructureMap.SolrNetIntegration.Config.SolrServers Member List

This is the complete list of members for StructureMap.SolrNetIntegration.Config.SolrServers, including all inherited members.
Add(SolrServerElement configurationElement) (defined in StructureMap.SolrNetIntegration.Config.SolrServers) | StructureMap.SolrNetIntegration.Config.SolrServers |
CollectionType (defined in StructureMap.SolrNetIntegration.Config.SolrServers) | StructureMap.SolrNetIntegration.Config.SolrServers |
CreateNewElement() (defined in StructureMap.SolrNetIntegration.Config.SolrServers) | StructureMap.SolrNetIntegration.Config.SolrServers | [protected]
ElementName (defined in StructureMap.SolrNetIntegration.Config.SolrServers) | StructureMap.SolrNetIntegration.Config.SolrServers | [protected]
GetElementKey(ConfigurationElement element) (defined in StructureMap.SolrNetIntegration.Config.SolrServers) | StructureMap.SolrNetIntegration.Config.SolrServers | [protected]
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Member List

StructureMap.SolrNetIntegration.SolrCore Member List

This is the complete list of members for StructureMap.SolrNetIntegration.SolrCore, including all inherited members.
DocumentType (defined in StructureMap.SolrNetIntegration.SolrCore) | StructureMap.SolrNetIntegration.SolrCore
Id (defined in StructureMap.SolrNetIntegration.SolrCore) | StructureMap.SolrNetIntegration.SolrCore
SolrCore(string id, Type documentType, string url) (defined in StructureMap.SolrNetIntegration.SolrCore) | StructureMap.SolrNetIntegration.SolrCore
Url (defined in StructureMap.SolrNetIntegration.SolrCore) | StructureMap.SolrNetIntegration.SolrCore
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Member List

StructureMap.SolrNetIntegration.SolrNetRegistry Member List

This is the complete list of members for StructureMap.SolrNetIntegration.SolrNetRegistry, including all inherited members.
SolrNetRegistry(SolrServers solrServers) (defined in StructureMap.SolrNetIntegration.SolrNetRegistry) StructureMap.SolrNetIntegration.SolrNetRegistry
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Alphabetical List

Class Index

A | B | C | D | E | F | G | H | I | L | M | N | O | P | Q | R | S | T | U | V | W
A
DSLQueryRange (SolrNet.DSL.Impl) IReadOnlyMappingManager (SolrNet) NHSolrQueryImpl (NHibernate.SolrNet.Impl) SolrFieldAttribute (SolrNet.Attributes)
AbstractFieldSerializer (SolrNet.Impl.FieldSerializers) | DSLRun (SolrNet.DSL.Impl) | ISelfSerializingQuery (SolrNet.Impl) | NotQuerySerializer (SolrNet.Impl.QuerySerializers) | SolrFieldModel (SolrNet)
AbstractSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules)
E
ISolrBasicOperations (SolrNet) NullableDateTimeRangeQuerySerializer (SolrNet.Impl.QuerySerializers) SolrFieldType (SolrNet.Schema)
AbstractSolrQuery (SolrNet) EnumFieldParser (SolrNet.Impl.FieldParsers) ISolrBasicReadOnlyOperations (SolrNet) NullableFieldParser (SolrNet.Impl.FieldParsers) SolrHasValueQuery (SolrNet)
AddCommand (SolrNet.Commands)
F
ISolrCache (SolrNet.Impl) NullableFieldSerializer (SolrNet.Impl.FieldSerializers) SolrMultipleCriteriaQuery (SolrNet)
AggregateDocumentVisitor (SolrNet.Impl.DocumentPropertyVisitors) | FacetDateOther (SolrNet) | ISolrCommand (SolrNet) | NullCache (SolrNet.Impl) | SolrNetException (SolrNet.Exceptions)
AggregateFacetQuerySerializer (SolrNet.Impl.FacetQuerySerializers) FacetParameters (SolrNet.Commands.Parameters) ISolrConnection (SolrNet)
O
SolrNetFacility (Castle.Facilities.SolrNetIntegration)
AggregateFieldParser (SolrNet.Impl.FieldParsers) FacetsResponseParser (SolrNet.Impl.ResponseParsers) ISolrDeleteParam (SolrNet.Commands.Parameters) SolrMultipleCriteriaQuery::Operator (SolrNet) SolrNetListener (NHibernate.SolrNet.Impl)
AggregateFieldSerializer (SolrNet.Impl.FieldSerializers) | FieldDefinition (SolrNet.DSL.Impl) | ISolrDocumentActivator (SolrNet.Impl) | OptimizeCommand (SolrNet.Commands) | SolrNetModule (Ninject.Integration.SolrNet)
AggregateQuerySerializer (SolrNet.Impl.QuerySerializers) FloatFieldParser (SolrNet.Impl.FieldParsers) ISolrDocumentPropertyVisitor (SolrNet.Impl)
P
SolrNetRegistry (StructureMap.SolrNetIntegration)
AllPropertiesMappingManager (SolrNet.Mapping) | FloatSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) | ISolrDocumentResponseParser (SolrNet.Impl) | PingCommand (SolrNet.Commands) | SolrNotQuery (SolrNet)
AttributesMappingManager (SolrNet.Mapping) | FormattableFieldSerializer (SolrNet.Impl.FieldSerializers) | ISolrDocumentSerializer (SolrNet) | PropertyNode (SolrNet.Impl) | SolrQuery (SolrNet)
B
Func (SolrNet.Utils) ISolrFacetQuery (SolrNet)
Q
SolrQueryBoost (SolrNet)
BoolFieldSerializer (SolrNet.Impl.FieldSerializers)
G
ISolrFacetQuerySerializer (SolrNet.Impl) QueryByFieldSerializer (SolrNet.Impl.QuerySerializers) SolrQueryByField (SolrNet)
BoolSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) | GenericDictionaryDocumentVisitor (SolrNet.Impl.DocumentPropertyVisitors) | ISolrFieldParser (SolrNet.Impl) | QueryInListSerializer (SolrNet.Impl.QuerySerializers) | SolrQueryByRange (SolrNet)
BoostQuerySerializer (SolrNet.Impl.QuerySerializers) | GenericDictionaryFieldSerializer (SolrNet.Impl.FieldSerializers) | ISolrFieldSerializer (SolrNet.Impl) | QueryOptions (SolrNet.Commands.Parameters) | SolrQueryExecuter (SolrNet.Impl)
C
GetSchemaCommand (SolrNet.Commands) ISolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules)
R
SolrQueryInList (SolrNet)
CfgHelper (NHibernate.SolrNet) | GuidFieldParser (SolrNet.Impl.FieldParsers) | ISolrHeaderResponseParser (SolrNet.Impl) | RandomSortOrder (SolrNet) | SolrQueryResultParser (SolrNet.Impl)
CollapsedDocument (SolrNet)
H
ISolrOperations (SolrNet) RangeDefinition (SolrNet.DSL.Impl) SolrQueryResults (SolrNet.Impl)
CollapseParameters (SolrNet.Commands.Parameters) HasValueQuerySerializer (SolrNet.Impl.QuerySerializers) ISolrQuery (SolrNet) RangeQuerySerializer (SolrNet.Impl.QuerySerializers) SolrSchema (SolrNet.Schema)
CollapseResponseParser (SolrNet.Impl.ResponseParsers) | HeaderResponseParser (SolrNet.Impl.ResponseParsers) | ISolrQueryByRange (SolrNet.Impl) | RegularDocumentVisitor (SolrNet.Impl.DocumentPropertyVisitors) | SolrSchemaParser (SolrNet.Schema)
CollapseResults (SolrNet) | HighlightingParameters (SolrNet.Commands.Parameters) | ISolrQueryExecuter (SolrNet) | RequiredFieldsAreMappedRule (SolrNet.Mapping.Validation.Rules) | SolrServer (SolrNet.Impl)
CollectionFieldParser (SolrNet.Impl.FieldParsers) HighlightingResponseParser (SolrNet.Impl.ResponseParsers) ISolrQueryResultParser (SolrNet) ResponseHeader (SolrNet) SolrServerElement (StructureMap.SolrNetIntegration.Config)
CollectionFieldSerializer (SolrNet.Impl.FieldSerializers) | HttpRuntimeCache (SolrNet.Impl) | ISolrQueryResults (SolrNet) | ResultsResponseParser (SolrNet.Impl.ResponseParsers) | SolrServers (StructureMap.SolrNetIntegration.Config)
CommitCommand (SolrNet.Commands) | HttpWebRequestAdapter (HttpWebAdapters.Adapters) | ISolrQuerySerializer (SolrNet.Impl) | RollbackCommand (SolrNet.Commands) | SolrSession (NHibernate.SolrNet)
CommitOptions (SolrNet.Commands.Parameters) HttpWebRequestFactory (HttpWebAdapters) ISolrReadOnlyOperations (SolrNet)
S
SolrUniqueKeyAttribute (SolrNet.Attributes)
Container (SolrNet.Utils) | HttpWebRequestMethod (HttpWebAdapters) | ISolrResponseParser (SolrNet.Impl) | SelfSerializingQuerySerializer (SolrNet.Impl.QuerySerializers) | SortOrder (SolrNet)
D
HttpWebResponseAdapter (HttpWebAdapters.Adapters) ISolrSchemaParser (SolrNet.Schema) SingleTypeFacetQuerySerializer (SolrNet.Impl.FacetQuerySerializers) SpellCheckingParameters (SolrNet.Commands.Parameters)
DateFacetingResult (SolrNet)
I
ISolrSession (NHibernate.SolrNet) SingleTypeQuerySerializer (SolrNet.Impl.QuerySerializers) SpellCheckResponseParser (SolrNet.Impl.ResponseParsers)
DateTimeFieldParser (SolrNet.Impl.FieldParsers) | ICommitSetting (NHibernate.SolrNet.Impl) | IValidationRule (SolrNet.Mapping.Validation.Rules) | SolrBasicServer (SolrNet.Impl) | SpellCheckResult (SolrNet.Impl)
DateTimeFieldSerializer (SolrNet.Impl.FieldSerializers) IContainer (SolrNet.Utils)
L
SolrCacheEntity (SolrNet.Impl) SpellCheckResults (SolrNet.Impl)
DateTimeRangeQuerySerializer (SolrNet.Impl.QuerySerializers) | IDSLFacetFieldOptions (SolrNet.DSL.Impl) | Local (Rhino.Commons) | SolrConfigurationSection (StructureMap.SolrNetIntegration.Config) | StatsParameters (SolrNet.Commands.Parameters)
DateTimeSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) | IDSLQuery (SolrNet.DSL.Impl) | LocalParams (SolrNet) | SolrConnection (SolrNet.Impl) | StatsResponseParser (SolrNet.Impl.ResponseParsers)
DecimalFieldParser (SolrNet.Impl.FieldParsers) IDSLQueryBetween (SolrNet.DSL.Impl) LocalParams::LocalParamsQuery (SolrNet) SolrConnectionException (SolrNet.Exceptions) StatsResult (SolrNet)
DecimalSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) IDSLQueryBy (SolrNet.DSL.Impl) LocalParamsSerializer (SolrNet.Impl.QuerySerializers) SolrCopyField (SolrNet.Schema) StrictArrayResolver (Castle.Facilities.SolrNetIntegration)
DefaultDocumentVisitor (SolrNet.Impl.DocumentPropertyVisitors) IDSLQueryRange (SolrNet.DSL.Impl) LongFieldParser (SolrNet.Impl.FieldParsers) SolrCore (Castle.Facilities.SolrNetIntegration) StringSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules)
DefaultFacetQuerySerializer (SolrNet.Impl.FacetQuerySerializers) IDSLRun (SolrNet.DSL.Impl) LongSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) SolrCore (StructureMap.SolrNetIntegration)
T
DefaultFieldParser (SolrNet.Impl.FieldParsers) IHttpWebRequest (HttpWebAdapters)
M
SolrDictionaryDocumentResponseParser (SolrNet.Impl) ToStringFieldSerializer (SolrNet.Impl.FieldSerializers)
DefaultFieldSerializer (SolrNet.Impl.FieldSerializers) | IHttpWebRequestFactory (HttpWebAdapters) | MappedPropertiesIsInSolrSchemaRule (SolrNet.Mapping.Validation.Rules) | SolrDictionarySerializer (SolrNet.Impl) | TypeConvertingFieldParser (SolrNet.Impl.FieldParsers)
DefaultQuerySerializer (SolrNet.Impl.QuerySerializers) | IHttpWebResponse (HttpWebAdapters) | MappingManager (SolrNet.Mapping) | SolrDocumentActivator (SolrNet.Impl) | TypeConvertingFieldSerializer (SolrNet.Impl.FieldSerializers)
DelegatingSession (NHibernate.SolrNet.Impl) | ILocalData (Rhino.Commons.LocalDataImpl) | MappingTypesAreCompatibleWithSolrTypesRule (SolrNet.Mapping.Validation.Rules) | SolrDocumentResponseParser (SolrNet.Impl) | TypeNotSupportedException (SolrNet.Exceptions)
DeleteBy (SolrNet.DSL.Impl) IMappingManager (SolrNet.Mapping) MappingValidator (SolrNet.Mapping.Validation) SolrDocumentSerializer (SolrNet.Impl)
U
DeleteByIdAndOrQueryParam (SolrNet.Commands.Parameters) IMappingValidator (SolrNet.Mapping.Validation) Memoizer (SolrNet.Utils) SolrDynamicField (SolrNet.Schema) UniqueKeyMatchesMappingRule (SolrNet.Mapping.Validation.Rules)
DeleteCommand (SolrNet.Commands) InferringFieldParser (SolrNet.Impl.FieldParsers) MemoizingMappingManager (SolrNet.Mapping) SolrFacetDateQuery (SolrNet)
V
DoubleFieldParser (SolrNet.Impl.FieldParsers) INHSolrQuery (NHibernate.SolrNet) MoreLikeThisParameters (SolrNet.Commands.Parameters) SolrFacetDateQuerySerializer (SolrNet.Impl.FacetQuerySerializers) ValidationError (SolrNet.Mapping.Validation)
DoubleSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) IntFieldParser (SolrNet.Impl.FieldParsers) MoreLikeThisResponseParser (SolrNet.Impl.ResponseParsers) SolrFacetFieldQuery (SolrNet) ValidationResult (SolrNet.Mapping.Validation)
DSLFacetFieldOptions (SolrNet.DSL.Impl) IntSolrFieldTypeChecker (SolrNet.Mapping.Validation.Rules) MultipleCriteriaQuerySerializer (SolrNet.Impl.QuerySerializers) SolrFacetFieldQuerySerializer (SolrNet.Impl.FacetQuerySerializers) ValidationWarning (SolrNet.Mapping.Validation)
DSLQuery (SolrNet.DSL.Impl) InvalidFieldException (SolrNet.Exceptions) MultivaluedMappedToCollectionRule (SolrNet.Mapping.Validation.Rules) SolrFacetQuery (SolrNet)
W
DSLQueryBetween (SolrNet.DSL.Impl) InvalidSortOrderException (SolrNet.Exceptions)
N
SolrFacetQuerySerializer (SolrNet.Impl.FacetQuerySerializers) WebResponseStub (HttpWebAdapters)
DSLQueryBy (SolrNet.DSL.Impl) InvalidURLException (SolrNet.Exceptions) NHHelper (NHibernate.SolrNet.Impl) SolrField (SolrNet.Schema)
A | B | C | D | E | F | G | H | I | L | M | N | O | P | Q | R | S | T | U | V | W
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KeepAlive : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • KVKey() : SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
  • KVValue() : SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LastModified : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub
  • Limit : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • LimitTo() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • List() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • List< T >() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • LockModes : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • LongSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • Mapper : Castle.Facilities.SolrNetIntegration.SolrNetFacility
  • MappingValidator() : SolrNet.Mapping.Validation.MappingValidator
  • Max : SolrNet.StatsResult
  • MaxDocs : SolrNet.Commands.Parameters.CollapseParameters
  • MaximumAutomaticRedirections : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • MaximumResponseHeadersLength : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • MaxQueryTerms : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MaxScore : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • MaxSegments : SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions
  • MaxTokens : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MaxWordLength : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Mean : SolrNet.StatsResult
  • MediaType : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Memoize< TArg, TResult >() : SolrNet.Utils.Memoizer
  • Message : SolrNet.Mapping.Validation.ValidationResult
  • Method : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.WebResponseStub , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • Min : SolrNet.StatsResult
  • MinCount : SolrNet.SolrFacetFieldQuery , SolrNet.Commands.Parameters.FacetParameters
  • MinDocFreq : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MinTermFreq : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MinWordLength : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Missing : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery , SolrNet.StatsResult
  • MoreLikeThis : SolrNet.Commands.Parameters.QueryOptions
  • MoreLikeThisParameters() : SolrNet.Commands.Parameters.MoreLikeThisParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name : SolrNet.Schema.SolrDynamicField , SolrNet.Schema.SolrField , SolrNet.Schema.SolrFieldType
  • NewDictionary() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
  • None : SolrNet.FacetDateOther
  • Not() : SolrNet.AbstractSolrQuery
  • NumFound : SolrNet.ISolrQueryResults< T > , SolrNet.Impl.SolrQueryResults< T > , SolrNet.Impl.SpellCheckResult
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • Offset : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • OnlyMorePopular : SolrNet.Commands.Parameters.SpellCheckingParameters
  • OpenSession() : NHibernate.SolrNet.CfgHelper
  • Oper : SolrNet.SolrMultipleCriteriaQuery
  • Optimize() : SolrNet.Impl.SolrServer< T > , SolrNet.ISolrBasicOperations< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrBasicServer< T >
  • OrderBy : SolrNet.Commands.Parameters.QueryOptions
  • Other : SolrNet.SolrFacetDateQuery
  • OtherResults : SolrNet.DateFacetingResult
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • Before : SolrNet.FacetDateOther
  • BeforeTerm : SolrNet.Commands.Parameters.HighlightingParameters
  • Between : SolrNet.FacetDateOther
  • BoolSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker
  • Boost() : SolrNet.AbstractSolrQuery , SolrNet.SolrFieldModel , SolrNet.Attributes.SolrFieldAttribute , SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Build : SolrNet.Commands.Parameters.SpellCheckingParameters
  • BuildSpellCheckDictionary() : SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrServer< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • Cache : SolrNet.Impl.SolrConnection
  • CanHandleSolrType() : SolrNet.Impl.FieldParsers.AggregateFieldParser , SolrNet.Impl.FieldParsers.DateTimeFieldParser , SolrNet.Impl.FieldParsers.EnumFieldParser , SolrNet.Impl.ISolrFieldParser , SolrNet.Impl.FieldParsers.FloatFieldParser , SolrNet.Impl.FieldParsers.DecimalFieldParser , SolrNet.Impl.FieldParsers.GuidFieldParser , SolrNet.Impl.FieldParsers.InferringFieldParser , SolrNet.Impl.FieldParsers.CollectionFieldParser , SolrNet.Impl.FieldParsers.DefaultFieldParser , SolrNet.Impl.FieldParsers.IntFieldParser , SolrNet.Impl.FieldParsers.LongFieldParser , SolrNet.Impl.FieldParsers.DoubleFieldParser , SolrNet.Impl.FieldParsers.NullableFieldParser , SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • CanHandleType() : SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > , SolrNet.Impl.FieldSerializers.AggregateFieldSerializer , SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor , SolrNet.Impl.FieldSerializers.CollectionFieldSerializer , SolrNet.Impl.FieldSerializers.DefaultFieldSerializer , SolrNet.Impl.FieldParsers.AggregateFieldParser , SolrNet.Impl.FieldSerializers.FormattableFieldSerializer , SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer , SolrNet.Impl.FieldParsers.CollectionFieldParser , SolrNet.Impl.FieldSerializers.NullableFieldSerializer , SolrNet.Impl.FieldSerializers.ToStringFieldSerializer , SolrNet.Impl.FieldParsers.DateTimeFieldParser , SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer , SolrNet.Impl.ISolrFieldParser , SolrNet.Impl.FieldParsers.DecimalFieldParser , SolrNet.Impl.ISolrFieldSerializer , SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker , SolrNet.Impl.FieldParsers.DefaultFieldParser , SolrNet.Impl.FieldParsers.DoubleFieldParser , SolrNet.Impl.FieldParsers.EnumFieldParser , SolrNet.Impl.FieldParsers.FloatFieldParser , SolrNet.Impl.FieldParsers.GuidFieldParser , SolrNet.Impl.FieldParsers.InferringFieldParser , SolrNet.Impl.FieldParsers.IntFieldParser , SolrNet.Impl.FieldParsers.LongFieldParser , SolrNet.Impl.FieldParsers.NullableFieldParser , SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • CfgHelper() : NHibernate.SolrNet.CfgHelper
  • CharacterSet : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub
  • Clear() : SolrNet.Impl.SolrQueryResults< T > , SolrNet.Utils.Container
  • ClientCertificates : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Close() : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • Collapse : SolrNet.Commands.Parameters.QueryOptions
  • CollapseCount : SolrNet.CollapsedDocument
  • CollapsedDocuments : SolrNet.CollapseResults
  • Collapsing : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Collate : SolrNet.Commands.Parameters.SpellCheckingParameters
  • Collation : SolrNet.Impl.SpellCheckResults
  • Commit : NHibernate.SolrNet.Impl.ICommitSetting , NHibernate.SolrNet.Impl.SolrNetListener< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrBasicOperations< T > , SolrNet.ISolrOperations< T >
  • CommitOptions() : SolrNet.Commands.Parameters.CommitOptions
  • Configure() : NHibernate.SolrNet.CfgHelper
  • Connection : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • ConnectionGroupName : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Container() : SolrNet.Utils.Container
  • Contains() : SolrNet.Impl.SolrQueryResults< T >
  • ContentEncoding : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse
  • ContentLength : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebResponse
  • ContentType : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebRequest
  • Convert< R >() : SolrNet.Utils.Func
  • CookieContainer : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Cookies : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.WebResponseStub , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • CopyTo() : SolrNet.Impl.SolrQueryResults< T >
  • Count : SolrNet.StatsResult , SolrNet.Impl.SolrQueryResults< T > , SolrNet.Commands.Parameters.SpellCheckingParameters , SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Create() : SolrNet.Impl.SolrDocumentActivator< T > , SolrNet.SolrMultipleCriteriaQuery , SolrNet.Impl.ISolrDocumentActivator< T >
  • Create< T >() : SolrNet.SolrMultipleCriteriaQuery
  • CreateSolrQuery() : NHibernate.SolrNet.SolrSession , NHibernate.SolrNet.ISolrSession , NHibernate.SolrNet.SolrSession
  • Credentials : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • Data : SolrNet.Impl.SolrCacheEntity
  • DateFacetingResult() : SolrNet.DateFacetingResult
  • DateResults : SolrNet.DateFacetingResult
  • DateTimeSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker
  • DefaultDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor
  • DefaultFieldParser() : SolrNet.Impl.FieldParsers.DefaultFieldParser
  • DefaultRows : SolrNet.Impl.SolrQueryExecuter< T >
  • Delete() : SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrBasicOperations< T > , SolrNet.ISolrOperations< T >
  • Destination : SolrNet.Schema.SolrCopyField
  • Dictionary : SolrNet.Commands.Parameters.SpellCheckingParameters
  • Dispose() : HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • DontSortByCount() : SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > , SolrNet.DSL.Impl.DSLFacetFieldOptions< T >
  • DoubleSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • End : SolrNet.DateFacetingResult
  • EndGetRequestStream() : HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • EndOffset : SolrNet.Impl.SpellCheckResult
  • EnumCacheMinDf : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • Enumerable() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • Enumerable< T >() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • EnumerateValidationResults() : SolrNet.Mapping.Validation.IMappingValidator , SolrNet.Mapping.Validation.MappingValidator
  • ETag : SolrNet.Impl.SolrCacheEntity
  • Execute() : SolrNet.ISolrCommand , SolrNet.Commands.PingCommand , SolrNet.Commands.RollbackCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Impl.SolrQueryExecuter< T > , SolrNet.ISolrQueryExecuter< T > , SolrNet.Commands.AddCommand< T > , SolrNet.Commands.CommitCommand , SolrNet.Commands.DeleteCommand , SolrNet.Commands.GetSchemaCommand
  • ExecuteUpdate() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • Expect : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • ExpungeDeletes : SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions , SolrNet.Commands.CommitCommand
  • ExtraParams : SolrNet.Commands.Parameters.QueryOptions
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • Facet : SolrNet.Commands.Parameters.QueryOptions
  • FacetDates : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • FacetFieldQuery() : SolrNet.Impl.SolrServer< T > , SolrNet.ISolrReadOnlyOperations< T >
  • FacetFields : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • FacetMode : SolrNet.Commands.Parameters.CollapseParameters
  • FacetQueries : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • FacetResults : SolrNet.StatsResult
  • Facets : SolrNet.Commands.Parameters.StatsParameters
  • Factor : SolrNet.SolrQueryBoost
  • Field : SolrNet.SolrFacetFieldQuery , SolrNet.CollapseResults , SolrNet.Commands.Parameters.CollapseParameters
  • FieldName : SolrNet.Attributes.SolrFieldAttribute , SolrNet.SolrFieldModel
  • FieldNameSuffix : SolrNet.Impl.PropertyNode
  • Fields : SolrNet.Commands.Parameters.HighlightingParameters , SolrNet.Commands.Parameters.MoreLikeThisParameters , SolrNet.Commands.Parameters.QueryOptions
  • FieldsWithFacets : SolrNet.Commands.Parameters.StatsParameters
  • FieldValue : SolrNet.Impl.PropertyNode
  • FilterQueries : SolrNet.Commands.Parameters.QueryOptions
  • FindSolrFieldByName() : SolrNet.Schema.SolrSchema
  • FloatSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker
  • Fragsize : SolrNet.Commands.Parameters.HighlightingParameters
  • FromCommitted : SolrNet.Commands.DeleteCommand
  • FromPending : SolrNet.Commands.DeleteCommand
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • Gap : SolrNet.DateFacetingResult
  • GenericDictionaryDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
  • Get() : SolrNet.ISolrConnection , SolrNet.Impl.SolrConnection
  • GetAllParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetCollapseQueryOptions() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetFacetFieldOptions() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetFields() : SolrNet.IReadOnlyMappingManager , SolrNet.Mapping.AllPropertiesMappingManager , SolrNet.Mapping.AttributesMappingManager , SolrNet.Mapping.MappingManager , SolrNet.Mapping.MemoizingMappingManager
  • GetFilterQueries() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetHighlightingParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetMoreLikeThisParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetRequestStream() : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • GetResponseHeader() : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.WebResponseStub
  • GetResponseStream() : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • GetSchema() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrBasicReadOnlyOperations< T >
  • GetSpellCheckingParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetStatsQueryOptions() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetUnderlyingType() : SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • GetUniqueKey() : SolrNet.Mapping.MappingManager , SolrNet.Mapping.AttributesMappingManager , SolrNet.Mapping.AllPropertiesMappingManager , SolrNet.Mapping.MemoizingMappingManager , SolrNet.IReadOnlyMappingManager
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HardEnd : SolrNet.SolrFacetDateQuery
  • HaveResponse : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Header : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Headers : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.IHttpWebRequest
  • Highlight : SolrNet.Commands.Parameters.QueryOptions
  • Highlights : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • HttpWebRequestFactory : SolrNet.Impl.SolrConnection
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Id : SolrNet.CollapsedDocument
  • IfModifiedSince : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • IgnoredFieldNames : SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule
  • IncludeMissing() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • IndexOf() : SolrNet.Impl.SolrQueryResults< T >
  • Insert() : SolrNet.Impl.SolrQueryResults< T >
  • IntSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker
  • InvalidFieldException() : SolrNet.Exceptions.InvalidFieldException
  • InvalidURLException() : SolrNet.Exceptions.InvalidURLException
  • IsFromCache : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • IsMultiValued : SolrNet.Schema.SolrField
  • IsMutuallyAuthenticated : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • IsReadOnly : SolrNet.Impl.SolrQueryResults< T >
  • IsRequired : SolrNet.Schema.SolrField
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Params : SolrNet.ResponseHeader
  • Parse() : SolrNet.Impl.FieldParsers.AggregateFieldParser , SolrNet.Impl.FieldParsers.DateTimeFieldParser , SolrNet.Impl.FieldParsers.EnumFieldParser , SolrNet.Impl.ISolrFieldParser , SolrNet.Impl.ISolrResponseParser< T > , SolrNet.Impl.FieldParsers.FloatFieldParser , SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > , SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > , SolrNet.Impl.FieldParsers.DecimalFieldParser , SolrNet.Impl.FieldParsers.GuidFieldParser , SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > , SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > , SolrNet.Impl.FieldParsers.InferringFieldParser , SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > , SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > , SolrNet.Impl.FieldParsers.CollectionFieldParser , SolrNet.Impl.FieldParsers.DefaultFieldParser , SolrNet.Impl.FieldParsers.IntFieldParser , SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > , SolrNet.Impl.ResponseParsers.StatsResponseParser< T > , SolrNet.Impl.FieldParsers.LongFieldParser , SolrNet.Impl.SolrQueryResultParser< T > , SolrNet.ISolrQueryResultParser< T > , SolrNet.Impl.FieldParsers.DoubleFieldParser , SolrNet.Impl.FieldParsers.NullableFieldParser , SolrNet.Schema.ISolrSchemaParser , SolrNet.Schema.SolrSchemaParser , SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • ParseCollapsedResults() : SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >
  • ParseDocument() : SolrNet.Impl.SolrDocumentResponseParser< T >
  • ParseFacetDates() : SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
  • ParseFacetFields() : SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
  • ParseFacetQueries() : SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
  • ParseHeader() : SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
  • ParseHighlighting() : SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
  • ParseHighlightingFields() : SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
  • ParseMoreLikeThis() : SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >
  • ParseResults() : SolrNet.Impl.SolrDocumentResponseParser< T > , SolrNet.Impl.ISolrDocumentResponseParser< T >
  • ParseSpellChecking() : SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >
  • ParseStats() : SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
  • Ping() : SolrNet.ISolrBasicReadOnlyOperations< T > , SolrNet.Impl.SolrServer< T > , SolrNet.Impl.SolrBasicServer< T >
  • Pipelined : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Post() : SolrNet.Impl.SolrConnection , SolrNet.ISolrConnection
  • PreAuthenticate : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Prefix : SolrNet.SolrFacetFieldQuery , SolrNet.Commands.Parameters.FacetParameters
  • Property : SolrNet.SolrFieldModel
  • ProtocolVersion : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Proxy : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QTime : SolrNet.ResponseHeader
  • Queries : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrMultipleCriteriaQuery
  • Query() : SolrNet.ISolrReadOnlyOperations< T > , SolrNet.Commands.Parameters.SpellCheckingParameters , SolrNet.ISolrReadOnlyOperations< T > , SolrNet.ISolrBasicReadOnlyOperations< T > , SolrNet.Impl.SolrServer< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.SolrQuery , SolrNet.Impl.SpellCheckResult , SolrNet.ISolrReadOnlyOperations< T >
  • QueryFields : SolrNet.Commands.Parameters.MoreLikeThisParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RandomSortOrder() : SolrNet.RandomSortOrder
  • ReadWriteTimeout : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Referer : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • RegexMaxAnalyzedChars : SolrNet.Commands.Parameters.HighlightingParameters
  • RegexPattern : SolrNet.Commands.Parameters.HighlightingParameters
  • RegexSlop : SolrNet.Commands.Parameters.HighlightingParameters
  • Register() : SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • Register< T >() : SolrNet.Utils.IContainer , SolrNet.Utils.Container
  • RegularDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor
  • Reload : SolrNet.Commands.Parameters.SpellCheckingParameters
  • Remove() : SolrNet.Impl.SolrQueryResults< T > , SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • Remove< T >() : SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • RemoveAll< T >() : SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • RemoveAt() : SolrNet.Impl.SolrQueryResults< T >
  • RemoveControlCharacters() : SolrNet.Commands.AddCommand< T >
  • RequestUri : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • RequireFieldMatch : SolrNet.Commands.Parameters.HighlightingParameters
  • ResponseUri : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • Rollback() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T >
  • Rows : SolrNet.Commands.Parameters.QueryOptions
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • Send() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T >
  • SendAndParseHeader() : SolrNet.ISolrBasicOperations< T > , SolrNet.Impl.SolrBasicServer< T >
  • SendChunked : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Serialize() : SolrNet.Impl.FieldSerializers.AggregateFieldSerializer , SolrNet.Impl.ISolrFieldSerializer , SolrNet.Impl.SolrDocumentSerializer< T > , SolrNet.Impl.FieldSerializers.CollectionFieldSerializer , SolrNet.ISolrDocumentSerializer< T > , SolrNet.Impl.FieldSerializers.DefaultFieldSerializer , SolrNet.Impl.FieldSerializers.FormattableFieldSerializer , SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer , SolrNet.Impl.FieldSerializers.NullableFieldSerializer , SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > , SolrNet.Impl.FieldSerializers.ToStringFieldSerializer , SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer
  • Server : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub
  • ServicePoint : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • SetFirstResult() : NHibernate.SolrNet.Impl.NHSolrQueryImpl , NHibernate.SolrNet.INHSolrQuery
  • SetKV() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
  • SetLockMode() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • SetMaxResults() : NHibernate.SolrNet.Impl.NHSolrQueryImpl , NHibernate.SolrNet.INHSolrQuery
  • SetSort() : NHibernate.SolrNet.Impl.NHSolrQueryImpl , NHibernate.SolrNet.INHSolrQuery
  • SetUniqueKey() : SolrNet.Mapping.AllPropertiesMappingManager , SolrNet.Mapping.IMappingManager , SolrNet.Mapping.MappingManager
  • SimilarResults : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • SlidingMinutes : SolrNet.Impl.HttpRuntimeCache
  • Snippets : SolrNet.Commands.Parameters.HighlightingParameters
  • SolrCacheEntity() : SolrNet.Impl.SolrCacheEntity
  • SolrConnectionException() : SolrNet.Exceptions.SolrConnectionException
  • SolrCopyFields : SolrNet.Schema.SolrSchema
  • SolrCore() : Castle.Facilities.SolrNetIntegration.SolrCore
  • SolrDynamicFields : SolrNet.Schema.SolrSchema
  • SolrFacetDateQuery() : SolrNet.SolrFacetDateQuery
  • SolrField() : SolrNet.Schema.SolrField
  • SolrFieldAttribute() : SolrNet.Attributes.SolrFieldAttribute
  • SolrFields : SolrNet.Schema.SolrSchema
  • SolrFieldType() : SolrNet.Schema.SolrFieldType
  • SolrFieldTypes : SolrNet.Schema.SolrSchema
  • SolrNetException() : SolrNet.Exceptions.SolrNetException
  • SolrNotQuery() : SolrNet.SolrNotQuery
  • SolrQuery() : SolrNet.SolrQuery
  • SolrQueryBoost() : SolrNet.SolrQueryBoost
  • SolrQueryByField() : SolrNet.SolrQueryByField
  • SolrSchema() : SolrNet.Schema.SolrSchema
  • SolrSession() : NHibernate.SolrNet.SolrSession
  • SolrUniqueKeyAttribute() : SolrNet.Attributes.SolrUniqueKeyAttribute
  • Sort : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • Source : SolrNet.Schema.SolrCopyField
  • SpellCheck : SolrNet.Commands.Parameters.QueryOptions
  • SpellChecking : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Start : SolrNet.Commands.Parameters.QueryOptions
  • StartingAt() : SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > , SolrNet.DSL.Impl.DSLFacetFieldOptions< T >
  • StartOffset : SolrNet.Impl.SpellCheckResult
  • Stats : SolrNet.Commands.Parameters.QueryOptions , SolrNet.ISolrQueryResults< T > , SolrNet.Impl.SolrQueryResults< T >
  • Status : SolrNet.ResponseHeader
  • StatusCode : HttpWebAdapters.WebResponseStub , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebResponse
  • StatusDescription : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse
  • StdDev : SolrNet.StatsResult
  • StringSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker
  • Suggestions : SolrNet.Impl.SpellCheckResult
  • Sum : SolrNet.StatsResult
  • SumOfSquares : SolrNet.StatsResult
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • this : SolrNet.Impl.HttpRuntimeCache , SolrNet.Impl.ISolrCache , SolrNet.Impl.SolrQueryResults< T > , SolrNet.Impl.NullCache
  • Threshold : SolrNet.Commands.Parameters.CollapseParameters
  • Timeout : SolrNet.Impl.SolrConnection , HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • ToXmlNode() : SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam , SolrNet.Commands.Parameters.ISolrDeleteParam
  • TransferEncoding : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Type : SolrNet.Schema.SolrField , SolrNet.Schema.SolrFieldType , SolrNet.Commands.Parameters.CollapseParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UniqueKey : SolrNet.Schema.SolrSchema
  • UnsafeAuthenticatedConnectionSharing : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Url : SolrNet.Impl.SolrCacheEntity
  • UseDefaultCredentials : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • UserAgent : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Validate() : SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker , SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker , SolrNet.Mapping.Validation.Rules.IValidationRule , SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule , SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule , SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule , SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker , SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule , SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule
  • ValidationError() : SolrNet.Mapping.Validation.ValidationError
  • ValidationResult() : SolrNet.Mapping.Validation.ValidationResult
  • ValidationWarning() : SolrNet.Mapping.Validation.ValidationWarning
  • Version : SolrNet.Impl.SolrConnection
  • Visit() : SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor , SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor , SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor , SolrNet.Impl.ISolrDocumentPropertyVisitor , SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WaitFlush : SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions
  • WaitSearcher : SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions
  • WithMinCount() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • WithPrefix() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- a -

  • Abort() : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Add() : SolrNet.Impl.ISolrCache , SolrNet.Impl.SolrServer< T > , SolrNet.Mapping.MappingManager , SolrNet.ISolrOperations< T > , SolrNet.Impl.NullCache , SolrNet.ISolrOperations< T > , SolrNet.Mapping.IMappingManager , SolrNet.Impl.HttpRuntimeCache , SolrNet.Impl.SolrQueryResults< T > , SolrNet.Mapping.IMappingManager , SolrNet.Impl.SolrServer< T > , SolrNet.Mapping.MappingManager
  • AddCore() : Castle.Facilities.SolrNetIntegration.SolrNetFacility
  • AddFacet() : SolrNet.Commands.Parameters.StatsParameters
  • AddField() : SolrNet.Commands.Parameters.StatsParameters
  • AddFieldWithFacet() : SolrNet.Commands.Parameters.StatsParameters
  • AddFieldWithFacets() : SolrNet.Commands.Parameters.StatsParameters
  • AddRange() : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • AddWithBoost() : SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrServer< T >
  • AggregateDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor
  • AggregateFieldParser() : SolrNet.Impl.FieldParsers.AggregateFieldParser
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- k -

  • KVKey() : SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
  • KVValue() : SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- l -

  • LimitTo() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • List() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • List< T >() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • LongSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- m -

  • MappingValidator() : SolrNet.Mapping.Validation.MappingValidator
  • Memoize< TArg, TResult >() : SolrNet.Utils.Memoizer
  • MoreLikeThisParameters() : SolrNet.Commands.Parameters.MoreLikeThisParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- n -

  • NewDictionary() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
  • Not() : SolrNet.AbstractSolrQuery
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- o -

  • OpenSession() : NHibernate.SolrNet.CfgHelper
  • Optimize() : SolrNet.ISolrBasicOperations< T > , SolrNet.Impl.SolrServer< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrOperations< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- b -

  • BoolSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker
  • Boost() : SolrNet.AbstractSolrQuery
  • BuildSpellCheckDictionary() : SolrNet.Impl.SolrServer< T > , SolrNet.ISolrOperations< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- c -

  • CanHandleSolrType() : SolrNet.Impl.FieldParsers.AggregateFieldParser , SolrNet.Impl.FieldParsers.CollectionFieldParser , SolrNet.Impl.FieldParsers.DecimalFieldParser , SolrNet.Impl.FieldParsers.FloatFieldParser , SolrNet.Impl.FieldParsers.GuidFieldParser , SolrNet.Impl.FieldParsers.DefaultFieldParser , SolrNet.Impl.FieldParsers.InferringFieldParser , SolrNet.Impl.FieldParsers.IntFieldParser , SolrNet.Impl.FieldParsers.DateTimeFieldParser , SolrNet.Impl.FieldParsers.DoubleFieldParser , SolrNet.Impl.FieldParsers.LongFieldParser , SolrNet.Impl.FieldParsers.NullableFieldParser , SolrNet.Impl.FieldParsers.EnumFieldParser , SolrNet.Impl.FieldParsers.TypeConvertingFieldParser , SolrNet.Impl.ISolrFieldParser
  • CanHandleType() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor , SolrNet.Impl.FieldSerializers.AggregateFieldSerializer , SolrNet.Impl.FieldSerializers.CollectionFieldSerializer , SolrNet.Impl.FieldParsers.AggregateFieldParser , SolrNet.Impl.FieldSerializers.DefaultFieldSerializer , SolrNet.Impl.FieldSerializers.FormattableFieldSerializer , SolrNet.Impl.FieldParsers.CollectionFieldParser , SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer , SolrNet.Impl.FieldSerializers.NullableFieldSerializer , SolrNet.Impl.FieldParsers.DateTimeFieldParser , SolrNet.Impl.FieldSerializers.ToStringFieldSerializer , SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker , SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer , SolrNet.Impl.FieldParsers.DecimalFieldParser , SolrNet.Impl.ISolrFieldParser , SolrNet.Impl.ISolrFieldSerializer , SolrNet.Impl.FieldParsers.DefaultFieldParser , SolrNet.Impl.FieldParsers.DoubleFieldParser , SolrNet.Impl.FieldParsers.EnumFieldParser , SolrNet.Impl.FieldParsers.FloatFieldParser , SolrNet.Impl.FieldParsers.GuidFieldParser , SolrNet.Impl.FieldParsers.InferringFieldParser , SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > , SolrNet.Impl.FieldParsers.IntFieldParser , SolrNet.Impl.FieldParsers.LongFieldParser , SolrNet.Impl.FieldParsers.NullableFieldParser , SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • CfgHelper() : NHibernate.SolrNet.CfgHelper
  • Clear() : SolrNet.Utils.Container , SolrNet.Impl.SolrQueryResults< T >
  • Close() : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • Commit() : SolrNet.Impl.SolrServer< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T >
  • CommitOptions() : SolrNet.Commands.Parameters.CommitOptions
  • Configure() : NHibernate.SolrNet.CfgHelper
  • Container() : SolrNet.Utils.Container
  • Contains() : SolrNet.Impl.SolrQueryResults< T >
  • Convert< R >() : SolrNet.Utils.Func
  • CopyTo() : SolrNet.Impl.SolrQueryResults< T >
  • Create() : SolrNet.Impl.ISolrDocumentActivator< T > , SolrNet.Impl.SolrDocumentActivator< T > , SolrNet.SolrMultipleCriteriaQuery
  • Create< T >() : SolrNet.SolrMultipleCriteriaQuery
  • CreateSolrQuery() : NHibernate.SolrNet.ISolrSession , NHibernate.SolrNet.SolrSession
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- d -

  • DateFacetingResult() : SolrNet.DateFacetingResult
  • DateTimeSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker
  • DefaultDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor
  • DefaultFieldParser() : SolrNet.Impl.FieldParsers.DefaultFieldParser
  • Delete() : SolrNet.Impl.SolrServer< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrOperations< T > , SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T > , SolrNet.Impl.SolrServer< T > , SolrNet.ISolrOperations< T >
  • Dispose() : HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • DontSortByCount() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • DoubleSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- e -

  • EndGetRequestStream() : HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Enumerable() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • Enumerable< T >() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • EnumerateValidationResults() : SolrNet.Mapping.Validation.IMappingValidator , SolrNet.Mapping.Validation.MappingValidator
  • Execute() : SolrNet.Commands.RollbackCommand , SolrNet.Commands.PingCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.GetSchemaCommand , SolrNet.Impl.SolrQueryExecuter< T > , SolrNet.Commands.CommitCommand , SolrNet.Commands.AddCommand< T > , SolrNet.ISolrCommand , SolrNet.Commands.DeleteCommand , SolrNet.ISolrQueryExecuter< T >
  • ExecuteUpdate() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- f -

  • FacetFieldQuery() : SolrNet.Impl.SolrServer< T > , SolrNet.ISolrReadOnlyOperations< T >
  • FindSolrFieldByName() : SolrNet.Schema.SolrSchema
  • FloatSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- g -

  • GenericDictionaryDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
  • Get() : SolrNet.Impl.SolrConnection , SolrNet.ISolrConnection
  • GetAllParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetCollapseQueryOptions() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetFacetFieldOptions() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetFields() : SolrNet.Mapping.AllPropertiesMappingManager , SolrNet.Mapping.AttributesMappingManager , SolrNet.Mapping.MappingManager , SolrNet.Mapping.MemoizingMappingManager , SolrNet.IReadOnlyMappingManager
  • GetFilterQueries() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetHighlightingParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetMoreLikeThisParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetRequestStream() : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • GetResponseHeader() : HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • GetResponseStream() : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • GetSchema() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicReadOnlyOperations< T > , SolrNet.Impl.SolrServer< T >
  • GetSpellCheckingParameters() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetStatsQueryOptions() : SolrNet.Impl.SolrQueryExecuter< T >
  • GetUnderlyingType() : SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • GetUniqueKey() : SolrNet.IReadOnlyMappingManager , SolrNet.Mapping.AllPropertiesMappingManager , SolrNet.Mapping.MemoizingMappingManager , SolrNet.Mapping.MappingManager , SolrNet.Mapping.AttributesMappingManager
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- i -

  • IncludeMissing() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • IndexOf() : SolrNet.Impl.SolrQueryResults< T >
  • Insert() : SolrNet.Impl.SolrQueryResults< T >
  • IntSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker
  • InvalidFieldException() : SolrNet.Exceptions.InvalidFieldException
  • InvalidURLException() : SolrNet.Exceptions.InvalidURLException
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- p -

  • Parse() : SolrNet.Impl.FieldParsers.AggregateFieldParser , SolrNet.Impl.FieldParsers.CollectionFieldParser , SolrNet.Impl.FieldParsers.DecimalFieldParser , SolrNet.Impl.FieldParsers.FloatFieldParser , SolrNet.Impl.ISolrResponseParser< T > , SolrNet.Impl.ResponseParsers.CollapseResponseParser< T > , SolrNet.Impl.FieldParsers.GuidFieldParser , SolrNet.Impl.ResponseParsers.FacetsResponseParser< T > , SolrNet.Impl.ResponseParsers.HeaderResponseParser< T > , SolrNet.Impl.FieldParsers.DefaultFieldParser , SolrNet.Impl.FieldParsers.InferringFieldParser , SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T > , SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T > , SolrNet.Impl.FieldParsers.IntFieldParser , SolrNet.Impl.ResponseParsers.ResultsResponseParser< T > , SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T > , SolrNet.Impl.FieldParsers.DateTimeFieldParser , SolrNet.Impl.FieldParsers.DoubleFieldParser , SolrNet.Impl.FieldParsers.LongFieldParser , SolrNet.Schema.SolrSchemaParser , SolrNet.Schema.ISolrSchemaParser , SolrNet.ISolrQueryResultParser< T > , SolrNet.Impl.ResponseParsers.StatsResponseParser< T > , SolrNet.Impl.SolrQueryResultParser< T > , SolrNet.Impl.FieldParsers.NullableFieldParser , SolrNet.Impl.FieldParsers.EnumFieldParser , SolrNet.Impl.FieldParsers.TypeConvertingFieldParser , SolrNet.Impl.ISolrFieldParser
  • ParseCollapsedResults() : SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >
  • ParseDocument() : SolrNet.Impl.SolrDocumentResponseParser< T >
  • ParseFacetDates() : SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
  • ParseFacetFields() : SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
  • ParseFacetQueries() : SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
  • ParseHeader() : SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
  • ParseHighlighting() : SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
  • ParseHighlightingFields() : SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
  • ParseMoreLikeThis() : SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >
  • ParseResults() : SolrNet.Impl.SolrDocumentResponseParser< T > , SolrNet.Impl.ISolrDocumentResponseParser< T >
  • ParseSpellChecking() : SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >
  • ParseStats() : SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
  • Ping() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicReadOnlyOperations< T > , SolrNet.Impl.SolrServer< T >
  • Post() : SolrNet.Impl.SolrConnection , SolrNet.ISolrConnection
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- q -

  • Query() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrReadOnlyOperations< T > , SolrNet.ISolrBasicReadOnlyOperations< T > , SolrNet.Impl.SolrServer< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- r -

  • RandomSortOrder() : SolrNet.RandomSortOrder
  • Register() : SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • Register< T >() : SolrNet.Utils.Container , SolrNet.Utils.IContainer , SolrNet.Utils.Container
  • RegularDocumentVisitor() : SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor
  • Remove() : SolrNet.Impl.SolrQueryResults< T > , SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • Remove< T >() : SolrNet.Utils.Container , SolrNet.Utils.IContainer
  • RemoveAll< T >() : SolrNet.Utils.IContainer , SolrNet.Utils.Container
  • RemoveAt() : SolrNet.Impl.SolrQueryResults< T >
  • RemoveControlCharacters() : SolrNet.Commands.AddCommand< T >
  • Rollback() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- s -

  • Send() : SolrNet.Impl.SolrBasicServer< T > , SolrNet.ISolrBasicOperations< T >
  • SendAndParseHeader() : SolrNet.ISolrBasicOperations< T > , SolrNet.Impl.SolrBasicServer< T >
  • Serialize() : SolrNet.Impl.FieldSerializers.DefaultFieldSerializer , SolrNet.ISolrDocumentSerializer< T > , SolrNet.Impl.FieldSerializers.FormattableFieldSerializer , SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T > , SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer , SolrNet.Impl.FieldSerializers.NullableFieldSerializer , SolrNet.Impl.FieldSerializers.AggregateFieldSerializer , SolrNet.Impl.FieldSerializers.ToStringFieldSerializer , SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer , SolrNet.Impl.FieldSerializers.CollectionFieldSerializer , SolrNet.Impl.ISolrFieldSerializer , SolrNet.Impl.SolrDocumentSerializer< T >
  • SetFirstResult() : NHibernate.SolrNet.Impl.NHSolrQueryImpl , NHibernate.SolrNet.INHSolrQuery
  • SetKV() : SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
  • SetLockMode() : NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • SetMaxResults() : NHibernate.SolrNet.Impl.NHSolrQueryImpl , NHibernate.SolrNet.INHSolrQuery
  • SetSort() : NHibernate.SolrNet.Impl.NHSolrQueryImpl , NHibernate.SolrNet.INHSolrQuery
  • SetUniqueKey() : SolrNet.Mapping.AllPropertiesMappingManager , SolrNet.Mapping.IMappingManager , SolrNet.Mapping.MappingManager
  • SolrCacheEntity() : SolrNet.Impl.SolrCacheEntity
  • SolrConnectionException() : SolrNet.Exceptions.SolrConnectionException
  • SolrCore() : Castle.Facilities.SolrNetIntegration.SolrCore
  • SolrFacetDateQuery() : SolrNet.SolrFacetDateQuery
  • SolrField() : SolrNet.Schema.SolrField
  • SolrFieldAttribute() : SolrNet.Attributes.SolrFieldAttribute
  • SolrFieldType() : SolrNet.Schema.SolrFieldType
  • SolrNetException() : SolrNet.Exceptions.SolrNetException
  • SolrNotQuery() : SolrNet.SolrNotQuery
  • SolrQuery() : SolrNet.SolrQuery
  • SolrQueryBoost() : SolrNet.SolrQueryBoost
  • SolrQueryByField() : SolrNet.SolrQueryByField
  • SolrSchema() : SolrNet.Schema.SolrSchema
  • SolrSession() : NHibernate.SolrNet.SolrSession
  • SolrUniqueKeyAttribute() : SolrNet.Attributes.SolrUniqueKeyAttribute
  • StartingAt() : SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > , SolrNet.DSL.Impl.DSLFacetFieldOptions< T >
  • StringSolrFieldTypeChecker() : SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- t -

  • ToXmlNode() : SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam , SolrNet.Commands.Parameters.ISolrDeleteParam
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- v -

  • Validate() : SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker , SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker , SolrNet.Mapping.Validation.Rules.IValidationRule , SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule , SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule , SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule , SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker , SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule , SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule
  • ValidationError() : SolrNet.Mapping.Validation.ValidationError
  • ValidationResult() : SolrNet.Mapping.Validation.ValidationResult
  • ValidationWarning() : SolrNet.Mapping.Validation.ValidationWarning
  • Visit() : SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor , SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor , SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor , SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor , SolrNet.Impl.ISolrDocumentPropertyVisitor
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- w -

  • WithMinCount() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
  • WithPrefix() : SolrNet.DSL.Impl.DSLFacetFieldOptions< T > , SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • Accept : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Address : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • After : SolrNet.FacetDateOther
  • AfterTerm : SolrNet.Commands.Parameters.HighlightingParameters
  • All : SolrNet.SolrQuery , SolrNet.FacetDateOther
  • AllowAutoRedirect : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • AllowWriteStreamBuffering : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • AlternateField : SolrNet.Commands.Parameters.HighlightingParameters
  • AutomaticDecompression : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • KeepAlive : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • LastModified : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub
  • Limit : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • LockModes : NHibernate.SolrNet.Impl.NHSolrQueryImpl
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • Mapper : Castle.Facilities.SolrNetIntegration.SolrNetFacility
  • Max : SolrNet.StatsResult
  • MaxDocs : SolrNet.Commands.Parameters.CollapseParameters
  • MaximumAutomaticRedirections : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • MaximumResponseHeadersLength : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • MaxQueryTerms : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MaxScore : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • MaxSegments : SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions
  • MaxTokens : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MaxWordLength : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Mean : SolrNet.StatsResult
  • MediaType : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Message : SolrNet.Mapping.Validation.ValidationResult
  • Method : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub
  • Min : SolrNet.StatsResult
  • MinCount : SolrNet.SolrFacetFieldQuery , SolrNet.Commands.Parameters.FacetParameters
  • MinDocFreq : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MinTermFreq : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • MinWordLength : SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Missing : SolrNet.SolrFacetFieldQuery , SolrNet.StatsResult , SolrNet.Commands.Parameters.FacetParameters
  • MoreLikeThis : SolrNet.Commands.Parameters.QueryOptions
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • Name : SolrNet.Schema.SolrDynamicField , SolrNet.Schema.SolrField , SolrNet.Schema.SolrFieldType
  • None : SolrNet.FacetDateOther
  • NumFound : SolrNet.ISolrQueryResults< T > , SolrNet.Impl.SpellCheckResult , SolrNet.Impl.SolrQueryResults< T >
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • Offset : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • OnlyMorePopular : SolrNet.Commands.Parameters.SpellCheckingParameters
  • Oper : SolrNet.SolrMultipleCriteriaQuery
  • OrderBy : SolrNet.Commands.Parameters.QueryOptions
  • Other : SolrNet.SolrFacetDateQuery
  • OtherResults : SolrNet.DateFacetingResult
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • Before : SolrNet.FacetDateOther
  • BeforeTerm : SolrNet.Commands.Parameters.HighlightingParameters
  • Between : SolrNet.FacetDateOther
  • Boost : SolrNet.Commands.Parameters.MoreLikeThisParameters , SolrNet.Attributes.SolrFieldAttribute , SolrNet.SolrFieldModel
  • Build : SolrNet.Commands.Parameters.SpellCheckingParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • Cache : SolrNet.Impl.SolrConnection
  • CharacterSet : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.WebResponseStub , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • ClientCertificates : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Collapse : SolrNet.Commands.Parameters.QueryOptions
  • CollapseCount : SolrNet.CollapsedDocument
  • CollapsedDocuments : SolrNet.CollapseResults
  • Collapsing : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Collate : SolrNet.Commands.Parameters.SpellCheckingParameters
  • Collation : SolrNet.Impl.SpellCheckResults
  • Commit : NHibernate.SolrNet.Impl.ICommitSetting , NHibernate.SolrNet.Impl.SolrNetListener< T >
  • Connection : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • ConnectionGroupName : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • ContentEncoding : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub
  • ContentLength : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • ContentType : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebResponse
  • CookieContainer : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • Cookies : HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • Count : SolrNet.Commands.Parameters.SpellCheckingParameters , SolrNet.Impl.SolrQueryResults< T > , SolrNet.StatsResult , SolrNet.Commands.Parameters.MoreLikeThisParameters
  • Credentials : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • Data : SolrNet.Impl.SolrCacheEntity
  • DateResults : SolrNet.DateFacetingResult
  • DefaultRows : SolrNet.Impl.SolrQueryExecuter< T >
  • Destination : SolrNet.Schema.SolrCopyField
  • Dictionary : SolrNet.Commands.Parameters.SpellCheckingParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • End : SolrNet.DateFacetingResult
  • EndOffset : SolrNet.Impl.SpellCheckResult
  • EnumCacheMinDf : SolrNet.SolrFacetFieldQuery , SolrNet.Commands.Parameters.FacetParameters
  • ETag : SolrNet.Impl.SolrCacheEntity
  • Expect : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • ExpungeDeletes : SolrNet.Commands.Parameters.CommitOptions , SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand
  • ExtraParams : SolrNet.Commands.Parameters.QueryOptions
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • Facet : SolrNet.Commands.Parameters.QueryOptions
  • FacetDates : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • FacetFields : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • FacetMode : SolrNet.Commands.Parameters.CollapseParameters
  • FacetQueries : SolrNet.ISolrQueryResults< T > , SolrNet.Impl.SolrQueryResults< T >
  • FacetResults : SolrNet.StatsResult
  • Facets : SolrNet.Commands.Parameters.StatsParameters
  • Factor : SolrNet.SolrQueryBoost
  • Field : SolrNet.CollapseResults , SolrNet.Commands.Parameters.CollapseParameters , SolrNet.SolrFacetFieldQuery
  • FieldName : SolrNet.SolrFieldModel , SolrNet.Attributes.SolrFieldAttribute
  • FieldNameSuffix : SolrNet.Impl.PropertyNode
  • Fields : SolrNet.Commands.Parameters.MoreLikeThisParameters , SolrNet.Commands.Parameters.HighlightingParameters , SolrNet.Commands.Parameters.QueryOptions
  • FieldsWithFacets : SolrNet.Commands.Parameters.StatsParameters
  • FieldValue : SolrNet.Impl.PropertyNode
  • FilterQueries : SolrNet.Commands.Parameters.QueryOptions
  • Fragsize : SolrNet.Commands.Parameters.HighlightingParameters
  • FromCommitted : SolrNet.Commands.DeleteCommand
  • FromPending : SolrNet.Commands.DeleteCommand
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • Gap : SolrNet.DateFacetingResult
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HardEnd : SolrNet.SolrFacetDateQuery
  • HaveResponse : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Header : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Headers : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.IHttpWebRequest
  • Highlight : SolrNet.Commands.Parameters.QueryOptions
  • Highlights : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • HttpWebRequestFactory : SolrNet.Impl.SolrConnection
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • Id : SolrNet.CollapsedDocument
  • IfModifiedSince : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • IgnoredFieldNames : SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule
  • IsFromCache : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • IsMultiValued : SolrNet.Schema.SolrField
  • IsMutuallyAuthenticated : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.IHttpWebResponse
  • IsReadOnly : SolrNet.Impl.SolrQueryResults< T >
  • IsRequired : SolrNet.Schema.SolrField
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • Params : SolrNet.ResponseHeader
  • Pipelined : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • PreAuthenticate : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Prefix : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • Property : SolrNet.SolrFieldModel
  • ProtocolVersion : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse
  • Proxy : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • QTime : SolrNet.ResponseHeader
  • Queries : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrMultipleCriteriaQuery
  • Query : SolrNet.Impl.SpellCheckResult , SolrNet.Commands.Parameters.SpellCheckingParameters , SolrNet.SolrQuery
  • QueryFields : SolrNet.Commands.Parameters.MoreLikeThisParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • ReadWriteTimeout : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Referer : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
  • RegexMaxAnalyzedChars : SolrNet.Commands.Parameters.HighlightingParameters
  • RegexPattern : SolrNet.Commands.Parameters.HighlightingParameters
  • RegexSlop : SolrNet.Commands.Parameters.HighlightingParameters
  • Reload : SolrNet.Commands.Parameters.SpellCheckingParameters
  • RequestUri : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • RequireFieldMatch : SolrNet.Commands.Parameters.HighlightingParameters
  • ResponseUri : HttpWebAdapters.IHttpWebResponse , HttpWebAdapters.Adapters.HttpWebResponseAdapter
  • Rows : SolrNet.Commands.Parameters.QueryOptions
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • SendChunked : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Server : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse
  • ServicePoint : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • SimilarResults : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • SlidingMinutes : SolrNet.Impl.HttpRuntimeCache
  • Snippets : SolrNet.Commands.Parameters.HighlightingParameters
  • SolrCopyFields : SolrNet.Schema.SolrSchema
  • SolrDynamicFields : SolrNet.Schema.SolrSchema
  • SolrFields : SolrNet.Schema.SolrSchema
  • SolrFieldTypes : SolrNet.Schema.SolrSchema
  • Sort : SolrNet.Commands.Parameters.FacetParameters , SolrNet.SolrFacetFieldQuery
  • Source : SolrNet.Schema.SolrCopyField
  • SpellCheck : SolrNet.Commands.Parameters.QueryOptions
  • SpellChecking : SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Start : SolrNet.Commands.Parameters.QueryOptions
  • StartOffset : SolrNet.Impl.SpellCheckResult
  • Stats : SolrNet.Commands.Parameters.QueryOptions , SolrNet.Impl.SolrQueryResults< T > , SolrNet.ISolrQueryResults< T >
  • Status : SolrNet.ResponseHeader
  • StatusCode : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse
  • StatusDescription : HttpWebAdapters.Adapters.HttpWebResponseAdapter , HttpWebAdapters.WebResponseStub , HttpWebAdapters.IHttpWebResponse
  • StdDev : SolrNet.StatsResult
  • Suggestions : SolrNet.Impl.SpellCheckResult
  • Sum : SolrNet.StatsResult
  • SumOfSquares : SolrNet.StatsResult
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • this : SolrNet.Impl.HttpRuntimeCache , SolrNet.Impl.ISolrCache , SolrNet.Impl.SolrQueryResults< T > , SolrNet.Impl.NullCache
  • Threshold : SolrNet.Commands.Parameters.CollapseParameters
  • Timeout : SolrNet.Impl.SolrConnection , HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • TransferEncoding : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Type : SolrNet.Schema.SolrField , SolrNet.Schema.SolrFieldType , SolrNet.Commands.Parameters.CollapseParameters
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UniqueKey : SolrNet.Schema.SolrSchema
  • UnsafeAuthenticatedConnectionSharing : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • Url : SolrNet.Impl.SolrCacheEntity
  • UseDefaultCredentials : HttpWebAdapters.IHttpWebRequest , HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • UserAgent : HttpWebAdapters.Adapters.HttpWebRequestAdapter , HttpWebAdapters.IHttpWebRequest
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • Version : SolrNet.Impl.SolrConnection
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • WaitFlush : SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions
  • WaitSearcher : SolrNet.Commands.CommitCommand , SolrNet.Commands.OptimizeCommand , SolrNet.Commands.Parameters.CommitOptions
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Hierarchical Index

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • NHibernate.SolrNet.CfgHelper
  • SolrNet.CollapsedDocument
  • SolrNet.Commands.Parameters.CollapseParameters
  • SolrNet.CollapseResults
  • SolrNet.Commands.Parameters.CommitOptions
  • SolrNet.DateFacetingResult
  • SolrNet.Impl.QuerySerializers.DateTimeRangeQuerySerializer
  • NHibernate.SolrNet.Impl.DelegatingSession
    • NHibernate.SolrNet.SolrSession
  • SolrNet.DSL.Impl.DeleteBy
  • SolrNet.FacetDateOther
  • SolrNet.Commands.Parameters.FacetParameters
  • SolrNet.DSL.Impl.FieldDefinition
  • SolrNet.Utils.Func
  • SolrNet.Commands.Parameters.HighlightingParameters
  • HttpWebAdapters.HttpWebRequestMethod
  • NHibernate.SolrNet.Impl.ICommitSetting
    • NHibernate.SolrNet.Impl.SolrNetListener< T >
  • SolrNet.Utils.IContainer
    • SolrNet.Utils.Container
  • SolrNet.DSL.Impl.IDSLQueryBetween< T, RT >
    • SolrNet.DSL.Impl.DSLQueryBetween< T, RT >
  • SolrNet.DSL.Impl.IDSLQueryBy< T >
    • SolrNet.DSL.Impl.DSLQueryBy< T >
  • SolrNet.DSL.Impl.IDSLRun< T >
    • SolrNet.DSL.Impl.DSLRun< T >
      • SolrNet.DSL.Impl.DSLFacetFieldOptions< T >
      • SolrNet.DSL.Impl.DSLQuery< T >
        • SolrNet.DSL.Impl.DSLQueryRange< T, RT >
    • SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
      • SolrNet.DSL.Impl.DSLFacetFieldOptions< T >
    • SolrNet.DSL.Impl.IDSLQuery< T >
      • SolrNet.DSL.Impl.DSLQuery< T >
      • SolrNet.DSL.Impl.IDSLQueryRange< T >
        • SolrNet.DSL.Impl.DSLQueryRange< T, RT >
  • HttpWebAdapters.IHttpWebRequest
    • HttpWebAdapters.Adapters.HttpWebRequestAdapter
  • HttpWebAdapters.IHttpWebRequestFactory
    • HttpWebAdapters.HttpWebRequestFactory
  • HttpWebAdapters.IHttpWebResponse
    • HttpWebAdapters.Adapters.HttpWebResponseAdapter
    • HttpWebAdapters.WebResponseStub
  • Rhino.Commons.LocalDataImpl.ILocalData
  • SolrNet.Mapping.Validation.IMappingValidator
    • SolrNet.Mapping.Validation.MappingValidator
  • NHibernate.SolrNet.INHSolrQuery
    • NHibernate.SolrNet.Impl.NHSolrQueryImpl
  • SolrNet.IReadOnlyMappingManager
    • SolrNet.Mapping.AllPropertiesMappingManager
    • SolrNet.Mapping.AttributesMappingManager
    • SolrNet.Mapping.IMappingManager
      • SolrNet.Mapping.MappingManager
    • SolrNet.Mapping.MemoizingMappingManager
  • SolrNet.ISolrBasicReadOnlyOperations< T >
    • SolrNet.ISolrBasicOperations< T >
      • SolrNet.Impl.SolrBasicServer< T >
    • SolrNet.ISolrReadOnlyOperations< T >
      • SolrNet.ISolrOperations< T >
        • SolrNet.Impl.SolrServer< T >
  • SolrNet.Impl.ISolrCache
    • SolrNet.Impl.HttpRuntimeCache
    • SolrNet.Impl.NullCache
  • SolrNet.ISolrCommand
    • SolrNet.Commands.AddCommand< T >
    • SolrNet.Commands.CommitCommand
    • SolrNet.Commands.DeleteCommand
    • SolrNet.Commands.GetSchemaCommand
    • SolrNet.Commands.OptimizeCommand
    • SolrNet.Commands.PingCommand
    • SolrNet.Commands.RollbackCommand
  • SolrNet.ISolrConnection
    • SolrNet.Impl.SolrConnection
  • SolrNet.Commands.Parameters.ISolrDeleteParam
    • SolrNet.Commands.Parameters.DeleteByIdAndOrQueryParam
  • SolrNet.Impl.ISolrDocumentActivator< T >
    • SolrNet.Impl.SolrDocumentActivator< T >
  • SolrNet.Impl.ISolrDocumentPropertyVisitor
    • SolrNet.Impl.DocumentPropertyVisitors.AggregateDocumentVisitor
    • SolrNet.Impl.DocumentPropertyVisitors.DefaultDocumentVisitor
    • SolrNet.Impl.DocumentPropertyVisitors.GenericDictionaryDocumentVisitor
    • SolrNet.Impl.DocumentPropertyVisitors.RegularDocumentVisitor
  • SolrNet.Impl.ISolrDocumentResponseParser< T >
    • SolrNet.Impl.SolrDocumentResponseParser< T >
  • SolrNet.ISolrDocumentSerializer< T >
    • SolrNet.Impl.SolrDocumentSerializer< T >
  • SolrNet.ISolrFacetQuery
    • SolrNet.SolrFacetDateQuery
    • SolrNet.SolrFacetFieldQuery
    • SolrNet.SolrFacetQuery
  • SolrNet.Impl.ISolrFacetQuerySerializer
    • SolrNet.Impl.FacetQuerySerializers.AggregateFacetQuerySerializer
    • SolrNet.Impl.FacetQuerySerializers.DefaultFacetQuerySerializer
    • SolrNet.Impl.FacetQuerySerializers.SingleTypeFacetQuerySerializer< T >
      • SolrNet.Impl.FacetQuerySerializers.SolrFacetDateQuerySerializer
      • SolrNet.Impl.FacetQuerySerializers.SolrFacetFieldQuerySerializer
      • SolrNet.Impl.FacetQuerySerializers.SolrFacetQuerySerializer
  • SolrNet.Impl.ISolrFieldParser
    • SolrNet.Impl.FieldParsers.AggregateFieldParser
    • SolrNet.Impl.FieldParsers.CollectionFieldParser
    • SolrNet.Impl.FieldParsers.DateTimeFieldParser
    • SolrNet.Impl.FieldParsers.DecimalFieldParser
    • SolrNet.Impl.FieldParsers.DefaultFieldParser
    • SolrNet.Impl.FieldParsers.DoubleFieldParser
    • SolrNet.Impl.FieldParsers.EnumFieldParser
    • SolrNet.Impl.FieldParsers.FloatFieldParser
    • SolrNet.Impl.FieldParsers.GuidFieldParser
    • SolrNet.Impl.FieldParsers.InferringFieldParser
    • SolrNet.Impl.FieldParsers.IntFieldParser
    • SolrNet.Impl.FieldParsers.LongFieldParser
    • SolrNet.Impl.FieldParsers.NullableFieldParser
    • SolrNet.Impl.FieldParsers.TypeConvertingFieldParser
  • SolrNet.Impl.ISolrFieldSerializer
    • SolrNet.Impl.FieldSerializers.AbstractFieldSerializer< T >
      • SolrNet.Impl.FieldSerializers.BoolFieldSerializer
      • SolrNet.Impl.FieldSerializers.DateTimeFieldSerializer
    • SolrNet.Impl.FieldSerializers.AggregateFieldSerializer
    • SolrNet.Impl.FieldSerializers.CollectionFieldSerializer
    • SolrNet.Impl.FieldSerializers.DefaultFieldSerializer
    • SolrNet.Impl.FieldSerializers.FormattableFieldSerializer
    • SolrNet.Impl.FieldSerializers.GenericDictionaryFieldSerializer
    • SolrNet.Impl.FieldSerializers.NullableFieldSerializer
    • SolrNet.Impl.FieldSerializers.ToStringFieldSerializer
    • SolrNet.Impl.FieldSerializers.TypeConvertingFieldSerializer
  • SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker
    • SolrNet.Mapping.Validation.Rules.AbstractSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.BoolSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.DateTimeSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.DoubleSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.FloatSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.IntSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.LongSolrFieldTypeChecker
      • SolrNet.Mapping.Validation.Rules.StringSolrFieldTypeChecker
    • SolrNet.Mapping.Validation.Rules.DecimalSolrFieldTypeChecker
  • SolrNet.Impl.ISolrHeaderResponseParser
    • SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
  • SolrNet.ISolrQuery
    • SolrNet.AbstractSolrQuery
      • SolrNet.SolrHasValueQuery
      • SolrNet.SolrMultipleCriteriaQuery
      • SolrNet.SolrNotQuery
      • SolrNet.SolrQuery
      • SolrNet.SolrQueryBoost
      • SolrNet.SolrQueryByField
      • SolrNet.SolrQueryByRange< RT >
      • SolrNet.SolrQueryInList
    • SolrNet.Impl.ISelfSerializingQuery
      • SolrNet.SolrQuery
    • SolrNet.LocalParams.LocalParamsQuery
  • SolrNet.Impl.ISolrQueryByRange
    • SolrNet.SolrQueryByRange< RT >
  • SolrNet.ISolrQueryExecuter< T >
    • SolrNet.Impl.SolrQueryExecuter< T >
  • SolrNet.ISolrQueryResultParser< T >
    • SolrNet.Impl.SolrQueryResultParser< T >
  • SolrNet.ISolrQueryResults< T >
    • SolrNet.Impl.SolrQueryResults< T >
  • SolrNet.Impl.ISolrQuerySerializer
    • SolrNet.Impl.QuerySerializers.AggregateQuerySerializer
    • SolrNet.Impl.QuerySerializers.DefaultQuerySerializer
    • SolrNet.Impl.QuerySerializers.RangeQuerySerializer
    • SolrNet.Impl.QuerySerializers.SelfSerializingQuerySerializer
    • SolrNet.Impl.QuerySerializers.SingleTypeQuerySerializer< T >
      • SolrNet.Impl.QuerySerializers.BoostQuerySerializer
      • SolrNet.Impl.QuerySerializers.HasValueQuerySerializer
      • SolrNet.Impl.QuerySerializers.LocalParamsSerializer
      • SolrNet.Impl.QuerySerializers.MultipleCriteriaQuerySerializer
      • SolrNet.Impl.QuerySerializers.NotQuerySerializer
      • SolrNet.Impl.QuerySerializers.QueryByFieldSerializer
      • SolrNet.Impl.QuerySerializers.QueryInListSerializer
  • SolrNet.Impl.ISolrResponseParser< T >
    • SolrNet.Impl.ResponseParsers.CollapseResponseParser< T >
    • SolrNet.Impl.ResponseParsers.FacetsResponseParser< T >
    • SolrNet.Impl.ResponseParsers.HeaderResponseParser< T >
    • SolrNet.Impl.ResponseParsers.HighlightingResponseParser< T >
    • SolrNet.Impl.ResponseParsers.MoreLikeThisResponseParser< T >
    • SolrNet.Impl.ResponseParsers.ResultsResponseParser< T >
    • SolrNet.Impl.ResponseParsers.SpellCheckResponseParser< T >
    • SolrNet.Impl.ResponseParsers.StatsResponseParser< T >
  • SolrNet.Schema.ISolrSchemaParser
    • SolrNet.Schema.SolrSchemaParser
  • NHibernate.SolrNet.ISolrSession
    • NHibernate.SolrNet.SolrSession
  • SolrNet.Mapping.Validation.Rules.IValidationRule
    • SolrNet.Mapping.Validation.Rules.MappedPropertiesIsInSolrSchemaRule
    • SolrNet.Mapping.Validation.Rules.MappingTypesAreCompatibleWithSolrTypesRule
    • SolrNet.Mapping.Validation.Rules.MultivaluedMappedToCollectionRule
    • SolrNet.Mapping.Validation.Rules.RequiredFieldsAreMappedRule
    • SolrNet.Mapping.Validation.Rules.UniqueKeyMatchesMappingRule
  • Rhino.Commons.Local
  • SolrNet.LocalParams
  • SolrNet.Utils.Memoizer
  • SolrNet.Commands.Parameters.MoreLikeThisParameters
  • NHibernate.SolrNet.Impl.NHHelper
  • SolrNet.Impl.QuerySerializers.NullableDateTimeRangeQuerySerializer
  • SolrNet.SolrMultipleCriteriaQuery.Operator
  • SolrNet.Impl.PropertyNode
  • SolrNet.Commands.Parameters.QueryOptions
  • SolrNet.DSL.Impl.RangeDefinition< T >
  • SolrNet.ResponseHeader
  • SolrNet.Impl.SolrCacheEntity
  • StructureMap.SolrNetIntegration.Config.SolrConfigurationSection
  • SolrNet.Schema.SolrCopyField
  • StructureMap.SolrNetIntegration.SolrCore
  • Castle.Facilities.SolrNetIntegration.SolrCore
  • SolrNet.Impl.SolrDictionaryDocumentResponseParser
  • SolrNet.Impl.SolrDictionarySerializer
  • SolrNet.Schema.SolrDynamicField
  • SolrNet.Schema.SolrField
  • SolrNet.Attributes.SolrFieldAttribute
    • SolrNet.Attributes.SolrUniqueKeyAttribute
  • SolrNet.SolrFieldModel
  • SolrNet.Schema.SolrFieldType
  • SolrNet.Exceptions.SolrNetException
    • SolrNet.Exceptions.InvalidFieldException
    • SolrNet.Exceptions.InvalidSortOrderException
    • SolrNet.Exceptions.InvalidURLException
    • SolrNet.Exceptions.SolrConnectionException
    • SolrNet.Exceptions.TypeNotSupportedException
  • Castle.Facilities.SolrNetIntegration.SolrNetFacility
  • Ninject.Integration.SolrNet.SolrNetModule
  • StructureMap.SolrNetIntegration.SolrNetRegistry
  • SolrNet.Schema.SolrSchema
  • StructureMap.SolrNetIntegration.Config.SolrServerElement
  • StructureMap.SolrNetIntegration.Config.SolrServers
  • SolrNet.SortOrder
    • SolrNet.RandomSortOrder
  • SolrNet.Commands.Parameters.SpellCheckingParameters
  • SolrNet.Impl.SpellCheckResult
  • SolrNet.Impl.SpellCheckResults
  • SolrNet.Commands.Parameters.StatsParameters
  • SolrNet.StatsResult
  • Castle.Facilities.SolrNetIntegration.StrictArrayResolver
  • SolrNet.Mapping.Validation.ValidationResult
    • SolrNet.Mapping.Validation.ValidationError
    • SolrNet.Mapping.Validation.ValidationWarning
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Main Page

SolrNet Documentation

0.3.0

Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.IHttpWebRequest Member List

This is the complete list of members for HttpWebAdapters.IHttpWebRequest, including all inherited members.
Abort() | HttpWebAdapters.IHttpWebRequest
Accept | HttpWebAdapters.IHttpWebRequest
AddRange(int from, int to) | HttpWebAdapters.IHttpWebRequest
AddRange(int range) | HttpWebAdapters.IHttpWebRequest
AddRange(string rangeSpecifier, int from, int to) | HttpWebAdapters.IHttpWebRequest
AddRange(string rangeSpecifier, int range) | HttpWebAdapters.IHttpWebRequest
Address | HttpWebAdapters.IHttpWebRequest
AllowAutoRedirect | HttpWebAdapters.IHttpWebRequest
AllowWriteStreamBuffering | HttpWebAdapters.IHttpWebRequest
AutomaticDecompression | HttpWebAdapters.IHttpWebRequest
BeginGetRequestStream(AsyncCallback callback, object state) (defined in HttpWebAdapters.IHttpWebRequest) | HttpWebAdapters.IHttpWebRequest
BeginGetResponse(AsyncCallback callback, object state) (defined in HttpWebAdapters.IHttpWebRequest) | HttpWebAdapters.IHttpWebRequest
ClientCertificates | HttpWebAdapters.IHttpWebRequest
Connection | HttpWebAdapters.IHttpWebRequest
ConnectionGroupName | HttpWebAdapters.IHttpWebRequest
ContentLength | HttpWebAdapters.IHttpWebRequest
ContentType | HttpWebAdapters.IHttpWebRequest
CookieContainer | HttpWebAdapters.IHttpWebRequest
Credentials | HttpWebAdapters.IHttpWebRequest
EndGetRequestStream(IAsyncResult result) (defined in HttpWebAdapters.IHttpWebRequest) | HttpWebAdapters.IHttpWebRequest
EndGetResponse(IAsyncResult result) (defined in HttpWebAdapters.IHttpWebRequest) | HttpWebAdapters.IHttpWebRequest
Expect | HttpWebAdapters.IHttpWebRequest
GetRequestStream() | HttpWebAdapters.IHttpWebRequest
GetResponse() (defined in HttpWebAdapters.IHttpWebRequest) | HttpWebAdapters.IHttpWebRequest
HaveResponse | HttpWebAdapters.IHttpWebRequest
Headers | HttpWebAdapters.IHttpWebRequest
IfModifiedSince | HttpWebAdapters.IHttpWebRequest
KeepAlive | HttpWebAdapters.IHttpWebRequest
MaximumAutomaticRedirections | HttpWebAdapters.IHttpWebRequest
MaximumResponseHeadersLength | HttpWebAdapters.IHttpWebRequest
MediaType | HttpWebAdapters.IHttpWebRequest
Method (defined in HttpWebAdapters.IHttpWebRequest) | HttpWebAdapters.IHttpWebRequest
Pipelined | HttpWebAdapters.IHttpWebRequest
PreAuthenticate | HttpWebAdapters.IHttpWebRequest
ProtocolVersion | HttpWebAdapters.IHttpWebRequest
Proxy | HttpWebAdapters.IHttpWebRequest
ReadWriteTimeout | HttpWebAdapters.IHttpWebRequest
Referer | HttpWebAdapters.IHttpWebRequest
RequestUri | HttpWebAdapters.IHttpWebRequest
SendChunked | HttpWebAdapters.IHttpWebRequest
ServicePoint | HttpWebAdapters.IHttpWebRequest
Timeout | HttpWebAdapters.IHttpWebRequest
TransferEncoding | HttpWebAdapters.IHttpWebRequest
UnsafeAuthenticatedConnectionSharing | HttpWebAdapters.IHttpWebRequest
UseDefaultCredentials | HttpWebAdapters.IHttpWebRequest
UserAgent | HttpWebAdapters.IHttpWebRequest
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.IHttpWebRequestFactory Member List

This is the complete list of members for HttpWebAdapters.IHttpWebRequestFactory, including all inherited members.
Create(Uri url) (defined in HttpWebAdapters.IHttpWebRequestFactory) HttpWebAdapters.IHttpWebRequestFactory
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2


SolrNet: Member List

HttpWebAdapters.IHttpWebResponse Member List

This is the complete list of members for HttpWebAdapters.IHttpWebResponse, including all inherited members.
CharacterSet | HttpWebAdapters.IHttpWebResponse
Close() | HttpWebAdapters.IHttpWebResponse
ContentEncoding | HttpWebAdapters.IHttpWebResponse
ContentLength | HttpWebAdapters.IHttpWebResponse
ContentType | HttpWebAdapters.IHttpWebResponse
Cookies | HttpWebAdapters.IHttpWebResponse
GetResponseHeader(string headerName) | HttpWebAdapters.IHttpWebResponse
GetResponseStream() | HttpWebAdapters.IHttpWebResponse
Headers | HttpWebAdapters.IHttpWebResponse
IsFromCache | HttpWebAdapters.IHttpWebResponse
IsMutuallyAuthenticated | HttpWebAdapters.IHttpWebResponse
LastModified | HttpWebAdapters.IHttpWebResponse
Method | HttpWebAdapters.IHttpWebResponse
ProtocolVersion | HttpWebAdapters.IHttpWebResponse
ResponseUri | HttpWebAdapters.IHttpWebResponse
Server | HttpWebAdapters.IHttpWebResponse
StatusCode | HttpWebAdapters.IHttpWebResponse
StatusDescription | HttpWebAdapters.IHttpWebResponse
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.INHSolrQuery Member List

This is the complete list of members for NHibernate.SolrNet.INHSolrQuery, including all inherited members.
SetFirstResult(int firstResult) | NHibernate.SolrNet.INHSolrQuery
SetMaxResults(int maxResults) | NHibernate.SolrNet.INHSolrQuery
SetSort(Order o) | NHibernate.SolrNet.INHSolrQuery
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.ISolrSession Member List

This is the complete list of members for NHibernate.SolrNet.ISolrSession, including all inherited members.
CreateSolrQuery(string query) | NHibernate.SolrNet.ISolrSession
CreateSolrQuery(ISolrQuery query) | NHibernate.SolrNet.ISolrSession
Generated on Thu Mar 31 2011 17:06:04 for SolrNet by doxygen 1.7.2


SolrNet: Member List

NHibernate.SolrNet.Impl.ICommitSetting Member List

This is the complete list of members for NHibernate.SolrNet.Impl.ICommitSetting, including all inherited members.
Commit NHibernate.SolrNet.Impl.ICommitSetting
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

Rhino.Commons.LocalDataImpl.ILocalData Member List

This is the complete list of members for Rhino.Commons.LocalDataImpl.ILocalData, including all inherited members.
Clear() (defined in Rhino.Commons.LocalDataImpl.ILocalData) | Rhino.Commons.LocalDataImpl.ILocalData
this (defined in Rhino.Commons.LocalDataImpl.ILocalData) | Rhino.Commons.LocalDataImpl.ILocalData
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Commands.Parameters.ISolrDeleteParam Member List

This is the complete list of members for SolrNet.Commands.Parameters.ISolrDeleteParam, including all inherited members.
ToXmlNode() SolrNet.Commands.Parameters.ISolrDeleteParam
Generated on Thu Mar 31 2011 17:06:07 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.IDSLFacetFieldOptions< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >, including all inherited members.
DontSortByCount() | SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
IncludeMissing() | SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
LimitTo(int limit) | SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run() (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run(int start, int rows) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
StartingAt(int offset) | SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(string query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(ISolrQuery query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithMinCount(int count) | SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
WithPrefix(string prefix) | SolrNet.DSL.Impl.IDSLFacetFieldOptions< T >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.IDSLQuery< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.IDSLQuery< T >, including all inherited members.
By(string fieldName) (defined in SolrNet.DSL.Impl.IDSLQuery< T >) | SolrNet.DSL.Impl.IDSLQuery< T >
ByRange< RT >(string fieldName, RT from, RT to) (defined in SolrNet.DSL.Impl.IDSLQuery< T >) | SolrNet.DSL.Impl.IDSLQuery< T >
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run() (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run(int start, int rows) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(string query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(ISolrQuery query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.IDSLQueryBetween< T, RT > Member List

This is the complete list of members for SolrNet.DSL.Impl.IDSLQueryBetween< T, RT >, including all inherited members.
And(RT i) (defined in SolrNet.DSL.Impl.IDSLQueryBetween< T, RT >) SolrNet.DSL.Impl.IDSLQueryBetween< T, RT >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.IDSLQueryBy< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.IDSLQueryBy< T >, including all inherited members.
Between< RT >(RT i) (defined in SolrNet.DSL.Impl.IDSLQueryBy< T >) | SolrNet.DSL.Impl.IDSLQueryBy< T >
Is(string s) (defined in SolrNet.DSL.Impl.IDSLQueryBy< T >) | SolrNet.DSL.Impl.IDSLQueryBy< T >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.IDSLQueryRange< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.IDSLQueryRange< T >, including all inherited members.
By(string fieldName) (defined in SolrNet.DSL.Impl.IDSLQuery< T >) | SolrNet.DSL.Impl.IDSLQuery< T >
ByRange< RT >(string fieldName, RT from, RT to) (defined in SolrNet.DSL.Impl.IDSLQuery< T >) | SolrNet.DSL.Impl.IDSLQuery< T >
Exclusive() (defined in SolrNet.DSL.Impl.IDSLQueryRange< T >) | SolrNet.DSL.Impl.IDSLQueryRange< T >
Inclusive() (defined in SolrNet.DSL.Impl.IDSLQueryRange< T >) | SolrNet.DSL.Impl.IDSLQueryRange< T >
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run() (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run(int start, int rows) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(string query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(ISolrQuery query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.DSL.Impl.IDSLRun< T > Member List

This is the complete list of members for SolrNet.DSL.Impl.IDSLRun< T >, including all inherited members.
OrderBy(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
OrderBy(string fieldName, Order o) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run() (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Run(int start, int rows) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetField(string fieldName) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(string query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithFacetQuery(ISolrQuery query) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlighting(HighlightingParameters parameters) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
WithHighlightingFields(params string[] fields) (defined in SolrNet.DSL.Impl.IDSLRun< T >) | SolrNet.DSL.Impl.IDSLRun< T >
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.IReadOnlyMappingManager Member List

This is the complete list of members for SolrNet.IReadOnlyMappingManager, including all inherited members.
GetFields(Type type) | SolrNet.IReadOnlyMappingManager
GetRegisteredTypes() (defined in SolrNet.IReadOnlyMappingManager) | SolrNet.IReadOnlyMappingManager
GetUniqueKey(Type type) | SolrNet.IReadOnlyMappingManager
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrBasicOperations< T > Member List

This is the complete list of members for SolrNet.ISolrBasicOperations< T >, including all inherited members.
AddWithBoost(IEnumerable< KeyValuePair< T, double?>> docs) | SolrNet.ISolrBasicOperations< T >
Commit(CommitOptions options) | SolrNet.ISolrBasicOperations< T >
Delete(IEnumerable< string > ids, ISolrQuery q) | SolrNet.ISolrBasicOperations< T >
GetSchema() | SolrNet.ISolrBasicReadOnlyOperations< T >
Optimize(CommitOptions options) | SolrNet.ISolrBasicOperations< T >
Ping() | SolrNet.ISolrBasicReadOnlyOperations< T >
Query(ISolrQuery query, QueryOptions options) | SolrNet.ISolrBasicReadOnlyOperations< T >
Rollback() | SolrNet.ISolrBasicOperations< T >
Send(ISolrCommand cmd) | SolrNet.ISolrBasicOperations< T >
SendAndParseHeader(ISolrCommand cmd) | SolrNet.ISolrBasicOperations< T >
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrBasicReadOnlyOperations< T > Member List

This is the complete list of members for SolrNet.ISolrBasicReadOnlyOperations< T >, including all inherited members.
GetSchema() | SolrNet.ISolrBasicReadOnlyOperations< T >
Ping() | SolrNet.ISolrBasicReadOnlyOperations< T >
Query(ISolrQuery query, QueryOptions options) | SolrNet.ISolrBasicReadOnlyOperations< T >
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrCommand Member List

This is the complete list of members for SolrNet.ISolrCommand, including all inherited members.
Execute(ISolrConnection connection) SolrNet.ISolrCommand
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrConnection Member List

This is the complete list of members for SolrNet.ISolrConnection, including all inherited members.
Get(string relativeUrl, IEnumerable< KeyValuePair< string, string >> parameters) | SolrNet.ISolrConnection
Post(string relativeUrl, string s) | SolrNet.ISolrConnection
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrDocumentSerializer< T > Member List

This is the complete list of members for SolrNet.ISolrDocumentSerializer< T >, including all inherited members.
Serialize(T doc, double?boost) SolrNet.ISolrDocumentSerializer< T >
Generated on Thu Mar 31 2011 17:06:05 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrOperations< T > Member List

This is the complete list of members for SolrNet.ISolrOperations< T >, including all inherited members.
Add(T doc) | SolrNet.ISolrOperations< T >
Add(IEnumerable< T > docs) | SolrNet.ISolrOperations< T >
AddWithBoost(T doc, double boost) | SolrNet.ISolrOperations< T >
AddWithBoost(IEnumerable< KeyValuePair< T, double?>> docs) | SolrNet.ISolrOperations< T >
BuildSpellCheckDictionary() | SolrNet.ISolrOperations< T >
Commit() | SolrNet.ISolrOperations< T >
Delete(T doc) | SolrNet.ISolrOperations< T >
Delete(IEnumerable< T > docs) | SolrNet.ISolrOperations< T >
Delete(ISolrQuery q) | SolrNet.ISolrOperations< T >
Delete(string id) | SolrNet.ISolrOperations< T >
Delete(IEnumerable< string > ids) | SolrNet.ISolrOperations< T >
Delete(IEnumerable< string > ids, ISolrQuery q) | SolrNet.ISolrOperations< T >
EnumerateValidationResults() (defined in SolrNet.ISolrOperations< T >) | SolrNet.ISolrOperations< T >
FacetFieldQuery(SolrFacetFieldQuery facets) | SolrNet.ISolrReadOnlyOperations< T >
GetSchema() | SolrNet.ISolrBasicReadOnlyOperations< T >
Optimize() | SolrNet.ISolrOperations< T >
Ping() | SolrNet.ISolrBasicReadOnlyOperations< T >
Query(string q) | SolrNet.ISolrReadOnlyOperations< T >
Query(string q, ICollection< SortOrder > orders) | SolrNet.ISolrReadOnlyOperations< T >
Query(string q, QueryOptions options) | SolrNet.ISolrReadOnlyOperations< T >
Query(ISolrQuery q) | SolrNet.ISolrReadOnlyOperations< T >
Query(ISolrQuery query, ICollection< SortOrder > orders) | SolrNet.ISolrReadOnlyOperations< T >
SolrNet::ISolrBasicReadOnlyOperations-g.Query(ISolrQuery query, QueryOptions options) | SolrNet.ISolrBasicReadOnlyOperations< T >
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrQueryExecuter< T > Member List

This is the complete list of members for SolrNet.ISolrQueryExecuter< T >, including all inherited members.
Execute(ISolrQuery q, QueryOptions options) SolrNet.ISolrQueryExecuter< T >
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrQueryResultParser< T > Member List

This is the complete list of members for SolrNet.ISolrQueryResultParser< T >, including all inherited members.
Parse(string r) SolrNet.ISolrQueryResultParser< T >
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrQueryResults< T > Member List

This is the complete list of members for SolrNet.ISolrQueryResults< T >, including all inherited members.
Collapsing | SolrNet.ISolrQueryResults< T >
FacetDates | SolrNet.ISolrQueryResults< T >
FacetFields | SolrNet.ISolrQueryResults< T >
FacetQueries | SolrNet.ISolrQueryResults< T >
Header | SolrNet.ISolrQueryResults< T >
Highlights | SolrNet.ISolrQueryResults< T >
MaxScore | SolrNet.ISolrQueryResults< T >
NumFound | SolrNet.ISolrQueryResults< T >
SimilarResults | SolrNet.ISolrQueryResults< T >
SpellChecking | SolrNet.ISolrQueryResults< T >
Stats | SolrNet.ISolrQueryResults< T >
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.ISolrReadOnlyOperations< T > Member List

This is the complete list of members for SolrNet.ISolrReadOnlyOperations< T >, including all inherited members.
FacetFieldQuery(SolrFacetFieldQuery facets) | SolrNet.ISolrReadOnlyOperations< T >
GetSchema() | SolrNet.ISolrBasicReadOnlyOperations< T >
Ping() | SolrNet.ISolrBasicReadOnlyOperations< T >
Query(string q) | SolrNet.ISolrReadOnlyOperations< T >
Query(string q, ICollection< SortOrder > orders) | SolrNet.ISolrReadOnlyOperations< T >
Query(string q, QueryOptions options) | SolrNet.ISolrReadOnlyOperations< T >
Query(ISolrQuery q) | SolrNet.ISolrReadOnlyOperations< T >
Query(ISolrQuery query, ICollection< SortOrder > orders) | SolrNet.ISolrReadOnlyOperations< T >
SolrNet::ISolrBasicReadOnlyOperations-g.Query(ISolrQuery query, QueryOptions options) | SolrNet.ISolrBasicReadOnlyOperations< T >
Generated on Thu Mar 31 2011 17:06:06 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISelfSerializingQuery Member List

This is the complete list of members for SolrNet.Impl.ISelfSerializingQuery, including all inherited members.
Query (defined in SolrNet.Impl.ISelfSerializingQuery) SolrNet.Impl.ISelfSerializingQuery
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrCache Member List

This is the complete list of members for SolrNet.Impl.ISolrCache, including all inherited members.
Add(SolrCacheEntity e) | SolrNet.Impl.ISolrCache
this | SolrNet.Impl.ISolrCache
Generated on Thu Mar 31 2011 17:06:08 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrDocumentActivator< T > Member List

This is the complete list of members for SolrNet.Impl.ISolrDocumentActivator< T >, including all inherited members.
Create() SolrNet.Impl.ISolrDocumentActivator< T >
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrDocumentPropertyVisitor Member List

This is the complete list of members for SolrNet.Impl.ISolrDocumentPropertyVisitor, including all inherited members.
Visit(object doc, string fieldName, XmlNode field) SolrNet.Impl.ISolrDocumentPropertyVisitor
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrDocumentResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ISolrDocumentResponseParser< T >, including all inherited members.
ParseResults(XmlNode parentNode) SolrNet.Impl.ISolrDocumentResponseParser< T >
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrFacetQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.ISolrFacetQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.ISolrFacetQuerySerializer) | SolrNet.Impl.ISolrFacetQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.ISolrFacetQuerySerializer) | SolrNet.Impl.ISolrFacetQuerySerializer
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrFieldParser Member List

This is the complete list of members for SolrNet.Impl.ISolrFieldParser, including all inherited members.
CanHandleSolrType(string solrType) | SolrNet.Impl.ISolrFieldParser
CanHandleType(Type t) | SolrNet.Impl.ISolrFieldParser
Parse(XmlNode field, Type t) | SolrNet.Impl.ISolrFieldParser
Generated on Thu Mar 31 2011 17:06:09 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrFieldSerializer Member List

This is the complete list of members for SolrNet.Impl.ISolrFieldSerializer, including all inherited members.
CanHandleType(Type t) | SolrNet.Impl.ISolrFieldSerializer
Serialize(object obj) | SolrNet.Impl.ISolrFieldSerializer
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrHeaderResponseParser Member List

This is the complete list of members for SolrNet.Impl.ISolrHeaderResponseParser, including all inherited members.
Parse(XmlDocument response) (defined in SolrNet.Impl.ISolrHeaderResponseParser) SolrNet.Impl.ISolrHeaderResponseParser
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrQueryByRange Member List

This is the complete list of members for SolrNet.Impl.ISolrQueryByRange, including all inherited members.
FieldName (defined in SolrNet.Impl.ISolrQueryByRange) | SolrNet.Impl.ISolrQueryByRange
From (defined in SolrNet.Impl.ISolrQueryByRange) | SolrNet.Impl.ISolrQueryByRange
Inclusive (defined in SolrNet.Impl.ISolrQueryByRange) | SolrNet.Impl.ISolrQueryByRange
To (defined in SolrNet.Impl.ISolrQueryByRange) | SolrNet.Impl.ISolrQueryByRange
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrQuerySerializer Member List

This is the complete list of members for SolrNet.Impl.ISolrQuerySerializer, including all inherited members.
CanHandleType(Type t) (defined in SolrNet.Impl.ISolrQuerySerializer) | SolrNet.Impl.ISolrQuerySerializer
Serialize(object q) (defined in SolrNet.Impl.ISolrQuerySerializer) | SolrNet.Impl.ISolrQuerySerializer
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Impl.ISolrResponseParser< T > Member List

This is the complete list of members for SolrNet.Impl.ISolrResponseParser< T >, including all inherited members.
Parse(XmlDocument xml, SolrQueryResults< T > results) SolrNet.Impl.ISolrResponseParser< T >
Generated on Thu Mar 31 2011 17:06:10 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.IMappingManager Member List

This is the complete list of members for SolrNet.Mapping.IMappingManager, including all inherited members.
Add(PropertyInfo property) | SolrNet.Mapping.IMappingManager
Add(PropertyInfo property, string fieldName) | SolrNet.Mapping.IMappingManager
Add(PropertyInfo property, string fieldName, float?boost) | SolrNet.Mapping.IMappingManager
GetFields(Type type) | SolrNet.IReadOnlyMappingManager
GetRegisteredTypes() (defined in SolrNet.IReadOnlyMappingManager) | SolrNet.IReadOnlyMappingManager
GetUniqueKey(Type type) | SolrNet.IReadOnlyMappingManager
SetUniqueKey(PropertyInfo property) | SolrNet.Mapping.IMappingManager
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.IMappingValidator Member List

This is the complete list of members for SolrNet.Mapping.Validation.IMappingValidator, including all inherited members.
EnumerateValidationResults(Type documentType, SolrSchema schema) SolrNet.Mapping.Validation.IMappingValidator
Generated on Thu Mar 31 2011 17:06:14 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker, including all inherited members.
CanHandleType(Type propertyType) (defined in SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker) | SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker
Validate(SolrFieldType solrFieldType, string propertyName, Type propertyType) | SolrNet.Mapping.Validation.Rules.ISolrFieldTypeChecker
Generated on Thu Mar 31 2011 17:06:15 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Mapping.Validation.Rules.IValidationRule Member List

This is the complete list of members for SolrNet.Mapping.Validation.Rules.IValidationRule, including all inherited members.
Validate(Type propertyType, SolrSchema solrSchema, IReadOnlyMappingManager mappingManager) SolrNet.Mapping.Validation.Rules.IValidationRule
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Schema.ISolrSchemaParser Member List

This is the complete list of members for SolrNet.Schema.ISolrSchemaParser, including all inherited members.
Parse(XmlDocument solrSchemaXml) SolrNet.Schema.ISolrSchemaParser
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Member List

SolrNet.Utils.IContainer Member List

This is the complete list of members for SolrNet.Utils.IContainer, including all inherited members.
Register(string key, Type serviceType, Converter< IContainer, object > factory) | SolrNet.Utils.IContainer
Register< T >(Converter< IContainer, T > factory) | SolrNet.Utils.IContainer
Register< T >(string key, Converter< IContainer, T > factory) | SolrNet.Utils.IContainer
Remove(string key, Type serviceType) | SolrNet.Utils.IContainer
Remove< T >() | SolrNet.Utils.IContainer
Remove< T >(string key) | SolrNet.Utils.IContainer
RemoveAll< T >() | SolrNet.Utils.IContainer
Generated on Thu Mar 31 2011 17:06:16 for SolrNet by doxygen 1.7.2


SolrNet: Class Members

  • Package Functions
  • All
  • Enumerations
  • CollapseFacetMode : SolrNet::Commands::Parameters
  • CollapseType : SolrNet::Commands::Parameters
  • Order : SolrNet
Generated on Thu Mar 31 2011 17:06:17 for SolrNet by doxygen 1.7.2


SolrNet: Package List

  • Package Functions

Package List

Here are the packages with brief descriptions (if available):
Castle.Facilities.SolrNetIntegration
HttpWebAdapters
HttpWebAdapters.Adapters
NHibernate.SolrNet
NHibernate.SolrNet.Impl
Ninject.Integration.SolrNet
Rhino.Commons.LocalDataImpl
SolrNet
SolrNet.Attributes
SolrNet.Commands
SolrNet.Commands.Parameters
SolrNet.DSL.Impl
SolrNet.Exceptions
SolrNet.Impl.DocumentPropertyVisitors
SolrNet.Impl.FacetQuerySerializers
SolrNet.Impl.FieldParsers
SolrNet.Impl.FieldSerializers
SolrNet.Impl.QuerySerializers
SolrNet.Impl.ResponseParsers
SolrNet.Mapping
SolrNet.Mapping.Validation
SolrNet.Mapping.Validation.Rules
SolrNet.Schema
SolrNet.Utils
StructureMap.SolrNetIntegration.Config
Generated on Thu Mar 31 2011 17:06:03 for SolrNet by doxygen 1.7.2